Sound Card Database

Questions about hardware, drivers and peripherals.
In the Original Post please also include the output of inxi -Fzx
User avatar
iridesce
Posts: 21
Joined: 14 Jan 2014 04:45
Location: Halfway between the mountains and the ocean, the rainforest and the volcano

Re: Sound Card Database

Postby iridesce » 22 Feb 2014 03:10

Dell Vostro 3300

Code: Select all

$ inxi -Ax
Audio:     Card-1: Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel bus-ID: 00:1b.0 
           Card-2: NVIDIA High Definition Audio Controller driver: snd_hda_intel bus-ID: 01:00.1 
           Sound: Advanced Linux Sound Architecture ver: k3.11-2-amd64
yeah, I know about the battery drain ....

Worked well oob

Chris M
Posts: 27
Joined: 01 Sep 2013 20:16

Re: Sound Card Database

Postby Chris M » 19 Mar 2014 06:05

https://bugzilla.kernel.org/show_bug.cgi?id=71861

This is a new Dell Inspiron 15 7000 Series (Inspiron 7537).

Code: Select all

chris@inspiron:~$ inxi -A
Audio: Card-1: Intel Lynx Point-LP HD Audio Controller driver: snd_hda_intel Sound: ALSA ver: k3.14.0-rc7
Card-2: Intel Haswell-ULT HD Audio Controller driver: snd_hda_intel

$ cat /proc/asound/cards
 0 [HDMI           ]: HDA-Intel - HDA Intel HDMI
                      HDA Intel HDMI at 0xe3610000 irq 64
 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xe3614000 irq 58

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC3223 Analog [ALC3223 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
I was getting no sound. Alsa was not picking up the 2nd HDA Intel PCH (true/real) playback card driving the realtek codec/driver (ALC283/ALC3223).
Takashi Iwai wrote:The error from aplay is expected behavior. The first card is HDMI, and it doesn't match with "default" PCM definition of alsa-lib. Set the default card to 1, or pass index=1,0 option to snd-hda-intel to swap the devices.
Adding "options snd-hda-intel index=1,0" to the alsa-base.conf worked.


I have also had loud pops at start up and shutdown. There is an intense kernel /sound/pci/hda/patch_realtek.c fix coming down the pipe, but if it comes in kernel 3.15, it may not make it into Jessie - the embedded fix for Testing may be a year off. For now, the popping fix in alsa-base.conf is:

snd-hda-intel model=,generic (note the comma)

The codec for my laptop is ALC3223, but that correlates with ALC283. The developer for realtek is also applying the same more intense kernel fix for ALC282. Again, the more intense fix may not make it into kernel 3.14. If it goes into 3.15, for ALC282, the same snd-hda-intel model=,generic can be tried.

3/25/14 Edit: 3.14-rc8 came just came out, and the Restore default value for alc283 and alc282 (popping fixes) are not going to make it into the 3.14 kernel. It's looking likely that 3.14 will be the kernel for Jessie, so unless you can mess with modules somehow, the quick fix will be to add snd-hda-intel model=,generic to alsa-base.conf

The popping is a fairly serious problem. The intense 3.15 fix restores the registers to prevent the abnormal digital power supply rising ratio/sequence to the codec, so you'll want to apply the snd-hda-intel model=,generic fix to alsa-base.conf as soon as possible.

6/7/14 Edit: The permanent ALC282 and ALC283 popping fixes have been backported into the 3.14 kernel.

And it looks like 3.16 will be the kernel for Jessie.

It also looks like Realtek fixes have slowed. The last one I'm seeing was on 4/28/14. It's all good.

aWanderer
Posts: 35
Joined: 18 Jan 2015 15:20

Re: Sound Card Database

Postby aWanderer » 02 Aug 2015 09:44

My sound stopped working a few days ago.
Audio: Card-1 Advanced Micro Devices [AMD/ATI] RS780 HDMI Audio [Radeon (HD) 3000 Series]
driver: snd_hda_intel bus-ID: 01:05.1 chip-ID: 1002:960f
Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
driver: snd_hda_intel bus-ID: 00:14.2 chip-ID: 1002:4383
Sound: Advanced Linux Sound Architecture v: k3.16.0-4-amd64
What do?

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: Sound Card Database

Postby Zill » 02 Aug 2015 10:09

aWanderer: I suggest you try opening a terminal and then run alsamixer...

Code: Select all

alsamixer
Then turn up all the sliders and make sure none are muted - you can toggle this with the "m" key. You can also select different sound cards (with F6) and play around with other settings from the alsamixer screen.

Hit Esc to close alsamixer and return to the terminal window.

See Alsamixer for more info.

To test your audio, would you please close all audio applications and then open a terminal and run the following command:

Code: Select all

aplay /usr/share/sounds/alsa/Front_Center.wav
Please advise if you can hear the "Front Center" announcement and/or also post any error message.


Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 1 guest