[solved] Video tearing (SolydK, NVIDIA)

Questions about hardware, drivers and peripherals.
In the Original Post please also include the output of inxi -Fzx
User avatar
TeaSwigger
Posts: 57
Joined: 27 Feb 2013 14:07

[solved] Video tearing (SolydK, NVIDIA)

Postby TeaSwigger » 17 Apr 2014 10:26

After the latest UP, "tearing" is visible playing videos. This occurs whether or not desktop effects are enabled.

DDM says recommended driver (NVIDIA) is installed and selected. This video card doesn't function with nouveau so NVIDIA is neccessary. Videos played fine with no "tearing" prior to UP.

Info:

Code: Select all

inxi -Fzx
System:    Host: [mines] Kernel: 3.13-1-amd64 x86_64 (64 bit, gcc: 4.8.2) Desktop: N/A Distro: SolydXK 1 testing
Machine:   Mobo: Gigabyte model: GA-MA770-UD3 version: x.x Bios: Award version: FG date: 12/29/2009
CPU:       Quad core AMD Phenom 9850 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 20091.4 
           Clock Speeds: 1: 1250.00 MHz 2: 1250.00 MHz 3: 1250.00 MHz 4: 2500.00 MHz
Graphics:  Card: NVIDIA G98 [GeForce 8400 GS Rev. 2] bus-ID: 01:00.0 
           X.org: 1.15.0 driver: nvidia tty size: 110x36 Advanced Data: N/A for root 
Audio:     Card: C-Media CMI8788 [Oxygen HD Audio] driver: snd_virtuoso port: ce00 bus-ID: 03:07.0 
           Sound: Advanced Linux Sound Architecture ver: k3.13-1-amd64
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 
           driver: r8169 ver: 2.3LK-NAPI port: de00 bus-ID: 02:00.0
           IF: eth1 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 2000.4GB (83.6% used) 1: id: /dev/sda model: ST2000DL003 size: 2000.4GB temp: 34C 
Partition: ID: / size: 16G used: 12G (79%) fs: ext4 ID: /home size: 38G used: 11G (31%) fs: ext4 
           ID: swap-1 size: 0.51GB used: 0.00GB (1%) fs: swap 
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 167 Uptime: 1:33 Memory: 1171.7/3963.7MB Runlevel: 2 Gcc sys: 4.8.2 Client: Shell (sudo) inxi: 1.9.17 

Code: Select all

inxi -Gxx
Graphics:  Card: NVIDIA G98 [GeForce 8400 GS Rev. 2] bus-ID: 01:00.0 chip-ID: 10de:06e4 
           X.Org: 1.15.0 driver: nvidia Resolution: 1440x900@59.9hz 
           GLX Renderer: GeForce 8400 GS/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 331.49 Direct Rendering: Yes
"You can't get to wonderful without passing through alright" -Bill Withers

SolydK 64-bit - AMD Quad Core - 4GB RAM - accursed NVIDIA GeForce 5800 graphics - lovely ASUS Xonar Essence ST sound

User avatar
mistergil
Posts: 106
Joined: 20 Sep 2013 00:33
Location: WV

Re: Video tearing (SolydK, NVIDIA)

Postby mistergil » 18 Apr 2014 02:46

I'm also experiencing this "tearing" since the UP on "AisleRiot", a simple card game. Have not noticed it on anything else.

Code: Select all

mistergil@mistergil:~/Desktop$ inxi -Gxx
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS482/RS485 [Radeon Xpress 1100/1150] bus-ID: 01:05.0 chip-ID: 1002:5974 
           X.Org: 1.15.0 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1280x1024@60.0hz 
           GLX Renderer: Gallium 0.4 on ATI RS480 GLX Version: 2.1 Mesa 9.2.2 Direct Rendering: Yes
Reg. #439601

User avatar
TeaSwigger
Posts: 57
Joined: 27 Feb 2013 14:07

Re: Video tearing (SolydK, NVIDIA)

Postby TeaSwigger » 18 Apr 2014 06:45

Extensive convoluted searching finally led me to a temporary fix, as per this KDE bug report: adding 'export __GL_YIELD="USLEEP"' to /etc/profile fixed the tearing.

I'm hesitant to mark it "solved" because I don't understand the fix or know when to remove the line from /etc/profile, but at least it's a temp fix and may help others with current video tearing issues.
mistergil wrote:I'm also experiencing this "tearing" since the UP on "AisleRiot", a simple card game. Have not noticed it on anything else.

Code: Select all

mistergil@mistergil:~/Desktop$ inxi -Gxx
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS482/RS485 [Radeon Xpress 1100/1150] bus-ID: 01:05.0 chip-ID: 1002:5974 
           X.Org: 1.15.0 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1280x1024@60.0hz 
           GLX Renderer: Gallium 0.4 on ATI RS480 GLX Version: 2.1 Mesa 9.2.2 Direct Rendering: Yes
Not sure if the above fix applies to your situation. If the problem is related to composting just on windows AisleRiot is in, you might try a "special window setting" rule to disable composting on those windows.
"You can't get to wonderful without passing through alright" -Bill Withers

SolydK 64-bit - AMD Quad Core - 4GB RAM - accursed NVIDIA GeForce 5800 graphics - lovely ASUS Xonar Essence ST sound

User avatar
TeaSwigger
Posts: 57
Joined: 27 Feb 2013 14:07

Re: [solved] Video tearing (SolydK, NVIDIA)

Postby TeaSwigger » 01 Aug 2014 07:41

Return of the Video Tearing is a strange story. KDM is being replaced by LightDM (has been on new ISOs) so I thought I'd go ahead and switch as per this thread:
http://forums.solydxk.nl/viewtopic.php?f=9&t=4368

LightDM works perfectly, it seems. But when I logged in, the dreaded video tearing had been resurrected to blight my videos!

So I reversed it (as per that thread) and reverted to KDM. Video tearing was vanquished once again.

Why in the world would that happen? At some point I'll probably have to switch from KDM, so I wonder if it's best to either hope whatever causes it is fixed by then or to sort it out now? Thought I'd ask if anyone here has any ideas.
"You can't get to wonderful without passing through alright" -Bill Withers

SolydK 64-bit - AMD Quad Core - 4GB RAM - accursed NVIDIA GeForce 5800 graphics - lovely ASUS Xonar Essence ST sound


Return to “Hardware”

Who is online

Users browsing this forum: Bing [Bot] and 3 guests