CPU cores disabled sometimes

Questions about hardware, drivers and peripherals.
In the Original Post please also include the output of inxi -Fzx
aWanderer
Posts: 35
Joined: 18 Jan 2015 15:20

CPU cores disabled sometimes

Postby aWanderer » 24 Jan 2016 11:02

I'm running an AMD FX-6300 on a Gigabyte 78LMT-USB3 and sometimes my CPU turns to mush. I can still do basic computing but my panel widget shows only 1 core active. When 'stress' is run with '--cpu 6' only one core runs, and some tasks are noticably slower. Rebooting fixes things but it's annoying to have to reboot. Is this a known problem? A while ago I ran 'dist-upgrade' a bit hastily (I don't want to run Enthusiast Edition).

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: CPU cores disabled sometimes

Postby Zill » 24 Jan 2016 12:28

aWanderer: Unless you have done something daft like overclocking the machine then, regrettably, it looks to me like your CPU is on the way out.

I suggest you could check the CPU temperatures and make sure they are within spec. If they are running hot then carefully vacuum out all the dust and make sure all cooling fans are working properly.

If the CPU is still unreliable then I think you may be looking at a CPU and/or motherboard replacement. :-(

Regarding "dist-upgrade", this is not necessary with systems running Debian Stable (such as SolydXK main edition) as a straight "upgrade" is fine. Having said that, "dist-upgrade" should not cause any problems with a Debian Stable system. Don't worry, this command will not have upgraded your machine to EE unless you have also changed the default repos!

aWanderer
Posts: 35
Joined: 18 Jan 2015 15:20

Re: CPU cores disabled sometimes

Postby aWanderer » 24 Jan 2016 21:44

Thank you for clearing up whether or not my machine was now on EE or not! :)

I actually neglected to mention that my machine is mildly overclocked. At stock this thing is 3.5-4.1 GHz, I run it at 4.1 all the time with Turbo disabled, Cool & Quiet enabled (voltage and freq varies). I suppose OCing could throw things out of whack... I hope the cpu isn't on the way out. Besides this issue it hasn't been presenting any other strangeness, and there are no problems with cooling or dust. One thing is that I tend to suspend the computer at least once a day without rebooting unless forced to. I suppose running everything at stock would be the way to go for now. I'm Hoping this is just a bug that has slipped under the radar and someone will figure it out :)

kurotsugi
Posts: 2174
Joined: 09 Jan 2014 00:17

Re: CPU cores disabled sometimes

Postby kurotsugi » 25 Jan 2016 09:50

linux actually support CPU hotplugging. some cpu driver even have auto hotplug which will enable/disable the cpu based on the load. I'm using intel's pstate which doesn't have auto-hotplug feature but I saw lot of arm cpu have this feature. if you want to turn on the cpu you can follow these guides

http://www.cyberciti.biz/faq/debian-rhe ... tplug-cpu/
https://www.kernel.org/doc/Documentatio ... otplug.txt

I think the auto-hotplug feature could be tweaked to make it less responsive but unfortunately I'm not experienced in this field.


Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 1 guest