Page 1 of 1

Is there are flash update [SOLVED]

Posted: 29 Jan 2015 22:51
by Fargo
Recently I keep getting notices that flash is vulnerable and should be updated. I also just had a friend calling and asking about this as well. Is their an update coming to take care of this?

Re: Is there are flash update

Posted: 29 Jan 2015 23:41
by Deleted User 2764
Update is already in the repos. Do:

Code: Select all

sudo apt-get update
sudo apt-get dist-upgrade
There's been a couple other updates as well so you should be all set if you do this today.

Re: Is there are flash update

Posted: 30 Jan 2015 00:56
by Fargo
Interesting. My update icon said I was up to date, but going into update manager the update was there. It must have uploaded after my system last checked. Thank you. I'll let my buddy know its been updated too.

Re: Is there are flash update

Posted: 30 Jan 2015 00:59
by Deleted User 2764
It could have been like you said. Updates can go online anytime but sooner or later the UM would have noticed. Seems you noticed before the UM. :)

Re: Is there are flash update

Posted: 31 Jan 2015 16:12
by bas_otten
It is NOT that I recommend this in general..... ;) but anyway:
In case you'd want to get rid of these warnings by Firefox whilst not having Flash updated just yet, you can do so by navigating to about:config, then find the setting named 'extensions.blocklist.enabled' and switch it to false.
Personally I use this in order to ease the frustration of family members whose computers I maintain and who have neither the skills nor the sudo-rights to apt-get dist-upgrade a system.
Yes yes, I'm aware of the risks, but I think - being on Linux in the first place - the risk is acceptable as long as we're talking about a few weeks or so.
Regards, Bas.

Re: Is there are flash update

Posted: 31 Jan 2015 18:08
by Deleted User 2764
I'd be very hesitent to ignore those risks even for a day, even on a linux system. So while you do have it disabled for their benefit, I hope you'll update their systems ASAP when you know it needs updating. I never turn those off so it reminds me to get an update.

Re: Is there are flash update

Posted: 31 Jan 2015 18:32
by kurotsugi
you can also do an automatic updates for flash using cron :3
a simple combo "apt-get update && apt-get install solydxk-flashplugin-11" should do the job.

Re: Is there are flash update

Posted: 31 Jan 2015 19:29
by bas_otten
To use cron to automate flash-upgrades: that is a pretty nice suggestion indeed. I'll take a look at that; thanx!

Re: Is there are flash update

Posted: 31 Jan 2015 22:38
by ane champenois
kurotsugi wrote:you can also do an automatic updates for flash using cron :3
a simple combo "apt-get update && apt-get install solydxk-flashplugin-11" should do the job.
@Fargo: Could you add a [solved] please? Thanks in advance.

Please give us the script: it's useful :geek:

Re: Is there are flash update

Posted: 02 Feb 2015 01:27
by Chris M
For a temp fix before Debian updates their package:

1) I would close your web browser(s).

2) http://get.adobe.com/flashplayer/?no_redirect

Download the package - select the .tar.gz package. For 64 bit, it will be install_flash_player_11_linux.x86_64.tar.gz

3) Extract it to a folder.

4) Place/copy the files into the places they already exist. I use XFCE, and there are really only 2 files that matter:

libflashplayer.so is copied into /usr/lib/flashplugin-nonfree/

flash-player-properties is copied into /usr/bin/


With XFCE, I have done a Configure custom action in Thunar called "Open a root Thunar here". You'll have to be able to copy the files over with root privileges. You could do this in Terminal also.

Re: Is there are flash update [SOLVED]

Posted: 02 Feb 2015 21:38
by kurotsugi
we actually could put the *.so file into /home/<username>/.mozilla/plugins/. no root permission needed :3

Re: Is there are flash update [SOLVED]

Posted: 06 Feb 2015 07:06
by Graybyrd
Nice! I just read this warning in "The Register" warning of 15 hijack flaws being patched, and this:
"Users of Adobe Flash Player for Linux should update to Adobe Flash Player 11.2.202.442."
Found that 11.2.202.440 was the last installed; did a quick apt-get update && apt-get dist-upgrade and Voila!! Found 11.2.202.442 waiting in the SolydXK repo. Thanks, guys! Somebody is on the ball. (Yeh, it's Flash, but some sites still insist on using it, but always remember: True friends don't let friends Flash while driving!)