Jave 6 & 7 no longer supported by Oracle (unless you pay)

Talking about SolydXK, another distribution or totally off-topic but within the Rules ? It's the right place!
User avatar
xendistar
Posts: 361
Joined: 08 Jun 2014 08:17
Location: Bournemouth, UK

Jave 6 & 7 no longer supported by Oracle (unless you pay)

Postby xendistar » 02 Jun 2017 11:09

Oracle have now stopped supporting Java 6 & 7 unless you are a paying support customer, see here (half way down the page)

http://www.oracle.com/technetwork/java/ ... 38363.html

User avatar
palimmo
Posts: 735
Joined: 19 Nov 2013 19:44
Contact:

Re: Jave 6 & 7 no longer supported by Oracle (unless you pay)

Postby palimmo » 02 Jun 2017 15:22

Well.. that means that it is time to uninstall java 6/7 from our machines and install java 8, correct?
can you please post a link to a tutorial?
It seems like on my computer I have openjdk 7 installed.
thanks!
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
ilu
Posts: 1665
Joined: 09 Oct 2013 12:45

Re: Jave 6 & 7 no longer supported by Oracle (unless you pay)

Postby ilu » 02 Jun 2017 15:24

Since debian provides openjdk 6, 7 and 8 for free in every sense of the word, there's no need to take Java from Oracle anyway. Just get rid of it and take the free and open version from the repos. Version 8 needs backports.

User avatar
palimmo
Posts: 735
Joined: 19 Nov 2013 19:44
Contact:

Re: Jave 6 & 7 no longer supported by Oracle (unless you pay)

Postby palimmo » 02 Jun 2017 15:26

so.. openjdk and java are completely unrelated projects, although have similar version numbers?
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
ilu
Posts: 1665
Joined: 09 Oct 2013 12:45

Re: Jave 6 & 7 no longer supported by Oracle (unless you pay)

Postby ilu » 02 Jun 2017 15:28

Unrelated? OpenJDK is the opensource Java framework and since it's compatible it has the same version numbers to make it easy to choose a compatible version. I use 7 from jessie and 8 from jessie backports (on different machines).
The package you need is openjdk-7-jre or openjdk-8-jre.


Return to “Open Chat / General Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest