Page 1 of 1

Can't do updates: Flash Plugin not found - Stalls

Posted: 11 Jun 2014 12:32
by Deleted User 2764
I'm trying to update SolydKBE. I've even run apt-get update --fix-missing in the terminal and then back to the UM and still getting this same problem. When it hits this, it won't continue with the installation so I can't get the newest stuff, including the new patched kernel. What do I do to fix it?

Here's the error:

Code: Select all

51 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 6,883 kB/164 MB of archives.
After this operation, 12.6 MB of additional disk space will be used.
Err http://packages.solydxk.com/business/ solydxk/main solydxk-flashplugin-11 amd64 11.2.202.359
  404  Not Found
Failed to fetch http://packages.solydxk.com/business/pool/main/s/solydxk-flashplugin-11/solydxk-flashplugin-11_11.2.202.359_amd64.deb  404  Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
Update: I resolved it by running the Synaptic Package Manager, searching "flashplugin" and removing the solydxk-flashplugin-11. Then I installed the flashplugin-nonfree. Then I closed that and restarted the Update Manager (UM) and tried the Install button again. Everything worked.

This bug needs fixing: Either solydxk-flashplug-11 needs to be removed from the lists or added to the BE repos.

Re: Can't do updates: Flash Plugin not found - Stalls

Posted: 11 Jun 2014 14:08
by Arjen Balfoort
It seems that Flash was updated correctly, but somehow the repository database was not. The package was updated, but the repository didn't save that information, and the old version remained. That's solved now.

Re: Can't do updates: Flash Plugin not found - Stalls

Posted: 11 Jun 2014 14:25
by Deleted User 2764
Thanks! :) Should I uninstall the nonfree version and reinstall the SolydXK version or are they the same?

Re: Can't do updates: Flash Plugin not found - Stalls

Posted: 11 Jun 2014 14:39
by Arjen Balfoort
They are not the same, but you can use either one of them.
Our version is automatically updated whenever a new version is available. Don't know about the other one.

Re: Can't do updates: Flash Plugin not found - Stalls

Posted: 11 Jun 2014 17:00
by Deleted User 2764
Ok, I guess it's best security-wise to uninstall the nonfree and update with the solydxk version then. Thanks for the info.

Re: Can't do updates: Flash Plugin not found - Stalls

Posted: 11 Jun 2014 18:26
by kurotsugi
the other one is only a wrapper which will download whatever in adobe's server and install it to our system. AFAIK you need to check whether if there's new version of flash manually from terminal.