Installer Question

Questions specific to SolydK Back Office
User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Installer Question

Postby MAYBL8 » 29 Jul 2013 20:35

I have identical drives in the server I am installing on.
When I got to the part of partitioning the drives I first selected sda and made it a ext4 drive and did the same with sdb.
So I was planning on having sda be the / partition and sdb be the /home partition.
The installer would only let me pick sda or sdb to install on. How do I get /home on sdb?
Thanks
Dan


User avatar
Arjen Balfoort
Site Admin
Posts: 8887
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Installer Question

Postby Arjen Balfoort » 30 Jul 2013 06:55

Sorry, currently you cannot install /home to another drive, only to another partition on the same drive.
It's on my wishlist, though.

I have never done this, but you could try to:
  • permanently mount /dev/sdb in fstab
  • move /home to that mount
  • create a symlink /home to the new location


SolydXK needs you!
Development | Testing | Translations

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Installer Question

Postby MAYBL8 » 30 Jul 2013 11:19

Thanks
I was thinking something like that after I got it installed.
I have done a similar thing on new installs on my pc's when I overwrite the / partition and leave /home on a separate partition if you know what I mean.
thanks
I'll let you know how it works or doesn't work.


User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Installer Question

Postby MAYBL8 » 30 Jul 2013 18:12

It turns out that the Dell Box has the drives installed as Raid 1.
Does that mean that SolydkBO is using the drives as Raid 1 Drives?
Also I would like to RDP into the server like I do now with the Windows Servers. Is that possible with SolydKBO?
Thanks
Dan


User avatar
Arjen Balfoort
Site Admin
Posts: 8887
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Installer Question

Postby Arjen Balfoort » 31 Jul 2013 19:26

Sorry, but I have no clue what you're talking about.
I see the code, but how the API's handle drives, is a mystery to me, I'm afraid.


SolydXK needs you!
Development | Testing | Translations

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Installer Question

Postby MAYBL8 » 31 Jul 2013 20:57

OK I will deal with that later. System is up and running.
I installed ssh onto the server so I could Putty into it. You might want to have that installed as part of the install.
There also seemed to be some packages that didn't need to be there. I can't remember which ones. Some kind of desktop applications that I would not use because I am using this as a server.
Other items that need attention.
LETODMS won't launch.
I also want to use Typo3 to replace my intranet server that I am using with Sharepoint right now.
This is going to be a big project. I don't know how much time I can put into it but I would like to do it.
Our Sharepoint (intranet ) basically is a storage for our ISO docs and a Company Anniversary / Birthday Calendar.
We will see how it goes.
Thanks for the help.
Dan


User avatar
Arjen Balfoort
Site Admin
Posts: 8887
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Installer Question

Postby Arjen Balfoort » 31 Jul 2013 21:09

Can you explain to me how to replicate the LetoDms issue?
Are there any error messages (also in /var/log/syslog)?


SolydXK needs you!
Development | Testing | Translations

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Installer Question

Postby MAYBL8 » 31 Jul 2013 21:42

from my workstation I goto
10.1.1.237/letodms and I get
Forbidden

You don't have permission to access /letodms on this server.

Apache/2.2.22 (Debian) Server at backoffice.corriganco.com Port 80

If I do the same thing for orangehrm it works. I get a web page for orangehrm
10.1.1.237/orangehrm

Here is the syslog file:
Attachments
log.txt
(92.77 KiB) Downloaded 227 times


User avatar
Arjen Balfoort
Site Admin
Posts: 8887
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Installer Question

Postby Arjen Balfoort » 01 Aug 2013 05:57

Thanks, I'll look at it after the UP.


SolydXK needs you!
Development | Testing | Translations

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Installer Question

Postby MAYBL8 » 01 Aug 2013 13:46

Another issue to add to your list.
For some reason the system is becoming unresponsive and I have to use the power button to restart it.
Not sure what is causing this or how to find out since when it happens I can't get it to respond to any commands.
Let me know what you think.
This has happened once each day.
Today I installed xrdp on it and after trying to get into it the non response started.
Thanks
Dan


User avatar
Arjen Balfoort
Site Admin
Posts: 8887
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Installer Question

Postby Arjen Balfoort » 13 Aug 2013 07:40

Today I have some time to look at the SolydK BO issues.
  • Zurmo is not running in the new iso
  • LetoDMS throws a 403 forbidden error
The second one was easy:
open as root: /etc/apache2/sites-available/letodms
And make it look like:

Code: Select all

Alias /letodms "/usr/share/letodms"
<Directory "/usr/share/letodms">
Options -Indexes
Options +MultiViews +FollowSymLinks
Redirect /letodms/conf/settings.xml http://localhost/letodms/
AllowOverride None
Order allow,deny
Allow from all
</Directory>
And restart apache:

Code: Select all

sudo service apache2 restart
Zurmo will be a lot more difficult...

[EDIT]
Changed the Options line to reflect the new standard


SolydXK needs you!
Development | Testing | Translations

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Installer Question

Postby MAYBL8 » 13 Aug 2013 15:25

Letodms working
Thanks


skorlowsky
Posts: 3
Joined: 18 Sep 2013 01:42

Re: Installer Question (letoDms)

Postby skorlowsky » 18 Sep 2013 01:49

Hello!

I have a problem with letodms as well, but is different,
I tried it before updating the latest package and it was showing the login page, now all I got is:
Not Found

The requested URL /letodms was not found on this server.
Apache/2.4.6 (Debian) Server at localhost Port 80

I have tried re-installing the packages using synaptic, but still not working.

is there anything I can do to fix this?
I will wait for your answer. Thanks!

Note: I am trying to connect from same pc (http://localhost/letodms)

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Installer Question

Postby MAYBL8 » 18 Sep 2013 02:06

Did you try this:
The second one was easy:
open as root: /etc/apache2/sites-available/letodms
And make it look like:

Alias /letodms "/usr/share/letodms"
<Directory "/usr/share/letodms">
Options -Indexes MultiViews FollowSymLinks
Redirect /letodms/conf/settings.xml http://localhost/letodms/
AllowOverride None
Order allow,deny
Allow from all
</Directory>

And restart apache:

sudo service apache2 restart


User avatar
Arjen Balfoort
Site Admin
Posts: 8887
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Installer Question

Postby Arjen Balfoort » 18 Sep 2013 06:07

Hi skorlowsky, and welcome to our forum!

I bet this doesn't work anymore:

Code: Select all

Options -Indexes MultiViews FollowSymLinks
Try this instead:

Code: Select all

Options -Indexes
Options +MultiViews +FollowSymLinks
Something with not allowing mixed options anymore...

[EDIT]
This was changed in the last version (1.0.8), and confirmed to work.


SolydXK needs you!
Development | Testing | Translations

skorlowsky
Posts: 3
Joined: 18 Sep 2013 01:42

Re: Installer Question

Postby skorlowsky » 18 Sep 2013 15:32

I will try what you suggest, maybe that will fix it.

The only thing I noticed change from the previous update, is the apache2.conf, since this update was applied, it changed to a new config file. I still have the previous apache2.conf,dpkg.old renemed that to apache2.conf to try but it didnt work either.

It has to be a simlink somewhere, so, I will try what you say, and let you know.

Thanks a lot, bty.... this is my first experience with solidxk, it looks very promising, thou I have been a linux user from 1997 at least, with RH 5.1 in those times, then suitched to Mandrake when it became available, Loooong time ago!

skorlowsky
Posts: 3
Joined: 18 Sep 2013 01:42

Re: Installer Question

Postby skorlowsky » 18 Sep 2013 15:57

Well... I am replying to myself :) - and the rest that follows this topic.

I got it working again, here is what I found out, and what I did.

I replace th apache2.conf file again and re-run (sudo service apache2 restart)
but it gave me an error, pointing to line 89 in the config file, I opened it with kwrite and check what was wrong on that line, it just points out to this:

# The accept serialization lock file MUST BE STORED ON A LOCAL DISK.
#
#LockFile ${APACHE_LOCK_DIR}/accept.lock (Commented out for testing purpuses only.)

executed the "sudo service apache2 restart" again, and this time I got to the login page of letoDms.

Now my question is, what implications has to comment out that entry: LockFile ${APACHE_LOCK_DIR}/accept.lock

But it works this way.
------------------------
This is a classified area. Access is permitted only to authorized personnel. Any violation will be prosecuted according to the national and international laws.
letoDMS free document management system - www.letodms.com
------------------------

User avatar
Arjen Balfoort
Site Admin
Posts: 8887
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Installer Question

Postby Arjen Balfoort » 18 Sep 2013 16:39

LockFile is not supported anymore with the current version of Apache2.
Unfortunately, the Apache developers hasn't included a graceful exit when it encounters the LockFile parameter, but choose to let it be handled by the error handler which results in a not so helpful message.


SolydXK needs you!
Development | Testing | Translations


Return to “SolydK Back Office”

Who is online

Users browsing this forum: No registered users and 1 guest