[SOLVED] Problem with my Back Office Server

Questions specific to SolydK Back Office
User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Problem with my Back Office Server

Postby MAYBL8 » 13 Feb 2014 21:11

I know I shouldn't reply to a solved post so if you want me to I can create a new topic.
I have installed the new SolydkBO and all is fine except for seeddms.
I get a blank screen at this location:
seeddms/out/out.ViewFolder.php

orangehrm and all other packages are coming up in the browser when I go to them.
Thanks


User avatar
Arjen Balfoort
Site Admin
Posts: 8720
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: [SOLVED] Problem with my Back Office Server

Postby Arjen Balfoort » 13 Feb 2014 21:20

MAYBL8 wrote:I know I shouldn't reply to a solved post so if you want me to I can create a new topic.
I have installed the new SolydkBO and all is fine except for seeddms.
I get a blank screen at this location:
seeddms/out/out.ViewFolder.php

orangehrm and all other packages are coming up in the browser when I go to them.
Thanks
Have you tried reinstalling it?

Code: Select all

sudo apt-get install --reinstall solydkbke-seeddms
Also check in phpMyAdmin if you have a seeddms database, and user.


SolydXK needs you!
Development | Testing | Translations

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Problem with my Back Office Server

Postby MAYBL8 » 14 Feb 2014 13:50

Re installed .
Still no luck
Still just a blank screen.
Checked phpadmin. The Database is there and the user root is there also.


User avatar
Arjen Balfoort
Site Admin
Posts: 8720
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Problem with my Back Office Server

Postby Arjen Balfoort » 14 Feb 2014 15:00

I just did a clean install of SolydK BO 201402: SeedDMS was functioning as expected live, and installed.

It seems I cannot reproduce your issue. So, let's take a look at the usual suspects:

Code: Select all

#!/bin/bash

if [ ! -e /var/www/seeddms/conf/settings.xml ]; then
  cp -f /usr/share/solydxk/seeddms/settings.xml /var/www/seeddms/conf/settings.xml
fi

# SeedDMS permissions
chgrp -R www-data /var/www/seeddms
chmod -R g+rw,o-w /var/www/seeddms/conf

# Create data directories and set permissions
sudo mkdir -p /home/seeddms/lucene
sudo mkdir -p /home/seeddms/staging
sudo mkdir -p /home/seeddms/cache
sudo chgrp -R www-data /home/seeddms
sudo chmod -R g+rw,o-w /home/seeddms
[EDIT]
I just re-read your last post: make sure the user "seeddms" exists, and has all privileges on the database "seeddms".


SolydXK needs you!
Development | Testing | Translations

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Problem with my Back Office Server

Postby MAYBL8 » 14 Feb 2014 15:28

I feel bad having you spend time on this and it isn't that important to me. I just wanted to try it out.
This install is right from the latest download and all the other packages are working fine.
This is the only one I end up with a blank page on.
I ran your script. It looks like it created the directories you had in there and changed the permissions.
Doesn't seemed to have helped.
Is there something i can check more than I did to see if the script did all it was suppose to do?
Thanks


User avatar
Arjen Balfoort
Site Admin
Posts: 8720
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Problem with my Back Office Server

Postby Arjen Balfoort » 14 Feb 2014 15:49

Not really, the only thing you could do is to purge solydkbo-seeddms, make sure both the seeddms database and the seeddms user are removed, and install solydkbo-seeddms.

Code: Select all

sudo apt-get purge solydkbo-seeddms
sudo clean
rm -rv /var/www/seeddms
rm -rv /home/seeddms
sudo apt-get autoremove
sudo apt-get install solydkbo-seeddms


SolydXK needs you!
Development | Testing | Translations

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Problem with my Back Office Server

Postby MAYBL8 » 14 Feb 2014 19:07

OK I did all of that and it appeared to do everything you said.
The only thing that didn't work was the command sudo clean
I haven't restarted the server.
everytime I try to goto seeddms it takes me here to a blank page still:
/seeddms/out/out.ViewFolder.php

It seems to be stuck on this page for some reason when I try to go there.
I can't get to the login page anymore.
I have tried to remove the browser cache but that didn't work either.
Any other suggestions?


User avatar
Arjen Balfoort
Site Admin
Posts: 8720
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Problem with my Back Office Server

Postby Arjen Balfoort » 14 Feb 2014 21:42

Sorry, I'm fresh out of ideas :oops:


SolydXK needs you!
Development | Testing | Translations

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Problem with my Back Office Server

Postby MAYBL8 » 17 Feb 2014 21:04

I have attached the error logs from the apache2 folder.
They have some items in there relating to seeddms.
When you get a chance can you take a look at them and see if they may lead to my problem.
There was a mention of a blank screen on the letodms forum and they looked in these logs for the problem.
I couldn't see from their forum that they had an answer.
Thanks
Dan
Attachments
error.log
(1.48 KiB) Downloaded 78 times
error.log.1.txt
(7.65 KiB) Downloaded 83 times


User avatar
Arjen Balfoort
Site Admin
Posts: 8720
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Problem with my Back Office Server

Postby Arjen Balfoort » 18 Feb 2014 08:31

Let's recreate the user again.

In terminal (you'll be asked for your mysql root password, default = solydxk):

Code: Select all

mysql -uroot -p -e 'DROP USER seeddms@localhost'
mysql -uroot -p -e "GRANT ALL PRIVILEGES ON seeddms.* TO seeddms@'localhost' IDENTIFIED BY 'seeddms'"
Try to login now.

[EDIT]
You could try if you can login into phpMyAdmin as user seeddms, with password seeddms.


SolydXK needs you!
Development | Testing | Translations

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: [SOLVED] Problem with my Back Office Server

Postby MAYBL8 » 18 Feb 2014 14:41

Looks like that took care of it.
Thanks


User avatar
Arjen Balfoort
Site Admin
Posts: 8720
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: [SOLVED] Problem with my Back Office Server

Postby Arjen Balfoort » 18 Feb 2014 14:48

Great, but still strange that live it all functions, and after install, which is a simple copy by the live-installer, the user hasn't got the right permissions.


SolydXK needs you!
Development | Testing | Translations

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: [SOLVED] Problem with my Back Office Server

Postby MAYBL8 » 18 Feb 2014 15:21

Not sure either.
I can do another complete install from the DVD if you want me to?


User avatar
Arjen Balfoort
Site Admin
Posts: 8720
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: [SOLVED] Problem with my Back Office Server

Postby Arjen Balfoort » 18 Feb 2014 15:26

MAYBL8 wrote:Not sure either.
I can do another complete install from the DVD if you want me to?
No, don't worry.
As long as you're the only one with this issue. It's not worth spending more time at.


SolydXK needs you!
Development | Testing | Translations

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Problem with my Back Office Server

Postby MAYBL8 » 26 Apr 2014 13:05

I'm reopening this post.
Due to a hard drive crash I had to reinstall my BO server at home. (I also have one at work).
I am having the same issue as I had (above) with Seeddms. However the fix above did not work this time.
This is not a major priority so when someone gets time I would like some suggestions of what to try.
Remember I did everything that was suggested previously.
I will try to investigate on my own and if I come up with something I will post it here.
If anyone else is running BO try the seeddms and let me know if you are having the same issue I am having.
Thanks
Dan

Update:
I also notice LetoDMS runs on the server also.
However no username and password that I have works for it.
I tried the default of
root
solydxk



Return to “SolydK Back Office”

Who is online

Users browsing this forum: No registered users and 1 guest