Failed to start xrdp daemon

Questions about software.
eikko
Posts: 17
Joined: 23 Oct 2014 08:54

Failed to start xrdp daemon

Postby eikko » 04 Dec 2017 13:56

Hello all,

i need a Remote-Connection on my SolydK9,
i installed xrdp but i get the error:

Dec 04 14:32:05 zrm-test systemd[1]: Starting xrdp daemon...
Dec 04 14:32:05 zrm-test systemd[1]: xrdp.service: Control process exited, code=exited status=1
Dec 04 14:32:05 zrm-test systemd[1]: Failed to start xrdp daemon.
Dec 04 14:32:05 zrm-test systemd[1]: xrdp.service: Unit entered failed state.
Dec 04 14:32:05 zrm-test systemd[1]: xrdp.service: Failed with result 'exit-code'.


Any Ideas

eikko

User avatar
ilu
Posts: 1665
Joined: 09 Oct 2013 12:45

Re: Failed to start xrdp daemon

Postby ilu » 04 Dec 2017 15:41

What do "systemctl status xrdp.service" and "journalctl -xe" say?

eikko
Posts: 17
Joined: 23 Oct 2014 08:54

Re: Failed to start xrdp daemon

Postby eikko » 05 Dec 2017 08:27

Hi ilu,

"systemctl status xrdp.service" says

Code: Select all

xrdp.service - xrdp daemon
   Loaded: loaded (/lib/systemd/system/xrdp.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2017-12-05 06:51:11 CET; 2h 28min ago
     Docs: man:xrdp(8)
           man:xrdp.ini(5)
  Process: 769 ExecStart=/usr/sbin/xrdp $XRDP_OPTIONS (code=exited, status=1/FAILURE)
  Process: 749 ExecStartPre=/bin/sh /usr/share/xrdp/socksetup (code=exited, status=0/SUCCESS)

Dez 05 06:51:11 zrm-test systemd[1]: Starting xrdp daemon...
Dez 05 06:51:11 zrm-test systemd[1]: xrdp.service: Control process exited, code=exited status=1
Dez 05 06:51:11 zrm-test systemd[1]: Failed to start xrdp daemon.
Dez 05 06:51:11 zrm-test systemd[1]: xrdp.service: Unit entered failed state.
Dez 05 06:51:11 zrm-test systemd[1]: xrdp.service: Failed with result 'exit-code'.


"journalctl -xe" says

Code: Select all

-- Unit UNIT has finished starting up.
--
-- The start-up result is done.
Dez 05 09:17:55 zrm-test dbus-daemon[2064]: Activating service name='org.kde.kuiserver'
Dez 05 09:17:55 zrm-test kernel: [UFW BLOCK] IN=enp1s0 OUT= MAC=01:00:5e:7f:ff:fa:c8:5b:76:85:48:f3:08:00 SRC=1
Dez 05 09:17:55 zrm-test dbus-daemon[2064]: Successfully activated service 'org.kde.kuiserver'
Dez 05 09:17:55 zrm-test kernel: [UFW BLOCK] IN=enp1s0 OUT= MAC=01:00:5e:7f:ff:fa:c8:5b:76:85:48:f3:08:00 SRC=1
Dez 05 09:18:01 zrm-test PackageKit[1741]: get-updates transaction /73_bcaadcad from uid 1000 finished with suc
Dez 05 09:18:03 zrm-test PackageKit[1741]: get-updates transaction /74_bccaceeb from uid 1000 finished with suc
Dez 05 09:18:05 zrm-test kernel: [UFW BLOCK] IN=enp1s0 OUT= MAC=01:00:5e:7f:ff:fa:c8:5b:76:85:48:f3:08:00 SRC=1
Dez 05 09:18:10 zrm-test dbus[580]: [system] Failed to activate service 'org.bluez': timed out
Dez 05 09:18:10 zrm-test pulseaudio[2206]: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesk
Dez 05 09:18:30 zrm-test kernel: [UFW BLOCK] IN=enp1s0 OUT= MAC=01:00:5e:7f:ff:fa:00:24:1d:c9:38:1e:08:00 SRC=1
Dez 05 09:19:13 zrm-test su[2481]: Successful su for root by huber
Dez 05 09:19:13 zrm-test su[2481]: + /dev/pts/1 huber:root
Dez 05 09:19:13 zrm-test su[2481]: pam_unix(su:session): session opened for user root by huber(uid=1000)
Dez 05 09:19:13 zrm-test su[2481]: pam_systemd(su:session): Cannot create session: Already running in a session
Dez 05 09:19:15 zrm-test kernel: [UFW BLOCK] IN=enp1s0 OUT= MAC=01:00:5e:00:00:01:38:10:d5:af:94:52:08:00 SRC=1
Dez 05 09:19:15 zrm-test kernel: [UFW BLOCK] IN=enp1s0 OUT= MAC=01:00:5e:7f:ff:fa:c8:5b:76:85:48:f3:08:00 SRC=1
Dez 05 09:19:25 zrm-test kernel: [UFW BLOCK] IN=enp1s0 OUT= MAC=01:00:5e:7f:ff:fa:c8:5b:76:85:48:f3:08:00 SRC=1
Dez 05 09:20:35 zrm-test kernel: [UFW BLOCK] IN=enp1s0 OUT= MAC=01:00:5e:7f:ff:fa:c8:5b:76:85:48:f3:08:00 SRC=1
Dez 05 09:20:36 zrm-test kernel: [UFW BLOCK] IN=enp1s0 OUT= MAC=01:00:5e:7f:ff:fa:c8:5b:76:85:48:f3:08:00 SRC=1
Dez 05 09:20:45 zrm-test kernel: [UFW BLOCK] IN=enp1s0 OUT= MAC=01:00:5e:7f:ff:fa:c8:5b:76:85:48:f3:08:00 SRC=1
Dez 05 09:20:46 zrm-test kernel: [UFW BLOCK] IN=enp1s0 OUT= MAC=01:00:5e:7f:ff:fa:c8:5b:76:85:48:f3:08:00 SRC=1
Dez 05 09:21:12 zrm-test kernel: [UFW BLOCK] IN=enp1s0 OUT= MAC=01:00:5e:7f:ff:fa:50:e5:49:52:06:bb:08:00 SRC=1
Dez 05 09:21:20 zrm-test kernel: [UFW BLOCK] IN=enp1s0 OUT= MAC=01:00:5e:00:00:01:38:10:d5:af:94:52:08:00 SRC=1
lines 2014-2039/2039 (END)


eikko

User avatar
ilu
Posts: 1665
Joined: 09 Oct 2013 12:45

Re: Failed to start xrdp daemon

Postby ilu » 05 Dec 2017 16:38

XRDP seems to have problems to run under debian and I'm not sure I can debug that. Please post the output of

Code: Select all

echo $XRDP_OPTIONS
cat /etc/xrdp
cat /etc/default/xrdp
ls -al /var/run/xrdp*

Try with sudo if necessary.

eikko
Posts: 17
Joined: 23 Oct 2014 08:54

Re: Failed to start xrdp daemon

Postby eikko » 06 Dec 2017 07:15

echo $XRDP_OPTIONS


cat /etc/xrdp
cat: /etc/xrdp: Ist ein Verzeichnis (... is a Directory)


cat /etc/default/xrdp
# do we need to start sesman? (set to 'yes' to start, anything else to not)
# note this setting is not honoured by the systemd service files
SESMAN_START=yes

# command line options for sesman (none by default)
SESMAN_OPTIONS=

# command line options for xrdp (none by default)
XRDP_OPTIONS=


ls -al /var/run/xrdp*
ls: Zugriff auf '/var/run/xrdp*' nicht möglich: Datei oder Verzeichnis nicht gefunden (...File or Directory not found)


Hope thats right!

eikko

User avatar
ilu
Posts: 1665
Joined: 09 Oct 2013 12:45

Re: Failed to start xrdp daemon

Postby ilu » 06 Dec 2017 20:59

From what I read xrdp doesn't play well with systemd. You can see hints about that in the config file you posted.

There are also bug reports for debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=854548 and https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=862837. This is supposed to be fixed in the latest packages for stretch, so you might check dpkg -l xrdp against https://packages.debian.org/stretch/xrdp (v. 0.9.1-9).

But there are strong indications that the package is still buggy, read the debian bug reports and pay special attention to https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=862837#26.

eikko
Posts: 17
Joined: 23 Oct 2014 08:54

Re: Failed to start xrdp daemon

Postby eikko » 08 Dec 2017 06:59

Bad news!

But thanks for your help!

eikko


Return to “Software”

Who is online

Users browsing this forum: Google [Bot] and 2 guests