Help with installation - acestream

Questions about software.
ptkfs
Posts: 6
Joined: 28 Mar 2014 17:25
Location: Slovenia

Help with installation - acestream

Postby ptkfs » 31 Mar 2014 17:53

I tried to install this software and I wasn't successfull. I tried to find any useful tip but no luck. I have had some issues with dependency and so on.
http://wiki.acestream.org/wiki/index.ph ... repository
Any tip would be appreciated.
Thanks!

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Help with installation - software

Postby zerozero » 31 Mar 2014 17:58

Hi
which instructions you used?
i see several in the site you linked above.
bliss of ignorance

ptkfs
Posts: 6
Joined: 28 Mar 2014 17:25
Location: Slovenia

Re: Help with installation - software

Postby ptkfs » 31 Mar 2014 18:08

I tried with Deb7, Sid and Ubuntu 13.10 repos, no luck :cry:
Thanks for quick response!

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Help with installation - software

Postby zerozero » 31 Mar 2014 18:12

as a principle i would say that the ubuntu repos are a no-go;

when you add the wheezy repo what is the error message you get? share the full output from the terminal.
bliss of ignorance

ptkfs
Posts: 6
Joined: 28 Mar 2014 17:25
Location: Slovenia

Re: Help with installation - software

Postby ptkfs » 31 Mar 2014 18:16

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 acestream-engine : Depends: python2.7-apsw but it is not installable
E: Unable to correct problems, you have held broken packages.

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Help with installation - software

Postby zerozero » 31 Mar 2014 18:23

if you remove that repo and put instead the one for sid do you still have the same error? or it's different.
share the output
bliss of ignorance

ptkfs
Posts: 6
Joined: 28 Mar 2014 17:25
Location: Slovenia

Re: Help with installation - software

Postby ptkfs » 31 Mar 2014 18:49

zerozero wrote:if you remove that repo and put instead the one for sid do you still have the same error? or it's different.
share the output
Yes, still the same error.

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Help with installation - software

Postby zerozero » 31 Mar 2014 19:07

i can see now that the dependency problem is still not solved;
python2.7-apsw is a virtual package (in fact it doesn't exist anymore and having an application depending on it means that the app is broken even if it says that the repo is for Sid)
https://packages.debian.org/hu/wheezy/python2.7-apsw

Code: Select all

zerozero@k64 ~ $ apt show acestream-engine
Package: acestream-engine
New: yes
State: not installed
Version: 2.1.6-1sid4
Priority: optional
Section: net
Maintainer: Ace Stream <info@acestream.net>
Architecture: amd64
Uncompressed Size: 9,904 k
Depends: python2.7 (>= 2.7.2), libpython2.7 (>= 2.7.2), python2.7-apsw,
         python2.7-m2crypto, libc6 (>= 2.13)
Conflicts: torrentstream-engine, torrentstream-engine, acestream-engine
Replaces: torrentstream-engine, torrentstream-engine
Description: Ace Stream HD
 
Homepage: http://www.acestream.org/

Code: Select all

zerozero@k64 ~ $ apt show python2.7-apsw
No current or candidate version found for python2.7-apsw
Package: python2.7-apsw
State: not a real package
if you have any chance to contact the maintainer of this app s/he should update the dependencies (at least in the Sid builds)
bliss of ignorance

ptkfs
Posts: 6
Joined: 28 Mar 2014 17:25
Location: Slovenia

Re: Help with installation - software

Postby ptkfs » 31 Mar 2014 19:22

Thanks a lot for your help! Much appreciated!
I will try to contact the developer via their official forum.

ess82
Posts: 44
Joined: 16 May 2014 12:49

Re: Help with installation - acestream

Postby ess82 » 28 May 2014 12:32

hi, did you manage to install that acestream? I get the same error when trying to install.
Furthermore, apt says, there is broken package, found by auditing that it's python-sexy, but reinstalling that package doesn't lead anywhere

and what does this mean? what are virtual packages? how do I get them?

Code: Select all

esso@dell-laptop ~ $ sudo aptitude install acestream-engine
The following NEW packages will be installed:
  acestream-engine{b} 
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 3,637 kB of archives. After unpacking 9,904 kB will be used.
The following packages have unmet dependencies:
 acestream-engine : Depends: python2.7-apsw which is a virtual package.
                    Depends: python2.7-m2crypto which is a virtual package.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     acestream-engine [Not Installed]                   



Accept this solution? [Y/n/q/?] y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Help with installation - acestream

Postby zerozero » 28 May 2014 13:01

this are virtual packages >> https://www.debian.org/doc/debian-polic ... irtual_pkg
i don't think (but might be wrong) that until the issue is fixed by the maintainer the app is uninstallable
bliss of ignorance

ess82
Posts: 44
Joined: 16 May 2014 12:49

Re: Help with installation - acestream

Postby ess82 » 29 May 2014 09:42

thanks for answer zerozero
I guess I'll just run it via winw until that's solved

ess82
Posts: 44
Joined: 16 May 2014 12:49

Re: Help with installation - acestream

Postby ess82 » 28 Dec 2014 21:41

found a way to watch acestream in solydxk

Code: Select all

https://github.com/enen92/P2P-Streams-Kodi
..needs XBMC but works perfectly


Return to “Software”

Who is online

Users browsing this forum: No registered users and 4 guests