Libopenjpeg: dependencies on obsolete version

Questions about software.
francesco312
Posts: 12
Joined: 16 Sep 2013 10:25

Libopenjpeg: dependencies on obsolete version

Postby francesco312 » 04 May 2014 12:59

Hello
I've noticed, as I was cleaning packages in the local/obsolete section of synaptics, that among them there was libopenjpeg2, which is not in any repository (a part from linuxmint, which a standard installation of solydxk should not have). Instead, solydxk provides a more updated version of that library, i.e. libopenjpeg5. But some packages (most notably all the libav/ffmpeg source package, but also gpac, and maybe something more) depend on libopenjpeg2. This is a problem, because if someone uninstalls those packages and autoremoves all dependencies, they can't reinstall that package any more.
I have tried to compile those packages after installing the most recent version of libopenjpeg-dev, and they have built without issues and now depend on libopenjpeg5: Would it be possible to recompile those packages that way, to use libopenjpeg5? thanks

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Libopenjpeg: dependencies on obsolete version

Postby zerozero » 05 May 2014 00:02

first (and second, i must admit) time i read this i didn't understand how we got into this situation.

but now i think i got it:
the now obsolete version (libopenjpeg2) migrated to testing on mid december last year
http://packages.qa.debian.org/o/openjpe ... 3917Z.html
libopenjpeg5 migrated on the exact day we synced our repos with debian testing
http://packages.qa.debian.org/o/openjpe ... 3911Z.html
making this way impossible to include in the UP all the app. that would be rebuilt against libopenjpeg5

at this point the less destructive (but probably not the most elegant) solution is to provide libopenjpeg2 in the repo as a legacy assurance
http://snapshot.debian.org/package/open ... -4.7:2b:b1
bliss of ignorance

francesco312
Posts: 12
Joined: 16 Sep 2013 10:25

Re: Libopenjpeg: dependencies on obsolete version

Postby francesco312 » 05 May 2014 19:39

For the next UP, could you manage to rebuild those packages? From what I see, there's no need to edit or patch anything


Return to “Software”

Who is online

Users browsing this forum: No registered users and 3 guests