[SOLVED] Playonlinux no wine option.

Questions about software.
User avatar
Uzi
Posts: 44
Joined: 27 Dec 2013 08:05

[SOLVED] Playonlinux no wine option.

Postby Uzi » 30 Jun 2014 12:05

Hi all,

I have had SolydX running for a few months but I did a fresh install a couple of days ago. All ok except Playonlinux. Installed Ok. Wine installed. My game (Sins of a Solar Empire) installed again. Go to launch it & no Wine option. Checked Menus & no Wine listed. Searched & no Wine listed.

Cant play my game as it doesn't give me the Wine launcher.

Ideas anyone?

Uzi

User avatar
smackthepony
Posts: 147
Joined: 28 Oct 2013 13:49
Location: the low countries

Re: Playonlinux no wine option.

Postby smackthepony » 30 Jun 2014 12:33

have you tried opening a terminal in the particular game directory and start with

Code: Select all

wine GAME.exe
i.e. if i were to start World of Warcraft i would type wine Wow.exe (case sensitive)
Image

User avatar
Uzi
Posts: 44
Joined: 27 Dec 2013 08:05

Re: Playonlinux no wine option.

Postby Uzi » 30 Jun 2014 23:11

Thanks for the reply but I am not looking for a work around. I am looking to identify what is wrong & fix it. I have played this game on every distro for at least a year inc SolydX & Arch & never had this happen.

Uzi

User avatar
Uzi
Posts: 44
Joined: 27 Dec 2013 08:05

Re: Playonlinux no wine option.

Postby Uzi » 02 Jul 2014 06:08

No one able to offer any help here? Even followed this - http://www.binarytides.com/install-wine-debian-wheezy/ and still Wine does not appear anywhere on the menu or by search.

User avatar
Uzi
Posts: 44
Joined: 27 Dec 2013 08:05

Re: [SOLVED] Playonlinux no wine option.

Postby Uzi » 02 Jul 2014 06:51

After exhausting every option, I looked down the list of 'open with' options and again Wine not listed but Playonlinux was. never tried this before so i selected it....and bingo, game launched. Weird but I have my game working as it should and always has.

User avatar
Uzi
Posts: 44
Joined: 27 Dec 2013 08:05

Re: [NOT SOLVED] Playonlinux no wine option.

Postby Uzi » 02 Jul 2014 07:59

Aarrgh - frustration overload. game launched ok but resolution was wrong. Bottom controls not visible. Changed the in game res & now doesn't work again. Just get black window. This is crazy I have never had a problem with this game using various Linux distros but now....!!! This is a deal breaker. I need to get it working.

User avatar
smackthepony
Posts: 147
Joined: 28 Oct 2013 13:49
Location: the low countries

Re: [NOT SOLVED] Playonlinux no wine option.

Postby smackthepony » 02 Jul 2014 10:15

If you rightclick on the file you wish to open with wine ==> select open with and point to /usr/bin/wine it should appear in your dialog menu (at least on KDE it does)
Snapshot1.jpg
Image

User avatar
Uzi
Posts: 44
Joined: 27 Dec 2013 08:05

Re: [NOT SOLVED] Playonlinux no wine option.

Postby Uzi » 02 Jul 2014 11:31

Open with only gives a list of apps & Wine is not on the list.

User avatar
smackthepony
Posts: 147
Joined: 28 Oct 2013 13:49
Location: the low countries

Re: [NOT SOLVED] Playonlinux no wine option.

Postby smackthepony » 02 Jul 2014 11:36

Uzi wrote:Open with only gives a list of apps & Wine is not on the list.
it's neither on KDE you have to manually navigate to /usr/bin/wine
Image

User avatar
Uzi
Posts: 44
Joined: 27 Dec 2013 08:05

Re: [NOT SOLVED] Playonlinux no wine option.

Postby Uzi » 02 Jul 2014 11:51

I dont know how to do that. There is no option to look outside the list except on the web.

User avatar
smackthepony
Posts: 147
Joined: 28 Oct 2013 13:49
Location: the low countries

Re: [NOT SOLVED] Playonlinux no wine option.

Postby smackthepony » 02 Jul 2014 12:18

Uzi wrote:I dont know how to do that. There is no option to look outside the list except on the web.
right click on the .exe file (you should see something like this)
step1.jpg
step1.jpg (43.11 KiB) Viewed 2545 times
next click on the little triangle as shown below
step2.jpg
step2.jpg (39.92 KiB) Viewed 2545 times
type /usr/bin/wine the the box or manually browse to /usr/bin/ and select wine
step3.jpg
step3.jpg (37.27 KiB) Viewed 2545 times
Image

User avatar
Uzi
Posts: 44
Joined: 27 Dec 2013 08:05

Re: [NOT SOLVED] Playonlinux no wine option.

Postby Uzi » 02 Jul 2014 12:45

There is no box or option to type anything. Getting late here. I will check to see if you or anyone has any thoughts in the morning. Thanks for trying.

User avatar
smackthepony
Posts: 147
Joined: 28 Oct 2013 13:49
Location: the low countries

Re: [NOT SOLVED] Playonlinux no wine option.

Postby smackthepony » 02 Jul 2014 13:24

Uzi wrote:There is no box or option to type anything.
In your OP you mentioned SolydX. The above screens were taken from stock 201405 SolydX-live environment in Vbox so either you have a different filemanager or you missed a step.
  • --> navigate to your game directory
    --> right click on the executable
    --> click Open With Other Application
    --> click on the little triangle at the left side of Use a custom command
    --> a box appears where you can type /usr/bin/wine or from the browse button navigate to /usr/bin and select wine
Image

User avatar
Uzi
Posts: 44
Joined: 27 Dec 2013 08:05

Re: [NOT SOLVED] Playonlinux no wine option.

Postby Uzi » 02 Jul 2014 21:30

I see where the problem was. I have Gnome 3 running over SolydX & that box wasn't there. Restarting with XFCE & it was. Didn't work though, still launched to a black screen. I need to rethink this whole thing as something is very wrong.

User avatar
Uzi
Posts: 44
Joined: 27 Dec 2013 08:05

Re: [NOT SOLVED] Playonlinux no wine option.

Postby Uzi » 03 Jul 2014 04:04

Did a complete fresh install on xfce only. Nvidia driver, everything updated, Playonlinux fresh install & no other apps added. Still no Wine listed & using /usr/bin/wine failed again.

Something on the upgrade seems to be breaking POL.

My solution is to Install Debian & see if everything works using stable instead of testing & work from there.

thanks for again for trying to help but VERY disappointed no one else offered any advice :(

yoast
Posts: 138
Joined: 20 Jan 2014 09:54

Re: [NOT SOLVED] Playonlinux no wine option.

Postby yoast » 05 Jul 2014 10:35

On SolydXK I have the following experiences with wine:
1. Using Winetricks to install software (irfanview) will usually get wine as an option under kde-menus.
2. Since I usually use Total Commander (from Ghisler.com) to start my various applications I usually look for a way to install that. If there is a z:\home\<user>\.wine\drive_c\ i will put the install.exe for total commander in there and just run "wine c:\installtotalcmd.exe" from the commandline. That will usually work. From then on I can just use total commander to click on the various esxe-files to install software (sometimes you have to change whetehr an exe is allowed tobe executed in linux with a filemanager like dolphin/krusader/double-commander .).

My approach is different from most becasue I want all my win-software available under one session with one prefix etc. I do not want the Play-on-linux" approach of starting different sessions for all win software.

Unfortunately Solyd does not support WOW64 so you cannot mix 64 and 32 bit applications (this does work under Ubuntu and Fedora). If you really need 64bit apps you will need to set up a diffferent prefix etc.. I just stck to 32bit apps under windows whenever I can. Maybe one day soon I'll switch them all to 64 bit.

I hope this helps.
Winetricks is great.

User avatar
Night Wing
Posts: 445
Joined: 26 Dec 2013 02:46
Location: Texas, USA

Re: [NOT SOLVED] Playonlinux no wine option.

Postby Night Wing » 05 Jul 2014 12:14

Uzi wrote:thanks for again for trying to help but VERY disappointed no one else offered any advice :(
Maybe you weren't offered any advice from other people is because people (like me) don't use Wine and therefore can't offer help.

User avatar
Uzi
Posts: 44
Joined: 27 Dec 2013 08:05

Re: [NOT SOLVED] Playonlinux no wine option.

Postby Uzi » 08 Jul 2014 02:33

Night Wing wrote:
Uzi wrote:thanks for again for trying to help but VERY disappointed no one else offered any advice :(
Maybe you weren't offered any advice from other people is because people (like me) don't use Wine and therefore can't offer help.
With almost 1,700 forum members - I dont think so. :roll:

Anyway found the answer - after trying many distro options, the cause is the Nvidia 331 driver. I installed Debian 7 which still uses the 304 driver & all runs without a hitch.

Maybe this will help others who are not using the latest hardware.

Uzi.


Return to “Software”

Who is online

Users browsing this forum: No registered users and 5 guests