Backupninja failure [SOLVED]

Questions about software.
plaircpa
Posts: 17
Joined: 17 Apr 2014 19:16

Backupninja failure [SOLVED]

Postby plaircpa » 30 Oct 2014 15:06

Anyone using Backupninja?

Since moving from Debian Wheezy my backups fail in backupninja. I am running SolydX home edition. I've got rdiff-backup configured to backup from my solydX machine to a remote computer also running solydX. Here is the logged error

Oct 28 01:00:43 Debug: ssh -o PasswordAuthentication=no jan-offsite -l scott 'echo -n 1'
Oct 28 01:00:48 Fatal: Can't connect to jan-offsite as scott.
Oct 28 01:00:48 Fatal: <<<< finished action /etc/backup.d/91-jan.rdiff: FAILED

I'm guessing that the script did not get the "1" echoed back from the remote. At first I thought the internet was down on one end, but did some checking and that is not the problem. When I run the backup in a terminal using ninjahelper it works normally. I just don't want to rely on manual backups. I also created a script:
"ssh -o PasswordAuthentication=no jan-offsite -l scott 'echo -n 1'"
and put the output in a log file. Indeed, I did get the "1" echoed back in the log. I'm not sure what else to try. Anyone have any ideas?

thanks.

** EDIT **

Just tried logging in manually again, but it failed this time. Apparently there is a difference in using the "su" and "su -l". I copied the keys again after doing a "su -l" and the backup just finished successfully.

Return to “Software”

Who is online

Users browsing this forum: No registered users and 2 guests