Apache not reachable from lan [solved]

Questions about software.
mox
Posts: 23
Joined: 11 Mar 2014 13:37

Apache not reachable from lan [solved]

Postby mox » 31 Oct 2014 16:40

Very confused about Apache 2.4, I'm trying to upgrade from 2.2 config file from Debian to new scratch SolydK- after some experiments I was able to run my cgi, but... from local computer I can refer my cgi using "localhost", "127.0.0.1" or the hostname and it works, but from the lan, using debian or m$, I cannot reach the cgi but also the index.html page is not accessible (and there is no response from apache and the logs don't report anything), so after many other experiments I am starting to think that apache could be rightly configured (or at least the index.html should be visible from local lan - I have not done changes on its configuration). Also ping works, but wget not.
In my researches, when searching typing text into the kde bar I view a "firewall", but when clicking on it nothing happens, so.... Is some firewall installed and not configurable from gui, is some iptables configuration or similar that make my computer not reachable from others in local lan?

Ok, in the scratch installation the firewall is "on" (and in my system only the ssh in opened). The worse is that if I follow the panel of system settings, clicking in the firewall icon brings the control interface and turning off firewall solve my problems, but if in the system kde menu I type "firewall" I see an icon, that clicked... Dohh, nothing happens!

Another strange thing is that in my researches in google the words "firewall solydxk" only brings me to an older post where some where talking about the necessity to integrate the firewall into release.... Argh!

Return to “Software”

Who is online

Users browsing this forum: No registered users and 2 guests