Digikam 4.1 freezes and crashes

Questions about software.
cmf5
Posts: 17
Joined: 12 Mar 2014 14:01

Digikam 4.1 freezes and crashes

Postby cmf5 » 08 Jan 2015 23:44

Digikam is one of the major applications I use, and I have been frustrated lately in getting the latest version (4.1.0) in the Solyd repositories to work. Specifically, the program crashes if I try to set it up with an SQLite database (which may be an SQLite issue, according to the Digikam forums). If I set up the database to use MySQL, my preference anyway, the program freezes if I try to add a collection or do anything else with the configure window (see bug 337737).

In addition, this version of Digikam cannot export directly to Flickr.

The former bug was fixed with version 4.5, and the latter with version 4.2. Apparently the 4.x series of Digikam has been very unstable, but initial reports are that the latest version of 4.6 is much better.

I tried to compile and package version 4.6, but I have been thwarted by some missing dependencies for digikam and some of the kipi-plugins. Unfortunately, this obstacle has stopped some photo projects I'm working on.

Has anyone packaged version 4.6 of digikam (and associated packages digikam-docs, digikam-data, digikam-private-libs, and kipi-plugins) for amd64 as a Wheezy backport? Would anyone want to give this a try and share it with the community?

Thanks.

User avatar
Arjen Balfoort
Site Admin
Posts: 9258
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Digikam 4.1 freezes and crashes

Postby Arjen Balfoort » 09 Jan 2015 09:14

Current version in Debian Jessie is 4.4: https://packages.debian.org/jessie/digikam
You could (temporally) add the Debian Jessie repository to your sources.list and install digikam from there.
I haven't tried it, though, and I don't know if that will solve your problem.

Jessie:

Code: Select all

deb http://ftp.us.debian.org/debian jessie main contrib non-free


SolydXK needs you!
Development | Testing | Translations

cmf5
Posts: 17
Joined: 12 Mar 2014 14:01

Re: Digikam 4.1 freezes and crashes

Postby cmf5 » 09 Jan 2015 14:28

Digikam 4.4 should fix the Flickr upload problem, but I don't expect it to fix the mysql freezing problem (which is the more serious bug that is stopping me in my tracks). That patch wasn't committed until version 4.5.

I was considering switching to Linux Mint 17.1, but that is at Digikam 4.3.5, which wouldn't help the freezing. There is a ppa of the latest stable Digikam (4.6) available for Ubuntu though, so I guess I could use it with Mint.

At this point, I am thinking about downgrading to digikam/kipi-plugins 3.5 or so. Do you know how I could obtain those older debs to try out?

On a related note, I was curious to know which programs would be backported in the future for SolydK. Will the choice of backports be decided by the Debian project, or will additional backports be available for SolydK? My vote would be to include the most recent versions of libreoffice, digikam, and maybe gramps.

User avatar
Arjen Balfoort
Site Admin
Posts: 9258
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Digikam 4.1 freezes and crashes

Postby Arjen Balfoort » 09 Jan 2015 14:40

Downgrading I don't know. Wheezy has version 2.6. So, that's not it. I think you'll have to build from source to get what you need.

I haven't decided on the backports yet.


SolydXK needs you!
Development | Testing | Translations

cmf5
Posts: 17
Joined: 12 Mar 2014 14:01

Re: Digikam 4.1 freezes and crashes

Postby cmf5 » 09 Jan 2015 14:53

Didn't SolydK offer some versions of digikam between 2.6 and the current 4.1? I seem to remember that.

Thanks for the clarification re: backports.

User avatar
Arjen Balfoort
Site Admin
Posts: 9258
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Digikam 4.1 freezes and crashes

Postby Arjen Balfoort » 09 Jan 2015 17:54

cmf5 wrote:Didn't SolydK offer some versions of digikam between 2.6 and the current 4.1? I seem to remember that.
I don't save previous repositories. I'm already using an insane amount of disk space on my ISP's servers.


SolydXK needs you!
Development | Testing | Translations

User avatar
Orbmiser
Posts: 829
Joined: 24 Aug 2013 22:58
Location: Portland,Oregon

Re: Digikam 4.1 freezes and crashes

Postby Orbmiser » 10 Jan 2015 07:32

cmf5 wrote:
I was considering switching to Linux Mint 17.1, but that is at Digikam 4.3.5, which wouldn't help the freezing. There is a ppa of the latest stable Digikam (4.6) available for Ubuntu though, so I guess I could use it with Mint.
Same kind of things forced me to move from Debian based. As need newer versions of Kernel,Krita & Gimp that supported my Huion Graphics tablet. So went to Netrunner rolling Manjaro Arch based. Right now have Digikam version 4.5.0-4 regular repo and Yaourt has 4.6.0.400. Wouldn't think Mint would be that minty fresh? Just a suggestion. As was always seem to be running into versions lags that had production stopping bugs for this or that app.
.
Portfolio
http://500px.com/Orbmiser
Flickr
http://www.flickr.com/photos/orb9220/

SolydK - Kernel 3.16-2-amd64 - KDE 4.14.1 Update Pack: 2014.10.15

User avatar
grizzler
Posts: 2160
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: Digikam 4.1 freezes and crashes

Postby grizzler » 10 Jan 2015 07:32

Do you know how I could obtain those older debs to try out?
There's always the Debian Snapshot archive: http://snapshot.debian.org/package/digikam/

No idea about dependency issues, though.
Frank

SolydX EE 64 - tracking Debian Testing


Return to “Software”

Who is online

Users browsing this forum: No registered users and 5 guests