Unable to start Virtualbox - SOLVED

Questions about software.
User avatar
iridesce
Posts: 30
Joined: 14 Jan 2014 04:45
Location: Halfway between the mountains and the ocean, the rainforest and the volcano

Unable to start Virtualbox - SOLVED

Postby iridesce » 07 Jul 2015 22:29

Code: Select all

Failed to create the VirtualBox COM object.

The application will now terminate.



Start tag expected, '<' not found.

Location: '/home/user/.VirtualBox/VirtualBox.xml', line 1 (0), column 1.

/build/virtualbox-_9gFzh/virtualbox-4.1.18-dfsg/src/VBox/Main/src-server/VirtualBoxImpl.cpp[484] (nsresult VirtualBox::init()).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: VirtualBox
Interface: IVirtualBox {c28be65f-1a8f-43b4-81f1-eb60cb516e66}
was what I was faced with as I attempted to start Virtualbox (see below )

What had gone before:

Today I had been running my work machine as usual and had an XP installation in Virtualbox running.
I noticed that outside of Virtualbox that my system was eating up memory at the rate of ~ 200 MB every couple of minutes.

I tried finding the big files using the FileSizeView in Konqueror and kcore seemed to be the largest 131,072 GB. A little research and found that this is a virtual file, so not an issue.

I tried shutting down and rebooting and wasn't able to boot into my user. So I booted into root.

A little more research and I found that often syslog and kernlog can be problems. Sure enough syslog.1 and kernlog were each at 19.1GB. The recommendation was to check those log files, which I tried and was unsuccessful. My guess is that as the available memory was zero, that kate couldn't open a file that large.

I understood that any .# or .gz files were rotated log files and that those could be deleted without serious harm other than a loss of old log files.

So, I deleted syslog.1 as there was a syslog. I did not delete kernlog as my understanding is that it is currently running.

I checked logrotate.conf and it looked fine and is set for weekly rotating. Checking the dates of kernlog ( 7/7/15 ) and kernlog.1 ( 7/2/15 ), it appears that that will rotate in the next day or two.

syslog is also currently fine at 373 KiB
kernlog is still at 19.1 GB

I shutdown and was able to reboot into the user fine. Though when I attempted to start Virtualbox, I received the above error message.

I should note that my machine has been running fine for the past couple of months and had not been shutdown during that period until this morning.

My next guess is that when the kernel was updated recently that may have affected how Virtualbox starts.

I did try

Code: Select all

aum ~ # modprobe vboxdrv
aum ~ # modprobe vboxnetflt
aum ~ # 
and then tried to start Virtualbox again resulting in the same lack of joy

The last couple of upgrades per Synaptic

Code: Select all

Commit Log for Tue Jul  7 13:34:38 2015


Upgraded the following packages:
bind9-host (1:9.8.4.dfsg.P1-6+nmu2+deb7u4) to 1:9.8.4.dfsg.P1-6+nmu2+deb7u5
cups-filters (1.0.18-2.1+deb7u1) to 1.0.18-2.1+deb7u2
dnsutils (1:9.8.4.dfsg.P1-6+nmu2+deb7u4) to 1:9.8.4.dfsg.P1-6+nmu2+deb7u5
libbind9-80 (1:9.8.4.dfsg.P1-6+nmu2+deb7u4) to 1:9.8.4.dfsg.P1-6+nmu2+deb7u5
libcupsfilters1 (1.0.18-2.1+deb7u1) to 1.0.18-2.1+deb7u2
libdns88 (1:9.8.4.dfsg.P1-6+nmu2+deb7u4) to 1:9.8.4.dfsg.P1-6+nmu2+deb7u5
libisc84 (1:9.8.4.dfsg.P1-6+nmu2+deb7u4) to 1:9.8.4.dfsg.P1-6+nmu2+deb7u5
libisccc80 (1:9.8.4.dfsg.P1-6+nmu2+deb7u4) to 1:9.8.4.dfsg.P1-6+nmu2+deb7u5
libisccfg82 (1:9.8.4.dfsg.P1-6+nmu2+deb7u4) to 1:9.8.4.dfsg.P1-6+nmu2+deb7u5
liblwres80 (1:9.8.4.dfsg.P1-6+nmu2+deb7u4) to 1:9.8.4.dfsg.P1-6+nmu2+deb7u5
libwmf-bin (0.2.8.4-10.3) to 0.2.8.4-10.3+deb7u1
libwmf0.2-7 (0.2.8.4-10.3) to 0.2.8.4-10.3+deb7u1

Code: Select all

Commit Log for Mon Jun 29 21:21:36 2015


Upgraded the following packages:
libcrypto++9 (5.6.1-6) to 5.6.1-6+deb7u1
linux-headers-3.2.0-4-amd64 (3.2.68-1+deb7u1) to 3.2.68-1+deb7u2
linux-headers-3.2.0-4-common (3.2.68-1+deb7u1) to 3.2.68-1+deb7u2
linux-image-3.2.0-4-amd64 (3.2.68-1+deb7u1) to 3.2.68-1+deb7u2
linux-libc-dev (3.2.68-1+deb7u1) to 3.2.68-1+deb7u2
python-gnupg-ng (1.2.5.1+0~20141111221632.20+wheezy~1.gbp94b932) to 2.0.2-2+0~20150626222249.23+wheezy~1.gbpc21cdb
unattended-upgrades (0.79.5+wheezy1) to 0.79.5+wheezy2

So, before I attempt to reinstall Virtualbox, I wanted to ask for your take on my current situation and find out if there is another way to repair the connection between the OS and Virtualbox so I don't have to reinstall Virtualbox, the XP installation.

Thanks for taking the time to read through this and help in any way possible

Code: Select all

$ inxi -Fxx
System:    Host: aum Kernel: 3.2.0-4-amd64 x86_64 (64 bit gcc: 4.6.3) 
           Desktop: KDE 4.8.4 (Qt 4.8.2) dm: kdm Distro: SolydXK 1 testing 
Machine:   System: Dell product: Precision WorkStation T3400 Chassis: type: 7
           Mobo: Dell model: 0TP412 Bios: Dell v: A08 date: 08/14/2008
CPU:       Dual core Intel Core2 Duo E4600 (-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 ssse3) bmips: 9576 
           Clock Speeds: 1: 2394 MHz 2: 2394 MHz
Graphics:  Card: NVIDIA G86 [Quadro NVS 290]
           bus-ID: 01:00.0 chip-ID: 10de:042f
           Display Server: X.Org 1.12.4 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1680x1050@60.0hz
           GLX Renderer: Gallium 0.4 on NV86
           GLX Version: 2.1 Mesa 8.0.5 Direct Rendering: Yes
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller 
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:293e 
           Sound: Advanced Linux Sound Architecture v: 1.0.24
Network:   Card-1: Atheros AR5416 Wireless Network Adapter [AR5008 802.11(a)bgn]
           driver: ath9k bus-ID: 05:04.0 chip-ID: 168c:0023
           IF: wlan0 state: down mac: 00:1e:e5:a8:72:7a
           Card-2: Broadcom NetXtreme BCM5754 Gigabit Ethernet PCI Express
           driver: tg3 v: 3.121 bus-ID: 04:00.0 chip-ID: 14e4:167a
           IF: eth1 state: up speed: 100 Mbps duplex: full 
           mac: 00:22:19:1b:42:6a
           Card-3: ADMtek NC100 Network Everywhere Fast Ethernet 10/100
           driver: tulip v: 1.1.15-NAPI port: cc00
           bus-ID: 05:05.0 chip-ID: 1317:0985
           IF: eth2 state: down mac: 00:0c:41:e5:0c:33
Drives:    HDD Total Size: 500.1GB (16.2% used)
           ID-1: /dev/sda model: WDC_WD5000AAKS size: 500.1GB serial: WD-WCASY2205563
Partition: ID-1: / size: 97G used: 74G (81%) fs: ext4 dev: /dev/sda6 
           ID-2: swap-1 size: 2.10GB used: 0.00GB (0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 50.0C mobo: N/A gpu: 59.0 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 155 Uptime: 25 min Memory: 888.9/7941.7MB 
           Init: SysVinit v: 2.88 runlevel: 2 default: 2 
           Gcc sys: 4.7.2 alt: 4.4/4.6 
           Client: Shell (bash 4.2.371 running in konsole) inxi: 2.1.28 

User avatar
belze
Posts: 221
Joined: 29 Sep 2014 16:31
Location: Torino, Italy

Re: Unable to start Virtualbox

Postby belze » 08 Jul 2015 07:23

make a backup of virtualbox VMs folder and than try:
  • try to upgrade extensions, if any
  • post the actual complete output of

    Code: Select all

    $ vboxmanage startvm vm_name
  • note:you are using a very old system
  • wait for more experienced users ;)
-------
Image

User avatar
grizzler
Posts: 2171
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: Unable to start Virtualbox

Postby grizzler » 08 Jul 2015 07:39

The error suggests there is something wrong with the file /home/user/.VirtualBox/VirtualBox.xml. What does it look like? Is there a /home/user/.VirtualBox/VirtualBox.xml-prev? What does it look like?
Frank

SolydX EE 64 - tracking Debian Testing

User avatar
iridesce
Posts: 30
Joined: 14 Jan 2014 04:45
Location: Halfway between the mountains and the ocean, the rainforest and the volcano

Re: Unable to start Virtualbox

Postby iridesce » 08 Jul 2015 15:10

Thanks for your help belze and grizzler. :clap:

belze - Grazie
I've been telling my boss that for the past few years. He just says, "We both know its fine, just make sure you keep it backed up".

And the winner is grizzler. Duizendmaal dank
Thanks for the prod kind sir. I am usually pretty good at following error messages and troubleshooting, and I froze when it had something to do with the one application we can't get beyond - quickbooks. in Virtualbox.
You were correct, renaming /home/user/.VirtualBox/VirtualBox.xml-prev and then ( following the subsequent error message ) /home/user/VirtualBox VMs/1405xp/1405_xp.vbox-prev back to their originals ( minus the -prev ) was the solution.

Health, happiness and prosperity to you and yours


Return to “Software”

Who is online

Users browsing this forum: No registered users and 6 guests