system crash after installing gWaei

Questions about software.
axioma
Posts: 5
Joined: 17 Aug 2015 00:56

system crash after installing gWaei

Postby axioma » 21 Aug 2015 06:04

This is the second time I tried to install gWaei, a dictionary for Jap-Eng language. The first time I ended up reinstalling the whole system again. I used Synaptic to install gWaei at the time. This time I used the default package installer and that went without a problem, no warning messages or anything. Than I tried to open Firefox or Thunderbird and it turned out they were uninstalled. This had happened the first time too.

Trying to reinstall the packages gave me an warning about broken packages. After rebooting I tried to install Firefox first in terminal. It gave me the message it was missing the hunspell-en-us packages. After having installed those, I could install and run Firefox again.

Then I tried to install Thunderbird and got this information and I do not have a clue how to fix this, as I have tried to remove earlier packages from /var/cache/apt/archives/ but keeping getting the same error:
sudo apt-get install thunderbird
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
fonts-kanjistrokeorders libmecab2 libwaei2 mecab-ipadic mecab-utils
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
thunderbird
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/42.1 MB of archives.
After this operation, 87.3 MB of additional disk space will be used.
(Reading database ... 318212 files and directories currently installed.)
Preparing to unpack .../thunderbird_38.2.0_amd64.deb ...
preinst called with unknown argument `install'
dpkg: error processing archive /var/cache/apt/archives/thunderbird_38.2.0_amd64.deb (--unpack):
subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/thunderbird_38.2.0_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Does anybody have an idea how to solve this? And how could I install gWaei without breaking my system?

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: system crash after installing gWaei

Postby Zill » 21 Aug 2015 09:32

axioma: Please open a terminal and post the full output from each of the following three commands:

Code: Select all

inxi -r
apt update
apt upgrade -s
In order to make the output easily readable on the forums, please enclose each output in "code" tags. e.g.

Code: Select all

[code]my output text
[/code]Note that there is a "Code" button at the top of the forum editing window which does this automatically for any highlighted text.

User avatar
Arjen Balfoort
Site Admin
Posts: 9284
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: system crash after installing gWaei

Postby Arjen Balfoort » 21 Aug 2015 19:29

You've got this problem because myspell-en-us is a dependency of Firefox and Thunderbird. gWaei seems to have a problem with that and wants to purge that and all packages that depend on myspell-en-us.

I've made some changes in the FF and TB packages and one of those changes is that it makes myspell-en-us a recommended package and not a dependency.

You'll need to clean up your install first:

Code: Select all

sudo apt purge firefox* thunderbird* hunspell-en-us myspell-en-us
Then download the adapted FF and TB you need (including the corresponding adjustments packages from here: http://downloads.solydxk.nl/dev/tb/
Install those packages and check that gWaei is installed and that all packages function as expected.

Please, report back and if everything went fine, I can add them to our repository.


SolydXK needs you!
Development | Testing | Translations

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: system crash after installing gWaei

Postby Zill » 21 Aug 2015 19:38

Well spotted Boss! ;-)

axioma
Posts: 5
Joined: 17 Aug 2015 00:56

Re: system crash after installing gWaei

Postby axioma » 22 Aug 2015 05:39

Got it to work!

I first purged FF, TB, Hunspell and Myspell as you suggested. Then I installed gWaei first with all the needed dictionaries.
Reinstalling FF was no problem and worked fine. Then I tried to reinstall TB with GDebi but got an error again. Fortunately, it said because it needed Myspell. So, I first installed Myspell and after that tried TB again. This time it installed without a problem. Now, all three the programs work fine.

Installed; firefox_40.0.2xk1_amd64.deb
firefox-solydxk-adjustments_40.0.2_all.deb
thunderbird_38.2.0xk1_amd64.deb
thunderbird-solydxk-adjustments_38.2.0_all.deb

Thanks for figuring this one out... :D

lilgman
Posts: 40
Joined: 04 Oct 2013 13:53
Location: Lesotho, Africa

Re: system crash after installing gWaei

Postby lilgman » 22 Sep 2015 08:25

This solution also worked for me even though my problem was completely unrelated to gWaei.

I love SolydX!


Return to “Software”

Who is online

Users browsing this forum: No registered users and 3 guests