Page 1 of 1

[v86d] causes High processor usage [solved]

Posted: 03 Mar 2017 18:28
by falke
Hi,

I realize that I have one user process running whick uses alone 50 % of the processor (v86)

it seems that this package is unusefull if im not running a live session

[quote][Re: Adding new Plymouth themes

Postby Schoelje ยป 04 May 2013 15:53

You can purge v86d.
It's only used for Plymouth in live mode. So, there's no need for it on a installed system.


SolydXK needs you!
Development | Testing | Translations | Todo list
/quote]

I have debian plymouth manager installed should I uninstall it (v86d) nevertheless ?

Re: [v86d]

Posted: 03 Mar 2017 20:56
by Zill
falke: I do have v86d installed on my SolydX 32-bit system, but I have also disabled plymouth.

I don't see any user process running as a result of having v86d installed and so, as this package is only 98kB in size, I cannot see any reason to remove it.

Are you sure that v86d is the cause of your high CPU usage? I doubt if this is the case but you should be able to remove this package if you wish to as it does not seem to have any reverse depends...

Code: Select all

roger@dino:~$ apt rdepends v86d
v86d
Reverse Depends:

Re: [v86d]

Posted: 03 Mar 2017 21:05
by falke
v86d
Reverse Depends:
v86d:i386

sometimes it consumes 100 %

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
104 root 20 0 7384 680 580 R 100,0 0,0 70:57.13 v86d

Re: [v86d]

Posted: 04 Mar 2017 10:11
by grizzler
It's a bit of a mess, it seems. Appears to be abandoned upstream as well: https://tracker.debian.org/pkg/v86d
Known to cause problems ("CPU hogging", anyone?): https://bugs.debian.org/cgi-bin/bugrepo ... bug=809062

Indeed, in this thread, Arjen suggested it isn't needed on an installed system (It's not present on mine).
Yet it's on all the ISOs and not in the list of packages to remove after installation (boot/live/filesystem.packages-remove). So what's that about...?

Re: [v86d]

Posted: 04 Mar 2017 12:22
by Zill
FWIW, I also have v86d installed on a LMDE2 (Mint - Debian jessie) system. However, my two CrunchBang Waldorf (now Debian wheezy) systems do not have v86d installed!

I'm not quite sure why v86d is needed on any system... :?

Re: [v86d] causes High processor usage

Posted: 05 Mar 2017 16:15
by ilu
I don't have v86d on my 2013 system but on my 2015 system it's installed. This should go into the bug fixing section.

Re: [v86d] causes High processor usage

Posted: 05 Mar 2017 22:36
by xendistar
A new version has just come in to Debian testing (solydXK EE) it is now version 0.1.10-1+b1. Guess it will make it into Debian Stretch

Re: [v86d] causes High processor usage

Posted: 06 Mar 2017 06:08
by falke
I've uninstall this (for me unusefull package)

Seems to be usefull when you have nvidia proprietary installed in conjonction (with plymouth or not) in order to have smoother graphical during the boot process..

buggy package should be removed from stable editions , isn't it ?

Re: [v86d] causes High processor usage

Posted: 06 Mar 2017 07:20
by grizzler
xendistar wrote:A new version has just come in to Debian testing (solydXK EE) it is now version 0.1.10-1+b1. Guess it will make it into Debian Stretch
Probably, but it's essentially still the old, unmaintained 2011 version. The +b1 part of the version number indicates a so called binary non maintainer upload. You'll see a lot of those during the freeze.