Page 1 of 1

Vivaldi video on all sites after problem

Posted: 05 Jul 2017 12:56
by rijnsma
I hope this can be of help:

Vivaldi (which is a nice browser overall in my opinion) did not display video on some sites.
It appeared to be codecs.

Solution with thanks to lamarca:

@lamarca said in Still no video on certain sites:

Your distro does not provide that package (when it's ubuntu thing). I use the archlinux herecura repo:
If you are using x86_64, download the package below:

https://repo.herecura.eu/herecura/x86_6 ... pkg.tar.xz

extract the package
install the libffmpeg.so issuing the following command:

sudo install libffmpeg.so /opt/vivaldi

or /opt/vivaldi-snapshot
At install be in the directory you downloaded in!

After that all works fine.

Re: Vivaldi video on all sites after problem

Posted: 05 Jul 2017 17:00
by ilu
The package ffmpeg is part of debian 8 (https://packages.debian.org/search?lang ... rds=ffmpeg) and 9 (https://packages.debian.org/search?lang ... rds=ffmpeg). Did you try installing one of them?

Your solution can very well lead to problems with dependencies and updates. I wouldn't recommend installing libraries from other systems because you can't count on debians stability anymore.

Shouldn't Vivaldi be able to use the debian packages?

Re: Vivaldi video on all sites after problem

Posted: 05 Jul 2017 19:12
by rijnsma
I like the browser.
I couldn't get it working on certain sites for about 4 months. Only an old version of Vivaldi did right.(Think of something simple like newsbulletins on nos.nl, familiar to you I suspect. Or video-tests on the web.) Now it does.
The package ffmpeg is part of debian 8 (https://packages.debian.org/search?lang ... rds=ffmpeg) and 9 (https://packages.debian.org/search?lang ... rds=ffmpeg). Did you try installing one of them?
Yes. Not working. I don't know why. I did a lot whith Chromium and Chrome also. They did work alright and why Vivaldi not? Chromium-based I believe? Earlier another solution was handed to me, but it did work only for a rather short period of time.

Thank you for warning.
But I understand. That's why I wrote at opening:
I hope this can be of help:
;)

I did not yet notice degrading stabillity or something like it. Solydx 8 still working great.

Re: Vivaldi video on all sites after problem

Posted: 06 Jul 2017 16:08
by ilu
You won't see any effects now - and maybe, hopefully, never. Problems might start if another program wants to (correctly) install the same library from debian and can't. You'll have to watch out for that.

Upon further inspection it seems that this library is not part of debians ffmpeg package, so most probably no conflict.

Re: Vivaldi video on all sites after problem

Posted: 06 Jul 2017 17:11
by rijnsma
Thanks for the tip, guys! Then I know where that problem comes from. ;)
For now I'm happy.

Re: Vivaldi video on all sites after problem

Posted: 07 Jul 2017 02:38
by kurotsugi
the problem seems have been solved. please allow me to add a small note. your mod will gone on ffmpeg update. i.e: when debian update their ffmpeg, your ffmpeg will get overwriten. if vivaldi video broken again, you can simply redo this mod again.

Re: Vivaldi video on all sites after problem

Posted: 07 Jul 2017 14:17
by rijnsma
O.k. dank, Arjen. ;)

Re: Vivaldi video on all sites after problem

Posted: 07 Jul 2017 14:25
by Arjen Balfoort
rijnsma wrote:O.k. dank, Arjen. ;)
You're welcome...but...I haven't done a thing... :D

Re: Vivaldi video on all sites after problem

Posted: 07 Jul 2017 18:51
by rijnsma
Ach.. 'goede raad is duur' met een nieuw langdurig protesterend softwaretje, als ik geen expert ben en dat ben ik niet, moet je maar rekenen. :lol: