Page 1 of 1

Widevine on chromium

Posted: 27 Apr 2018 20:25
by ilu
I wanted to watch Netflix but the already installed widevine component wasn't recognised. It seems that debian widevine does not work. This worked:

Code: Select all

sudo mkdir /usr/lib/chromium
sudo mv /usr/lib/chromium
sudo chmod 644 /usr/lib/chromium/
Please notice that, as time goes on, you will have to adjust the name of the downloaded and unzipped widevine version. You can see the current version with . It's difficult to find the download link, so here is a script that has the relevant information: ... 4d29fe37f1. It was developed for vivaldi but should be easily adapted for chromium.

The vivaldi guy says:
Install the package "chromium-codecs-ffmpeg-extra" to provide H.264/MP4 support (used by videos on Netflix). After install, you need to restart Chromium. You can confirm that it is installed and working correctly by going to and checking that the first video listed plays.
Next run the script ( This will create the file "" in "/opt/google/chrome".
Replace the "" provided by Chromium with a symlink to the file from Chrome:

Code: Select all

sudo ln -fs /opt/google/chrome/ /usr/lib/chromium-browser/ 
Note: The path is typically "/usr/lib64/chromium/lib/" on non Debian/Ubuntu based distros.
You can confirm that DRM'd H.264/MP4 content is now playable by going to and trying some of the demos.
Delete any cookies or data associated with Netflix. If you have failed to play videos once, then Netflix stores information about this in a cookie and you won't be able to play vidoes, even once your system is now correctly configured. Another "WTF‽" moment from the Netflix team.
One final point. Every time Chromium upgrades it will replace the symlink with its own file. Thus you will need to remove it and re-create the symlink. I would also suggest re-running at that point, to check for new versions and upgrade if needed.
He also recommends to spoof the user agent but I don't think that's necessary anymore. If you decide to do that use either user-agent-switcher or uMatrix by gorhill. ... er-agents/ has a list of common user agents.

Just in case I'm documenting the script here for reference:

Code: Select all

#!/usr/bin/env bash

available () {
  command -v $1 >/dev/null 2>&1

# Make sure we have wget or curl
if available wget; then
  SILENT_DL="wget -qO-"
elif available curl; then
  SILENT_DL="curl -s"
  LOUD_DL="curl -O"
  echo "Install wget or curl" >&2
  exit 1

# Use the architecture of the current machine or whatever the user has set
# externally
ARCH=${ARCH:-$(uname -m)}

if [ "$ARCH" = "x86_64" ]; then
elif [[ "$ARCH" = i?86 ]]; then
  echo "The architecture $ARCH is not supported." >&2
  exit 1

# Set Output dir

# Set temp dir

# Set staging dir

# Work out the latest Widevine version

# Error out if $VERISON is unset, e.g. because previous command failed
if [ -z $VERSION ]; then
  echo "Could not work out the latest version; exiting" >&2
  exit 1

# Don't start repackaging if the same version is already installed
if [ -e "$WIDEVINE_INSTALL_DIR/widevine-$VERSION" ] ; then
  echo "The latest Widevine ($VERSION) is already installed"
  exit 0

# If the staging directory is already present from the past, clear it down
# and re-create it.
if [ -d "$STAGINGDIR" ]; then
  rm -fr "$STAGINGDIR"

set -e
mkdir -p "$STAGINGDIR"

# Now get the latest widevine zip for the users architecture

# Extract the contents of Widevine package
if available unzip; then
  unzip ${VERSION}-linux-${WIDEVINEARCH}.zip
elif available bsdtar; then
  bsdtar xf ${VERSION}-linux-${WIDEVINEARCH}.zip
  echo "Install unzip or bsdtar" >&2
  exit 1

# Add version number file
touch "widevine-$VERSION"

# Escalate privileges if needed and copy files into place
if [ "$UID" = 0 ]; then
  install -Dm644 "$WIDEVINE_INSTALL_DIR/"
  install -Dm644 widevine-$VERSION "$WIDEVINE_INSTALL_DIR/widevine-$VERSION"
elif [ -r /etc/os-release ] && grep -qx 'ID=ubuntu' /etc/os-release; then
  echo "Calling sudo ... If prompted, please enter your password so Widevine can be copied into place"
  sudo install -Dm644 "$WIDEVINE_INSTALL_DIR/"
  if [ -e "$WIDEVINE_INSTALL_DIR/" ]; then
    sudo install -Dm644 widevine-$VERSION "$WIDEVINE_INSTALL_DIR/widevine-$VERSION"
    echo "Something went wrong installing" >&2
    exit 1
  echo "Please enter your root password so Widevine can be copied into place"
  su -c "sh -c \"install -Dm644 $WIDEVINE_INSTALL_DIR/ && install -Dm644 widevine-$VERSION $WIDEVINE_INSTALL_DIR/widevine-$VERSION\""

# Tell the user we are done
echo "Widevine ($VERSION) installed into $WIDEVINE_INSTALL_DIR"

Re: Widevine on chromium

Posted: 27 Apr 2018 23:24
by patzy
It didn't work for me. :cry:

Re: Widevine on chromium

Posted: 28 Apr 2018 00:19
by ilu
I have the debian package installed - I kept it - and then just did the terminal commands, restarted chromium and it worked. What error message do you see - in terminal and from Netflix?

Re: Widevine on chromium

Posted: 29 Apr 2018 10:23
by patzy
ilu wrote:
28 Apr 2018 00:19
I have the debian package installed - I kept it - and then just did the terminal commands, restarted chromium and it worked. What error message do you see - in terminal and from Netflix?
I installed chromium from the Solyd repos, so I suppose I have the debian version as well. I got no error from chromium and the usual "oops!" missing component stuff from netflix, - no detail on what is missing.
When I did the terminal commands I got no error messages.

Chromium has some updates today, I installed them but the same thing happened when I tried to watch netflix.
Nope it still didn't work.
Any thoughts on what might be 'missing'?

Re: Widevine on chromium

Posted: 29 Apr 2018 18:16
by ilu
Login and browsing films always worked. Upon starting a film I got the message from netflix that, oops, widevine was missing although I had installed it from debian. That was fixed by extracting the widevine component from the google download and copying it via the terminal commands. Problem is that chromium has absolutely no debugging mechanism for widevine.

Maybe the recently updated chromium needs another widevine version now? There is none. I can't seem to find a proper download page. I've edited my first post, have a look again.

Re: Widevine on chromium

Posted: 03 May 2018 14:11
by ilu
You might need to delete cookies.