Page 1 of 1

Is there an issue with exim4?

Posted: 06 Jan 2020 03:27
by troypulk

Code: Select all

Errors were encountered while processing:
 exim4-config
 exim4-base
 exim4
 exim4-daemon-light
E: Sub-process /usr/bin/dpkg returned an error code (1)
Just tried an update using apt

Thanks

EDIT:

I think I found the issue

Code: Select all

Installing new version of config file /etc/exim4/exim4.conf.template ...
/usr/sbin/exim4: /lib64/libcrypt.so.1: version `XCRYPT_2.0' not found (required by /usr/sbin/exim4)

Code: Select all

dpkg: error processing package exim4-base (--configure):
 dependency problems - leaving unconfigured
I was under the impression that if a package was not ready for install for this issue it would be held back until the dependency was installed.

Re: Is there an issue with exim4?

Posted: 06 Jan 2020 15:17
by Arjen Balfoort
I did not have any problems installing exim4 on SolydX 10.

I found the libcrypt here:

Code: Select all

$ dpkg -S libcrypt.so.1
libc6:i386: /lib/i386-linux-gnu/libcrypt.so.1
libc6:amd64: /lib/x86_64-linux-gnu/libcrypt.so.1
Note that exim4 is not installed by default on SolydXK. So, I only could do a clean install of exim4, but I tried to simulate your situation by installing an older version first and upgrade that. Still no errors.

I found this article with a possible solution: https://unix.stackexchange.com/question ... ersion-xcr

Re: Is there an issue with exim4?

Posted: 07 Jan 2020 02:07
by troypulk
Thanks I'll look into it further.

The error message I posted:

Code: Select all

/usr/sbin/exim4: /lib64/libcrypt.so.1: version `XCRYPT_2.0' not found (required by /usr/sbin/exim4)
says that XCRYPT_2.0 is missing and required for exim4.

Re: Is there an issue with exim4?

Posted: 07 Jan 2020 02:40
by troypulk
I did this:

Code: Select all

sudo dpkg --configure -a
[sudo] password for troypulk: 
Setting up exim4-config (4.93-5) ...
/usr/sbin/exim4: /lib64/libcrypt.so.1: version `XCRYPT_2.0' not found (required by /usr/sbin/exim4)
Invalid new configfile /var/lib/exim4/config.autogenerated.tmp, not installing 
/var/lib/exim4/config.autogenerated.tmp to /var/lib/exim4/config.autogenerated
dpkg: error processing package exim4-config (--configure):
 installed exim4-config package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of exim4-base:
 exim4-base depends on exim4-config (>= 4.82) | exim4-config-2; however:
  Package exim4-config is not configured yet.
  Package exim4-config-2 is not installed.
  Package exim4-config which provides exim4-config-2 is not configured yet.

dpkg: error processing package exim4-base (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of exim4:
 exim4 depends on exim4-base (<< 4.93-5.1); however:
  Package exim4-base is not configured yet.
 exim4 depends on exim4-base (>= 4.93-5); however:
  Package exim4-base is not configured yet.

dpkg: error processing package exim4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of exim4-daemon-light:
 exim4-daemon-light depends on exim4-base (>= 4.93); however:
  Package exim4-base is not configured yet.

dpkg: error processing package exim4-daemon-light (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 exim4-config
 exim4-base
 exim4
 exim4-daemon-light
I'm not sure why exim4 was installed so I deleted it, no more issue.

If something comes of it I'll reinstall it.

Re: Is there an issue with exim4?

Posted: 07 Jan 2020 17:24
by ilu
We have purged exim on newer ISOs but of course its still present on older installs. If you don't need it purging is best.