Latest Waterfox Classic and SolydX 9

Questions about software.
dclement
Posts: 44
Joined: 14 Mar 2013 10:34
Location: France

Latest Waterfox Classic and SolydX 9

Postby dclement » 13 Jan 2020 14:59

Hello,

A couple of days ago, Waterfox Classic was updated to 2020.01-1. But afterwards, it would't start:

Code: Select all

daniel@e6330d:~$ /opt/waterfox-classic/waterfox
XPCOMGlueLoad error for file /opt/waterfox-classic/libnspr4.so:
/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.30' not found (required by /opt/waterfox-classic/libnspr4.so)
Couldn't load XPCOM.
Could this be solved (with perhaps a clever symlink?), or is my system to old for the latest Waterfox Classic? (I'm still under SolydX 9, I'll only update everything next summer.)

TIA - best regards, Daniel

User avatar
ilu
Posts: 2602
Joined: 09 Oct 2013 12:45

Re: Latest Waterfox Classic and SolydX 9

Postby ilu » 14 Jan 2020 02:27

Thank you for your report.

This seems to be a known issue: https://github.com/MrAlex94/Waterfox/is ... -573793752 for Ubuntu 18.10. It would help if you reported it on Github for Debian9. It's probably the same for Debian10.

I'm still at 1912 and I'll hold off updating. Arjen, could you please upload v. 1912 again so everybody can roll back?

User avatar
Arjen Balfoort
Site Admin
Posts: 9381
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Latest Waterfox Classic and SolydX 9

Postby Arjen Balfoort » 14 Jan 2020 10:22

waterfox-classic 2020.01 on solydxk-10 installs fine.

I have rebuilt waterfox-classic 2019.12 and uploaded the packages for solydxk-8 and solydxk-9 only, leaving waterfox-classic 2020.01 for solydxk-10 and solydxk-11.

Let me know if this solves this issue.


SolydXK needs you!
Development | Testing | Translations

dclement
Posts: 44
Joined: 14 Mar 2013 10:34
Location: France

Re: Latest Waterfox Classic and SolydX 9

Postby dclement » 14 Jan 2020 13:33

ilu wrote:
14 Jan 2020 02:27
[...] This seems to be a known issue: https://github.com/MrAlex94/Waterfox/is ... -573793752 for Ubuntu 18.10.
Hmm... Now that I've read that, I no longer think it's trivial!
It would help if you reported it on Github for Debian9. It's probably the same for Debian10. [...]
I'll do that ASAP.
Arjen Balfoort wrote:
14 Jan 2020 10:22
[...]I have rebuilt waterfox-classic 2019.12 and uploaded the packages for solydxk-8 and solydxk-9 only, leaving waterfox-classic 2020.01 for solydxk-10 and solydxk-11.

Let me know if this solves this issue.
Sure works, that's what I had done in the 1st place (rolling back). Now with the latest build of waterfox-classic 2019.12 installed, everything is just as fine, and waterfox-classic 2020.01 no longer appears among the proposed updates.

Thanks to both!

User avatar
ilu
Posts: 2602
Joined: 09 Oct 2013 12:45

Re: Latest Waterfox Classic and SolydX 9

Postby ilu » 14 Jan 2020 19:07

@Arjen: 2020.01 installs fine, but it does not run for me on SolydX10:

Code: Select all

/opt/waterfox-classic-test/waterfox  %u -p Test -no-remote
XPCOMGlueLoad error for file /opt/waterfox-classic-test/libnspr4.so:
/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.30' not found (required by /opt/waterfox-classic-test/libnspr4.so)
Couldn't load XPCOM.

ldd --version
ldd (Debian GLIBC 2.28-10) 2.28
Copyright (C) 2018 Free Software Foundation, Inc. <snip>
I downloaded the latest version from waterfox.net/releases. The tar.gz file from our repo is identical. I could not try the .deb from our repo because I need my main browser in working order. But I'm sure its the same anyway.

It seems that Alex Kontos used a cutting edge build system and I'm hoping that he will correct this mistake. I added our report on github.

dclement
Posts: 44
Joined: 14 Mar 2013 10:34
Location: France

Re: Latest Waterfox Classic and SolydX 9

Postby dclement » 15 Jan 2020 11:30

ilu wrote:
14 Jan 2020 19:07
[...]
It seems that Alex Kontos used a cutting edge build system and I'm hoping that he will correct this mistake. I added our report on github.
Not many distros must have glibc 2.30!

Alex Kontos has issued a tweet saying he was aware of the problem, so we can expect a fix pretty soon.

User avatar
Arjen Balfoort
Site Admin
Posts: 9381
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Latest Waterfox Classic and SolydX 9

Postby Arjen Balfoort » 15 Jan 2020 12:56

I have replaced all waterfox-classic packages with version 2019.12-4.

I see that the waterfox-current version has the same problem but I am unable to find older sources to build.


SolydXK needs you!
Development | Testing | Translations

User avatar
grizzler
Posts: 2197
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: Latest Waterfox Classic and SolydX 9

Postby grizzler » 15 Jan 2020 16:11

The previous version of the binary (waterfox-current_2019.10-3_amd64.deb) was still in my system's cache, so I downgraded. If anyone needs a copy, let me know.
Frank

SolydX EE 64 - tracking Debian Testing

User avatar
Arjen Balfoort
Site Admin
Posts: 9381
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Latest Waterfox Classic and SolydX 9

Postby Arjen Balfoort » 15 Jan 2020 19:32

I do! :mrgreen:

I could use that to replace the current version in the repositories.


SolydXK needs you!
Development | Testing | Translations

User avatar
grizzler
Posts: 2197
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: Latest Waterfox Classic and SolydX 9

Postby grizzler » 15 Jan 2020 22:07

Right. Here it is: https://duinsoft.nl/pkg/pool/all/waterf ... _amd64.deb

SHA256: b1cba1a71dec692a745bba483c24764a6a3b1129fca17b1d741de5c618e6c32a
Frank

SolydX EE 64 - tracking Debian Testing

User avatar
Arjen Balfoort
Site Admin
Posts: 9381
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Latest Waterfox Classic and SolydX 9

Postby Arjen Balfoort » 16 Jan 2020 08:21

Thanks grizzler, that helped.

In the mean time I have rebuild waterfox-current and upped the revision number to 2019.10-4.

Lets hope the next release will be better.

[EDIT]
Posted here: https://solydxk.com/news/waterfox-downgrade
and: viewtopic.php?f=2&t=7751&p=71683


SolydXK needs you!
Development | Testing | Translations


Return to “Software”

Who is online

Users browsing this forum: No registered users and 4 guests