Page 1 of 1

Autoremove Error Message

Posted: 25 Jan 2020 21:24
by troypulk
I was doing an autoremove today and got the following message:

Code: Select all

Processing triggers for glx-alternative-mesa (1.1.0) ...
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/mesa-diverted because link group libGL.so-master is broken
update-alternatives: warning: skip creation of /usr/lib/x86_64-linux-gnu/libEGL.so because associated file /usr/lib/mesa-diverted/x86_64-linux-gnu/libEGL.so (of link group libGL.so-master) doesn't exist
update-alternatives: warning: skip creation of /usr/lib/x86_64-linux-gnu/libGLESv1_CM.so because associated file /usr/lib/mesa-diverted/x86_64-linux-gnu/libGLESv1_CM.so (of link group libGL.so-master) doesn't exist
update-alternatives: warning: skip creation of /usr/lib/x86_64-linux-gnu/libGLESv2.so because associated file /usr/lib/mesa-diverted/x86_64-linux-gnu/libGLESv2.so (of link group libGL.so-master) doesn't exist
update-alternatives: warning: forcing reinstallation of alternative /usr/lib/mesa-diverted because link group glx is broken
update-alternatives: warning: skip creation of /usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1 because associated file /usr/lib/mesa-diverted/x86_64-linux-gnu/libGLESv1_CM.so.1 (of link group glx) doesn't exist
The thing that sticks out is: "mesa-diverted because link group glx is broken"

So what should I do with this?

System Info:
Host: solydx Kernel: 5.4.0-3-amd64 x86_64 bits: 64 compiler: gcc v: 9.2.1 Desktop: Xfce 4.14.2 Distro: solydxk-11 11
Linux solydx 5.4.0-3-amd64 #1 SMP Debian 5.4.13-1 (2020-01-19) x86_64

Thanks

Re: Autoremove Error Message

Posted: 26 Jan 2020 15:47
by ilu
glx is graphics so info about your systems graphics would be helpful. I'm guessing nVidia? Try glxinfo. The driver install might be broken.

Re: Autoremove Error Message

Posted: 26 Jan 2020 18:32
by troypulk

Code: Select all

Graphics: Device-1: Advanced Micro Devices [AMD/ATI] RS880 [Radeon HD 4290] vendor: Micro-Star MSI driver: radeon 
           v: kernel bus ID: 01:05.0 
           Display: x11 server: X.Org 1.20.7 driver: ati,radeon unloaded: fbdev,modesetting,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD RS880 (DRM 2.50.0 / 5.4.0-3-amd64 LLVM 9.0.1) v: 3.3 Mesa 19.3.2 direct render: Yes 

Code: Select all

glxinfo: incomplete
0x4bc 32 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
0x4bd 32 tc  0  32  0 r  y .   8  8  8  8 .  .  0 24  8  0  0  0  0  0 0 None
0x4be 32 tc  0  32  0 r  . .   8  8  8  8 .  s  0  0  0  0  0  0  0  0 0 None
0x4bf 32 tc  0  32  0 r  y .   8  8  8  8 .  s  0  0  0  0  0  0  0  0 0 None
0x4c0 32 tc  0  32  0 r  y .   8  8  8  8 .  s  0  0  0  0  0  0  0  0 0 None
0x4c1 32 tc  0  32  0 r  . .   8  8  8  8 .  s  0 16  0  0  0  0  0  0 0 None
0x4c2 32 tc  0  32  0 r  y .   8  8  8  8 .  s  0 16  0  0  0  0  0  0 0 None
0x4c3 32 tc  0  32  0 r  y .   8  8  8  8 .  s  0 16  0  0  0  0  0  0 0 None
0x4c4 32 tc  0  32  0 r  . .   8  8  8  8 .  s  0 24  0  0  0  0  0  0 0 None
0x4c5 32 tc  0  32  0 r  y .   8  8  8  8 .  s  0 24  0  0  0  0  0  0 0 None
0x4c6 32 tc  0  32  0 r  y .   8  8  8  8 .  s  0 24  0  0  0  0  0  0 0 None
0x4c7 32 tc  0  32  0 r  . .   8  8  8  8 .  s  0 24  8  0  0  0  0  0 0 None
0x4c8 32 tc  0  32  0 r  y .   8  8  8  8 .  s  0 24  8  0  0  0  0  0 0 None
0x4c9 32 tc  0  32  0 r  y .   8  8  8  8 .  s  0 24  8  0  0  0  0  0 0 None
On a side note there appears to be no issues with the graphics.

Re: Autoremove Error Message

Posted: 26 Jan 2020 20:52
by ilu
glxinfo in human readable form would be better for me, that's glxinfo -B - I'm not THAT nerdy. :ugeek:

It should not do any harm to apt install --reinstall glx-alternative-mesa glx-diversions libegl1 libegl1-mesa libegl-mesa0 . That should trigger update-alternatives. Check that you have these packages with dpkg -l first. You might also want to test first by using the -s (simulate) option.

Anyway, if graphics work, do you really need to "fix" anything? Since you are on testing I'm asuming that you know what you are doing. Your graphic setup might differ from mine and I'm not on bullseye.

Re: Autoremove Error Message

Posted: 27 Jan 2020 01:02
by troypulk
Anyway, if graphics work, do you really need to "fix" anything? Since you are on testing I'm asuming that you know what you are doing. Your graphic setup might differ from mine and I'm not on bullseye.
I'm mostly just reporting to see if anything is really wrong with the system, if it doesn't need to be fixed then I will not worry about it, unles something else happens.

Even though I'm using testing it's more about using the latest than I know what I'm doing.