Page 2 of 5

Re: UP - 30/07/2013 12:00 UTC

Posted: 30 Jul 2013 21:47
by GeneC
zerozero wrote:Thanks my friends 8-)

===
===
the only issue so far that i couldn't solve is scrolling in synaptic: just doesn't happen. anyone can replicate it?
Hey 'z'... :D

Nope, scrolls fine here.

Re: UP - 30/07/2013 12:00 UTC

Posted: 30 Jul 2013 22:11
by GeneC
Update Manager says I am updated, but APT ...not...

Code: Select all

sudo apt-get update && sudo apt-get upgrade
[...]

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  libjack-jackd2-0 libjack-jackd2-0:i386
The following packages will be upgraded:
  ia32-libs ia32-libs-i386:i386 solydxk-keyring solydxk-softwaremanager solydxk-sws
5 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Need to get 11.5 MB of archives.
After this operation, 117 kB of additional disk space will be used.
Do you want to continue [Y/n]? 

Re: UP - 30/07/2013 12:00 UTC

Posted: 30 Jul 2013 22:25
by GeneC
What is all this?
Anything to worry about?

Code: Select all

gene@solydx:~$ gksudo medit /etc/apt/sources.list
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
glibtop: Non-standard uts for running kernel:
release 3.9-1-amd64=3.9.0 gives version code 198912

(gksudo:6948): GLib-CRITICAL **: g_str_has_prefix: assertion `str != NULL' failed
MY
"/etc/fonts/conf.d/50-user.conf"

Code: Select all

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
	<!-- Load per-user customization file -->
	<include ignore_missing="yes" prefix="xdg">fontconfig/conf.d</include>
	<include ignore_missing="yes" prefix="xdg">fontconfig/fonts.conf</include>
	<!-- the following elements will be removed in the future -->
	<include ignore_missing="yes" deprecated="yes">~/.fonts.conf.d</include>
	<include ignore_missing="yes" deprecated="yes">~/.fonts.conf</include>
</fontconfig>
==================

EDIT:
All fixed... :mrgreen:

I edited my
"/etc/fonts/conf.d/50-user.conf"
to

Code: Select all

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
	<!-- Load per-user customization file -->
	<include ignore_missing="yes" prefix="xdg">fontconfig/conf.d</include>
	<include ignore_missing="yes" prefix="xdg">fontconfig/fonts.conf</include>
	<!-- the following elements will be removed in the future -->
	<include ignore_missing="yes" deprecated="yes">~/.fonts.conf.d</include>
	<!-- include ignore_missing="yes" deprecated="yes">~/.fonts.conf</include -->
</fontconfig>
note the
<!-- include ignore_missing="yes" deprecated="yes">~/.fonts.conf</include -->
No error messages now.

Code: Select all

gene@solydx:~$ gksudo medit /etc/apt/sources.list
=============

EDIT:
I spoke too soon. It fixed the error messages, but fonts lost some quality.
I have no idea.
Reverting to old
"/etc/fonts/conf.d/50-user.conf"
======================

Re: UP - 30/07/2013 12:00 UTC

Posted: 30 Jul 2013 23:01
by zerozero
updated X-64bit

Code: Select all

zerozero@x64-vb:~$ inxi -S; uname -a
System:    Host x64-vb Kernel 3.9-1-amd64 x86_64 (64 bit) Distro SolydXK 1 solydxk
Linux x64-vb 3.9-1-amd64 #1 SMP Debian 3.9.8-1 x86_64 GNU/Linux
clean, no issues at all

- i use here the default oxygen theme so don't suffer from the gtk3.4/3.8 transition

- no issue also with multiarch mismatch

Code: Select all

zerozero@x64-vb:~$ dpkg -l | grep multiarch
ii  multiarch-support                      2.17-7                        amd64        Transitional package to ensure multiarch compatibility
- scrolling in synaptic works

- no tearing

the VM is in better condition than the host :mrgreen:

Re: UP - 30/07/2013 12:00 UTC

Posted: 30 Jul 2013 23:10
by zerozero
GeneC wrote:What is all this?
interesting, Gene 8-)

Code: Select all

zerozero@x64-vb:~$ cat /etc/fonts/conf.d/50-user.conf
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
	<!-- Load per-user customization file -->
	<include ignore_missing="yes" prefix="xdg">fontconfig/conf.d</include>
	<include ignore_missing="yes" prefix="xdg">fontconfig/fonts.conf</include>
	<!-- the following elements will be removed in the future -->
	<include ignore_missing="yes" deprecated="yes">~/.fonts.conf.d</include>
	<include ignore_missing="yes" deprecated="yes">~/.fonts.conf</include>
</fontconfig>
very similar to yours and

Code: Select all

zerozero@x64-vb:~$ gksu mousepad /etc/apt/sources.list
sh: 1: kde4-config: not found
sh: 1: kde4-config: not found
glibtop: Non-standard uts for running kernel:
release 3.9-1-amd64=3.9.0 gives version code 198912

sh: 1: kde4-config: not found
sh: 1: kde4-config: not found
zerozero@x64-vb:~$ gksudo mousepad /etc/apt/sources.list
sh: 1: kde4-config: not found
sh: 1: kde4-config: not found
glibtop: Non-standard uts for running kernel:
release 3.9-1-amd64=3.9.0 gives version code 198912


Re: UP - 30/07/2013 12:00 UTC

Posted: 30 Jul 2013 23:15
by GeneC
hi 'z'... 8-)

Well it fixed the error message, but I lost font quality in browsers. I went back to stock, and will live with the error messages till I can find a new fix.... :? .... :mrgreen:

I do not get that error message in SolydX-64 tracking SID.

Now I only get this error

Code: Select all

gene@solydx:~$ gksudo medit /etc/apt/sources.list
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
All the SCARY stuff

Code: Select all

glibtop: Non-standard uts for running kernel:
release 3.9-1-amd64=3.9.0 gives version code 198912

(gksudo:6948): GLib-CRITICAL **: g_str_has_prefix: assertion `str != NULL' failed
is gone.... :?:

Re: UP - 30/07/2013 12:00 UTC

Posted: 30 Jul 2013 23:53
by Deleted User 2761
kernel have bug in nouveau-modul

during boot, i think this is normal code

Code: Select all

/var/log/dmesg.0:[    7.810027] fbcon: nouveaufb (fb0) is primary device
/var/log/dmesg.0:[    7.887800] nouveau 0000:02:00.0: fb0: nouveaufb frame buffer device
/var/log/dmesg.0:[    7.887817] nouveau 0000:02:00.0: registered panic notifier
/var/log/dmesg.0:[    7.887839] [drm] Initialized nouveau 1.1.0 20120801 for 0000:02:00.0 on minor 0
and if I want to restart then the nouveau give me this output and the computer will not restart (it hangs in a endless loop]

Code: Select all

/var/log/dmesg.0:[   63.669020] nouveau W[   PFIFO][0000:02:00.0] INTR 0x00000001: 0x00000004
/var/log/dmesg.0:[   91.186664] nouveau W[   PFIFO][0000:02:00.0] INTR 0x00000001: 0x00000004
/var/log/dmesg.0:[   91.399717] nouveau W[   PFIFO][0000:02:00.0] INTR 0x00000001: 0x00000004
/var/log/dmesg.0:[  176.047476] nouveau W[   PFIFO][0000:02:00.0] INTR 0x00000001: 0x00000004
/var/log/dmesg.0:[  226.504478] nouveau W[   PFIFO][0000:02:00.0] INTR 0x00000001: 0x00000004
/var/log/dmesg.0:[  226.506145] nouveau W[   PFIFO][0000:02:00.0] INTR 0x00000001: 0x00000004
/var/log/dmesg.0:[  229.217390] nouveau W[   PFIFO][0000:02:00.0] INTR 0x00000001: 0x00000004
/var/log/dmesg.0:[  229.219071] nouveau W[   PFIFO][0000:02:00.0] INTR 0x00000001: 0x00000004
/var/log/dmesg.0:[  393.544894] nouveau W[   PFIFO][0000:02:00.0] INTR 0x00000001: 0x00000004
/var/log/dmesg.0:[  393.546706] nouveau W[   PFIFO][0000:02:00.0] INTR 0x00000001: 0x00000004
/var/log/dmesg.0:[  397.982987] nouveau W[   PFIFO][0000:02:00.0] INTR 0x00000001: 0x00000004
/var/log/dmesg.0:[  397.984718] nouveau W[   PFIFO][0000:02:00.0] INTR 0x00000001: 0x00000004
/var/log/dmesg.0:[  402.720122] nouveau W[   PFIFO][0000:02:00.0] INTR 0x00000001: 0x00000004
/var/log/dmesg.0:[  402.721855] nouveau W[   PFIFO][0000:02:00.0] INTR 0x00000001: 0x00000004
------------------
------------------

Re: UP - 30/07/2013 12:00 UTC

Posted: 30 Jul 2013 23:57
by Deleted User 2761
@ /etc/fonts/conf.d/50-user.conf

this is my output from sid. its the same in testing.

Code: Select all

crizzly@sid:~/sdb3_Programme_Scripte/FreeFileSync$ ./Free*
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
crizzly@sid:~/sdb3_Programme_Scripte/FreeFileSync$ 

Code: Select all

crizzly@sid:~$ cat -n /etc/fonts/conf.d/50-user.conf
     1  <?xml version="1.0"?>
     2  <!DOCTYPE fontconfig SYSTEM "fonts.dtd">
     3  <fontconfig>
     4          <!-- Load per-user customization file -->
     5          <include ignore_missing="yes" prefix="xdg">fontconfig/conf.d</include>
     6          <include ignore_missing="yes" prefix="xdg">fontconfig/fonts.conf</include>
     7          <!-- the following elements will be removed in the future -->
     8          <include ignore_missing="yes" deprecated="yes">~/.fonts.conf.d</include>
     9          <include ignore_missing="yes" deprecated="yes">~/.fonts.conf</include>
    10  </fontconfig>
crizzly@sid:~$ 
is it a good idea to delete line 9 ? line 7 say: the following elements will be removed in the future but if i deleted line 9 then I have the same problem as GeneC

Re: UP - 30/07/2013 12:00 UTC

Posted: 31 Jul 2013 00:01
by zerozero
@crizzly:
according to Gene, you will loose quality (some) in font rendering.

Re: UP - 30/07/2013 12:00 UTC

Posted: 31 Jul 2013 00:06
by Deleted User 2761
yes, i edit my post.

Re: UP - 30/07/2013 12:00 UTC

Posted: 31 Jul 2013 04:20
by zerozero
zerozero wrote:[...]
the issues in the picture above are (i'm almost sure now) theme related.
once i restored to defaults and rebooted those issues went away; after that i managed to reconstruct almost all the previous desktop again (except bespin, this one triggers the tearing)

===
[...]
i was wrong. the tearing is still present even if less evident. the only way to suppress it is changing from openGL to Xrender (and loosing some desktop effects);
even a newer xserver-xorg-video-intel (from experimental) was useless; has nothing to do with bespin or smaragd.

Re: UP - 30/07/2013 12:00 UTC

Posted: 31 Jul 2013 06:22
by Arjen Balfoort
Crizzly's issue is a deal breaker. I'll take a look at it tonight when I'm back.
In the mean time I'm working with Santa to prepare the packages.solydxk.nl repository.
In theory it should work, but that needs to be tested as well.

Re: UP - 30/07/2013 12:00 UTC

Posted: 31 Jul 2013 11:00
by GeneC
crizzly wrote:@ /etc/fonts/conf.d/50-user.conf

this is my output from sid. its the same in testing.

Code: Select all

crizzly@sid:~/sdb3_Programme_Scripte/FreeFileSync$ ./Free*
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
crizzly@sid:~/sdb3_Programme_Scripte/FreeFileSync$ 

Code: Select all

crizzly@sid:~$ cat -n /etc/fonts/conf.d/50-user.conf
     1  <?xml version="1.0"?>
     2  <!DOCTYPE fontconfig SYSTEM "fonts.dtd">
     3  <fontconfig>
     4          <!-- Load per-user customization file -->
     5          <include ignore_missing="yes" prefix="xdg">fontconfig/conf.d</include>
     6          <include ignore_missing="yes" prefix="xdg">fontconfig/fonts.conf</include>
     7          <!-- the following elements will be removed in the future -->
     8          <include ignore_missing="yes" deprecated="yes">~/.fonts.conf.d</include>
     9          <include ignore_missing="yes" deprecated="yes">~/.fonts.conf</include>
    10  </fontconfig>
crizzly@sid:~$ 
is it a good idea to delete line 9 ? line 7 say: the following elements will be removed in the future but if i deleted line 9 then I have the same problem as GeneC

I have to amend my previous post where I said things were OK in SID. I was wrong. Like Grizzly I get the same error message there.

Code: Select all

gene@solydx64:~$ gksudo medit /etc/apt/sources.list
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
I tested the 'fix' again, and yes i do notice a depreciation of fonts in the browsers (firefox and more in chrome). Fonts are fine everywhere else. Not a big issue as fonts are fine with the error message (and less so with the 'fix')..

Re: UP - 30/07/2013 12:00 UTC

Posted: 31 Jul 2013 11:03
by zerozero
the tearing in HD3000/4000 are documented here and here (it's a bug in kwin that mesa's upgrade to 9.x exposed and was fixed in kde 4.9.3

for the time being the solution in comment 5 allows me to use openGL and almost tear-free.

Re: UP - 30/07/2013 12:00 UTC

Posted: 31 Jul 2013 11:52
by zerozero
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=718415
i guess that this applies to crizzly's situation

Re: UP - 30/07/2013 12:00 UTC

Posted: 31 Jul 2013 14:43
by zerozero
even without 4.10 migration from testing we got several packages that slipped through

Code: Select all

zerozero@home ~ $ dpkg -l | grep 4.10.5
ii  kde-wallpapers-default                 4:4.10.5-1                         all          default wallpaper for the Plasma workspace
ii  ksaneplugin                            4:4.10.5-1                         amd64        KScan plugin for scanning through libksane
ii  libqtruby4shared2                      4:4.10.5-1                         amd64        internal library for Qt 4 Ruby bindings
ii  libsmokebase3                          4:4.10.5-1                         amd64        SMOKE base library
ii  libsmokeqtcore4-3                      4:4.10.5-1                         amd64        Qt Core SMOKE library
ii  libsmokeqtdbus4-3                      4:4.10.5-1                         amd64        Qt D-Bus SMOKE library
ii  libsmokeqtgui4-3                       4:4.10.5-1                         amd64        Qt Gui SMOKE library
ii  libsmokeqtnetwork4-3                   4:4.10.5-1                         amd64        Qt Network SMOKE library
ii  libsmokeqtopengl4-3                    4:4.10.5-1                         amd64        Qt OpenGL SMOKE library
ii  libsmokeqtsql4-3                       4:4.10.5-1                         amd64        Qt Sql SMOKE library
ii  libsmokeqtsvg4-3                       4:4.10.5-1                         amd64        Qt Svg SMOKE library
ii  libsmokeqtwebkit4-3                    4:4.10.5-1                         amd64        Qt WebKit SMOKE library
ii  libsmokeqtxml4-3                       4:4.10.5-1                         amd64        Qt Xml SMOKE library
ii  oxygen-icon-theme                      4:4.10.5-1                         all          Oxygen icon theme
ii  ruby-qt4                               4:4.10.5-1                         amd64        Qt 4 bindings for the Ruby language
ii  ruby-qt4-webkit                        4:4.10.5-1                         amd64        QtWebKit bindings for the Ruby language

Re: UP - 30/07/2013 12:00 UTC

Posted: 31 Jul 2013 15:07
by Arjen Balfoort
I just had a chat with Santa:

He'll probably have KDE 4.10 ready in 3 days. I'll have to add it to our repositories. So, I hope we can start testing the new KDE version in 4 days. This is a first, and changes quite dramatically the UP process. So, be warned that it can take a bit longer than usual.

He also mentioned zerozero's issue:
http://forums.solydxk.nl/viewtopic.php?p=10502#p10502
http://forums.solydxk.nl/viewtopic.php?p=10499#p10499

and that it all points to opus:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=674467

The patch is there but Debian doesn't implement it.
Santa will implement the patch with the next UP.

Re: UP - 30/07/2013 12:00 UTC

Posted: 31 Jul 2013 15:43
by zerozero

Code: Select all

zerozero@home ~ $ dpkg -l | grep opus
ii  libopus0                               1.1~beta-3                         amd64        Opus codec runtime library
and tks for the link; it's one of those moments (together with this one http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=640499 now finally closed after almost 2 years) that we exasperate with debian :mrgreen:

Re: UP - 30/07/2013 12:00 UTC

Posted: 31 Jul 2013 15:56
by GeneC
zerozero wrote:......it's one of those moments ........ that we exasperate with debian :mrgreen:
Yes, and too many of those moments in Debian as of late.
Time for Schoelje to make SolydXK-ARCH (in his spare time).... :lol:

Re: UP - 30/07/2013 12:00 UTC

Posted: 31 Jul 2013 15:59
by Arjen Balfoort
2 years?
I know that the Debian way is stable, but slow...but two years is very long.
However, now that we run this little project, I understand that (development) time is a very scarce thing.