UP - 29/09/2013 [TESTING][DONE]

SolydXK is too quiet for you? SolydXK Enthusiast Editions, based on Debian Testing is for you! Here you can find news about Debian Testing and Unstable too, and also tests on SolydXK programs.
The support for SolydXK EE is provided by the community.
User avatar
Santa
Posts: 16
Joined: 09 Jun 2013 23:39

Re: UP - 29/09/2013 [TESTING]

Postby Santa » 04 Oct 2013 17:29

Schoelje wrote:I just updated kget, kopete, libktorrent, libkopete and removed xserver-xorg-video-chips from the repository.
I then tested it on SolydK64 with UM: no issues.
Thanks a lot. I have another couple of updates:

One is kdelibs; I have changed this package recently in siduction to use udisks2 instead of udisks version 1, however while kdelibs with udisks2 works perfectly for me, for some people it couldn't detect correctly their storage devices like card readers, cdroms and such. So my plan is: revert this change now and switch to udisks2 once we have solved the issues.

The other one is plasma-widget-smooth-tasks; someone reported a few hours ago that it wasn't uninstallable. It seems it's a bug inherited from debian.
Sometimes, standing for what you believe means standing alone.

User avatar
Arjen Balfoort
Site Admin
Posts: 9165
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby Arjen Balfoort » 04 Oct 2013 20:54

The repository is updated.


SolydXK needs you!
Development | Testing | Translations

Mr. B
Posts: 41
Joined: 01 Apr 2013 19:32

Re: UP - 29/09/2013 [TESTING]

Postby Mr. B » 04 Oct 2013 23:25

Santa wrote: The other one is plasma-widget-smooth-tasks; someone reported a few hours ago that it wasn't uninstallable. It seems it's a bug inherited from debian.
If you talk about a guy named DarkEra that would have been me. It was on the 64 bit of SolydK (Production) latest iso/install where i discovered in synaptic that plasma-widget-smooth-tasks couldn't be installed because the package turns out to be broken. That is the case ;)

User avatar
jdhedden
Posts: 106
Joined: 26 Aug 2013 11:34
Location: Gibbstown, NJ
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby jdhedden » 05 Oct 2013 14:20

I have found a problem with the testing repositories. The fglrx-drive 1:13.8~beta1-2 package cannot be installed due to broken dependencies. To fix this the glx-alternative-fglrx package (and its dependencies) must also be made available.
Jerry : SolydX / Siduction / Liquorix Kernel / Dell XPS 8700 / NVIDIA GeForce GT 635

User avatar
Arjen Balfoort
Site Admin
Posts: 9165
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby Arjen Balfoort » 05 Oct 2013 15:14

jdhedden wrote:I have found a problem with the testing repositories. The fglrx-drive 1:13.8~beta1-2 package cannot be installed due to broken dependencies. To fix this the glx-alternative-fglrx package (and its dependencies) must also be made available.
I've removed the beta version from our repository. So, the Jessie version is the one left:

Code: Select all

solydxk@solydxk ~ $ apt policy fglrx-driver
fglrx-driver:
  Installed: (none)
  Candidate: 1:13.4-3
  Version table:
     1:13.4-3 0
        500 http://debian.solydxk.com/testing/ testing/non-free amd64 Packages


SolydXK needs you!
Development | Testing | Translations

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby zerozero » 05 Oct 2013 15:32

Santa wrote:I have another couple of updates:

Code: Select all

The following packages will be upgraded:
  kdelibs-bin kdelibs5-data kdelibs5-dev kdelibs5-plugins kdoctools libkcmutils4 libkde3support4
  libkdeclarative5 libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4
  libkfile4 libkhtml5 libkidletime4 libkimproxy4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4
  libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkprintutils4 libkpty4
  libkrosscore4 libkrossui4 libktexteditor4 libkunitconversion4 libkutils4 libnepomuk4
  libnepomukquery4a libnepomukutils4 libplasma3 libsolid4 libthreadweaver4
40 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 15.4 MB of archives.
After this operation, 155 kB of additional disk space will be used.
:)
bliss of ignorance

kyodev
Posts: 505
Joined: 06 Jul 2013 09:47
Location: Lyon, France

Re: UP - 29/09/2013 [TESTING]

Postby kyodev » 05 Oct 2013 15:40

I restored solydX32, by curiosity, I search why ndiswrapper can block install linux-headers-3.10.3. one thing seems to me strange. when I test:

Code: Select all

# apt-get install --reinstall ndiswrapper-dkms
...
La réinstallation de ndiswrapper-dkms est impossible, il ne peut pas être téléchargé
In english: reinstallationn of ndiswrapper is impossible, it can't be downloaded

# apt policy ndiswrapper-dkms
ndiswrapper-dkms:
  Installé : 1.58+solydxk-3.9patch
  Candidat : 1.58+solydxk-3.9patch
 Table de version :
 *** 1.58+solydxk-3.9patch 0
        100 /var/lib/dpkg/status
     1.58-2 0
        500 http://ftp.nluug.nl/os/Linux/distr/solydxk/debian/production/ testing/main i386 Packages
if I understand, 1.58+solydxk-3.9patch 0 is no longer available in solydxk repos and anyone can reinstall ndiswrapper, no? update with 1.58-2 will be not automatic.

I have the same results for ndiswrapper with solydK32 but the update testing was done without problems!

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby zerozero » 05 Oct 2013 16:37

kyodev wrote:I search why ndiswrapper can block install linux-headers-3.10.3.
as far as i remember ndiswrapper spits some strange errors but are harmless and in no way should prevent the installation of kernel-headers.

anyway, unless you are using (and really need windows wireless drivers) ndiswrapper is not need at all (and i believe that was the reason why the patched version was removed from our repo: one more package to maintain and in the end of the day nobody would use it)

if you have a situation where ndiswrapper is really blocking the kernel-headers installation, then it's different :o
bliss of ignorance

kyodev
Posts: 505
Joined: 06 Jul 2013 09:47
Location: Lyon, France

Re: UP - 29/09/2013 [TESTING]

Postby kyodev » 05 Oct 2013 17:16

zerozero wrote:ndiswrapper is not need at all
yes I removed it and I will start update to see the change. but I never installed ndiswrapper and never use. it was installed with iso 06.2013.
perhaps, I'm not the only in this case?
if you have a situation where ndiswrapper is really blocking the kernel-headers installation, then it's different
thats a good question, with solydK: no, with solidX, in a previous try, yes?:

Code: Select all

apt install linux-headers-3.10-3-686-pae
Les NOUVEAUX paquets suivants seront installés :
  linux-headers-3.10-3-686-pae linux-headers-3.10-3-common
 ...
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.10-3-686-pae
Error! Bad return status for module build on kernel: 3.10-3-686-pae (i686)
Consult /var/lib/dkms/ndiswrapper/1.58/build/make.log for more information.
perhaps an exception?
Attachments
make.log.ndiswrapper.txt
(5.51 KiB) Downloaded 88 times

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby zerozero » 05 Oct 2013 17:28

it comes installed by default with all the isos (at least until now)

===
that error doesn't show us (at least not in the part quoted) that linux-headers fails to install because of ndiswrapper; shows that dkms fails to build the ndiswrapper module for that kernel (it's a very verbose error but afaik never had any real consequence >> unless you needed the windows drivers and then you would be out of luck)
bliss of ignorance

kyodev
Posts: 505
Joined: 06 Jul 2013 09:47
Location: Lyon, France

Re: UP - 29/09/2013 [TESTING]

Postby kyodev » 05 Oct 2013 22:58

yes, not simple..
I removed ndiswrapper, update error:
Your kernel headers for kernel 3.10-3-686-pae cannot be found...*

apt search 3.10-3-686-pae
p linux-headers-3.10-3-686-pae
apt search linux-headers-3.10.2
i linux-headers-3.10-2-686-pae
i A linux-headers-3.10-2-common

apt install linux-headers-3.10-3-686-pae
apt-get install --reinstall nvidia-kernel-dkms
and all is ok.
linux-headers is not installed, but this time not because ndiswrapper!

User avatar
ane champenois
Posts: 1539
Joined: 24 Feb 2013 08:17
Location: Grands lacs Forêt d'Orient, France

Re: UP - 29/09/2013 [TESTING]

Postby ane champenois » 06 Oct 2013 09:34

Ane, the return :mrgreen:
so with my bran new install: SolydX 32
Testing ok; install smoothly 8-)
Just a few questions
  • I had several ask about configurations files: tumbler.rc, LightDM, and another one i forgot :oops: Do we/users have to answer replace or keep? I choose 'replace' each time
  • Is there a new realease of LightDM? I notice a different way to ask for accounts:no list with choice. Perhaps it is linked with the config file replacement :roll:
They did not know it was impossible so they did it.

kyodev
Posts: 505
Joined: 06 Jul 2013 09:47
Location: Lyon, France

Re: UP - 29/09/2013 [TESTING]

Postby kyodev » 06 Oct 2013 13:41

conf: lightDM and updatemanager for me.
lightdm 1.6.0-3 1.6.2-1

User avatar
Arjen Balfoort
Site Admin
Posts: 9165
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby Arjen Balfoort » 06 Oct 2013 13:48

This testing repository has now gone to production.
The production and testing environments are identical.

http://forums.solydxk.nl/viewtopic.php? ... 01&p=16426


SolydXK needs you!
Development | Testing | Translations


Return to “Testing Zone”

Who is online

Users browsing this forum: No registered users and 2 guests