UP - 29/09/2013 [TESTING][DONE]

SolydXK is too quiet for you? SolydXK Enthusiast Editions, based on Debian Testing is for you! Here you can find news about Debian Testing and Unstable too, and also tests on SolydXK programs.
The support for SolydXK EE is provided by the community.
User avatar
Arjen Balfoort
Site Admin
Posts: 9519
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby Arjen Balfoort » 02 Oct 2013 15:38

Confirmed.
This is one of the many reasons why I'd like to rebuild UM. Its complexity, inflexibility (I have to keep patching it with almost every UP), and bugs make it a high-maintenance package. Unfortunately, we'll have to live with it for quite some time. Although a nuisance, UM functions, and doesn't jeopardize the system's stability or security. Because of that, changing or rebuilding it has low priority.


SolydXK needs you!
Development | Testing | Translations

User avatar
Arjen Balfoort
Site Admin
Posts: 9519
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby Arjen Balfoort » 02 Oct 2013 18:33

I just updated the testing repository: Santa has finished the KDE packages.

He has reported an issue: UM wants to remove kde-workspace, plasma-desktop, plasma-netbook, and kde-standard.
He didn't have trouble with apt-get or aptitude.

I'm running the upgrade now with UM, and I cannot confirm what Santa has reported.

I'll post back when I'm done.


SolydXK needs you!
Development | Testing | Translations

User avatar
Arjen Balfoort
Site Admin
Posts: 9519
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby Arjen Balfoort » 02 Oct 2013 18:51

Done, and rebooted: no issues whatsoever.

[EDIT]
Let me rephrase that: no issues whatsoever, except that I don't have kopete anymore:

Code: Select all

solydxk@solydxk ~ $ sudo apt-get install kopete
[sudo] password for solydxk: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kopete : Depends: libmediastreamer-base3 (>= 3.6.1) but it is not installable
          Depends: libortp9 (>= 3.6.1) but it is not installable
E: Unable to correct problems, you have held broken packages.
solydxk@solydxk ~ $ apt policy libmediastreamer-base3
libmediastreamer-base3:
  Installed: (none)
  Candidate: (none)
  Version table:
solydxk@solydxk ~ $ apt policy libortp9
libortp9:
  Installed: (none)
  Candidate: (none)
  Version table:
solydxk@solydxk ~ $ 


SolydXK needs you!
Development | Testing | Translations

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby zerozero » 02 Oct 2013 18:56

snapshot147.png
going for it now, can't replicate Santa's issues
bliss of ignorance

User avatar
Arjen Balfoort
Site Admin
Posts: 9519
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby Arjen Balfoort » 02 Oct 2013 19:02

Code: Select all

The following packages have been kept back:
  kopete xserver-xorg-video-chips
I think the missing packages in my previous post are the culprit of this (both in sid only).

Kopete's update was built for these sid packages:

Code: Select all

solydxk@solydxk ~ $ apt policy kopete
kopete:
  Installed: 4:4.11.1-0r2.1+b3
  Candidate: 4:4.11.2-90r1
  Version table:
     4:4.11.2-90r1 0
        700 http://packages.solydxk.com/testing/ solydxk/kdenext i386 Packages
 *** 4:4.11.1-0r2.1+b3 0
        100 /var/lib/dpkg/status
     4:4.10.5-2 0
        500 http://debian.solydxk.com/testing/ testing/main i386 Packages


SolydXK needs you!
Development | Testing | Translations

User avatar
Arjen Balfoort
Site Admin
Posts: 9519
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby Arjen Balfoort » 02 Oct 2013 19:08

Code: Select all

solydxk@solydxk ~ $ sudo apt-get install  xserver-xorg-video-chips
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xserver-xorg-video-chips : Depends: xorg-video-abi-14 but it is not installable
                            Depends: xserver-xorg-core (>= 2:1.13.99.901) but 2:1.12.4-6 is to be installed
E: Unable to correct problems, you have held broken packages.
solydxk@solydxk ~ $ sudo apt-get install xorg-video-abi-14
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package xorg-video-abi-14 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'xorg-video-abi-14' has no installation candidate
xorg-video-abi-14 is not in the Debian repositories.


SolydXK needs you!
Development | Testing | Translations

User avatar
Arjen Balfoort
Site Admin
Posts: 9519
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby Arjen Balfoort » 02 Oct 2013 19:19

I just sent Santa a PM.
I suggested to remove both kopete and xserver-xorg-video-chips from our kdenext repository, but would like to know if he has another idea.


SolydXK needs you!
Development | Testing | Translations

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby zerozero » 02 Oct 2013 23:18

from what i see the issue with xserver-xorg-video-chips it's only on i386

Code: Select all

zerozero@home ~ $ apt policy xserver-xorg-video-chips xserver-xorg-video-chips:i386
xserver-xorg-video-chips:
  Installed: 1:1.2.4-2
  Candidate: 1:1.2.4-2
  Version table:
 *** 1:1.2.4-2 0
        500 http://debian.solydxk.com/testing/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
xserver-xorg-video-chips:i386:
  Installed: (none)
  Candidate: 1:1.2.5-0r0
  Version table:
     1:1.2.5-0r0 0
        700 http://packages.solydxk.com/testing/ solydxk/kdenext i386 Packages
     1:1.2.4-2 0
        500 http://debian.solydxk.com/testing/ testing/main i386 Packages
the i386 package is newer and comes from kdenext
bliss of ignorance

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby zerozero » 02 Oct 2013 23:22

i have a strange issue with bespin (yes, again :mrgreen: )
this latest version (or revision 1686 from cloudcity i just built) doesn't keep the settings:
- i select bespin in s-s and the theme is applied; next time i open a random app it reverts to oxygen :o
bliss of ignorance

kyodev
Posts: 505
Joined: 06 Jul 2013 09:47
Location: Lyon, France

Re: UP - 29/09/2013 [TESTING]

Postby kyodev » 03 Oct 2013 11:13

problem with nvidia driver 304

solydX32
Linux 3.10-3-686-pae #1 SMP Debian 3.10.11-1 (2013-09-10) i686 GNU/Linux
Graphics: Card:NVIDIA ION LE VGA X.org:1.12.4 driver:FAILED:nvidia tty size:80x25 Advanced Data:N/A for root out of X

yesterday:
apt dist-upgrade:
apt-get install --reinstall nvidia-kernel-dkms

with kernel 3.10.2 or 3.10.3
with plymouth, at boot startpar: service returned failure: plymouth ...
without: fail to boot, no warning in boot.log
remove xorg.conf
boot ok, but system too hot.
tried to downgrade nvidia driver:
apt install nvidia-kernel-dkms=304.88-6)
nvidia-xconfig
no success
perhaps this method is not good. How to downgrade nvidia driver?

this morning:
restore,
install apt-listbugs
updatemanager 1.4.5->1.4.7

Code: Select all

Bogues de gravité critical sur nvidia-driver (304.88-6 -> 304.108-1) <non corrigé>
 #725067 - nvidia-driver: driver update breaks gdm, most window managers, most xfce and gtk apps
Bogues de gravité grave sur upower (0.9.21-2 -> 0.9.21-3) <non corrigé>
 #722474 - upower: on update fails with critical glib errors & doesn't work properly after reboot
 #722612 - upower --status hangs on upgrade
Bogues de gravité serious sur libclutter-1.0-0 (1.14.4-2 -> 1.14.4-3) <non corrigé>
 #722912 - libclutter-1.0-0: apt does not find an upgrade path from wheezy to jessie: libcogl12 : Breaks: libclutter-1.0-0 (< 1.14) but 1.10.8-2 is to be installed
Résumé :
 nvidia-driver(1 bogue), libclutter-1.0-0(1 bogue), upower(2 bogues)
Êtes-vous certain de vouloir installer/mettre à jour les paquets ci-dessus ? [Y/n/?/...] Y
I go, fail to index man-db
apt-get -f install
second time: updatemanager
ok, reboot
down, as above
tried more apt-get install --reinstall nvidia-kernel-dkms, not better

I will restore and pinning the nvidia-driver, upower, libclutter and I will see.
I'm afraid that mister everyone knows use that and backups and restore easely...

kyodev
Posts: 505
Joined: 06 Jul 2013 09:47
Location: Lyon, France

Re: UP - 29/09/2013 [TESTING]

Postby kyodev » 03 Oct 2013 14:45

great
the updatemanager 1.4.8 allows to resize progress download windows but not the details windows (very little worry)

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby zerozero » 03 Oct 2013 15:09

kyodev
i don't understand why so many problems with nvidia this time :shock: it's haunted? :mrgreen: from other reports it should be an easy upgrade.

the bug that apt-listbugs finds is not the reason for all that trouble. reading the bug report >>here<< we can see that it reports other issue.
bliss of ignorance

kyodev
Posts: 505
Joined: 06 Jul 2013 09:47
Location: Lyon, France

Re: UP - 29/09/2013 [TESTING]

Postby kyodev » 03 Oct 2013 19:30

zerozero wrote: so many problems with nvidia this time
why many? with nvidia I can't start, with vesa, I can ...
I made 2 updates with same effects. I haven't an only VB (it's to simple).

I finished the third update with pinning of apt-listbugs. now I have nvidia 304.88 and 108 at same time :(

Code: Select all

dpkg -l *nvidia* | grep ^i
ii  glx-alternative-nvidia                 0.4.0   
ii  libgl1-nvidia-glx:i386                 304.108-1  
ii  libxvmcnvidia1:i386                    304.108-1  
ii  nvidia-alternative                     304.108-1  
ii  nvidia-detect                          319.17-1   
ii  nvidia-installer-cleanup               20130816+1 
ii  nvidia-kernel-common                   20130816+1 
ii  nvidia-kernel-dkms                     304.108-1  
ii  nvidia-settings                        304.108-2  
ii  nvidia-support                         20130816+1 
ii  nvidia-vdpau-driver:i386               304.108-1  
ii  nvidia-xconfig                         304.108-1  
ii  xserver-xorg-video-nvidia              304.108-1  
I imagine that I will boot failure; more time. in attachment, I put logs UM of the third update.
I dont know what try or what indications to give...

in my logs, you will see, that update ended with error
then (line 374):
apt-get -f install
Les NOUVEAUX paquets suivants seront installés (the new packages wil installed) :
libperl4-corelibs-perl
more updatemanager and good end,.
this happened with my two try with updatemanager

I need to find a process for downgrade nvidia (I have backup apt/cache) but apt install nvidia-kernel-dkms=304.88-6) seems not enough. If someone can give me few indications...
Attachments
update.testing3.txt
(123.12 KiB) Downloaded 105 times

kyodev
Posts: 505
Joined: 06 Jul 2013 09:47
Location: Lyon, France

Re: UP - 29/09/2013 [TESTING]

Postby kyodev » 03 Oct 2013 19:53

zerozero wrote:we can see that it reports other issue.
yes, perhaps xorgs with nouveau =>nvidia
and I imagine also that all nvidia cards are not affected.

what about libperl4-corelibs-perl that isn't downloaded in firts update?

User avatar
Santa
Posts: 16
Joined: 09 Jun 2013 23:39

Re: UP - 29/09/2013 [TESTING]

Postby Santa » 03 Oct 2013 20:03

Hi,
Schoelje wrote:I just sent Santa a PM.
I suggested to remove both kopete and xserver-xorg-video-chips from our kdenext repository, but would like to know if he has another idea.
xserver-xorg-video-chips was included by accident, it should not be there. This package actually belongs to siduction's fixes repository; we included it by mistake when we fixed a mess with the xorg drivers in debian sid. So I have removed it from siduction's kdenext/solydk.

The problem with kopete is that it failed to build so the siduction package remained in the repository. This issue is fixed now, since I made kopete build under solydk, overriding the package meant to work under siduction. Please, don't remove it from solydk, just sync again the repository.

When working on the kopete issue I also found that kget wasn't build properly because of a bug in libktorrent packaging, so I fixed it and now you have kget 4.11.2 available.

Last but not least, I can't reproduce the problem of UM trying to remove things which it shouldn't when updating from the solydk's official testing repos, it only happens if I add siduction's kdenext/solydk to my sources.list. Since this is not a problem for end-users, I would just forget about this problem for now.
Sometimes, standing for what you believe means standing alone.

User avatar
Arjen Balfoort
Site Admin
Posts: 9519
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby Arjen Balfoort » 03 Oct 2013 21:16

I just updated kget, kopete, libktorrent, libkopete and removed xserver-xorg-video-chips from the repository.
I then tested it on SolydK64 with UM: no issues.


SolydXK needs you!
Development | Testing | Translations

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 29/09/2013 [TESTING]

Postby zerozero » 03 Oct 2013 21:47

kyodev
you have a very complex update here

- it breaks half-way through with man-db

Code: Select all

Des erreurs ont été rencontrées pendant l'exécution :
 man-db
- you have to recover that with -f install but the biggest issue is

Code: Select all

Your kernel headers for kernel 3.10-3-686-pae cannot be found at
/lib/modules/3.10-3-686-pae/build or /lib/modules/3.10-3-686-pae/source.
Error! echo
which causes nvidia to fail to build here

Code: Select all

Paramétrage de nvidia-kernel-dkms (304.108-1) ...
Loading new nvidia-current-304.108 DKMS files...
Building for 3.10-2-686-pae and 3.10-3-686-pae
Building initial module for 3.10-2-686-pae
Done.

nvidia-current:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.10-2-686-pae/updates/dkms/

depmod....

DKMS: install completed.
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
bliss of ignorance

kyodev
Posts: 505
Joined: 06 Jul 2013 09:47
Location: Lyon, France

Re: UP - 29/09/2013 [TESTING]

Postby kyodev » 04 Oct 2013 13:58

hi zerozero,
felicitations, you have better eyes that me...
it breaks half-way through with man-db
yes, always, see my follow post on testing solydK update.
Your kernel headers for kernel 3.10-3-686-pae cannot be found
this kernel does not seem to be installed.
voilà! here is the problem, thanks.
this morning I boot with success with 3.10.2, fail with 3.10.3

but why headers isn't updated/installed?..

Code: Select all

apt search  3.10-3-686-pae
p   linux-headers-3.10-3-686-pae
i A linux-image-3.10-3-686-pae                

apt search 3.10-2-686-pae
i   linux-headers-3.10-2-686-pae   
i   linux-image-3.10-2-686-pae               

dpkg --get-selections *3.10-3-686-pae
linux-image-3.10-3-686-pae			install
I try

Code: Select all

apt install linux-headers-3.10-3-686-pae
Les NOUVEAUX paquets suivants seront installés :
  linux-headers-3.10-3-686-pae linux-headers-3.10-3-common
  
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.10-3-686-pae
Error! Bad return status for module build on kernel: 3.10-3-686-pae (i686)
Consult /var/lib/dkms/ndiswrapper/1.58/build/make.log for more information.

apt remove ndiswrapper-dkms ndiswrapper-common ndiswrapper-utils-1.9
apt remove linux-headers-3.10-3-686-pae
apt autoremove
apt install linux-headers-3.10-3-686-pae
### ok, pinning removed  for all
apt dist-upgrade
apt-get install --reinstall nvidia-kernel-dkms
###reboot ok, inxi -SG
System:    Host: 1201nl Kernel: 3.10-3-686-pae i686 (32 bit) Desktop: Xfce 4.10.2 Distro: SolydXK 1 testing
Graphics:  Card: NVIDIA ION LE VGA X.Org: 1.12.4 driver: nvidia Resolution: 1366x768@60.0hz 
           GLX Renderer: ION LE/integrated/SSE2 GLX Version: 3.3.0 NVIDIA 304.108
it seems that the problem is solved. my ndiswraper configuration was corrupt?
I wait a moment for other suggestions and I will retry tomorrow, if possible with updatemanger, after a restore and a purge of ndiswrapper. I can also test for the man-db error.

is ndiswrapper useful for someone, in standard distro?

kyodev
Posts: 505
Joined: 06 Jul 2013 09:47
Location: Lyon, France

Re: UP - 29/09/2013 [TESTING]

Postby kyodev » 04 Oct 2013 14:10

SolydK32

Code: Select all

 inxi -SG
System:    Host: 1201nl Kernel: 3.10-3-686-pae i686 (32 bit) Desktop: KDE 4.11.2 Distro: SolydXK 1 testing
Graphics:  Card: NVIDIA ION LE VGA X.Org: 1.12.4 driver: nvidia Resolution: 1366x768@60.0hz 
           GLX Renderer: ION LE/integrated/SSE2 GLX Version: 3.3.0 NVIDIA 304.108
update this mornig. all is fine. without apparent problems

just a little annoyance, with solydx and with solydK, update process is stopped with this erreur

Code: Select all

E: man-db: script post-installation subprocess installed was killed by signal (Segmentation fault) (translated)

apt-get -f install
the additional packages below will be installed:
  libperl4-corelibs-perl
the NEW packages below will be installed:
  libperl4-corelibs-perl
0 updated, 1 new installed,  0 to remove and 430 not updated

updatemaanger
...
ok
Attachments
logs201310.txt
(182.44 KiB) Downloaded 87 times

kyodev
Posts: 505
Joined: 06 Jul 2013 09:47
Location: Lyon, France

Re: UP - 29/09/2013 [TESTING]

Postby kyodev » 04 Oct 2013 14:55

for information:
curious message in updatemanager, at the end of each installation

Code: Select all

W: A attendu dpkg --assert-multi-arch mais il n'était pas présent - dpkgGo (10: Aucun processus enfant)
I don't know if it's new. all seems work as expected.


Return to “Testing Zone”

Who is online

Users browsing this forum: No registered users and 12 guests