UP - 31/10/2013 [TESTING][DONE]

SolydXK is too quiet for you? SolydXK Enthusiast Editions, based on Debian Testing is for you! Here you can find news about Debian Testing and Unstable too, and also tests on SolydXK programs.
The support for SolydXK EE is provided by the community.
User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 31/10/2013 [TESTING]

Postby zerozero » 03 Nov 2013 01:58

timber
i can't figure out from the log where the installation fails but there's one pkg that is not installable in your system
can you please run

Code: Select all

sudo apt-get -s install --reinstall linux-headers-3.10-3-amd64 build-essential nvidia-xconfig nvidia-driver nvidia-settings nvidia-kernel-dkms ia32-libs
bliss of ignorance

User avatar
timber
Posts: 539
Joined: 11 Aug 2013 21:01
Location: Pacific Northwest

Re: UP - 31/10/2013 [TESTING]

Postby timber » 03 Nov 2013 03:26

Code: Select all

dave@wolf ~ $ sudo apt-get -s install --reinstall linux-headers-3.10-3-amd64 build-essential nvidia-xconfig nvidia-driver nvidia-settings nvidia-kernel-dkms ia32-libs
[sudo] password for dave: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-driver : Depends: libgl1-nvidia-glx (= 304.108-4) but it is not going to be installed
                 Depends: xserver-xorg-video-nvidia (= 304.108-4) but it is not going to be installed
                 Recommends: libgl1-nvidia-glx-i386
E: Unable to correct problems, you have held broken packages.
dave@wolf ~ $ 
Of course, now I am using nouveau driver in order to function.

Happy to try anything you would like, any time ... signed, Your Happy guinea pig ... :lol:
timber

Samsung R580-M430 @ 2.27GHz - 8 GB RAM
Geforce 310M w/ nvidia-driver
SolydX/SolydM - Kernel 3.14-2-amd64 - Update Pack: 2014.07.15
SolydK - Kernel 3.14-2-amd64 - Update Pack: 2014.07.15
SolydKBE - Kernel 3.2.0-4-amd64 - LTS Update Pack: 2014.07.15

User avatar
Arjen Balfoort
Site Admin
Posts: 9394
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 31/10/2013 [TESTING]

Postby Arjen Balfoort » 03 Nov 2013 06:34

Gentlemen, I propose to do another synchronization of the Debian repository.
It looks like they were in the midst of updating their repository while we were synchronizing with ours.


SolydXK needs you!
Development | Testing | Translations

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 31/10/2013 [TESTING]

Postby zerozero » 03 Nov 2013 07:04

timber wrote:Your Happy guinea pig ... :lol:
thanks 8-)
Schoelje wrote:Gentlemen, I propose to do another synchronization of the Debian repository.
agreed!
bliss of ignorance

User avatar
Arjen Balfoort
Site Admin
Posts: 9394
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 31/10/2013 [TESTING]

Postby Arjen Balfoort » 03 Nov 2013 07:44

synchronizing now...


SolydXK needs you!
Development | Testing | Translations

User avatar
timber
Posts: 539
Joined: 11 Aug 2013 21:01
Location: Pacific Northwest

Re: UP - 31/10/2013 [TESTING]

Postby timber » 03 Nov 2013 08:02

We'll see what this sync brings ... just for the record, I tried adding the two dependencies noted above.

Code: Select all

The following packages have unmet dependencies:
 nvidia-driver : Depends: libgl1-nvidia-glx (= 304.108-4) but it is not going to be installed
                 Depends: xserver-xorg-video-nvidia (= 304.108-4) but it is not going to be installed
No luck with that ... but I've got faith in the team ... you guys are the best!!!

I'll UP when I get the go ahead ... FYI, everything else (besides the nvidia drivers) seems to be working great ... no other issues that I've found. (With all the changes that nvidia has been making here, it's little wonder we're not having a smooth go of it ... no blame directed toward the SolydXK team at all, hope you realize that). Just let me know if there is anything that you need me to try regarding the nvidia drivers (or other). :D
timber

Samsung R580-M430 @ 2.27GHz - 8 GB RAM
Geforce 310M w/ nvidia-driver
SolydX/SolydM - Kernel 3.14-2-amd64 - Update Pack: 2014.07.15
SolydK - Kernel 3.14-2-amd64 - Update Pack: 2014.07.15
SolydKBE - Kernel 3.2.0-4-amd64 - LTS Update Pack: 2014.07.15

User avatar
Arjen Balfoort
Site Admin
Posts: 9394
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 31/10/2013 [TESTING]

Postby Arjen Balfoort » 03 Nov 2013 09:01

Synchronization has finished, and DDM had another update (both Nvidia and ATI handling were improved).

[EDIT]
It seems that my card is now provided in the new 304 legacy packages:

Code: Select all

$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-chips xserver-xorg-video-i128 xserver-xorg-video-i740
  xserver-xorg-video-rendition xserver-xorg-video-s3 xserver-xorg-video-s3virge xserver-xorg-video-sis xserver-xorg-video-tseng
  xserver-xorg-video-voodoo
The following NEW packages will be installed:
  libboost-iostreams1.54.0 libelf1:i386 libgl1-nvidia-legacy-304xx-glx libgl1-nvidia-legacy-304xx-glx:i386
  libgl1-nvidia-legacy-304xx-glx-i386:i386 libgnutls28 libhogweed2 libllvm3.3 libllvm3.3:i386 liblog-message-simple-perl
  libmjpegutils-2.1-0 libmpeg2encpp-2.1-0 libmplex2-2.1-0 libsasl2-modules-db libsasl2-modules-db:i386 libspice-server1 libx264-133
  libxatracker1 libxvmc1:i386 libxvmcnvidia1:i386 nvidia-legacy-304xx-alternative nvidia-legacy-304xx-driver
  nvidia-legacy-304xx-kernel-dkms nvidia-settings-legacy-304xx xserver-xorg-video-modesetting xserver-xorg-video-nvidia-legacy-304xx
  xserver-xorg-video-qxl
According to UM, these extra packages are being removed :shock: :

Code: Select all

kde-plasma-desktop
kde-window-manager
kde-workspace
libavcodec53:i386
libcairo2-dev
libgtk-3-dev
libpango1.0-dev
I'm going to proceed, and see what happens.
[EDIT2]
The process ended in an error:

Code: Select all

E: /var/cache/apt/archives/libc6_2.17-93_amd64.deb: subprocess new pre-installation script was killed by signal (Segmentation fault)
E: man-db: subprocess installed post-installation script was killed by signal (Segmentation fault)
I think libc6:i386 needs to be updated before proceeding with the upgrade.


SolydXK needs you!
Development | Testing | Translations

toothandnail
Posts: 94
Joined: 02 Jun 2013 18:45
Location: Oxfordshire, UK

Re: UP - 31/10/2013 [TESTING]

Postby toothandnail » 03 Nov 2013 11:09

I applied the new update to my testing SolydX. Went through without errors. Optical device support is completely broken. I can mount a CD/DVD manually, but even ejecting the device is giving me problems:

Code: Select all

Error ejecting /media/cdrom: Command-line `eject "/media/cdrom"' 
exited with non-zero exit status 1: eject: unable to eject, 
last error: Inappropriate ioctl for device
I've found that if I use something like this:

Code: Select all

sudo touch /dev/sr0
the CD will appear on the desktop and automount, but it then can't be ejected. Right-click on the device and click the 'eject' button leads to this error:

Code: Select all

Error ejecting /dev/sr0: Command-line `eject "/dev/sr0"' 
exited with non-zero exit status 1: eject: unable to eject, 
last error: Inappropriate ioctl for device
Other than that, system seems to be running well. My laptop has Intel graphics, so I've not hit any of the Nvidia or Ati problems other people are having.

Paul.

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 31/10/2013 [TESTING]

Postby zerozero » 03 Nov 2013 13:46

in my main system did the 2nd part of the UP

Code: Select all

The following NEW packages will be installed:
  libelf1:i386 libllvm3.3 libllvm3.3:i386
The following packages will be upgraded:
  cpp-4.7 ddm debootstrap dh-python fonts-opensymbol g++-4.7 gcc-4.7 gcc-4.7-base gcc-4.7-base:i386 gnome-icon-theme gnome-icon-theme-symbolic libavutil51 libdatrie1 libdatrie1:i386 libegl1-mesa
  libegl1-mesa:i386 libegl1-mesa-dev libegl1-mesa-drivers libegl1-mesa-drivers:i386 libgbm1 libgbm1:i386 libgcc-4.7-dev libgl1-mesa-dev libgl1-mesa-dri:i386 libgl1-mesa-dri libgl1-mesa-glx
  libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386 libgles2-mesa libhtml-template-perl libimage-exiftool-perl libmpfr4 libopenvg1-mesa libopenvg1-mesa:i386 libreoffice libreoffice-base
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-emailmerge libreoffice-impress libreoffice-java-common libreoffice-kde libreoffice-math
  libreoffice-report-builder-bin libreoffice-style-galaxy libreoffice-style-oxygen libreoffice-writer libstdc++6-4.7-dev libtxc-dxtn-s2tc0 libtxc-dxtn-s2tc0:i386 libxatracker1 libxnvctrl0
  mesa-common-dev nvidia-detect oss4-dev plymouth plymouth-drm plymouth-x11 ppp python-apt python-apt-common python-apt-dev python-uno python3-apt timidity timidity-daemon uno-libs3 ure
  xserver-xorg-input-evdev
73 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 152 MB of archives.
After this operation, 58.3 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
smooth, no issues to report.
same as Paul above using intel.

i'm now performing a full upgrade with part 1 and 2.
will report when finished.
bliss of ignorance

User avatar
Arjen Balfoort
Site Admin
Posts: 9394
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 31/10/2013 [TESTING]

Postby Arjen Balfoort » 03 Nov 2013 13:55

I updated the UM, and the pre script.
The pre script is now executed before listing the changes, and asking for confirmation, in stead of after.
The pre script now includes pre installation of these packages: libc6:i386, libc6, and libegl1-mesa-drivers.

I'm running a full upgrade now...


SolydXK needs you!
Development | Testing | Translations

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 31/10/2013 [TESTING]

Postby zerozero » 03 Nov 2013 14:44

just for the record (in xfce) this is the pre-upgrade action that UM performs before updating itself (in slower connections it might look that it's frozen but it's not, it's working in the background <<actually we have the output in the status bar>>)

Code: Select all

Start-Date: 2013-11-03  14:34:55
Commandline: apt-get purge -y --force-yes mate-*
Purge: libcaja-extension:amd64 (1.6.1-2), libmatecorba:amd64 (1.4.0-1+wheezy), libmateconf:amd64 (1.4.0-1+wheezy), mate-polkit:amd64 (1.6.0-1), mate-system-tools:amd64 (1.6.0-1), libmatedesktop:amd64 (1.4.1-1+wheezy), libmatepolkit:amd64 (1.6.0-1)
End-Date: 2013-11-03  14:35:03

Start-Date: 2013-11-03  14:35:06
Commandline: apt-get install -y --force-yes usermanager
Install: usermanager:amd64 (0.5.9)
End-Date: 2013-11-03  14:35:08

Start-Date: 2013-11-03  14:35:10
Commandline: apt-get install -y --force-yes sambashare
Install: sambashare:amd64 (0.5.8)
End-Date: 2013-11-03  14:35:11

Start-Date: 2013-11-03  14:36:35
Commandline: apt-get install --reinstall -y --force-yes libegl1-mesa-drivers
Install: libllvm3.3:amd64 (3.3-9, automatic), libllvm3.3:i386 (3.3-9, automatic), libelf1:i386 (0.153-2, automatic)
Upgrade: libgl1-mesa-dev:amd64 (9.1.6-2+b1, 9.2.2-1), libegl1-mesa:amd64 (9.1.6-2+b1, 9.2.2-1), libegl1-mesa:i386 (9.1.6-2+b1, 9.2.2-1), libegl1-mesa-drivers:amd64 (9.1.6-2+b1, 9.2.2-1), libegl1-mesa-drivers:i386 (9.1.6-2+b1, 9.2.2-1), libegl1-mesa-dev:amd64 (9.1.6-2+b1, 9.2.2-1), libgl1-mesa-dri:i386 (9.1.6-2+b1, 9.2.2-1), libgl1-mesa-dri:amd64 (9.1.6-2+b1, 9.2.2-1), libglapi-mesa:amd64 (9.1.6-2+b1, 9.2.2-1), libglapi-mesa:i386 (9.1.6-2+b1, 9.2.2-1), libgl1-mesa-glx:amd64 (9.1.6-2+b1, 9.2.2-1), libgl1-mesa-glx:i386 (9.1.6-2+b1, 9.2.2-1), mesa-common-dev:amd64 (9.1.6-2+b1, 9.2.2-1)
End-Date: 2013-11-03  14:36:43

Start-Date: 2013-11-03  14:37:18
Commandline: apt-get install --reinstall -y --force-yes libc6:i386
Upgrade: libc6-i686:i386 (2.17-92+b1, 2.17-93), libc-dev-bin:amd64 (2.17-92+b1, 2.17-93), libc6:amd64 (2.17-92+b1, 2.17-93), libc6:i386 (2.17-92+b1, 2.17-93), libc6-i386:amd64 (2.17-92+b1, 2.17-93), libc6-dev:amd64 (2.17-92+b1, 2.17-93)
End-Date: 2013-11-03  14:37:27

Start-Date: 2013-11-03  14:37:29
Commandline: apt-get install --reinstall -y --force-yes libc6
Reinstall: libc6:amd64 (2.17-93), libc6:i386 (2.17-93)
End-Date: 2013-11-03  14:37:34

Start-Date: 2013-11-03  14:37:42
Commandline: /usr/sbin/synaptic --hide-main-window --non-interactive --parent-window-id 81789037 -o Synaptic::closeZvt=true --progress-str Please wait, this can take some time --finish-str Update is complete --set-selections-file /tmp/tmpceUC41
Upgrade: updatemanager:amd64 (1.4.8, 1.5.1)
End-Date: 2013-11-03  14:37:42
bliss of ignorance

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 31/10/2013 [TESTING]

Postby zerozero » 03 Nov 2013 15:13

one update done (X-64) with UM: no issues to report!
bliss of ignorance

User avatar
Arjen Balfoort
Site Admin
Posts: 9394
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 31/10/2013 [TESTING]

Postby Arjen Balfoort » 03 Nov 2013 15:30

Unfortunately, I have some issues to report.

I finally got the update running, and it finished without an error.
Upon reboot, X failed to start.
I deleted xorg.conf, and all nvidia* files in modprobe.d.
Nouveau started without a problem.
I saw that both the current Nvidia drivers as the new 404 legacy drivers were installed.
nvidia-detect tells me I should use the current Nvidia drivers, and my card (9800 GT) isn't in this list either: http://packages.debian.org/jessie/nvidi ... 4xx-driver

This is caused by aforementioned libxvmcnvidia1:

Code: Select all

# apt-get install libxvmcnvidia1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libgl1-nvidia-legacy-304xx-glx libgl1-nvidia-legacy-304xx-glx:i386 libgl1-nvidia-legacy-304xx-glx-i386:i386 libxvmc1:i386
  libxvmcnvidia1:i386 nvidia-alternative nvidia-legacy-304xx-alternative nvidia-legacy-304xx-driver nvidia-legacy-304xx-kernel-dkms
  nvidia-settings-legacy-304xx nvidia-vdpau-driver xserver-xorg-video-nvidia-legacy-304xx
I had to remove this package from DDM because it should be handled by the driver itself whether it needs it or not (it's a dependency). I also added the purge of this package in the pre-script.

Now that I only have the current drivers installed, my system can use the Nvidia drivers without a problem.


SolydXK needs you!
Development | Testing | Translations

User avatar
jdhedden
Posts: 106
Joined: 26 Aug 2013 11:34
Location: Gibbstown, NJ
Contact:

Re: UP - 31/10/2013 [TESTING]

Postby jdhedden » 03 Nov 2013 15:36

Schoelje wrote:I'm running a full upgrade now...
I ran the full upgrade from a base system (solydx32_201308.iso + 9/6 update + ati drivers), and everything went well and appears to be working correctly.
Jerry : SolydX / Siduction / Liquorix Kernel / Dell XPS 8700 / NVIDIA GeForce GT 635

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 31/10/2013 [TESTING]

Postby zerozero » 03 Nov 2013 15:56

Schoelje wrote:Unfortunately, I have some issues to report.

I finally got the update running, and it finished without an error.
Upon reboot, X failed to start.
I deleted xorg.conf, and all nvidia* files in modprobe.d.
Nouveau started without a problem.
I saw that both the current Nvidia drivers as the new 404 legacy drivers were installed.
nvidia-detect tells me I should use the current Nvidia drivers, and my card (9800 GT) isn't in this list either: http://packages.debian.org/jessie/nvidi ... 4xx-driver

This is caused by aforementioned libxvmcnvidia1:

Code: Select all

# apt-get install libxvmcnvidia1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libgl1-nvidia-legacy-304xx-glx libgl1-nvidia-legacy-304xx-glx:i386 libgl1-nvidia-legacy-304xx-glx-i386:i386 libxvmc1:i386
  libxvmcnvidia1:i386 nvidia-alternative nvidia-legacy-304xx-alternative nvidia-legacy-304xx-driver nvidia-legacy-304xx-kernel-dkms
  nvidia-settings-legacy-304xx nvidia-vdpau-driver xserver-xorg-video-nvidia-legacy-304xx
I had to remove this package from DDM because it should be handled by the driver itself whether it needs it or not (it's a dependency). I also added the purge of this package in the pre-script.

Now that I only have the current drivers installed, my system can use the Nvidia drivers without a problem.
but i asked that last night ;) http://forums.solydxk.nl/viewtopic.php? ... =20#p18607
anyway glad it's solved 8-)
bliss of ignorance

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 31/10/2013 [TESTING]

Postby zerozero » 03 Nov 2013 16:03

another successful upgrade (X-64) this time using the terminal; no issues no report this way either

Code: Select all

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
always a joy to see this displayed :lol:

Code: Select all

The following packages will be REMOVED:
  xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-chips xserver-xorg-video-i128 xserver-xorg-video-rendition
  xserver-xorg-video-s3 xserver-xorg-video-s3virge xserver-xorg-video-sis xserver-xorg-video-tseng xserver-xorg-video-voodoo
The following NEW packages will be installed:
  libboost-iostreams1.54.0 libelf1:i386 libgnutls28 libhogweed2 libllvm3.3 libllvm3.3:i386 liblog-message-simple-perl libsasl2-modules-db
  libspice-server1 libxatracker1 libzeitgeist-2.0-0 xserver-xorg-video-modesetting xserver-xorg-video-qxl
bliss of ignorance

User avatar
smitty1
Posts: 248
Joined: 23 Jun 2013 13:50
Location: Pittsburgh, PA USA

Re: UP - 31/10/2013 [TESTING]

Postby smitty1 » 03 Nov 2013 16:03

Interesting update:
After updatemanager updates itself at the nest stage it wants to remove kde-plasma-desktop, kde-window-manager & kde-workspace.
But if I look at the same update through the terminal there are no removals

Code: Select all

Calculating upgrade... Done
The following NEW packages will be installed:
  libelf1:i386 libllvm3.3 libllvm3.3:i386
The following packages will be upgraded:
  cpp-4.7 ddm dh-python fonts-opensymbol g++-4.7 gcc-4.7 gcc-4.7-base
  gcc-4.7-base:i386 gnome-icon-theme gnome-icon-theme-symbolic libavutil51
  libdatrie1 libegl1-mesa libegl1-mesa-drivers libgbm1 libgcc-4.7-dev
  libgl1-mesa-dev libgl1-mesa-dri:i386 libgl1-mesa-dri libgl1-mesa-glx
  libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386 libhtml-template-perl
  libimage-exiftool-perl libmpfr4 libopenvg1-mesa libreoffice libreoffice-base
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-help-en-us libreoffice-impress
  libreoffice-java-common libreoffice-kde libreoffice-math
  libreoffice-report-builder-bin libreoffice-style-galaxy
  libreoffice-style-oxygen libreoffice-writer libstdc++6-4.7-dev libxatracker1
  mesa-common-dev nvidia-detect ppp python-apt python-apt-common python-uno
  python3-apt timidity timidity-daemon uno-libs3 ure xserver-xorg-input-evdev
57 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 151 MB of archives.
After this operation, 57.4 MB of additional disk space will be used.
Do you want to continue? [Y/n] n
I think I'll wait a bit.

No Good Deed Goes Unpunished

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 31/10/2013 [TESTING]

Postby zerozero » 03 Nov 2013 16:11

smitty
you can update either way (UM or terminal) those packages won't be uninstalled; that is an UM quirk that has to be tacked.
i believe that there's something in the legacy code that is messing something up (remember that our UM is forked <and heavily different> from mintupdate-debian and this one was patched from the regular mintupdate <ubuntu-versions> after much cry&shout back in the days)
bliss of ignorance

User avatar
Arjen Balfoort
Site Admin
Posts: 9394
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 31/10/2013 [TESTING]

Postby Arjen Balfoort » 03 Nov 2013 16:13

@smitty1
Please run:

Code: Select all

sudo apt-get update
sudo apt-get install updatemanager
sudo killall updatemanager
sudo rm /usr/lib/solydxk/updatemanager/*.pre
sudo rm /usr/lib/solydxk/updatemanager/*.post
updatemanager
Check /usr/lib/solydxk/updatemanager whether the new pre-, and post-scripts were downloaded.
You can verify that by opening the .pre script, and check that you have this at the bottom:

Code: Select all

handle_pck 'libxvmcnvidia1' 'purge' 'all'
handle_pck 'libegl1-mesa-drivers' 'reinstall' 'all'
handle_pck 'libc6:i386'  'reinstall' 'all'
handle_pck 'libc6' 'reinstall' 'all'
This should make sure you really have the latest UM, and the pre-, and post-scripts (I've updated them less than half an hour ago).


SolydXK needs you!
Development | Testing | Translations

User avatar
smitty1
Posts: 248
Joined: 23 Jun 2013 13:50
Location: Pittsburgh, PA USA

Re: UP - 31/10/2013 [TESTING]

Postby smitty1 » 03 Nov 2013 17:23

On the theory that anything worth doing is worth over doing I followed both zerozero and Schoelje advice. :lol:
In my 64 bit SolydK vb I just accepted the warning box in um and it updated without problem and without removing kde.

In my 32 vb install I followed Schoelje advice which also worked. However I do not have any .pre or .post files

Code: Select all

vb-32-k updatemanager # ls -lah
total 308K
drwxr-xr-x 2 root root 4.0K Nov  3 11:54 .
drwxr-xr-x 7 root root 4.0K Feb 20  2013 ..
-rw-r--r-- 1 root root 2.9K Nov  3 08:45 changelogRetriever.py
-rw-r--r-- 1 root root 2.6K Nov  3 10:48 changelogRetriever.pyc
-rwxr-xr-x 1 root root 2.8K Nov  3 08:45 checkAPT.py
-rwxr-xr-x 1 root root 1.3K Nov  3 08:45 checkWarnings.py
-rw-r--r-- 1 root root 2.6K Nov  3 08:45 config.py
-rw-r--r-- 1 root root 3.1K Nov  3 10:48 config.pyc
-rw-r--r-- 1 root root 3.0K Nov  3 08:45 dialogs.py
-rw-r--r-- 1 root root 3.3K Nov  3 10:48 dialogs.pyc
-rw-r--r-- 1 root root 2.2K Nov  3 08:45 execcmd.py
-rw-r--r-- 1 root root 2.5K Nov  3 10:48 execcmd.pyc
-rw-r--r-- 1 root root  21K Nov  3 08:45 functions.py
-rw-r--r-- 1 root root  20K Nov  3 10:48 functions.pyc
-rw-r--r-- 1 root root 4.6K Nov  3 08:45 logger.py
-rw-r--r-- 1 root root 3.6K Nov  3 10:48 logger.pyc
-rw-r--r-- 1 root root 1023 Nov  3 08:45 lts.html
-rwxr-xr-x 1 root root 4.8K Nov  3 08:45 mirror.py
-rw-r--r-- 1 root root 4.1K Nov  3 10:48 mirror.pyc
-rw-r--r-- 1 root root  319 Nov  3 11:54 mirrors.list
-rw-r--r-- 1 root root  849 Nov  3 08:45 notfound.html
-rw-r--r-- 1 root root  32K Nov  3 08:45 threadClasses.py
-rw-r--r-- 1 root root  20K Nov  3 10:48 threadClasses.pyc
-rw-r--r-- 1 root root  15K Nov  3 08:45 treeview.py
-rw-r--r-- 1 root root 9.6K Nov  3 10:48 treeview.pyc
-rw-r--r-- 1 root root  942 Nov  3 12:06 updatemanager.conf
-rw-r--r-- 1 root root  943 Oct  2 08:35 updatemanager.conf.dpkg-old
-rw-r--r-- 1 root root 7.3K Nov  3 12:09 updatemanager.log
-rwxr-xr-x 1 root root  73K Nov  3 08:45 updatemanager.py
-rw-r--r-- 1 root root   10 Sep 29 12:53 up.hist
vb-32-k updatemanager # 
But still it worked. :D :?:

No Good Deed Goes Unpunished


Return to “Testing Zone”

Who is online

Users browsing this forum: No registered users and 5 guests