Breakages and News tracking Debian Testing

SolydXK is too quiet for you? SolydXK Enthusiast Editions, based on Debian Testing is for you! Here you can find news about Debian Testing and Unstable too, and also tests on SolydXK programs.
The support for SolydXK EE is provided by the community.
User avatar
grizzler
Posts: 2180
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: Breakages and News tracking Debian Testing

Postby grizzler » 06 Sep 2015 14:11

Odd. One of the packages forcing removals is gstreamer0.10-plugins-good (from the gst-plugins-good0.10 source). This has a version in Unstable (built a month ago) which doesn't even show up on the tracker page. However, it is available in the snapshot repository. The only difference is one dependency (from the taglib source: libtag1v5-vanilla instead of the obsolete libtag1c2a), which just happens to be the one that causes the problem. Providing that gstreamer package from my local repository reduces the number of real removals to one (plus two dependencies - libraries - which are the cause there).

I'm starting to wonder how reliable this tracker really is...

Also, I thought I had this migration system (Unstable => Testing) figured out, but if a package can 'hang' in Unstable for a month without being visible in the main tracker or the testing migration queries (which means the reason for not migrating is obscured as well...), I'm starting to wonder about that too... :?
Frank

SolydX EE 64 - tracking Debian Testing

User avatar
belze
Posts: 221
Joined: 29 Sep 2014 16:31
Location: Torino, Italy

Re: Breakages and News tracking Debian Testing

Postby belze » 06 Sep 2015 14:13

i'd ask on debian-devel if it an expected behavior or not!
-------
Image

User avatar
smitty1
Posts: 244
Joined: 23 Jun 2013 13:50
Location: Pittsburgh, PA USA

Re: Breakages and News tracking Debian Testing

Postby smitty1 » 06 Sep 2015 20:53

I don't know if this applies to anyone here but me, but FWIW.
On this machine I run Windows and 3 Linux distros, Linux Mint 17.2 Mate Desktop, SolydK tracking testing, and Debian Gnome Tracking Sid. This is on a gpt/efi machine.
Yesterday i did dist-upgrades, with SolydK being last. I then switched to Windows for a while before closing up for the day. When I started this morning none of the Linux distros would boot. I noticed that the SolydK upgrade had taken control of the grub process, it was the first distro listed as opposed to Linux Mint. Each of the Linux distros gave the same error when trying to boot;

Code: Select all

error symbol grub_efi_secure_boot not found.
I checked that secure boot was still disabled & it was.
Searching around I found some info on the Ach and Manjaro wiki's that led to solution. the arch wiki
https://wiki.archlinux.org/index.php/Change_root is a good instruction on using chroot
https://wiki.manjaro.org/index.php?titl ... Bootloader is a from the Manjaro wiki good primer on restoring grub from a live usb/cd, but it must be modified slightly to work SolydK. Particularly in the grub install command our EFI folder is is /boot/EFI instead of /boot/efi. Working these out got all 3 of my linux distro's working again.
The forum thread at the start of this is 3 pages long but instructive. I t starts herehttps://forum.manjaro.org/index.php?PHP ... #msg159124, the solution starts herehttps://forum.manjaro.org/index.php?top ... #msg159444.
Just in time for the gcc5 related updates. :lol:

No Good Deed Goes Unpunished

User avatar
belze
Posts: 221
Joined: 29 Sep 2014 16:31
Location: Torino, Italy

Re: Breakages and News tracking Debian Testing

Postby belze » 07 Sep 2015 08:44

today on my system:

Code: Select all

LANG=C sudo apt-get dist-upgrade -d
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  ant* ant-optional* aptitude* braindump* calligra* calligra-data* calligra-l10n-it* calligra-libs* calligra-semanticitems* calligraauthor* calligraflow*
  calligraflow-data* calligraplan* calligrasheets* calligrastage* calligrastage-data* calligrawords* calligrawords-data* clementine* coinor-libcbc3* coinor-libcgl1*
  coinor-libclp1* coinor-libcoinmp1* coinor-libcoinutils3* coinor-libosi1* digikam* digikam-private-libs* filezilla* filezilla-common* gstreamer0.10-plugins-good*
  inkscape* karbon* kde-style-oxygen* kexi* kexi-data* kipi-plugins* krita* krita-data* libapache-poi-java* libarmadillo5* libarpack2* libasprintf0c2* libavcodec56*
  libavdevice55* libavfilter5* libavformat56* libavresample2* libavutil54* libboost-chrono1.55.0* libboost-date-time1.55.0* libboost-locale1.55.0* libboost-python1.55.0*
  libboost1.55-dev* libcec2* libclucene-contribs1* libclucene-core1* libcmis-0.4-4* libcmis-0.5-5* libcommons-codec-java* libdap17* libdapclient6* libdapserver7*
  libdom4j-java* libebml4* libechonest2.1* libepsilon1* libept1.4.12* libfarstream-0.1-0* libffmpegthumbnailer4* libflac++6* libfreexl1* libgdal1h* libgeos-3.4.2*
  libgeos-c1* libgltf-0.0-0* libgpgme++2* libhdf4-0-alt* libid3-3.8.3c2a* libilmbase6* libisorelax-java* libjaxen-java* libjdom1-java* libjsoncpp0* libkml0* libkolab0*
  libkolabxml1* liblucene++0* liblwgeom-2.1.8* libmagick++-6.q16-5* libmagickcore5-extra* libmatroska6* libmsv-java* libmusicbrainz3-6* libmusicbrainz5cc2* libnetcdfc7*
  libogdi3.2* libopencolorio1* libopencv-calib3d2.4* libopencv-contrib2.4* libopencv-core2.4* libopencv-features2d2.4* libopencv-flann2.4* libopencv-gpu2.4*
  libopencv-highgui2.4* libopencv-imgproc2.4* libopencv-legacy2.4* libopencv-ml2.4* libopencv-objdetect2.4* libopencv-ocl2.4* libopencv-photo2.4* libopencv-stitching2.4*
  libopencv-superres2.4* libopencv-ts2.4* libopencv-video2.4* libopencv-videostab2.4* libopenexr6* liborcus-0.10-0* libpcrecpp0* libphononexperimental4* libpq5* libproj9*
  libprojectm2* libprotobuf9* libpurple-bin* libpurple0* libqalculate5* libqapt-runtime* libqapt1* libqtgstreamerutils-1.0-0* libqxt-core0* libqxt-gui0*
  librelaxng-datatype-java* libsidplay1* libsoprano-dev* libspatialite7* libspnav0* libstreamanalyzer0* libstreams0* libsuperlu4* libswscale3* libtag1-vanilla*
  libtag1c2a* libtinyxml2.6.2* liburiparser1* libvamp-hostsdk3* libwxbase3.0-0* libwxgtk3.0-0* libxapian22* libxmlbeans-java* libxom-java* libxpp2-java* libxpp3-java*
  libyaml-cpp0.3* merkaartor* proj-bin* proj-data* projectm-data* solydxk-system* telepathy-haze*
The following NEW packages will be installed:
  appstream cpp-5 g++-5 gcc-5 kdepim-doc ktnef libapt-inst1.7 libapt-pkg4.16 libasan2 libasprintf0v5 libboost-chrono1.58.0 libboost-date-time1.58.0
  libboost-filesystem1.58.0 libboost-iostreams1.58.0 libboost-locale1.58.0 libboost-program-options1.58.0 libboost-python1.58.0 libboost-random1.58.0 libboost-regex1.58.0
  libboost-system1.58.0 libboost-thread1.58.0 libboost1.58-dev libcc1-0 libcec-platform1v5 libcec3 libclucene-contribs1v5 libclucene-core1v5 libcmis-0.5-5v5 libcpprest2.6
  libebml4v5 libept1.4.16 libexiv2-14 libffmpegthumbnailer4v5 libflac++6v5 libfstrcmp0 libgcc-5-dev libgltf-0.0-0v5 libgpgme++2v5 libicu55 libid3-3.8.3v5 libilmbase6v5
  libjsoncpp0v5 libkolab0v5 libkolabxml1v5 liblockdev1 liblucene++0v5 libmagick++-6.q16-5v5 libmatroska6v5 libmpx0 libmusicbrainz3-6v5 libmusicbrainz5cc2v5
  libopencv-calib3d2.4v5 libopencv-contrib2.4v5 libopencv-core2.4v5 libopencv-features2d2.4v5 libopencv-flann2.4v5 libopencv-gpu2.4v5 libopencv-highgui2.4v5
  libopencv-imgproc2.4v5 libopencv-legacy2.4v5 libopencv-ml2.4v5 libopencv-objdetect2.4v5 libopencv-ocl2.4v5 libopencv-photo2.4v5 libopencv-stitching2.4v5
  libopencv-superres2.4v5 libopencv-ts2.4v5 libopencv-video2.4v5 libopencv-videostab2.4v5 libopenexr6v5 liborcus-0.10-0v5 libpcrecpp0v5 libqalculate5v5 libsdl2-2.0-0
  libsidplay1v5 libstdc++-5-dev libstreamanalyzer0v5 libstreams0v5 libtag1v5 libtag1v5-vanilla libtinyxml2.6.2v5 libtorrent-rasterbar8 libvamp-hostsdk3v5 libwxbase3.0-0v5
  libwxgtk3.0-0v5 libxapian22v5 phonon4qt5 sound-theme-freedesktop
The following packages have been kept back:
  gparted libavcodec-ffmpeg56 libavcodec-ffmpeg56:i386 libavresample-ffmpeg2 libavresample-ffmpeg2:i386 libavutil-ffmpeg54 libavutil-ffmpeg54:i386 libproxy-tools
  libswresample-ffmpeg1 libswresample-ffmpeg1:i386
The following packages will be upgraded:
  acpi-fakekey acpi-support acpi-support-base acpid akonadi-backend-mysql akonadi-backend-sqlite akonadi-server akonadiconsole akregator amarok amarok-common amarok-utils
  appstream-index apt apt-utils audacity autopoint baloo-kf5 baloo-kf5-dev baloo-utils bash bind9-host blogilo btrfs-tools cdrdao chromium chromium-l10n cmake
  command-not-found cpp dictionaries-common dns-root-data dvgrab evolution-data-server-common exiv2 ffmpeg ffmpegthumbnailer fluxbox fonts-opensymbol frameworkintegration
  freespacenotifier frei0r-plugins g++ gcc gcc-5-base gcc-5-base:i386 geoip-bin gettext gettext-base gir1.2-packagekitglib-1.0 gstreamer0.10-plugins-ugly
  gstreamer1.0-plugins-bad gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio hostname hugin hugin-tools imagemagick imagemagick-6.q16
  imagemagick-common iso-codes juk k3b kactivities kaddressbook kalarm kde-config-cddb kde-config-touchpad kde-plasma-desktop kde-runtime kde-runtime-data kde-standard
  kde-workspace-kgreet-plugins kdeadmin kdebase-runtime kded5 kded5-dev kdegraphics kdegraphics-mobipocket kdegraphics-strigi-analyzer kdelibs-bin kdelibs5-data
  kdelibs5-dev kdelibs5-plugins kdemultimedia kdenetwork kdepim kdepim-kresources kdepim-runtime kdepimlibs-kio-plugins kdesignerplugin-data kdeutils kdoctools
  kdoctools-dev kdoctools5 kgendesignerplugin kget kgpg kid3 kid3-cli kid3-core kid3-qt kinit kinit-dev kio kio-dev kjots kleopatra kmail knode knotes kodi kodi-bin
  konsolekalendar kontact konversation konversation-data korganizer kpackagelauncherqml kpackagetool5 kross kross-dev kscd ktexteditor-data ktexteditor-katepart
  ktimetracker ktorrent ktorrent-data kup-client libakonadi-calendar4 libakonadi-contact4 libakonadi-kabc4 libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4
  libakonadi-notes4 libakonadiprotocolinternals1 libappstream2 libapt-pkg-perl libasprintf-dev libatk-wrapper-java libatk-wrapper-java-jni libatomic1 libav-tools
  libavdevice-ffmpeg56 libavfilter-ffmpeg5 libavformat-ffmpeg56 libbaloocore4 libbaloofiles4 libbaloopim4 libbalooqueryparser4 libbalooxapian4 libbind9-90 libboost-dev
  libbrlapi0.6 libcalendarsupport4 libcdr-0.1-1 libcilkrts5 libcld2-0 libcomposereditorng4 libdns-export100 libdns100 libdvdnav4 liberror-perl libeventviews4
  libfollowupreminder4 libftdi1 libgcc1 libgcc1:i386 libgegl-0.2-0 libgeoip-dev libgeoip1 libgettextpo-dev libgettextpo0 libgfortran3 libgomp1 libgomp1:i386
  libgstreamer-plugins-bad1.0-0 libharfbuzz-icu0 libharfbuzz0b libhdf5-8 libhunspell-1.3-0 libimage-magick-perl libimage-magick-q16-perl libincidenceeditorsng4
  libirs-export91 libisc-export95 libisc95 libisccc90 libisccfg-export90 libisccfg90 libitm1 libjack-jackd2-0 libjack-jackd2-0:i386 libk3b6 libk3b6-extracodecs libkabc4
  libkalarmcal2 libkate1 libkblog4 libkcal4 libkcalcore4 libkcalutils4 libkcddb4 libkcmutils4 libkcompactdisc4 libkdcraw-data libkdcraw23 libkde3support4 libkdeclarative5
  libkdecorations4abi2 libkdecore5 libkdepim4 libkdepimdbusinterfaces4 libkdesu5 libkdeui5 libkdewebkit5 libkdgantt2-0 libkdnssd4 libkemoticons4 libkephal4abi1
  libkexiv2-11 libkexiv2-data libkf5activities-dev libkf5activities5 libkf5activitiesexperimentalstats1 libkf5auth-bin-dev libkf5auth-data libkf5auth-dev libkf5auth5
  libkf5baloo1 libkf5balooxapian1 libkf5bookmarks-data libkf5bookmarks-dev libkf5bookmarks5 libkf5completion-data libkf5completion-dev libkf5completion5
  libkf5configwidgets-data libkf5configwidgets-dev libkf5configwidgets5 libkf5crash-dev libkf5crash5 libkf5declarative-data libkf5declarative-dev libkf5declarative5
  libkf5emoticons-bin libkf5emoticons-data libkf5emoticons-dev libkf5emoticons5 libkf5filemetadata-bin libkf5filemetadata-data libkf5filemetadata-dev libkf5filemetadata3
  libkf5globalaccel-bin libkf5globalaccel-data libkf5globalaccel-dev libkf5globalaccel5 libkf5globalaccelprivate5 libkf5iconthemes-bin libkf5iconthemes-data
  libkf5iconthemes-dev libkf5iconthemes5 libkf5jobwidgets-data libkf5jobwidgets-dev libkf5jobwidgets5 libkf5kcmutils-data libkf5kcmutils-dev libkf5kcmutils5
  libkf5kdelibs4support-data libkf5kdelibs4support-dev libkf5kdelibs4support5 libkf5kdelibs4support5-bin libkf5kiocore5 libkf5kiofilewidgets5 libkf5kiontlm5
  libkf5kiowidgets5 libkf5krosscore5 libkf5krossui5 libkf5mediaplayer-data libkf5mediaplayer-dev libkf5mediaplayer5 libkf5newstuff-data libkf5newstuff-dev libkf5newstuff5
  libkf5notifications-data libkf5notifications-dev libkf5notifications5 libkf5notifyconfig-data libkf5notifyconfig-dev libkf5notifyconfig5 libkf5package-data
  libkf5package-dev libkf5package5 libkf5parts-data libkf5parts-dev libkf5parts-plugins libkf5parts5 libkf5people-data libkf5people-dev libkf5people5 libkf5peoplebackend5
  libkf5peoplewidgets5 libkf5plasma5 libkf5plasmaquick5 libkf5pty-data libkf5pty-dev libkf5pty5 libkf5quickaddons5 libkf5service-bin libkf5service-data libkf5service-dev
  libkf5service5 libkf5style-dev libkf5style5 libkf5su-bin libkf5su-data libkf5su-dev libkf5su5 libkf5texteditor5 libkf5textwidgets-data libkf5textwidgets-dev
  libkf5textwidgets5 libkf5threadweaver-dev libkf5threadweaver5 libkf5unitconversion-data libkf5unitconversion-dev libkf5unitconversion5 libkf5wallet-bin
  libkf5wallet-data libkf5wallet-dev libkf5wallet5 libkf5webkit-dev libkf5webkit5 libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlgui-dev libkf5xmlgui5
  libkf5xmlrpcclient-data libkf5xmlrpcclient5 libkfile4 libkfilemetadata4 libkfontinst5 libkfontinstui5 libkgapi2-2 libkholidays4 libkhtml5 libkidletime4 libkimap4
  libkimproxy4 libkio5 libkipi-data libkipi11 libkjsapi4 libkjsembed4 libkldap4 libkleo4 libkmanagesieve4 libkmbox4 libkmediaplayer4 libkmime4 libknewstuff2-4
  libknewstuff3-4 libknotifyconfig4 libkntlm4 libkontactinterface4a libkparts4 libkpgp4 libkpimidentities4 libkpimtextedit4 libkpimutils4 libkprintutils4 libkpty4
  libkresources4 libkrosscore4 libkrossui4 libksane-data libksane0 libkscreensaver5 libksgrd4 libksieve4 libksieveui4 libksignalplotter4 libktexteditor4 libktnef4
  libktorrent-l10n libktorrent5 libkunitconversion4 libkutils4 libkwalletbackend5-5 libkwineffects1abi5 libkwinglesutils1 libkwinglutils1abi2 libkworkspace4abi2
  libkworkspace5-5 libkxmlrpcclient4 libllvm3.4 libllvm3.4:i386 liblsan0 liblwres90 libmagickcore-6.q16-2 libmagickcore-6.q16-2-extra libmagickwand-6.q16-2 libmailcommon4
  libmailimporter4 libmailtransport4 libmessagecomposer4 libmessagecore4 libmessagelist4 libmessageviewer4 libmicroblog4 libmspub-0.1-1 libmysqlclient18 libnepomuk4
  libnepomukcore4 libnepomukquery4a libnepomukutils4 libnet-smtp-ssl-perl libnoteshared4 libofa0 libpackagekit-glib2-18 libpam-systemd libpcre16-3 libpcre3 libpcre3:i386
  libpcre3-dev libpcre32-3 libphonon-dev libphonon4 libphonon4qt5-4 libphonon4qt5-dev libphonon4qt5experimental-dev libphonon4qt5experimental4 libpimcommon4
  libplasma-geolocation-interface4 libplasma-geolocation-interface5 libplasma3 libplasmaclock4abi4 libplasmagenericshell4 libplist3 libpoppler-glib8 libpoppler-qt4-4
  libpoppler-qt5-1 libpoppler46 libpostproc-ffmpeg53 libppl-c4 libppl13 libprocesscore4abi1 libprocessui4a libprotobuf-c1 libpsl0 libpstoedit0c2a libqalculate5-data
  libqapt3 libqapt3-runtime libqca-qt5-2 libqca-qt5-2-dev libqca-qt5-2-plugins libqca2 libqca2-dev libqca2-plugin-ossl libqca2-plugins libqgpgme1 libqmobipocket1
  libqt4-dbus libqt4-dbus:i386 libqt4-declarative libqt4-designer libqt4-dev libqt4-dev-bin libqt4-help libqt4-network libqt4-network:i386 libqt4-opengl
  libqt4-opengl:i386 libqt4-opengl-dev libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml
  libqt4-xml:i386 libqt4-xmlpatterns libqt4-xmlpatterns:i386 libqt5clucene5 libqt5concurrent5 libqt5core5a libqt5dbus5 libqt5designer5 libqt5designercomponents5
  libqt5gui5 libqt5help5 libqt5network5 libqt5opengl5 libqt5opengl5-dev libqt5printsupport5 libqt5qml5 libqt5quick5 libqt5quickparticles5 libqt5quicktest5
  libqt5quickwidgets5 libqt5sql5 libqt5sql5-sqlite libqt5test5 libqt5webkit5 libqt5webkit5-dev libqt5widgets5 libqt5xml5 libqtcore4 libqtcore4:i386 libqtdbus4
  libqtdbus4:i386 libqtglib-2.0-0 libqtgstreamer-1.0-0 libqtgstreamerui-1.0-0 libqtgui4 libqtgui4:i386 libqtwebkit-dev libqtwebkit4:i386 libqtwebkit4 libquadmath0
  libreoffice libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core libreoffice-base-drivers libreoffice-calc libreoffice-common libreoffice-core
  libreoffice-draw libreoffice-gtk3 libreoffice-help-en-us libreoffice-impress libreoffice-java-common libreoffice-kde libreoffice-l10n-it libreoffice-math
  libreoffice-report-builder-bin libreoffice-style-galaxy libreoffice-style-oxygen libreoffice-style-sifr libreoffice-style-tango libreoffice-writer libseccomp2
  libsendlater4 libsolid4 libsoprano4 libstdc++6 libstdc++6:i386 libswscale-ffmpeg3 libsyndication4 libsystemd0 libsystemd0:i386 libtag-extras1 libtaskmanager4abi4
  libtaskmanager5 libtemplateparser4 libtext-wrapi18n-perl libthreadweaver4 libtiff5 libtiff5:i386 libtiff5-dev libtiffxx5 libtommath0 libtsan0 libubsan0 libudev1
  libudev1:i386 libusb-0.1-4 libusb-dev libvigraimpex4 libvlc-dev libvlc5 libvlccore8 libweather-ion6 libweather-ion7 libxapian-dev libxerces-c3.1 luckybackup
  luckybackup-data mldonkey-server mysql-common mysql-server-core-5.5 nepomuk-core-runtime opencv-data packagekit packagekit-tools perlmagick phonon
  phonon-backend-gstreamer phonon-backend-gstreamer-common phonon-backend-vlc phonon4qt5-backend-null plasma-dataengines-workspace plasma-desktop plasma-desktop-data
  plasma-framework plasma-framework-dev plasma-mediacenter plasma-netbook plasma-scriptengine-javascript plasma-scriptengine-python plasma-widgets-workspace
  plasma-workspace plasma-workspace-dev poedit poedit-common poppler-utils printer-driver-brlaser pstoedit python-brlapi python-cryptography python-idna python-ipaddress
  python-libtorrent python-opencv python-ufw python-wxgtk3.0 python-xapian python3-uno qapt-batch qdbus qdbus-qt5 qml-module-org-kde-draganddrop
  qml-module-org-kde-extensionplugin qml-module-org-kde-kcoreaddons qml-module-org-kde-kio qml-module-org-kde-kquickcontrols qml-module-org-kde-kquickcontrolsaddons
  qml-module-org-kde-kwindowsystem qml-module-qtquick-window2 qml-module-qtquick2 qml-module-qtwebkit qt4-linguist-tools qt4-qmake qt5-qmake qtbase5-dev qtbase5-dev-tools
  qtcore4-l10n qtdeclarative5-dev qtdeclarative5-kf5declarative qtgstreamer-declarative qttools5-dev-tools ruby-debian sddm-theme-breeze solydxk-constructor
  soprano-daemon soundkonverter synaptic systemd systemd-sysv tar udev ufraw-batch ufw uno-libs3 ure user-manager virtualbox virtualbox-dkms virtualbox-qt vlc vlc-data
  vlc-nox vlc-plugin-notify vlc-plugin-pulse vlc-plugin-samba vpnc-scripts wesnoth-1.12-core wireless-regdb wx-common xterm
677 upgraded, 88 newly installed, 159 to remove and 10 not upgraded.
Need to get 613 MB of archives.
After this operation, 66.7 MB disk space will be freed.
Do you want to continue? [Y/n] 

Note:
  • solydxk-system* packages are going to be removed
  • phonon4qt5 is part of new packages
-------
Image

User avatar
grizzler
Posts: 2180
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: Breakages and News tracking Debian Testing

Postby grizzler » 07 Sep 2015 09:46

Yup, solydxk-system depends on aptitude, which is also in that list.

I built myself a private version of solydxk-system without that dependency (it's only there because some functions of the apt script require it) and went ahead anyway. Apparently some earlier update messed up my LibreOffice Calc, so I figured I'd try LibreOffice 5.0.1, which did indeed fix that problem.

Interesting times... ;)

Edit
Changed the setup a little: back to default solydxk-system, but with aptitude from sid. Works just as well.
Frank

SolydX EE 64 - tracking Debian Testing

kurotsugi
Posts: 2240
Joined: 09 Jan 2014 00:17

Re: Breakages and News tracking Debian Testing

Postby kurotsugi » 07 Sep 2015 19:21

after removing some unnecessary packages due to previous transitions:

Code: Select all

Calculating upgrade... The following packages were automatically installed and are no longer required:
  coinor-libcbc3 coinor-libcgl1 coinor-libclp1 coinor-libcoinmp1
  coinor-libcoinutils3 coinor-libosi1 g++-4.9 gstreamer0.10-nice
  libboost-system1.55.0 libgadu3 libgssdp-1.0-3 libgupnp-1.0-4
  libgupnp-igd-1.0-4 libmeanwhile1 libnice10 libprotobuf-c1 libzephyr4
  pidgin-data
Use 'apt-get autoremove' to remove them.
Done
The following packages will be REMOVED:
  aptitude gstreamer0.10-plugins-good libasprintf0c2 libbinio1ldbl
  libboost-date-time1.55.0 libclucene-contribs1 libclucene-core1 libcmis-0.5-5
  libept1.4.12 libfarstream-0.1-0 libflac++6 libgltf-0.0-0 libilmbase6
  libopencv-calib3d2.4 libopencv-contrib2.4 libopencv-core2.4
  libopencv-features2d2.4 libopencv-flann2.4 libopencv-highgui2.4
  libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4
  libopencv-objdetect2.4 libopencv-video2.4 libopenexr6 liborcus-0.10-0
  libproxy1 libpurple0 libsidplay1 libsidplayfp3 libtag1-vanilla libtag1c2a
  libtagc0 libvamp-hostsdk3 libwxbase3.0-0 libwxgtk3.0-0 libxapian22 pidgin
  thunar-media-tags-plugin
153 upgraded, 44 newly installed, 39 to remove and 10 not upgraded.

I'm still stuck with libboost and ffmpeg transition. I'm not sure whether if I should continue. Somehow sid is lil bit better

Code: Select all

Calculating upgrade... The following packages were automatically installed and are no longer required:
  coinor-libcgl1 coinor-libclp1 coinor-libcoinutils3v5 coinor-libosi1v5
  g++-4.9 libboost-system1.55.0 libicu52:i386 libirs-export91
  libisccfg-export90 libpth20
Use 'apt-get autoremove' to remove them.
Done
The following packages will be REMOVED:
  aptitude coinor-libcbc3 coinor-libcoinmp1 coinor-libcoinutils3
  coinor-libosi1 libasprintf0c2 libatkmm-1.6-1 libbinio1ldbl
  libboost-date-time1.55.0 libcairomm-1.0-1 libclucene-contribs1
  libclucene-core1 libcmis-0.5-5 libcwidget3 libept1.4.12 libflac++6
  libglibmm-2.4-1c2a libgltf-0.0-0 libgtkmm-2.4-1c2a libgtkmm-3.0-1
  libilmbase6 libllvm3.5 libllvm3.5:i386 libmagick++-6.q16-5
  libopencv-calib3d2.4 libopencv-contrib2.4 libopencv-core2.4
  libopencv-features2d2.4 libopencv-flann2.4 libopencv-highgui2.4
  libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4
  libopencv-objdetect2.4 libopencv-video2.4 libopenexr6 liborcus-0.10-0
  libpangomm-1.4-1 libproxy1 libqpdf13 libsidplay1 libsidplayfp3
  libsigc++-2.0-0c2a libtag1-vanilla libtag1c2a libvamp-hostsdk3
  libwxbase3.0-0 libwxgtk3.0-0 libxapian22
259 upgraded, 65 newly installed, 49 to remove and 8 not upgraded.
sid simulation shows that that only one problem left (libboost) and our ffmpeg transition will be over in next few days. I was tempted to temporary move into sid but unfortunately I heavily depends on aptitude to do some tasks. I think I'll wait to see whether if the libboost transition could be solved in next few days. then, if it's possible, I'll partially move my system to sid.

User avatar
grizzler
Posts: 2180
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: Breakages and News tracking Debian Testing

Postby grizzler » 07 Sep 2015 19:37

Check the dist-upgrade listing again and in particular compare the REMOVED section with the NEW section. You should see that most of the packages in the former are also in the latter, but with a slightly different name (often with v5 tagged on to it). This includes the libboost packages.

The ones that cause real issues are aptitude and gstreamer0.10-plugins-good. I've put the versions from sid in my local repository (also aptitude-common) and with that, only one single package was left that really couldn't be kept. Except for that one, I now have a fully up to date SolydX EE.
Frank

SolydX EE 64 - tracking Debian Testing

kurotsugi
Posts: 2240
Joined: 09 Jan 2014 00:17

Re: Breakages and News tracking Debian Testing

Postby kurotsugi » 08 Sep 2015 08:37

that was fast :3

perhaps my repo haven't synched yet but last night sid's aptitude also broken. it complained about libboost so I assume libboost transition haven't calmed down yet.

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Breakages and News tracking Debian Testing

Postby MAYBL8 » 08 Sep 2015 11:41

Just went to update this morning:

Code: Select all

dcihon@solydk64 / $ sudo apt-get autoremove && sudo apt-get update && sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 632 not upgraded.
Hit http://repository.solydxk.com solydxk-8 InRelease
Hit http://ftp.debian.org testing InRelease                                          
Hit http://ftp.debian.org jessie-backports InRelease                                                      
Hit http://repository.solydxk.com solydxk-8/upstream amd64 Packages                  
Get:1 http://ftp.debian.org testing/main amd64 Packages/DiffIndex [7,876 B]                                
Hit http://repository.solydxk.com solydxk-8/upstream i386 Packages                            
Hit http://repository.solydxk.com solydxk-8/main amd64 Packages                     
Get:2 http://ftp.debian.org testing/contrib amd64 Packages/DiffIndex [7,819 B]      
Get:3 http://ftp.debian.org testing/non-free amd64 Packages/DiffIndex [7,819 B]     
Get:4 http://ftp.debian.org testing/main i386 Packages/DiffIndex [7,876 B]          
Get:5 http://ftp.debian.org testing/contrib i386 Packages/DiffIndex [7,819 B]       
Get:6 http://ftp.debian.org testing/non-free i386 Packages/DiffIndex [7,819 B]
Hit http://repository.solydxk.com solydxk-8/import amd64 Packages                                  
Get:7 http://ftp.debian.org jessie-backports/main amd64 Packages/DiffIndex [7,819 B]
Hit http://repository.solydxk.com solydxk-8/main i386 Packages                                
Hit http://repository.solydxk.com solydxk-8/import i386 Packages                                      
Get:8 http://ftp.debian.org jessie-backports/contrib amd64 Packages/DiffIndex [367 B]
Get:9 http://ftp.debian.org jessie-backports/non-free amd64 Packages/DiffIndex [919 B]
Get:10 http://ftp.debian.org jessie-backports/main i386 Packages/DiffIndex [7,819 B]
Get:11 http://ftp.debian.org jessie-backports/contrib i386 Packages/DiffIndex [367 B]
Get:12 http://ftp.debian.org jessie-backports/non-free i386 Packages/DiffIndex [919 B]
Hit http://ftp.debian.org jessie-backports/non-free amd64 Packages
Hit http://ftp.debian.org jessie-backports/main i386 Packages
Hit http://security.debian.org testing/updates InRelease     
Hit http://security.debian.org testing/updates/main amd64 Packages                                                          
Hit http://security.debian.org testing/updates/contrib amd64 Packages                                                       
Hit http://security.debian.org testing/updates/non-free amd64 Packages                                                      
Hit http://security.debian.org testing/updates/main i386 Packages                                                           
Hit http://security.debian.org testing/updates/contrib i386 Packages                                                        
Hit http://security.debian.org testing/updates/non-free i386 Packages                                                       
Fetched 65.2 kB in 6s (9,542 B/s)                                                                                           
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... The following packages were automatically installed and are no longer required:
  amor ant ant-optional calligra-data calligraflow-data calligrastage-data calligrawords-data coinor-libcbc3 coinor-libcgl1
  coinor-libclp1 coinor-libcoinmp1 coinor-libcoinutils3 coinor-libosi1 filezilla-common glib-networking:i386
  gstreamer0.10-gconf:i386 gstreamer0.10-x:i386 kexi-data krita-data ktux libaa1:i386 libapache-poi-java libavc1394-0:i386
  libavdevice55 libavformat56 libbz2-1.0:i386 libcaca0:i386 libcairo-gobject2:i386 libcommons-codec-java
  libdbus-glib-1-2:i386 libdom4j-java libdv4:i386 libgconf-2-4:i386 libgnome-desktop-2-17 libgnomedesktop2.20-cil
  libgudev-1.0-0:i386 libiec61883-0:i386 libisorelax-java libjack-jackd2-0:i386 libjaxen-java libjdom1-java libkiten4abi1
  libkrossui4 libmsv-java libmusicbrainz5cc2 libncursesw5:i386 libopencolorio1 libopus0:i386 libphononexperimental4
  libproxy1v5:i386 libraw1394-11:i386 librelaxng-datatype-java librsvg2-2.18-cil libsamplerate0:i386 libshout3:i386
  libslang2:i386 libsoup-gnome2.4-1:i386 libsoup2.4-1:i386 libspeex1:i386 libspnav0 libswscale3 libtinyxml2.6.2
  libwavpack1:i386 libwnck2.20-cil libxmlbeans-java libxom-java libxpp2-java libxpp3-java libxv1:i386 libyaml-cpp0.3
Use 'apt-get autoremove' to remove them.
Done
The following packages will be REMOVED:
  amarok amarok-utils aptitude braindump calligra calligra-libs calligra-semanticitems calligraauthor calligraflow
  calligraplan calligrasheets calligrastage calligrawords filezilla gstreamer0.10-plugins-good
  gstreamer0.10-plugins-good:i386 karbon kexi krita libasprintf0c2 libavfilter5 libbinio1ldbl libboost-date-time1.55.0
  libclucene-contribs1 libclucene-core1 libcmis-0.4-4 libcmis-0.5-5 libebml4 libept1.4.12 libfarstream-0.1-0
  libffmpegthumbnailer4 libflac++6 libgltf-0.0-0 libgpgme++2 libid3-3.8.3c2a libilmbase6 libkolab0 libkolabxml1
  libmagickcore5-extra libmatroska6 libmediainfo0 libmusicbrainz3-6 libopenconnect2 libopenconnect3 libopencv-calib3d2.4
  libopencv-contrib2.4 libopencv-core2.4 libopencv-features2d2.4 libopencv-flann2.4 libopencv-gpu2.4 libopencv-highgui2.4
  libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4 libopencv-objdetect2.4 libopencv-ocl2.4 libopencv-photo2.4
  libopencv-stitching2.4 libopencv-superres2.4 libopencv-ts2.4 libopencv-video2.4 libopencv-videostab2.4 libopenexr6
  liborcus-0.10-0 libproxy1 libproxy1:i386 libpurple-bin libpurple0 libqalculate5 libqapt-runtime libqapt1 libsidplay1
  libsidplayfp3 libstreamanalyzer0 libstreams0 libtag1-vanilla libtag1-vanilla:i386 libtag1c2a libtag1c2a:i386
  libvamp-hostsdk3 libwxbase3.0-0 libwxgtk3.0-0 libxapian22 libzen0 pdf2djvu solydxk-system telepathy-haze
The following NEW packages will be installed:
  cpp-5 g++-5 gcc-5 kdepim-doc ktnef libapt-inst1.7 libapt-pkg4.16 libasan2 libasprintf0v5 libbabeltrace-ctf1
  libbabeltrace1 libbinio1v5 libboost-date-time1.58.0 libboost-filesystem1.58.0 libboost-iostreams1.58.0
  libboost-program-options1.58.0 libboost-python1.58.0 libboost-regex1.58.0 libboost-system1.58.0 libboost-thread1.58.0
  libcc1-0 libclucene-contribs1v5 libclucene-core1v5 libcmis-0.5-5v5 libebml4v5 libept1.4.16 libexiv2-14
  libffmpegthumbnailer4v5 libflac++6v5 libgcc-5-dev libgkeyfile1.0-cil libgltf-0.0-0v5 libgpgme++2v5 libicu55
  libid3-3.8.3v5 libilmbase6v5 libkiten5 libkolab0v5 libkolabxml1v5 libmatroska6v5 libmediainfo0v5 libmpx0
  libmusicbrainz3-6v5 libmusicbrainz5cc2v5 libopencv-calib3d2.4v5 libopencv-contrib2.4v5 libopencv-core2.4v5
  libopencv-features2d2.4v5 libopencv-flann2.4v5 libopencv-gpu2.4v5 libopencv-highgui2.4v5 libopencv-imgproc2.4v5
  libopencv-legacy2.4v5 libopencv-ml2.4v5 libopencv-objdetect2.4v5 libopencv-ocl2.4v5 libopencv-photo2.4v5
  libopencv-stitching2.4v5 libopencv-superres2.4v5 libopencv-ts2.4v5 libopencv-video2.4v5 libopencv-videostab2.4v5
  libopenexr6v5 liborcus-0.10-0v5 libproxy1v5 libproxy1v5:i386 libqalculate5v5 libqca-qt5-2 libqca-qt5-2-plugins
  libreoffice-style-breeze libsidplay1v5 libsidplayfp4 libstdc++-5-dev libstreamanalyzer0v5 libstreams0v5 libtag1v5
  libtag1v5-vanilla libtorrent-rasterbar8 libvamp-hostsdk3v5 libwxbase3.0-0v5 libwxgtk3.0-0v5 libxapian22v5 libzen0v5
  phonon4qt5 phonon4qt5-backend-vlc sound-theme-freedesktop
The following packages have been kept back:
  libpstoedit0c2a pavucontrol
The following packages will be upgraded:
  acpi-support-base acpid akonadi-backend-mysql akonadi-backend-sqlite akonadi-server apt apt-utils audacious-plugins
  audacity autopoint baloo-utils baloo4 bash bind9-host cantor cantor-backend-kalgebra cdrdao chromium chromium-l10n
  command-not-found cpp dictionaries-common dns-root-data dnsutils docky dosbox dvgrab evolution-data-server-common exiv2
  ffmpeg ffmpegthumbnailer fonts-opensymbol frameworkintegration freespacenotifier frei0r-plugins g++ gcc gcc-5-base
  gcc-5-base:i386 gdb gdbserver gettext gettext-base gir1.2-packagekitglib-1.0 glib-networking glib-networking:i386
  glib-networking-services gstreamer1.0-plugins-bad gstreamer1.0-plugins-good gstreamer1.0-plugins-ugly
  gstreamer1.0-pulseaudio hostname hugin hugin-tools id3v2 imagemagick imagemagick-6.q16 imagemagick-common iso-codes juk
  k3b kactivities kaddressbook kde-config-cddb kde-games-core-declarative kde-plasma-desktop kde-runtime kde-runtime-data
  kde-workspace-kgreet-plugins kdeaccessibility kdeadmin kdebase-runtime kded5 kdeedu kdegames kdegames-card-data
  kdegames-mahjongg-data kdelibs-bin kdelibs5-data kdelibs5-plugins kdemultimedia kdepim-kresources kdepim-runtime
  kdepimlibs-kio-plugins kdetoys kdeutils kdm kdoctools kdoctools5 keyutils kget kgpg kinit kio kiten kmail knotes
  konversation konversation-data korganizer kpackagelauncherqml kpackagetool5 kross kscd ktexteditor-data
  ktexteditor-katepart ktorrent ktorrent-data lib32gcc1 lib32stdc++6 libakonadi-calendar4 libakonadi-contact4
  libakonadi-kabc4 libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4 libakonadi-notes4 libakonadiprotocolinternals1
  libapt-pkg-perl libasprintf-dev libatk-wrapper-java libatk-wrapper-java-jni libatomic1 libav-tools libavcodec-extra
  libavcodec-ffmpeg-extra56 libavdevice-ffmpeg56 libavfilter-ffmpeg5 libavformat-ffmpeg56 libavresample-ffmpeg2
  libavutil-ffmpeg54 libbaloocore4 libbaloofiles4 libbaloopim4 libbalooqueryparser4 libbalooxapian4 libbind9-90
  libbrlapi0.6 libcalendarsupport4 libcdr-0.1-1 libcilkrts5 libconfig9 libdee-1.0-4 libdns-export100 libdns100 libdvdnav4
  liberror-perl libevdev2 libeventviews4 libfollowupreminder4 libfont-ttf-perl libftdi1 libgcc1 libgcc1:i386 libgegl-0.2-0
  libgeoip1 libgettextpo-dev libgettextpo0 libgexiv2-2 libgfortran3 libgomp1 libgstreamer-plugins-bad1.0-0 libharfbuzz-icu0
  libharfbuzz0b libharfbuzz0b:i386 libhdf5-8 libhunspell-1.3-0 libimage-magick-perl libimage-magick-q16-perl
  libincidenceeditorsng4 libirs-export91 libisc-export95 libisc95 libisccc90 libisccfg-export90 libisccfg90 libitm1
  libjack-jackd2-0 libjack-jackd2-0:i386 libk3b6 libk3b6-extracodecs libkabc4 libkalarmcal2 libkblog4 libkcal4 libkcalcore4
  libkcalutils4 libkcddb4 libkcmutils4 libkcompactdisc4 libkdcraw-data libkdcraw23 libkde3support4 libkdeclarative5
  libkdecorations4abi2 libkdecore5 libkdegames6abi1 libkdegamesprivate1abi1 libkdepim4 libkdepimdbusinterfaces4 libkdesu5
  libkdeui5 libkdewebkit5 libkdgantt2-0 libkdnssd4 libkemoticons4 libkephal4abi1 libkexiv2-11 libkexiv2-data libkeyutils1
  libkeyutils1:i386 libkf5activities5 libkf5activitiesexperimentalstats1 libkf5auth-data libkf5auth5 libkf5baloo1
  libkf5balooxapian1 libkf5bookmarks-data libkf5bookmarks5 libkf5completion-data libkf5completion5 libkf5configwidgets-data
  libkf5configwidgets5 libkf5crash5 libkf5declarative-data libkf5declarative5 libkf5emoticons-data libkf5emoticons5
  libkf5filemetadata-bin libkf5filemetadata-data libkf5filemetadata3 libkf5globalaccel-bin libkf5globalaccel-data
  libkf5globalaccel5 libkf5globalaccelprivate5 libkf5iconthemes-bin libkf5iconthemes-data libkf5iconthemes5
  libkf5jobwidgets-data libkf5jobwidgets5 libkf5kcmutils-data libkf5kcmutils5 libkf5kdelibs4support-data
  libkf5kdelibs4support5 libkf5kdelibs4support5-bin libkf5kiocore5 libkf5kiofilewidgets5 libkf5kiontlm5 libkf5kiowidgets5
  libkf5krosscore5 libkf5krossui5 libkf5newstuff-data libkf5newstuff5 libkf5notifications-data libkf5notifications5
  libkf5notifyconfig-data libkf5notifyconfig5 libkf5package-data libkf5package5 libkf5parts-data libkf5parts-plugins
  libkf5parts5 libkf5people-data libkf5people5 libkf5peoplebackend5 libkf5peoplewidgets5 libkf5plasma5 libkf5plasmaquick5
  libkf5pty-data libkf5pty5 libkf5quickaddons5 libkf5runner5 libkf5service-bin libkf5service-data libkf5service5
  libkf5style5 libkf5su-bin libkf5su-data libkf5su5 libkf5texteditor5 libkf5textwidgets-data libkf5textwidgets5
  libkf5threadweaver5 libkf5wallet-bin libkf5wallet-data libkf5wallet5 libkf5webkit5 libkf5xmlgui-bin libkf5xmlgui-data
  libkf5xmlgui5 libkf5xmlrpcclient-data libkf5xmlrpcclient5 libkfile4 libkfilemetadata4 libkfontinst5 libkfontinstui5
  libkgapi2-2 libkholidays4 libkhtml5 libkidletime4 libkimap4 libkio5 libkipi-data libkipi11 libkjsapi4 libkjsembed4
  libkldap4 libkleo4 libkmahjongglib4 libkmanagesieve4 libkmbox4 libkmediaplayer4 libkmime4 libknewstuff2-4 libknewstuff3-4
  libknotifyconfig4 libkntlm4 libkontactinterface4a libkparts4 libkpathsea6 libkpgp4 libkpimidentities4 libkpimtextedit4
  libkpimutils4 libkprintutils4 libkpty4 libkresources4 libkrosscore4 libkrossui4 libksane-data libksane0 libkscreensaver5
  libksgrd4 libksieve4 libksieveui4 libksignalplotter4 libktexteditor4 libktnef4 libktorrent-l10n libktorrent5
  libkunitconversion4 libkutils4 libkwalletbackend5-5 libkwineffects1abi5 libkwinglesutils1 libkwinglutils1abi2
  libkworkspace4abi2 libkworkspace5-5 libkxmlrpcclient4 libllvm3.4 libllvm3.4:i386 liblsan0 liblwres90
  libmagickcore-6.q16-2 libmagickcore-6.q16-2-extra libmagickwand-6.q16-2 libmailcommon4 libmailimporter4 libmailtransport4
  libmessagecomposer4 libmessagecore4 libmessagelist4 libmessageviewer4 libmicroblog4 libmspub-0.1-1 libmsv-java
  libmysqlclient18 libnepomuk4 libnepomukcore4 libnepomukquery4a libnepomukutils4 libnet-smtp-ssl-perl libnoteshared4
  libofa0 libofx6 libopenconnect5 libpackagekit-glib2-18 libpam-systemd libpcre16-3 libpcre3 libpcre3:i386 libpimcommon4
  libplasma-geolocation-interface4 libplasma-geolocation-interface5 libplasma3 libplasmaclock4abi4 libplasmagenericshell4
  libplist3 libpoppler-glib8 libpoppler-qt4-4 libpoppler-qt5-1 libpoppler46 libpostproc-ffmpeg53 libppl-c4 libppl13
  libprocesscore4abi1 libprocessui4a libprotobuf-c1 libproxy-tools libpsl0 libptexenc1 libqalculate5-data libqapt3
  libqapt3-runtime libqca2 libqca2-plugin-ossl libqca2-plugins libqgpgme1 libqmobipocket1 libqt4-dbus libqt4-declarative
  libqt4-designer libqt4-help libqt4-network libqt4-network:i386 libqt4-opengl libqt4-opengl:i386 libqt4-qt3support
  libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml
  libqt4-xml:i386 libqt4-xmlpatterns libqt4-xmlpatterns:i386 libqt5clucene5 libqt5concurrent5 libqt5core5a libqt5dbus5
  libqt5designer5 libqt5designercomponents5 libqt5gui5 libqt5help5 libqt5network5 libqt5opengl5 libqt5printsupport5
  libqt5qml5 libqt5quick5 libqt5quickwidgets5 libqt5sql5 libqt5sql5-sqlite libqt5test5 libqt5webkit5 libqt5widgets5
  libqt5xml5 libqtcore4 libqtcore4:i386 libqtdbus4 libqtdbus4:i386 libqtglib-2.0-0 libqtgstreamer-1.0-0
  libqtgstreamerui-1.0-0 libqtgui4 libqtgui4:i386 libqtwebkit4:i386 libqtwebkit4 libquadmath0 libreoffice
  libreoffice-avmedia-backend-gstreamer libreoffice-base libreoffice-base-core libreoffice-base-drivers libreoffice-calc
  libreoffice-common libreoffice-core libreoffice-draw libreoffice-gtk3 libreoffice-help-en-us libreoffice-impress
  libreoffice-java-common libreoffice-kde libreoffice-math libreoffice-report-builder-bin libreoffice-style-galaxy
  libreoffice-style-oxygen libreoffice-style-tango libreoffice-writer libseccomp2 libsendlater4 libsolid4 libsoprano4
  libstdc++6 libstdc++6:i386 libswresample-ffmpeg1 libswscale-ffmpeg3 libsynctex1 libsyndication4 libsystemd0
  libsystemd0:i386 libtag-extras1 libtagc0 libtaskmanager4abi4 libtaskmanager5 libtelepathy-qt4-2
  libtelepathy-qt4-farstream2 libtemplateparser4 libtexlua52 libtexluajit2 libtext-wrapi18n-perl libthreadweaver4
  libtiff-tools libtiff5 libtiff5:i386 libtsan0 libubsan0 libudev1 libudev1:i386 libusb-0.1-4 libvigraimpex4 libvlc5
  libvlccore8 libweather-ion6 libweather-ion7 libxerces-c3.1 libzeitgeist-2.0-0 luckybackup luckybackup-data mediainfo
  mkvtoolnix mysql-common mysql-server-core-5.5 opencv-data packagekit packagekit-tools perlmagick phonon-backend-gstreamer
  phonon-backend-gstreamer-common phonon-backend-vlc plasma-dataengines-workspace plasma-desktop plasma-desktop-data
  plasma-framework plasma-netbook plasma-scriptengine-javascript plasma-scriptengine-python plasma-widgets-workspace
  plasma-workspace poppler-utils printer-driver-brlaser pstoedit python-brlapi python-idna python-ipaddress
  python-libtorrent python-opencv python-pyexiv2 python-recoll python-service-identity python-six python-ufw
  python-wxgtk3.0 python-xapian python3-six python3-uno qapt-batch qdbus qdbus-qt5 qml-module-org-kde-draganddrop
  qml-module-org-kde-extensionplugin qml-module-org-kde-kcoreaddons qml-module-org-kde-kio
  qml-module-org-kde-kquickcontrols qml-module-org-kde-kquickcontrolsaddons qml-module-org-kde-kwindowsystem
  qml-module-org-kde-runnermodel qml-module-qtquick-window2 qml-module-qtquick2 qml-module-qtwebkit qt4-qtconfig
  qtcore4-l10n qtdeclarative5-kf5declarative qtgstreamer-declarative qttools5-dev-tools recoll ruby-debian
  sddm-theme-breeze soprano-daemon step synaptic systemd systemd-sysv tex-common texlive-binaries thunar-media-tags-plugin
  udev ufraw-batch ufw uno-libs3 ure virtualbox virtualbox-dkms virtualbox-guest-dkms virtualbox-guest-source
  virtualbox-guest-utils virtualbox-guest-x11 virtualbox-qt vlc vlc-data vlc-nox vlc-plugin-fluidsynth vlc-plugin-notify
  vlc-plugin-pulse vlc-plugin-samba vpnc-scripts winff winff-gtk2 wireless-regdb zeitgeist-core
612 upgraded, 86 newly installed, 87 to remove and 2 not upgraded.
Need to get 587 MB of archives.
After this operation, 282 MB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.
Will there be someway to know when all this gets straightened out?
What posts from testing do I need to watch?
Thanks guys


User avatar
belze
Posts: 221
Joined: 29 Sep 2014 16:31
Location: Torino, Italy

Re: Breakages and News tracking Debian Testing

Postby belze » 08 Sep 2015 11:52

https://release.debian.org/transitions/ ... dc++6.html this is quite a long list of packages. This transition started at the end of July, it is now at 32%. Every package in the list above needs to be fixed. This may require a lot of rebuild, a lot of packages will change deps and broke with an upgrade.
This GCC5 transition is one of the stronger i ever had using sid in the last ~7 years.
Read this can help you to understand more https://wiki.debian.org/GCC5
You can follow and read some discussion there https://lists.debian.org/debian-devel/2 ... html#00146
-------
Image

kurotsugi
Posts: 2240
Joined: 09 Jan 2014 00:17

Re: Breakages and News tracking Debian Testing

Postby kurotsugi » 08 Sep 2015 13:27

AFAIK currently the root of breakage in testing are : ffmpeg, gcc5, plasma5. the problem is that all of them are huge transitions and overlapped each other. ffmpeg is quite easy to track. you simply can use transition tracker to see whether if the transition is over or simply wait until no packages removed. kde is more or less similar with ffmpeg. as for gcc...i think it was supposed to be a smooth transition (and it was) but gcc transition is extremely huge so this situation is unavoidable. however, after libboost stuff and other small transition is over I'd expect the situation will calmed down.

anyway, after trimming down my system (I temporary remove libasound2-plugins:i386 and related packages to smoothen ffmpeg transition) it seems that the only messy transition in sid is something related to gparted. all the aforementioned issue seems already gone. we can expect issues in testing will be resolved in 2-5 days.

User avatar
belze
Posts: 221
Joined: 29 Sep 2014 16:31
Location: Torino, Italy

Re: Breakages and News tracking Debian Testing

Postby belze » 08 Sep 2015 14:14

i put an eye there http://forum.siduction.org/index.php?topic=5719.0 daily.

edit:status of my VM at dist-upgrade of today

Code: Select all

LANG=C sudo apt-get dist-upgrade -d
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  aptitude libept1.4.12 libopencv-calib3d2.4 libopencv-contrib2.4 libopencv-core2.4 libopencv-features2d2.4 libopencv-flann2.4 libopencv-highgui2.4 libopencv-imgproc2.4 libopencv-legacy2.4
  libopencv-ml2.4 libopencv-objdetect2.4 libopencv-photo2.4 libopencv-video2.4 libproxy1 libqapt-runtime libqapt1 libwxbase3.0-0 libwxgtk3.0-0 libxapian22 solydxk-system
The following NEW packages will be installed:
  libapt-inst1.7 libapt-pkg4.16 libboost-python1.58.0 libept1.4.16 libkf5itemmodels5 libopencv-calib3d2.4v5 libopencv-contrib2.4v5 libopencv-core2.4v5 libopencv-features2d2.4v5
  libopencv-flann2.4v5 libopencv-highgui2.4v5 libopencv-imgproc2.4v5 libopencv-legacy2.4v5 libopencv-ml2.4v5 libopencv-objdetect2.4v5 libopencv-photo2.4v5 libopencv-video2.4v5 libproxy1v5
  libtorrent-rasterbar8 libwxbase3.0-0v5 libwxgtk3.0-0v5 libxapian22v5
The following packages will be upgraded:
  acpi-support-base acpid apt apt-utils baloo-kf5 dns-root-data frameworkintegration gdb-minimal gir1.2-packagekitglib-1.0 glib-networking glib-networking-services gwenview hostname
  iso-codes kactivities kde-plasma-desktop kde-standard kded5 keyutils kgpg kpackagelauncherqml kpackagetool5 kross ktexteditor-data ktexteditor-katepart libapt-pkg-perl libatk-wrapper-java
  libatk-wrapper-java-jni libbaloocore4 libbaloofiles4 libbaloopim4 libbalooqueryparser4 libbalooxapian4 libevdev2 libkeyutils1 libkf5activities5 libkf5baloo1 libkf5balooxapian1
  libkf5declarative-data libkf5declarative5 libkf5kcmutils-data libkf5kcmutils5 libkf5krosscore5 libkf5krossui5 libkf5package-data libkf5package5 libkf5plasma5 libkf5plasmaquick5
  libkf5quickaddons5 libkf5runner5 libkf5style5 libkf5texteditor5 libkf5webkit5 libopenconnect5 libpackagekit-glib2-18 libpoppler-glib8 libpoppler-qt4-4 libpoppler-qt5-1 libpoppler46
  libprotobuf-c1 libproxy-tools libqapt3 libqapt3-runtime libseccomp2 libtiff5 packagekit packagekit-tools phonon-backend-vlc phonon4qt5-backend-vlc plasma-framework poppler-utils
  python-idna python-ipaddress python-libtorrent python-opencv python-service-identity python-six python-wxgtk3.0 python-xapian python3-six qapt-batch qml-module-org-kde-draganddrop
  qml-module-org-kde-extensionplugin qml-module-org-kde-kcoreaddons qml-module-org-kde-kio qml-module-org-kde-kquickcontrols qml-module-org-kde-kquickcontrolsaddons
  qml-module-org-kde-kwindowsystem qml-module-org-kde-runnermodel qtdeclarative5-kf5declarative ruby-debian solydxk-welcome synaptic
93 upgraded, 22 newly installed, 21 to remove and 0 not upgraded.
Need to get 35.7 kB/45.5 MB of archives.
After this operation, 3623 kB of additional disk space will be used.
Do you want to continue? [Y/n] 
so a lot less packages!
-------
Image

User avatar
belze
Posts: 221
Joined: 29 Sep 2014 16:31
Location: Torino, Italy

Re: Breakages and News tracking Debian Testing

Postby belze » 10 Sep 2015 09:23

i upgraded my legal win7 (preinstalled oem) to win10 and i don't know if this broken my solyd box. last time i booted all was working as usual and i did not install nor upgrade anything. anyway, i am not able to boot. I have a gentoo box and i chrooted to solyd.
I did a full upgrade from testing blindly. I have this:

Code: Select all

LANG=C apt-get dist-upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  gparted qpdf
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up solydk-system-adjustments (2.1.6) ...
update-rc.d: error: initscript does not exist: /etc/init.d/solydxk-system
dpkg: error processing package solydk-system-adjustments (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 solydk-system-adjustments
E: Sub-process /usr/bin/dpkg returned an error code (1)
i did not reboot into it yet, this will need a now post to ask help if i'll need it. I guess i have this dpkg error because aptitude went away and is needed by solydxk-system. So i'll wait :)
-------
Image

kurotsugi
Posts: 2240
Joined: 09 Jan 2014 00:17

Re: Breakages and News tracking Debian Testing

Postby kurotsugi » 10 Sep 2015 12:50

for aptitude....I think, as suggested by grizzler, you can remove aptitude during d-u then reinstall it from sid. that would be the quickest way to solve the breakage. else, you can temporary move into sid. I prefer the later since all the issue have been fixed in sid. I'm not sure about plasma but my xfce setup works fine with sid.

as for solydxk-system, it doesn't looks like a dependency issue for me. it's more like there was something wrong with the installer script. I'm not quite sure but perhaps you can reinstall it after get aptitude back.

User avatar
belze
Posts: 221
Joined: 29 Sep 2014 16:31
Location: Torino, Italy

Re: Breakages and News tracking Debian Testing

Postby belze » 10 Sep 2015 12:52

Code: Select all

LANG=C sudo apt-get -t unstable install aptitude
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 aptitude : Depends: libcwidget3v5 but it is not going to be installed
            Depends: libsigc++-2.0-0v5 (>= 2.2.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
-------
Image

User avatar
grizzler
Posts: 2180
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: Breakages and News tracking Debian Testing

Postby grizzler » 10 Sep 2015 13:30

That's an odd error. Both those dependencies are the same version in Testing and Unstable. They're already installed on my system. They must have dependency issues of their own (that can go really 'deep'...). What's the error if you try install them separately?

The solydk-system-adjustments error definitely is related to solydxk-system's dependency on aptitude. Apparently solydxk-system has been removed because of it. According to solydk-system-adjustments' control file, solydxk-system is not a dependency. However, solydk-system-adjustments' postinst script uses an update-rc.d call referencing solydxk-system. That's inconsistent.

Edit
Unless it gets blocked for some as yet unknown (to me at least) reason, aptitude 0.7.1-1 should migrate to Testing in a day or two.
Frank

SolydX EE 64 - tracking Debian Testing

User avatar
belze
Posts: 221
Joined: 29 Sep 2014 16:31
Location: Torino, Italy

Re: Breakages and News tracking Debian Testing

Postby belze » 10 Sep 2015 13:35

Code: Select all

LANG=C sudo apt-get -s install solydxk-system 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 solydxk-system : Depends: aptitude
                  Recommends: solydk-info but it is not going to be installed or
                              solydx-info but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
and

Code: Select all

LANG=C sudo apt-get -s install solydk-info 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  solydkee-info*
The following NEW packages will be installed:
  solydk-info
0 upgraded, 1 newly installed, 1 to remove and 2 not upgraded.
Purg solydkee-info [1.0.3]
Inst solydk-info (1.1.6 SolydXK:1/solydxk [amd64])
Conf solydk-info (1.1.6 SolydXK:1/solydxk [amd64])
-------
Image

User avatar
grizzler
Posts: 2180
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: Breakages and News tracking Debian Testing

Postby grizzler » 10 Sep 2015 13:40

I meant the two dependencies that blocked aptitude: libcwidget3v5 and libsigc++-2.0-0v5
Frank

SolydX EE 64 - tracking Debian Testing

User avatar
belze
Posts: 221
Joined: 29 Sep 2014 16:31
Location: Torino, Italy

Re: Breakages and News tracking Debian Testing

Postby belze » 10 Sep 2015 13:44

grizzler wrote:I meant the two dependencies that blocked aptitude: libcwidget3v5 and libsigc++-2.0-0v5
sorry

Code: Select all

LANG=C sudo apt-get -t unstable install libcwidget3v5
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcwidget3v5 : Depends: libsigc++-2.0-0v5 (>= 2.2.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
and

Code: Select all

LANG=C sudo apt-get -t unstable install libsigc++-2.0-0v5 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  gparted* libatkmm-1.6-1* libcairomm-1.0-1* libcwidget3* libglibmm-2.4-1c2a* libgtkmm-2.4-1c2a* libpangomm-1.4-1* libparted-fs-resize0* libsigc++-2.0-0c2a*
The following NEW packages will be installed:
  libsigc++-2.0-0v5
0 upgraded, 1 newly installed, 9 to remove and 205 not upgraded.
Need to get 51.1 kB of archives.
After this operation, 16.4 MB disk space will be freed.
Do you want to continue? [Y/n] 
just this morning i needed gparted to restore my system :/
-------
Image

User avatar
grizzler
Posts: 2180
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: Breakages and News tracking Debian Testing

Postby grizzler » 10 Sep 2015 13:53

And by (re)installing it, you may have removed some of the recent gcc-5 updates, because all those packages listed as dependency problems/removals for libsigc++-2.0-0v5 are old and should have been replaced by gcc-5 versions.

To be honest, I don't understand why gparted would still need the old ones. My system has the entire new set and gparted is there and up-to-date. What's the version you have installed? It should be 0.19.0-3+b2 (that is from Testing, by the way).

Edit
Wait a minute. I just noticed the "205 not upgraded". Did you hold off the gcc-5 upgrade?
Frank

SolydX EE 64 - tracking Debian Testing


Return to “Testing Zone”

Who is online

Users browsing this forum: No registered users and 3 guests