UP - 01/04/2014 [TESTING] [DONE]

SolydXK is too quiet for you? SolydXK Enthusiast Editions, based on Debian Testing is for you! Here you can find news about Debian Testing and Unstable too, and also tests on SolydXK programs.
The support for SolydXK EE is provided by the community.
User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 01/04/2014 [TESTING]

Postby zerozero » 06 Apr 2014 20:26

EDIT:
Dan, we posted the same issue almost at the same time :lol:
===

while debugging this >> http://forums.solydxk.nl/viewtopic.php? ... 411#p31775 i found out that gdebi-kde is not working.
the usual way of using it (click or double-click a deb file) produces initial feedback in the panel, gdebi's interface never appears and after some seconds *nada* :evil:

===
starting it from the commandline shows

Code: Select all

zerozero@home ~/Downloads $ gksu gdebi-kde updatemanager_2.0.1_all.deb
glibtop: Non-standard uts for running kernel:
release 3.13-1-amd64=3.13.0 gives version code 199936

Traceback (most recent call last):
  File "/usr/bin/gdebi-kde", line 27, in <module>
    from PyKDE4.kdeui import KApplication, KMessageBox, ki18n
ImportError: cannot import name ki18n

Code: Select all

zerozero@home ~/Downloads $ kdesudo gdebi-kde updatemanager_2.0.1_all.deb
Traceback (most recent call last):
  File "/usr/bin/gdebi-kde", line 27, in <module>
    from PyKDE4.kdeui import KApplication, KMessageBox, ki18n
ImportError: cannot import name ki18n
the pure commandline gdebi works though

Code: Select all

zerozero@home ~/Downloads $ sudo gdebi updatemanager_2.0.1_all.deb 
[sudo] password for zerozero: 
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Building data structures... Done 
Building data structures... Done 

SolydXK Update Manager
 Helps installing security updates and new versions of packages.
Do you want to install the software package? [y/N]:y
(Reading database ... 312344 files and directories currently installed.)
Preparing to unpack updatemanager_2.0.1_all.deb ...
Unpacking updatemanager (2.0.1) over (2.0.0) ...
Setting up updatemanager (2.0.1) ...
Processing triggers for menu (2.1.46) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.54) ...
but this is not the reason why gdebi is great (having a functional commandline option), it's the click-click option.

===
anyone else sees this?
and:
does it also happens in SolydX?
bliss of ignorance

User avatar
stelios
Posts: 128
Joined: 28 Feb 2013 21:31
Location: Athens

Re: UP - 01/04/2014 [TESTING]

Postby stelios » 06 Apr 2014 21:44

It is an upstream bug, so..

Code: Select all

stelios@SolydK ~ $ apt-listbugs list gdebi-kde
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
grave bugs of gdebi-kde (→ ) <Outstanding>
 #743756 - gdebi-kde does not run (various python errors)
Summary:
 gdebi-kde(1 bug)
And trying to install the 0.9.5 version from unstable

Code: Select all

Retrieving bug reports... Done
Parsing Found/Fixed information... Done
grave bugs of gdebi-kde (0.9.4 → 0.9.5.2) <Outstanding>
 #743756 - gdebi-kde does not run (various python errors)
Summary:
 gdebi-kde(1 bug)
So it seems that even the SID version is broken. I did not install it though to try it myself.

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: UP - 01/04/2014 [TESTING]

Postby MAYBL8 » 06 Apr 2014 22:04

Would we have noticed that if we had listbugs turned on during the update?

Can we run apt-listbugs against all of our updated packages?


User avatar
fleabus
Posts: 1227
Joined: 16 Sep 2013 04:24
Location: Winchester, VA USA

Re: UP - 01/04/2014 [TESTING]

Postby fleabus » 07 Apr 2014 00:37

Re gdebi ---
zerozero wrote:i found out that gdebi-kde is not working.
the usual way of using it (click or double-click a deb file) produces initial feedback in the panel, gdebi's interface never appears and after some seconds *nada* :evil:
===
anyone else sees this?
and:
does it also happens in SolydX?
Ditto for SolydX, while trying to install qt4-fsarchiver and CoolReader3, gdebi gui appears very briefly, maybe a second or so, then crash, abracadabra, disappears in a puff of smoke... :)

User avatar
fleabus
Posts: 1227
Joined: 16 Sep 2013 04:24
Location: Winchester, VA USA

Re: UP - 01/04/2014 [TESTING]

Postby fleabus » 07 Apr 2014 01:15

jdhedden wrote:the upgrade to grub 2.0 will cause problems if you try restore to a pre-'grub 2.0' backup.
I've always used a SuperGrub2Disk in these situations, just another 2c...

Also the latest release candidate, with grub 2.00-22 has worked fine for me so far, keeping fingers crossed, only used this one once as of yet..... :mrgreen: :oops:

User avatar
Arjen Balfoort
Site Admin
Posts: 9223
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 01/04/2014 [TESTING]

Postby Arjen Balfoort » 07 Apr 2014 05:27

I suggest to try to repackage gdebi, gdebi-kde, and gdebi-core from the current production environment so that systems will get upgraded by those working versions.

[EDIT]
Packages are added to our testing repository. If it doesn't work, I'll remove them.

I also added an updated version of UM: http://forums.solydxk.nl/viewtopic.php?p=31806#p31806


SolydXK needs you!
Development | Testing | Translations

User avatar
grizzler
Posts: 2139
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: UP - 01/04/2014 [TESTING]

Postby grizzler » 07 Apr 2014 06:23

If I try to mark gdebi and gdebi-core for upgrading in synaptic, it tells me it can't do that because gdebi wants gdebi-core 0.9.4 and 0.9.4+solydxk1 is to be installed. Me thinks gdebi's Depends line needs a >= instead of a =.
Frank

SolydX EE 64 - tracking Debian Testing

User avatar
grizzler
Posts: 2139
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: UP - 01/04/2014 [TESTING]

Postby grizzler » 07 Apr 2014 06:31

One item in the 2014.04.15 set needs another update: solydxk-flashplugin-11 claims to be the newest at 11.2.202.341. However, last February a security update was released bringing the current version to 11.2.202.346.
Frank

SolydX EE 64 - tracking Debian Testing

User avatar
Arjen Balfoort
Site Admin
Posts: 9223
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 01/04/2014 [TESTING]

Postby Arjen Balfoort » 07 Apr 2014 06:57

Thanks grizzler.
I've updated flash, and the gdebi packages.

Could you do an apt-get update, and reinstall the gdebi packages?


SolydXK needs you!
Development | Testing | Translations

User avatar
pnlarsson
Posts: 21
Joined: 30 Aug 2013 21:19
Location: Gothenburg

Re: UP - 01/04/2014 [TESTING]

Postby pnlarsson » 07 Apr 2014 07:15

Hi,

did the terminal way on an former linux-mint -> linux-mint-kde (switched to solydk a while ago) installation and after a reboot everything is working!

Got this during update:

Code: Select all

The following packages have unmet dependencies:
 tcl : Breaks: tcl8.4 (< 8.4.20-2) but 8.4.20-1 is installed.
 libmate-desktop-2-17 : Breaks: libmatedesktop (< 1.6.1) but 1.4.1-1+wheezy is installed.
 ruby : Conflicts: ruby1.8 but 1.8.7.358-9 is installed.
        Conflicts: rubygems but 1.8.24-1 is installed.
 libtxc-dxtn-s2tc0:i386 : Conflicts: libtxc-dxtn0 but 1.0.1-dmo1 is installed.
                          Conflicts: libtxc-dxtn0:i386 but 1.0.1-dmo1 is installed.
 libmate-menu2 : Breaks: libmatemenu but 1.4.0-1+wheezy is installed.
 gdebi : Depends: gdebi-core (= 0.9.2) but 0.9.4+solydxk1 is to be installed.
 cups-filters : Conflicts: foomatic-filters but 4.0.17-1 is installed.
                Conflicts: ghostscript-cups but 9.05~dfsg-8+b1 is installed.
 libmatekbd4 : Conflicts: libmatekbd but 1.4.0-1+wheezy is installed.
               Breaks: libmatekbd but 1.4.0-1+wheezy is installed.
The following actions will resolve these dependencies:

      Remove the following packages:                       
1)      foomatic-filters                                   
2)      foomatic-filters-ppds                              
3)      gdebi                                              
4)      ghostscript-cups                                   
5)      libmatedesktop                                     
6)      libmatekbd                                         
7)      libmatemenu                                        
8)      ruby1.8                                            
9)      rubygems                                           
10)     steam:i386                                         
11)     tcl8.4                                             

      Keep the following packages at their current version:
12)     libtxc-dxtn-s2tc0:i386 [Not Installed]             

      Leave the following dependencies unresolved:         
13)     ruby-qt4 recommends ruby1.8                        
14)     ruby1.8-dev recommends ruby1.8 (= 1.8.7.358-9)     


Accept this solution? [Y/n/q/?] The following NEW packages will be installed:
And had to run aptitude dist-upgrade three times before all was done

Code: Select all

niklas@niklas-minty ~ $ inxi -Fzx
System:    Host: niklas-minty Kernel: 3.13-1-amd64 x86_64 (64 bit, gcc: 4.8.2) 
           Desktop: KDE 4.12.4 (Qt 4.8.6) Distro: SolydXK 1 testing
Machine:   Mobo: MSI model: P67A-GD65 (MS-7681) version: 2.0 Bios: American Megatrends version: V1.15 date: 10/27/2011
CPU:       Quad core Intel Core i5-2500K CPU (-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 26339.1 
           Clock Speeds: 1: 2940.996 MHz 2: 3517.207 MHz 3: 3051.210 MHz 4: 3426.457 MHz
Graphics:  Card: NVIDIA GK106 [GeForce GTX 650 Ti] bus-ID: 01:00.0 
           X.Org: 1.15.0 driver: nvidia Resolution: 1280x1024@60.0hz, 1920x1080@60.0hz, 1920x1080@60.0hz 
           GLX Renderer: GeForce GTX 650 Ti/PCIe/SSE2 GLX Version: 4.4.0 NVIDIA 331.49 Direct Rendering: Yes
Audio:     Card-1: NVIDIA GK106 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1 Sound: ALSA ver: k3.13-1-amd64
           Card-2: Intel 6 Series/C200 Series Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0 
           Card-3: Plantronics driver: USB Audio usb-ID: 005-004 
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 
           driver: r8169 ver: 2.3LK-NAPI port: b000 bus-ID: 08:00.0
           IF: eth1 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: MosChip MCS7830 10/100 Mbps Ethernet adapter driver: MOSCHIP usb-ethernet driver usb-ID: 005-003
           IF: eth2 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 990.2GB (36.6% used) 1: id: /dev/sda model: INTEL_SSDSC2CT24 size: 240.1GB 
           2: id: /dev/sdb model: SAMSUNG_HD502HJ size: 500.1GB 3: id: /dev/sdc model: ST3250318AS size: 250.1GB 
Partition: ID: / size: 209G used: 171G (87%) fs: ext4 ID: swap-1 size: 12.55GB used: 0.00GB (0%) fs: swap 
RAID:      Device-1: /dev/md0 - active (auto-read-only) components: online: sdb5[0] sdc1[1]
           Info: raid: 1 report: 2/2 blocks: 244139968 chunk size: N/A
Sensors:   System Temperatures: cpu: 46.0C mobo: N/A gpu: 0.0:46C 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 200 Uptime: 7 min Memory: 1699.7/7974.7MB Runlevel: 2 Gcc sys: 4.8.2 
           Client: Shell (bash 4.3.0) inxi: 1.9.17 
No issues with grub at all. Am happy and will continue testing

User avatar
fleabus
Posts: 1227
Joined: 16 Sep 2013 04:24
Location: Winchester, VA USA

Re: UP - 01/04/2014 [TESTING]

Postby fleabus » 07 Apr 2014 08:13

Schoelje wrote:I've updated flash, and the gdebi packages.
Ran the update/dist-upgrade, 4 new packages, the gdebi packages plus new flash and UM. Gdebi now working fine in both X64 and K64, my two test partitions on the HP dv7 laptop mentioned above.
Used to install qt4-fsarchiver-0.6.19-1-amd64.deb for wheezy from sourceforge.

User avatar
grizzler
Posts: 2139
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: UP - 01/04/2014 [TESTING]

Postby grizzler » 07 Apr 2014 08:44

Schoelje wrote:Could you do an apt-get update, and reinstall the gdebi packages?
Working fine now. Thanks.
Frank

SolydX EE 64 - tracking Debian Testing

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: UP - 01/04/2014 [TESTING]

Postby MAYBL8 » 07 Apr 2014 11:07

Resusts of latest update:

Code: Select all

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  gdebi-core gdebi-kde solydxk-flashplugin-11
3 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 5,294 kB of archives.
After this operation, 14.3 kB disk space will be freed.
Get:1 http://packages.solydxk.com/testing/ solydxk/import gdebi-kde all 0.9.4+solydxk1 [28.0 kB]
Get:2 http://packages.solydxk.com/testing/ solydxk/import gdebi-core all 0.9.4+solydxk1 [130 kB]
Get:3 http://packages.solydxk.com/testing/ solydxk/main solydxk-flashplugin-11 amd64 11.2.202.346 [5,136 kB]
Fetched 5,294 kB in 3s (1,620 kB/s)                 


Retrieving bug reports... Done
Parsing Found/Fixed information... Done
(Reading database ... 164290 files and directories currently installed.)
Preparing to unpack .../gdebi-kde_0.9.4+solydxk1_all.deb ...
Unpacking gdebi-kde (0.9.4+solydxk1) over (0.9.4) ...
Preparing to unpack .../gdebi-core_0.9.4+solydxk1_all.deb ...
Unpacking gdebi-core (0.9.4+solydxk1) over (0.9.4) ...
Preparing to unpack .../solydxk-flashplugin-11_11.2.202.346_amd64.deb ...
Unpacking solydxk-flashplugin-11 (11.2.202.346) over (11.2.202.341) ...
Processing triggers for man-db (2.6.6-1) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.54) ...
Setting up gdebi-core (0.9.4+solydxk1) ...
Setting up gdebi-kde (0.9.4+solydxk1) ...
Setting up solydxk-flashplugin-11 (11.2.202.346) ...
update-alternatives: warning: /etc/alternatives/libflashplayer.so is dangling; it will be updated with best choice
update-alternatives: using /opt/solydxk-flashplugin/libflashplayer.so to provide /usr/lib/mozilla/plugins/libflashplayer.so (libflashplayer.so) in auto mode



User avatar
stelios
Posts: 128
Joined: 28 Feb 2013 21:31
Location: Athens

Re: UP - 01/04/2014 [TESTING]

Postby stelios » 07 Apr 2014 13:08

I just got an update of the Update Manager. The problem is, it ignores the sources preferences file and presents updates coming from unstable, which it shouldn't do. Synaptic and dist-upgrade show zero updates, as they should, but update manager wants, for example, to upgrade libgles2-mesa 10.1.0-4 (testing) to 10.1.0-5 (unstable)

User avatar
Arjen Balfoort
Site Admin
Posts: 9223
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 01/04/2014 [TESTING]

Postby Arjen Balfoort » 07 Apr 2014 13:35

As far as I know dist-upgrade had no reporting mechanism (give me a list of upgradable packages, their current version, and new version).
What we can use are:

Code: Select all

aptitude search '~U'
apt-show-versions -u
I cannot only use apt-show-versions because it only uses the local cache (see http://forums.solydxk.nl/viewtopic.php?f=13&t=3411). Aptitude search does give a better list, but obviously disregards the preferences file. I then have to cross link that list with apt-show-versions to get all version numbers.

If you, or anybody else do know a better way to get a list with upgradable packages, their current version, and new version, I'd really appreciate that.


SolydXK needs you!
Development | Testing | Translations

User avatar
stelios
Posts: 128
Joined: 28 Feb 2013 21:31
Location: Athens

Re: UP - 01/04/2014 [TESTING]

Postby stelios » 07 Apr 2014 13:44

dist-upgrade

Code: Select all

sudo apt-get dist-upgrade
[sudo] password for stelios: 
Ανάγνωση Λιστών Πακέτων... Ολοκληρώθηκε
Κατασκευή Δένδρου Εξαρτήσεων                  
Ανάγνωση περιγραφής της τρέχουσας κατάσταση... Ολοκληρώθηκε
Υπολογισμός της αναβάθμισης... Ετοιμο
0 αναβαθμίστηκαν, 0 νέο εγκατεστημένα, 0 θα αφαιρεθούν και 0 δεν αναβαθμίζονται.
update manager
xbmc7.png
dist-upgrade targeting unstable

Code: Select all

stelios@SolydK ~ $ sudo apt-get dist-upgrade -t unstable
Ανάγνωση Λιστών Πακέτων... Ολοκληρώθηκε
Κατασκευή Δένδρου Εξαρτήσεων                  
Ανάγνωση περιγραφής της τρέχουσας κατάσταση... Ολοκληρώθηκε
Υπολογισμός της αναβάθμισης... Ετοιμο
Τα ακόλουθα πακέτα εγκαταστάθηκαν αυτόματα και δεν χρειάζονται πλέον:
  libgcrypt20 libmodemmanagerqt0 libnetworkmanagerqt0 libpoppler37 libppl12 libxatracker1
Χρησιμοποιήστε 'apt-get autoremove' για να τα διαγράψετε.
Τα ακόλουθα ΝΕΑ πακέτα θα εγκατασταθούν:
  firmware-zd1211 libbind9-90 libdebconfclient0 libdns100 libfakeroot libglib2.0-0:i386
  libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386 libisc95 libisccc90 libisccfg90 liblwres90 libmbim-glib0
  libmm-glib0 libmodemmanagerqt1 libnetworkmanagerqt1 liborc-0.4-0:i386 libpam-systemd libplist2 libpoppler44 libppl13
  libqmi-glib0 librest-0.7-0 libruby2.0 libsystemd-id128-0 libsystemd-id128-0:i386 libsystemd-journal0:i386
  libva-wayland1 libxatracker2 ruby2.0 rubygems-integration systemd
Τα ακόλουθα πακέτα θα αναβαθμιστούν:
  acpid apt apt-listbugs apt-utils arduino arduino-core autoconf autopkgtest baobab base-passwd bash bind9-host
  binfmt-support binutils binutils-avr bsdutils console-setup console-setup-linux cpp cpp-4.4 cpp-4.6 cpp-4.7 cpp-4.8
  cups cups-browsed cups-bsd cups-client cups-common cups-core-drivers cups-daemon cups-filters cups-filters-core-drivers
  cups-ppdc cups-server-common dictionaries-common dosfstools dtv-scan-tables exim4-base exim4-config exim4-daemon-light
  fakeroot fancontrol fontconfig fontconfig-config fonts-beng fuse g++ g++-4.4 g++-4.6 g++-4.7 g++-4.8 gcc gcc-4.4
  gcc-4.4-base gcc-4.6 gcc-4.6-base gcc-4.7 gcc-4.7-base gcc-4.7-base:i386 gcc-4.8 gcc-4.8-base gcc-4.8-base:i386
  gdebi-core gdebi-kde gimp gimp-data gir1.2-atk-1.0 gir1.2-freedesktop gir1.2-glib-2.0 gir1.2-gtk-3.0 gir1.2-soup-2.4
  git-buildpackage glib-networking glib-networking-common glib-networking-services grub-common grub-pc grub-pc-bin grub2
  grub2-common gstreamer0.10-nice gstreamer1.0-plugins-ugly gtk2-engines-pixbuf guvcview gvfs gvfs-daemons gvfs-libs
  icedtea-7-jre-jamvm inkscape inxi iso-codes keyboard-configuration libapt-inst1.5 libapt-pkg4.12 libarchive-zip-perl
  libasan0 libatk1.0-0 libatk1.0-data libatomic1 libautodie-perl libblkid1 libcloog-ppl1 libcups2 libcupscgi1
  libcupsfilters1 libcupsimage2 libcupsmime1 libcupsppdc1 libdaemon0 libegl1-mesa libegl1-mesa-drivers libffms2-3
  libfftw3-3 libfftw3-double3 libfftw3-long3 libfftw3-single3 libfile-mimeinfo-perl libfontconfig1 libfontconfig1:i386
  libfontembed1 libfuse2 libfuse2:i386 libgail18 libgbm1 libgcc-4.7-dev libgcc-4.8-dev libgcc1 libgcc1:i386 libgcj-common
  libgfortran3 libgimp2.0 libgirepository-1.0-1 libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386
  libglapi-mesa libglapi-mesa:i386 libgles2-mesa libglib2.0-0 libglib2.0-data libgmp10 libgmpxx4ldbl
  libgnome-keyring-common libgnome-keyring0 libgomp1 libgpod-common libgpod4 libgtk-3-0 libgtk-3-bin libgtk-3-common
  libgtk2-perl libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libimobiledevice4 libio-socket-ssl-perl libitm1 liblcms1
  liblogging-stdlog0 libmount1 libmtdev1 libnet-domain-tld-perl libnice10 libnl-3-200 libnl-genl-3-200 libnl-route-3-200
  libnm-glib-vpn1 libnm-glib4 libnm-util2 libodbc1 libopenjpeg5 libopenvg1-mesa libparted0debian1 libpoppler-glib8
  libpoppler-qt4-4 libppl-c4 libprison0 libprocps3 libpulse-mainloop-glib0 libpulse0 libpulse0:i386 libpulsedsp
  libpython3.4 libpython3.4-minimal libpython3.4-stdlib libquadmath0 libreadline6 libruby1.8 libsecret-1-0
  libsecret-common libsensors4 libsgutils2-2 libsmokekdecore4-3 libsmokekdeui4-3 libsmokekfile3 libsmokekhtml3
  libsmokekio3 libsmokeknewstuff2-3 libsmokeknewstuff3-3 libsmokekparts3 libsmokektexteditor3 libsmokekutils3
  libsmokenepomuk3 libsmokesolid3 libsoup-gnome2.4-1 libsoup2.4-1 libstdc++-4.8-dev libstdc++6 libstdc++6:i386
  libstdc++6-4.4-dev libstdc++6-4.6-dev libstdc++6-4.7-dev libsvn-perl libsvn1 libtsan0 libupower-glib1 libusb-1.0-0
  libusb-1.0-0:i386 libusbmuxd2 libuuid1 libuuid1:i386 libva-drm1 libva-glx1 libva-x11-1 libva1 libwayland-egl1-mesa
  libwildmidi-config libwildmidi1 libwine:i386 libwine-alsa:i386 libwine-bin:i386 libwine-gl:i386 libyelp0 libzvbi-common
  libzvbi0 lintian lm-sensors mobile-broadband-provider-info modemmanager mount mp3gain network-manager ntfs-3g odbcinst
  odbcinst1debian2 openjdk-7-jdk openjdk-7-jre openjdk-7-jre-headless openjdk-7-jre-lib openssh-client parted plasma-nm
  plasma-widget-networkmanagement plymouth plymouth-drm plymouth-x11 poppler-utils printer-driver-foo2zjs
  printer-driver-foo2zjs-common procps pulseaudio pulseaudio-esound-compat pulseaudio-module-gconf pulseaudio-module-x11
  pulseaudio-module-zeroconf pulseaudio-utils python-apt python-apt-common python-pkg-resources python3-apt
  python3-pkg-resources python3.4 python3.4-minimal readline-common ruby ruby-kde4 subversion synaptic tzdata tzdata-java
  unattended-upgrades unixodbc upower usb-modeswitch usb-modeswitch-data usbmuxd util-linux uuid-runtime vainfo wine
  wine-bin:i386 wine32:i386 x11-common xnest xserver-common xserver-xorg xserver-xorg-core xserver-xorg-input-all
  xserver-xorg-video-all xserver-xorg-video-vmware yelp yelp-xsl zd1211-firmware
304 αναβαθμίστηκαν, 32 νέο εγκατεστημένα, 0 θα αφαιρεθούν και 0 δεν αναβαθμίζονται.
Χρειάζεται να μεταφορτωθούν 281 MB/281 MB από αρχεία.
Μετά από αυτή τη λειτουργία, θ
I don't know why it shows only certain packages from unstable as upgradeable and not all. I have no idea.

User avatar
stelios
Posts: 128
Joined: 28 Feb 2013 21:31
Location: Athens

Re: UP - 01/04/2014 [TESTING]

Postby stelios » 07 Apr 2014 14:19

Ok, i found the cause of this. If a packet from unstable is already installed, then it will appear as upgradeable. If it is not installed, it will not show up at all. Still, i do not know how dist-upgrade and synaptic manage to solve this.

The question is when and why i installed these things from unstable :shock: I need to make a clean install for testing the new UP or all the testing and its results are useless if i have these packages from unstable.

User avatar
stelios
Posts: 128
Joined: 28 Feb 2013 21:31
Location: Athens

Re: UP - 01/04/2014 [TESTING]

Postby stelios » 07 Apr 2014 14:51

Schoelje wrote:As far as I know dist-upgrade had no reporting mechanism (give me a list of upgradable packages, their

If you, or anybody else do know a better way to get a list with upgradable packages, their current version, and new version, I'd really appreciate that.
I don't know if this helps, butthe command

Code: Select all

apt-show-versions -u | grep -w 'testing\|unstable'
will look for upgrades only in the specific repositories. Perhaps Synaptic and dist-upgrade do something like this. A suggestion would be to use something like this and add a switch to UM to choose between production and testing repositories. it will not show however updates from other repositories people have added.

belgiumsolydk
Posts: 73
Joined: 06 Mar 2014 12:17
Location: Erpe-Mere Belgium

Re: UP - 01/04/2014 [TESTING]

Postby belgiumsolydk » 07 Apr 2014 14:53

Hi,

maybe a stupid remark but debian Jessie has libgl1-mesa 10.1.0-5. Same a Sid.
Or are you pointing to the wrong repositories?

User avatar
stelios
Posts: 128
Joined: 28 Feb 2013 21:31
Location: Athens

Re: UP - 01/04/2014 [TESTING]

Postby stelios » 07 Apr 2014 14:57

belgiumsolydk wrote:Hi,

maybe a stupid remark but debian Jessie has libgl1-mesa 10.1.0-5. Same a Sid.
Or are you pointing to the wrong repositories?
Because these were installed from Sid, at a time that they were not present in Jessie, they are marked as manually installed coming from Sid.


Return to “Testing Zone”

Who is online

Users browsing this forum: No registered users and 1 guest