UP - 01/10/2014 [TESTING] [DONE]

SolydXK is too quiet for you? SolydXK Enthusiast Editions, based on Debian Testing is for you! Here you can find news about Debian Testing and Unstable too, and also tests on SolydXK programs.
The support for SolydXK EE is provided by the community.
User avatar
fleabus
Posts: 1227
Joined: 16 Sep 2013 04:24
Location: Winchester, VA USA

Re: UP - 01/10/2014 [TESTING]

Postby fleabus » 02 Oct 2014 19:39

zerozero wrote:Attempt to unlock mutex that was not locked
Found this over at Debian...?

http://forums.debian.net/viewtopic.php?f=6&t=117788
After an update to GLib in Jessie the other day some/a lot of program may exit with the message Attempt to unlock mutex that was not locked. This is because of change in how GLib handles unlocking of non locked mutex.
Since GLib ≥ 2.41, attempting to release an unlocked mutex will abort(), as it happens on most systems already
https://mail.gnome.org/archives/commits ... 08240.html
Some packages are already updated but file a bug report if you find one that hasn't been reported yet.
https://www.debian.org/Bugs/
Veeery interestink... What's a mother to do...? :cry: :twisted:

I never use SW-manager, missed that one entirely...
<ahem>actually I always<ahem>remove it<ahem>along with a<ahem>bunch of other stuff...<coughcough>

User avatar
smitty1
Posts: 254
Joined: 23 Jun 2013 13:50
Location: Pittsburgh, PA USA

Re: UP - 01/10/2014 [TESTING]

Postby smitty1 » 02 Oct 2014 19:45

This was my terminal session

Code: Select all

jim@k-up ~ $ echo $PATH
/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games

k-up ~ # /usr/bin/softwaremanager		
add_categories took 1.078 ms
build_matched_packages took 0.182 ms
'googleearth'
'virtualbox-nonfree'
'miro'
'vuze'
'netbeans'
'skype'
'avidemux'
'worldofgoodemo'
'steam-launcher'
'seamonkey-browser'
'midori'
'galeon'
'prism'
'dooble'
'rekonq'
'anjal'
'prism-google-mail'
'seamonkey-mailnews'
'freepops'
'mailody'
'kcheckmail'
'skype'
'gossip'
'kadu'
'sim'
'centerim'
'cgiirc'
'naim'
'seamonkey-chatzilla'
'sirc'
'eva'
'prism-google-talk'
'qutim'
'kasablanca'
'amule'
'frostwire'
'vuze'
'foff'
'giver'
'gnunet-qt'
'gwget'
'kbluetooth'
'kepas'
'kflickr'
'kradioripper'
'miro'
'moserial'
'tork'
'tucan'
'minitunes'
'mplayer'
'xine'
'acidrip'
'lastfm'
'k9copy'
'gnomebaker'
'listen'
'aqualung'
'mencoder'
'mplayer-gui'
'dumphd'
'kivio'
'kolourpaint'
'openoffice.org-draw'
'skencil'
'xaralx'
'gqview'
'f-spot'
'gpixpod'
'flegita'
'kcoloredit'
'kflickr'
'kiconedit'
'koverartist'
'opencascade-draw'
'kivio'
'kolourpaint'
'skencil'
'kcoloredit'
'kiconedit'
'koverartist'
'fontmatrix'
'openoffice.org-draw'
'pencil'
'salasaga'
'xaralx'
'gqview'
'f-spot'
'gpixpod'
'kflickr'
'luciole'
'phatch'
'rawstudio'
'flegita'
'acroread'
'epdfview'
'omaque'
'pdfedit'
'viewpdf.app'
'xpdf-reader'
'steam-launcher'
'worldofgoodemo'
'ggz-python-games'
'ggz-kde-games'
'pouetchess'
'stroq'
'open-arena'
'urban-terror'
'warsow'
'boson'
'glest'
'wormux'
'zsnes'
'uae'
'pearpc'
'pcsx-df'
'pose-skins'
'nestra'
'kxmame'
'snes9express'
'gfceu'
'dgen'
'armagetron'
'planetpenguin-racer'
'wine1.2'
'virtualbox-guest-additions'
'virtualbox-ose'
'virtualbox-3.1'
'compizconfig-settings-manager'
'ttf-telugu-fonts'
'ttf-farsiweb'
'ttf-droid'
'ttf-indic-fonts-core'
'ttf-linux-libertine'
'ttf-monapo'
'ttf-sil-gentium'
'ttf-sil-gentium-basic'
'carmetal'
'controlaula'
'drgeo'
'edubuntu-desktop-kde'
'edubuntu-desktop'
'freespeak'
'denemo'
'k3dsurf'
'kalcul'
'kayali'
'klavaro'
'lletters'
'ubuntu-edu-preschool'
'ubuntu-edu-primary'
'qucs'
'score-reading-trainer'
'ubuntu-edu-secondary'
'squeak'
'sugar-emulator-0.88'
'ubuntu-edu-tertiary'
'tipptrainer'
add_packages took 5950.416 ms
add_reviews took 949.009 ms
__init__ took 7758.261 ms
Attempt to unlock mutex that was not locked
Aborted
The last line [Attempt to unlock mutex that was not locked] I have seen recently in a debian bug report but I didn't bookmark it. IIRC it has something to do wit the gtk2 -> gtk3 transition. But the details are in that patch of dead neurons :oops:

No Good Deed Goes Unpunished

User avatar
fleabus
Posts: 1227
Joined: 16 Sep 2013 04:24
Location: Winchester, VA USA

Re: UP - 01/10/2014 [TESTING]

Postby fleabus » 02 Oct 2014 19:51

smitty1 wrote:I have seen recently in a debian bug report but I didn't bookmark it. IIRC it has something to do wit the gtk2 -> gtk3 transition. But the details are in that patch of dead neurons :oops:
Here's one?

https://bugs.debian.org/cgi-bin/bugrepo ... bug=758619

According to that poster, a few reports have been filed...

I have a patch of neurons like that. It's in my skull. :shock:

User avatar
Arjen Balfoort
Site Admin
Posts: 9477
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 01/10/2014 [TESTING]

Postby Arjen Balfoort » 02 Oct 2014 19:58

I think somebody already created a pull request for that for mintinstall: https://github.com/linuxmint/mintinstall/pull/75

Tomorrow I'll have some time to check it out.


SolydXK needs you!
Development | Testing | Translations

User avatar
Arjen Balfoort
Site Admin
Posts: 9477
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 01/10/2014 [TESTING]

Postby Arjen Balfoort » 02 Oct 2014 21:02

Software Manager updated and uploaded to the testing repository.

Did you find any other applications with the same behavior?


SolydXK needs you!
Development | Testing | Translations

User avatar
smitty1
Posts: 254
Joined: 23 Jun 2013 13:50
Location: Pittsburgh, PA USA

Re: UP - 01/10/2014 [TESTING]

Postby smitty1 » 02 Oct 2014 22:10

The new version of solydxk-softwaremanager fixed the problem. That was quick.
I haven't found anymore yet, but i'll still be at this tommorrow, sometimes life interferes :lol:

No Good Deed Goes Unpunished

User avatar
timber
Posts: 539
Joined: 11 Aug 2013 21:01
Location: Pacific Northwest

Re: UP - 01/10/2014 [TESTING]

Postby timber » 02 Oct 2014 23:33

Fresh install: solydk64_201407.iso using an existing /home on separate partition
Install went well, production updates went well. Everything working beautifully.
Sources list changed to Testing repositories
dist-upgrade (below) done via CLI
Used Pre-script, did update and dist-upgrade then did nvidia dkms install per instructions.
System rebooted with no major problems (nvidia working).
Rebooted several times with no changes in issues noted below.

Issues:
Network asked for password each reboot (evidentally know problem).
SolydK conky quit working. Lua rings and clock missing, text is there.

Next update: solydxk-softwaremanager

After reboot System won't go to X but doesn't seem to be nvidia problem
I reverted to nouveau driver to be sure but still will not boot to X.
Boot goes to command line prompt but only can type in when mouse is moved near text (mouse pointer is active with apparent text box in upper left corner)
If I try 'startx' then I get the following message:
xauth: timeout in locking athority file /home/user/.Xathority
X: user not authorized to run X server, aborting

Not sure how to proceed or recover.
Any ideas?

Thanks
timber

p.s. Auto Login was enabled via LightDM manager prior to problems.
Boot problem only after installing solydxk-softwaremanager via UM
timber

Samsung R580-M430 @ 2.27GHz - 8 GB RAM
Geforce 310M w/ nvidia-driver
SolydX/SolydM - Kernel 3.14-2-amd64 - Update Pack: 2014.07.15
SolydK - Kernel 3.14-2-amd64 - Update Pack: 2014.07.15
SolydKBE - Kernel 3.2.0-4-amd64 - LTS Update Pack: 2014.07.15

User avatar
Snap
Posts: 1244
Joined: 25 Aug 2013 20:01
Location: Spain

Re: UP - 01/10/2014 [TESTING]

Postby Snap » 03 Oct 2014 01:47

Can you access the logs? /var/log/dpkg.log /var/log/updatemanger.log /var/log/Xorg.0.log. Maybe you can find there what went wrong.

BTW, I've never knew how to open .Xauthority. The text editors I've tried didn't opened it.
This likely means that your installation is broken. -Mr Pixbuf.

Image

User avatar
timber
Posts: 539
Joined: 11 Aug 2013 21:01
Location: Pacific Northwest

Re: UP - 01/10/2014 [TESTING]

Postby timber » 03 Oct 2014 03:26

Hi Snap,

I'll check the log in the AM, wife is watching Netflix now.
Thanks for pointing me in the right direction.

timber
timber

Samsung R580-M430 @ 2.27GHz - 8 GB RAM
Geforce 310M w/ nvidia-driver
SolydX/SolydM - Kernel 3.14-2-amd64 - Update Pack: 2014.07.15
SolydK - Kernel 3.14-2-amd64 - Update Pack: 2014.07.15
SolydKBE - Kernel 3.2.0-4-amd64 - LTS Update Pack: 2014.07.15

User avatar
fleabus
Posts: 1227
Joined: 16 Sep 2013 04:24
Location: Winchester, VA USA

Re: UP - 01/10/2014 [TESTING]

Postby fleabus » 03 Oct 2014 05:24

A Successful X32 upgrade, on a P4 Dell XPS Gen2 (2004?). Had to give up DMO this time due to a bit of difficulty with an Audigy2. Got that working (completely off the wall, appeared to be a missing alsa-base.conf). This was installed 04 Apr 2014 from the 2014-01 ISO. Last upgraded 30 May 2014...

Code: Select all

fleabus@p4-xps-gen2:~$ uname -a
Linux p4-xps-gen2 3.16-2-686-pae #1 SMP Debian 3.16.3-2 (2014-09-20) i686 GNU/Linux
fleabus@p4-xps-gen2:~$ inxi -Frzxxx
System:    Host: p4-xps-gen2 Kernel: 3.16-2-686-pae i686 (32 bit gcc: 4.8.3) 
           Desktop: N/A info: xfce4-panel dm: lightdm Distro: SolydXK 1 testing 
Machine:   System: Dell product: Dimension XPS Gen 2 Chassis: type: 6
           Mobo: Dell model: 0U2424 Bios: Dell v: A06 date: 09/27/2004
CPU:       Single core Intel Pentium 4 (-HT-) cache: 512 KB flags: (pae sse sse2) bmips: 6384 
           Clock Speeds: 1: 3192 MHz 2: 3192 MHz
Graphics:  Card: NVIDIA G73 [GeForce 7600 GT] bus-ID: 01:00.0 chip-ID: 10de:02e0
           Display Server: X.Org 1.16.1 driver: nvidia Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce 7650 GS/AGP/SSE2 GLX Version: 2.1.2 NVIDIA 304.123 Direct Rendering: Yes
Audio:     Card Creative Labs SB Audigy driver: snd_emu10k1 port: df00 bus-ID: 02:02.0 chip-ID: 1102:0004 
           Sound: Advanced Linux Sound Architecture v: k3.16-2-686-pae
Network:   Card: Intel 82540EM Gigabit Ethernet Controller
           driver: e1000 v: 7.3.21-k8-NAPI port: df40 bus-ID: 02:0c.0 chip-ID: 8086:100e
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 100.3GB (17.1% used)
           ID-1: /dev/sda model: Maxtor_6L100P0 size: 100.3GB serial: L20482TH
Partition: ID-1: / size: 15G used: 4.2G (31%) fs: ext4 dev: /dev/sda3 
           ID-2: swap-1 size: 4.19GB used: 0.00GB (0%) fs: swap dev: /dev/sda2 
Sensors:   None detected - is lm-sensors installed and configured?
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://home.solydxk.com/testing/ solydxk main upstream import
           deb http://debian.solydxk.com/testing testing main contrib non-free
           deb http://debian.solydxk.com/security testing/updates main contrib non-free
           deb http://community.solydxk.com/testing/ solydxk main
Info:      Processes: 155 Uptime: 19 min Memory: 374.6/2023.0MB 
           Init: systemd v: 208 runlevel: 5 default: 2 Gcc sys: 4.9.1 alt: 4.6/4.7/4.8 
           Client: Shell (bash 4.3.251 running in xfce4-terminal) inxi: 2.1.28 
fleabus@p4-xps-gen2:~$ 

User avatar
pnlarsson
Posts: 21
Joined: 30 Aug 2013 21:19
Location: Gothenburg

Re: UP - 01/10/2014 [TESTING]

Postby pnlarsson » 03 Oct 2014 08:24

Hi all,

did an upgrade on an old former mint installation and things went smooth - har to restart update-manager after http://i.imgur.com/fGxKDkK.png updating update-manager.

Issues:
mysql-workbench (GTK) does not display any results http://i.imgur.com/pDqObCe.png - i tested latest version (had to compile myself) and the one in the repo 6.1.7.

Logged from CLI when executing the query;

Code: Select all

(mysql-workbench-bin:7080): GLib-GObject-WARNING **: attempting to add an interface (GtkTreeModel) to class (gtkmm__CustomObject_13GridViewModel) after class_init

(mysql-workbench-bin:7080): GLib-GObject-WARNING **: attempting to add an interface (GtkTreeDragDest) to class (gtkmm__CustomObject_13GridViewModel) after class_init

(mysql-workbench-bin:7080): GLib-GObject-WARNING **: attempting to add an interface (GtkTreeDragSource) to class (gtkmm__CustomObject_13GridViewModel) after class_init

(mysql-workbench-bin:7080): Gtk-CRITICAL **: IA__gtk_tree_view_set_model: assertion 'model == NULL || GTK_IS_TREE_MODEL (model)' failed

(mysql-workbench-bin:7080): Gtk-CRITICAL **: IA__gtk_tree_view_set_model: assertion 'model == NULL || GTK_IS_TREE_MODEL (model)' failed

(mysql-workbench-bin:7080): Gtk-CRITICAL **: IA__gtk_tree_view_scroll_to_cell: assertion 'tree_view->priv->model != NULL' failed

(mysql-workbench-bin:7080): Gtk-CRITICAL **: IA__gtk_tree_view_set_model: assertion 'model == NULL || GTK_IS_TREE_MODEL (model)' failed

(mysql-workbench-bin:7080): Gtk-CRITICAL **: IA__gtk_tree_view_set_model: assertion 'model == NULL || GTK_IS_TREE_MODEL (model)' failed

(mysql-workbench-bin:7080): Gtk-CRITICAL **: IA__gtk_tree_view_set_model: assertion 'model == NULL || GTK_IS_TREE_MODEL (model)' failed

(mysql-workbench-bin:7080): Gtk-CRITICAL **: IA__gtk_tree_view_set_model: assertion 'model == NULL || GTK_IS_TREE_MODEL (model)' failed

(mysql-workbench-bin:7080): Gtk-CRITICAL **: IA__gtk_tree_view_set_model: assertion 'model == NULL || GTK_IS_TREE_MODEL (model)' failed
Looks like this bug: https://bugs.launchpad.net/ubuntu/+sour ... ug/1155571

And debian bug: https://bugs.debian.org/cgi-bin/bugrepo ... bug=763356

I have downgraded libglib to 2.40.0 and will test on Monday when I'm back at the office.

Did an remote X session and it mysql-workbench is now working as it should.

User avatar
timber
Posts: 539
Joined: 11 Aug 2013 21:01
Location: Pacific Northwest

Re: UP - 01/10/2014 [TESTING]

Postby timber » 03 Oct 2014 18:49

Attached: Compressed to Zip
  • updatemanager.log
    dpkg.log
  • As noted in post above fresh install SolydK but using existing /home partition
    Production edition updated, everything working fine.
    Repositories changed to Testing
    Updated (big UP), everything working (except network connection needing password each boot)
    Rebooted several time, all OK
    Then Problem with Update for solydxk-softwaremanager update, will not boot into X (and user no longer autorized to access X)
Note: Nvidia was working but reverted to Noveau driver to see if that helped (it didn't).
Tried Recovery and previous kernels to access (no luck).

UPDATE:
Now when I boot all I get is some kind of test screens (white, green, blue etc) no clue what's happening.
Time to start over. (I think something in solydxk-softwaremanager update doesn't agree with my laptop).
I will just reinstall, update and stay with Production Repositories.
All other installations work fine (SolydX/Testing, SolydKBE/Production) so don't think it's a hardware problem.


Thanks,
timber
Attachments
dpkg.log.zip
(133.96 KiB) Downloaded 81 times
timber

Samsung R580-M430 @ 2.27GHz - 8 GB RAM
Geforce 310M w/ nvidia-driver
SolydX/SolydM - Kernel 3.14-2-amd64 - Update Pack: 2014.07.15
SolydK - Kernel 3.14-2-amd64 - Update Pack: 2014.07.15
SolydKBE - Kernel 3.2.0-4-amd64 - LTS Update Pack: 2014.07.15

User avatar
smitty1
Posts: 254
Joined: 23 Jun 2013 13:50
Location: Pittsburgh, PA USA

Re: UP - 01/10/2014 [TESTING]

Postby smitty1 » 03 Oct 2014 19:29

It appears that imagemagick is broken. There are 2 entries in the menu but neither works.
imagemagick-not-work.png
imagemagick-not-work.png (59.8 KiB) Viewed 5123 times
From the terminal

Code: Select all

jim@vm-x-test:~$ pol imagemagick
imagemagick:
  Installed: 8:6.8.9.6-4
  Candidate: 8:6.8.9.6-4
  Version table:
 *** 8:6.8.9.6-4 0
        500 http://debian.solydxk.com/testing/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
jim@vm-x-test:~$ imagemagick
bash: imagemagick: command not found
jim@vm-x-test:~$ locate imagemagick
/home/jim/.icons/16x16/apps/imagemagick.png
/home/jim/.icons/22x22/apps/imagemagick.png
/home/jim/.icons/24x24/apps/imagemagick.png
/home/jim/.icons/256x256/apps/imagemagick.png
/home/jim/.icons/32x32/apps/imagemagick.png
/home/jim/.icons/48x48/apps/imagemagick.png
/home/jim/.icons/64x64/apps/imagemagick.png
/home/jim/.icons/96x96/apps/imagemagick.png
/home/jim/Downloads/solydx/usr/share/icons/evolvere/apps/64/imagemagick.svg
/home/jim/Downloads/solydx/usr/share/icons/evolvere-dark-fallback/apps/64/imagemagick.svg
/home/jim/Downloads/solydx/usr/share/icons/evolvere-vivid-sunken/apps/64/imagemagick.svg
/home/jim/Downloads/solydx/usr/share/icons/evolvere-vivid-sunken-dark-fallback/apps/64/imagemagick.svg
/usr/lib/mime/packages/imagemagick
/usr/share/bug/imagemagick
/usr/share/bug/imagemagick/presubj
/usr/share/bug/imagemagick/script
/usr/share/doc/imagemagick
/usr/share/doc/imagemagick-6.q16
/usr/share/doc/imagemagick-common
/usr/share/doc/imagemagick/NEWS.Debian.gz
/usr/share/doc/imagemagick/changelog.Debian.gz
/usr/share/doc/imagemagick/changelog.gz
/usr/share/doc/imagemagick/copyright
/usr/share/doc/imagemagick-6.q16/NEWS.Debian.gz
/usr/share/doc/imagemagick-6.q16/changelog.Debian.gz
/usr/share/doc/imagemagick-6.q16/changelog.gz
/usr/share/doc/imagemagick-6.q16/copyright
/usr/share/doc/imagemagick-common/NEWS.Debian.gz
/usr/share/doc/imagemagick-common/README.Debian
/usr/share/doc/imagemagick-common/README.txt.gz
/usr/share/doc/imagemagick-common/TODO.Debian
/usr/share/doc/imagemagick-common/changelog.Debian.gz
/usr/share/doc/imagemagick-common/changelog.gz
/usr/share/doc/imagemagick-common/copyright
/usr/share/icons/evolvere/apps/64/imagemagick.svg
/usr/share/icons/evolvere-dark-fallback/apps/64/imagemagick.svg
/usr/share/icons/evolvere-vivid-sunken/apps/64/imagemagick.svg
/usr/share/icons/evolvere-vivid-sunken-dark-fallback/apps/64/imagemagick.svg
/usr/share/menu/imagemagick
/var/cache/apt/archives/imagemagick-6.q16_8%3a6.8.9.6-4_amd64.deb
/var/cache/apt/archives/imagemagick-common_8%3a6.8.9.6-4_all.deb
/var/cache/apt/archives/imagemagick_8%3a6.8.9.6-4_amd64.deb
/var/lib/dpkg/info/imagemagick-6.q16.list
/var/lib/dpkg/info/imagemagick-6.q16.md5sums
/var/lib/dpkg/info/imagemagick-common.conffiles
/var/lib/dpkg/info/imagemagick-common.list
/var/lib/dpkg/info/imagemagick-common.md5sums
/var/lib/dpkg/info/imagemagick-common.postinst
/var/lib/dpkg/info/imagemagick-common.postrm
/var/lib/dpkg/info/imagemagick-common.preinst
/var/lib/dpkg/info/imagemagick.list
/var/lib/dpkg/info/imagemagick.md5sums
/var/lib/dpkg/info/imagemagick.postinst
/var/lib/dpkg/info/imagemagick.postrm
/var/lib/dpkg/info/imagemagick.prerm
jim@vm-x-test:~$ locate imagemagick | grep bin
jim@vm-x-test:~$ 
This is in both SolydX 64 VM & SolydK 64 on metal.
In the Virtual machine I totally purged imagemagick and then reinstalled, but that did not help.
Interestingly the same thing is happenning in Debian -Xfce

No Good Deed Goes Unpunished

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 01/10/2014 [TESTING]

Postby zerozero » 03 Oct 2014 19:57

imagemagick is a very "sneaky" application :lol:

Code: Select all

zerozero@x64-vb:~$ apt content imagemagick | grep bin
/usr/bin
/usr/bin/mogrify-im6
/usr/bin/montage-im6
/usr/bin/display-im6
/usr/bin/stream-im6
/usr/bin/identify-im6
/usr/bin/import-im6
/usr/bin/conjure-im6
/usr/bin/composite-im6
/usr/bin/convert-im6
/usr/bin/animate-im6
/usr/bin/compare-im6

Code: Select all

zerozero@x64-vb:~$ apt policy imagemagick
imagemagick:
  Installed: 8:6.8.9.6-4
  Candidate: 8:6.8.9.6-4
  Version table:
 *** 8:6.8.9.6-4 0
        500 http://debian.solydxk.com/testing/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
zerozero@x64-vb:~$ 
open with should have 2(?) functional imagemagick entries.
bliss of ignorance

User avatar
smitty1
Posts: 254
Joined: 23 Jun 2013 13:50
Location: Pittsburgh, PA USA

Re: UP - 01/10/2014 [TESTING]

Postby smitty1 » 03 Oct 2014 20:08

Thanks for that tip zz. It does work that way. Sorry for the blather.

No Good Deed Goes Unpunished

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 01/10/2014 [TESTING]

Postby zerozero » 03 Oct 2014 21:22

Schoelje wrote:Did you find any other applications with the same behavior?
so far (apart from the already reported issues with mirage and reportbug)
[BTW, for the record: reportbug bug and mirage bug ]

i found (not an exhaustive list)
  1. SpaceFM (fixed in sid)
  2. geany (has a workaround to disable one conflicting plugin that "solves" the problem but the it seems that the general fix is not working)
  3. general bug report against libgtk2.0-0 where exaile is also listed as affected although it ran in my systems.
  4. disk-manager and radiotray
  5. xvidcap
  6. nautilus-dropbox (patched in sid)
  7. Deadbeef (patched also in DMO-SID)
  8. pidgin-skype (fixed version already in sid)
  9. keepnote (apparently the patch doesn't work)
  10. blueproximity
    • reported at ubuntu
  11. psensor
bliss of ignorance

User avatar
fleabus
Posts: 1227
Joined: 16 Sep 2013 04:24
Location: Winchester, VA USA

Re: UP - 01/10/2014 [TESTING]

Postby fleabus » 03 Oct 2014 23:18

:mrgreen:
Finally UP-ing my SX64 test install on the main machine - pristine SX64 installed from 201407 iso:

Code: Select all

fleabus@dv7-1270us:~$ uname -a
Linux dv7-1270us 3.16-2-amd64 #1 SMP Debian 3.16.3-2 (2014-09-20) x86_64 GNU/Linux
fleabus@dv7-1270us:~$ inxi -Fzrxxx
System:    Host: dv7-1270us Kernel: 3.16-2-amd64 x86_64 (64 bit gcc: 4.8.3) 
           Desktop: N/A info: xfce4-panel dm: lightdm Distro: SolydXK 1 testing 
Machine:   System: Hewlett-Packard product: HP Pavilion dv7 Notebook PC v: F.2D Chassis: Compal type: 10
           Mobo: Compal model: 30F4 v: 99.B6 Bios: Hewlett-Packard v: F.2D date: 11/29/2010
CPU:       Dual core Intel Core2 Duo P8600 (-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 9575 
           Clock Speeds: 1: 1600 MHz 2: 2400 MHz
Graphics:  Card: NVIDIA G96M [GeForce 9600M GT] bus-ID: 01:00.0 chip-ID: 10de:0649
           Display Server: X.Org 1.16.1 driver: nvidia Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce 9600M GT/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 340.32 Direct Rendering: Yes
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller 
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:293e 
           Sound: Advanced Linux Sound Architecture v: k3.16-2-amd64
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 05:00.0 chip-ID: 10ec:8168
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Intel PRO/Wireless 5100 AGN [Shiloh] Network Connection
           driver: iwlwifi v: in-tree: bus-ID: 02:00.0 chip-ID: 8086:4237
           IF: wlan0 state: down mac: <filter>
Drives:    HDD Total Size: 2750.6GB (0.5% used)
           ID-1: /dev/sda model: WDC_WD7500BPKT size: 750.2GB serial: WD-WXA1A43S4031
           ID-2: USB /dev/sdb model: 02FAEX size: 2000.4GB serial: DCA017607038-0:0
Partition: ID-1: / size: 20G used: 5.4G (30%) fs: ext4 dev: /dev/sda17 
           ID-2: swap-1 size: 8.60GB used: 0.00GB (0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 42.0C mobo: N/A gpu: 0.0:45C 
           Fan Speeds (in rpm): cpu: N/A 
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.solydxk.com/testing/ solydxk main upstream import
           deb http://debian.solydxk.com/testing testing main contrib non-free
           deb http://debian.solydxk.com/security testing/updates main contrib non-free
           deb http://community.solydxk.com/testing/ solydxk main
Info:      Processes: 176 Uptime: 1 min Memory: 302.7/3933.0MB 
           Init: systemd v: 208 runlevel: 5 default: 2 Gcc sys: 4.9.1 alt: 4.6/4.7/4.8 
           Client: Shell (bash 4.3.251 running in xfce4-terminal) inxi: 2.1.28 
fleabus@dv7-1270us:~$
A bit of apt-snobbery:

Code: Select all

Errors were encountered while processing:
 /var/cache/apt/archives/acpid_1%3a2.0.23-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
dv7-1270us fleabus #
So...

Code: Select all

dv7-1270us fleabus # dpkg --configure -a
The upgrade finished ok, but I have Post-UP user paranoia so I had to mess with it some more... :mrgreen:

Code: Select all

dv7-1270us fleabus # apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  cgmanager libcgmanager0 libnih-dbus1 libnih1
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

dv7-1270us fleabus # apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... The following packages were automatically installed and are no longer required:
  cgmanager libcgmanager0 libnih-dbus1 libnih1
Use 'apt-get autoremove' to remove them.
Done
The following packages have been kept back:
  systemd-shim
The following packages will be upgraded:
  acpid  <-->##(problem from before)
1 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/55.7 kB of archives.
After this operation, 9,216 B disk space will be freed.
Do you want to continue? [Y/n] Y

(Reading database ... 164186 files and directories currently installed.)
Preparing to unpack .../acpid_1%3a2.0.23-1_amd64.deb ...
Warning: Stopping acpid.service, but it can still be activated by:
  acpid.socket
Unpacking acpid (1:2.0.23-1) over (1:2.0.22-2) ...
dpkg: warning: unable to delete old directory '/etc/systemd/system/sockets.target.wants': Directory not empty
Processing triggers for man-db (2.6.7.1-1) ...
Setting up acpid (1:2.0.23-1) ...  <--> ##(problem gone)

dv7-1270us fleabus # apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... The following packages were automatically installed and are no longer required:
  cgmanager libcgmanager0 libnih-dbus1 libnih1
Use 'apt-get autoremove' to remove them.
Done
The following packages have been kept back:
  systemd-shim
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

## (So I'll just get rid of it):

dv7-1270us fleabus # apt-get purge systemd-shim
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  cgmanager libcgmanager0 libnih-dbus1 libnih1
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  systemd-shim*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 94.2 kB disk space will be freed.
Do you want to continue? [Y/n] Y

(Reading database ... 164183 files and directories currently installed.)
Removing systemd-shim (6-3) ...
Removing 'diversion of /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service to /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd by systemd-shim'
Purging configuration files for systemd-shim (6-3) ...
No diversion 'diversion of /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service to /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd by systemd-shim', none removed.
Processing triggers for dbus (1.8.6-2) ...

dv7-1270us fleabus # apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... The following packages were automatically installed and are no longer required:
  cgmanager libcgmanager0 libnih-dbus1 libnih1
Use 'apt-get autoremove' to remove them.
Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

dv7-1270us fleabus # apt-get autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  cgmanager libcgmanager0 libnih-dbus1 libnih1
0 upgraded, 0 newly installed, 4 to remove and 0 not upgraded.
After this operation, 933 kB disk space will be freed.
Do you want to continue? [Y/n] Y

(Reading database ... 164176 files and directories currently installed.)
Removing cgmanager (0.32-4) ...
Removing libcgmanager0:amd64 (0.32-4) ...
Removing libnih-dbus1 (1.0.3-4.3) ...
Removing libnih1 (1.0.3-4.3) ...
Processing triggers for man-db (2.6.7.1-1) ...
Processing triggers for libc-bin (2.19-11) ...
dv7-1270us fleabus # 

## All Clean! (Maybe.  :oops: Fingers crossed in paranoia.)
Very smooth... 8-)

(Again!) Even systemd is behaving...

User avatar
Arjen Balfoort
Site Admin
Posts: 9477
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP - 01/10/2014 [TESTING]

Postby Arjen Balfoort » 04 Oct 2014 11:07

I've updated solydxk-system to handle those applications you don't want to see in the menu (like ImageMagick).

As far as I can see is that of all the applications that are installed by default, the software manager was the only one affected by the Gtk2 bug.
Are there any packages that I need to add to our repository?
I have to do this manually (downloading the necessary packages, removing the affected packages and replacing them with the new ones). So, please limit the number of packages to add.


SolydXK needs you!
Development | Testing | Translations

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP - 01/10/2014 [TESTING]

Postby zerozero » 04 Oct 2014 18:56

added keepnote and blueproximity to the affected applications
Schoelje wrote:Are there any packages that I need to add to our repository?
exaile is listed as one of the affected; it would be interesting to have others test it.
bliss of ignorance

User avatar
grizzler
Posts: 2208
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: UP - 01/10/2014 [TESTING]

Postby grizzler » 04 Oct 2014 19:25

Exaile starts here (the warnings are probably because it's 'empty' as I don't use it). It gives the familiar 'mutex' error on exit.

Code: Select all

p07@asus:~$ LANG=C exaile
INFO    : Loading Exaile 3.4.0 on Python 2.7.8...
INFO    : Loading settings...
INFO    : Using unknown locale
INFO    : Loading plugins...
INFO    : Loading collection...
WARNING : Exception occurred while loading /home/p07/.local/share/exaile/music.db
WARNING : Exception occurred while loading /home/p07/.local/share/exaile/music.db
WARNING : Exception occurred while loading /home/p07/.local/share/exaile/music.db
INFO    : Loading devices...
INFO    : Connected to udisks2
INFO    : Loading interface...
INFO    : Using GTK+ 2.24.24
INFO    : Loading main window...
INFO    : Connecting main window events...
INFO    : Loading panels...
INFO    : Connecting panel events...
INFO    : Done loading main window...
INFO    : WARNING: could not open podcast file
INFO    : Exaile is shutting down...
INFO    : Disabling plugins...
INFO    : Saving state...
Attempt to unlock mutex that was not locked
Afgebroken
The last three INFO lines and the error don't appear until the GUI is closed.

There's radiotray, but a fixed version has entered unstable and should migrate to testing before the 15th, so you might consider putting that in the UP instead.
Frank

SolydX EE 64 - tracking Debian Testing


Return to “Testing Zone”

Who is online

Users browsing this forum: No registered users and 5 guests