Page 12 of 16

Re: New ISOs in ce/testing

Posted: 26 Dec 2017 21:17
by grizzler
Thanks for testing. Looks like typical unpredictable EE behaviour. To be honest, SolydK EE not working as expected never surprises me.

The apt bit is odd though, because there should always be an executable called apt, either our own or the 'real' one (which is part of the same package as apt-get).
Is there a file called apt in /usr/bin?
Anything useful in the log files in /var/log/apt?

I'll try to find the time to run some tests myself tomorrow.

Re: New ISOs in ce/testing

Posted: 26 Dec 2017 23:15
by smitty1
There is no /usr/bin/apt and I couldn't find anything useful in the logs.
I removed the package from the archive & then reinstalled but that was no help. The package is marked as an alpha, and Debian has a boatload of bugs against it in Sid(?).
That is a far as I can go today, I'll play around some with it tomorrow.

Re: New ISOs in ce/testing

Posted: 27 Dec 2017 11:50
by grizzler
Great. The live installer removes solydxk-system with the live packages. Something pulls out udisks2 and that causes solydxk-system (and usb-creator) to be removed as well:

Code: Select all

--> Removing live packages
Removing live configuration (packages) (17 of 19)
Executing: LANG=nl_NL.UTF-8 chroot /target/ /bin/sh -c "DEBIAN_FRONTEND=noninteractive apt-get --assume-yes --quiet --allow-downgrades --allow-remove-essential --allow-change-held-packages -o Dpkg::Options::=--force-confmiss -o Dpkg::Options::=--force-confnew purge live-installer* python3-geoip geoip-database-contrib live-boot live-boot-initramfs-tools live-config live-config-sysvinit live-config-systemd live-build live-tools gdisk gparted jfsutils libgtkmm-2.4-1c2a xfsprogs streamer isoquery"
Pakketlijsten worden ingelezen...
Boom van vereisten wordt opgebouwd...
De statusinformatie wordt gelezen...
Pakket 'live-installer' is niet geïnstalleerd, en wordt dus niet verwijderd
Pakket 'live-installer-slideshow' is niet geïnstalleerd, en wordt dus niet verwijderd
Pakket 'libgtkmm-2.4-1c2a' is niet geïnstalleerd, en wordt dus niet verwijderd
Pakket 'live-build' is niet geïnstalleerd, en wordt dus niet verwijderd
Pakket 'live-config-sysvinit' is niet geïnstalleerd, en wordt dus niet verwijderd
Pakket 'live-tools' is niet geïnstalleerd, en wordt dus niet verwijderd
De volgende pakketten zijn automatisch geïnstalleerd en zijn niet langer nodig:
  cryptsetup haveged libblockdev-crypto2 libblockdev-fs2 libblockdev-loop2
  libblockdev-part-err2 libblockdev-swap2 libblockdev-utils2 libblockdev2
  libcdio-cdda2 libcdio-paranoia2 libgdata-common libgdata22 libgtkmm-2.4-1v5
  libhavege1 liboauth0 libvolume-key1 python3-dateutil python3-parted
  python3-pyqt4 python3-sip
Gebruik 'sudo apt autoremove' om ze te verwijderen.
De volgende pakketten zullen VERWIJDERD worden:
  gdisk* geoip-database-contrib* gparted* gvfs* gvfs-backends* gvfs-daemons*
  gvfs-fuse* isoquery* jfsutils* libblockdev-part2* live-boot*
  live-boot-initramfs-tools* live-config* live-config-systemd*
  live-installer-3* live-installer-3-slideshow* python3-geoip* solydxk-system*
  streamer* udisks2* usb-creator* xfsprogs*
0 opgewaardeerd, 0 nieuw geïnstalleerd, 22 te verwijderen en 37 niet opgewaardeerd.
I haven't identified yet what dependency causes udisks2 to be removed *), but at least this explains why apt is gone. Only it doesn't, because removing 'our' apt shoud reinstate the original, which was diverted. However, apt-divert is still there. Strange.

As smitty1 noted, libreoffice doesn't work on the live system. Starting it from the terminal shows it crashes with a stack trace. Not sure what to do about that.

Code: Select all

solydxk@solydxk:~$ libreoffice


Fatal exception: Signal 11
Stack:
/usr/lib/libreoffice/program/libuno_sal.so.3(+0x13505)[0x7f8a0b89a505]
/usr/lib/libreoffice/program/libuno_sal.so.3(+0x3b7e6)[0x7f8a0b8c27e6]
/lib/x86_64-linux-gnu/libc.so.6(+0x33af0)[0x7f8a0b517af0]
/usr/lib/libreoffice/program/libuno_cppu.so.3(uno_type_any_assign+0x705)[0x7f8a03e32b85]
/usr/lib/libreoffice/program/libmergedlo.so(+0x2e198a8)[0x7f8a0e8f98a8]
/usr/lib/libreoffice/program/libmergedlo.so(+0x2e1a64a)[0x7f8a0e8fa64a]
/usr/lib/libreoffice/program/libmergedlo.so(_ZN3utl10ConfigItemC2ERKN3rtl8OUStringE14ConfigItemMode+0xcb)[0x7f8a0e8eec9b]
/usr/lib/libreoffice/program/libmergedlo.so(+0x2e72965)[0x7f8a0e952965]
/usr/lib/libreoffice/program/libmergedlo.so(_ZN19SvtSysLocaleOptionsC1Ev+0x125)[0x7f8a0e953f15]
/usr/lib/libreoffice/program/libmergedlo.so(+0x2e99033)[0x7f8a0e979033]
/usr/lib/libreoffice/program/libmergedlo.so(_ZN12SvtSysLocaleC1Ev+0xfc)[0x7f8a0e9791bc]
/usr/lib/libreoffice/program/libmergedlo.so(+0x31ab58c)[0x7f8a0ec8b58c]
/usr/lib/libreoffice/program/libmergedlo.so(_ZN11AllSettingsC1Ev+0x46)[0x7f8a0ec8b6c6]
/usr/lib/libreoffice/program/libmergedlo.so(+0x31b14af)[0x7f8a0ec914af]
/usr/lib/libreoffice/program/libmergedlo.so(_ZN11Application11GetSettingsEv+0x32)[0x7f8a0ec92482]
/usr/lib/libreoffice/program/libvclplug_gtklo.so(+0x3bfa5)[0x7f89f81abfa5]
/usr/lib/libreoffice/program/libmergedlo.so(_Z7InitVCLv+0x2e2)[0x7f8a0ec97ab2]
/usr/lib/libreoffice/program/libmergedlo.so(+0x31b90dd)[0x7f8a0ec990dd]
/usr/lib/libreoffice/program/libmergedlo.so(_Z6SVMainv+0x30)[0x7f8a0ec99140]
/usr/lib/libreoffice/program/libmergedlo.so(soffice_main+0x115)[0x7f8a0dcfc185]
/usr/lib/libreoffice/program/soffice.bin(+0x78b)[0x55ce52f5278b]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf1)[0x7f8a0b504561]
/usr/lib/libreoffice/program/soffice.bin(+0x7ca)[0x55ce52f527ca]
solydxk@solydxk:~$
This does not happen in the installed system, by the way.

I'll look at SolydK EE later.

Sidenote: SolydX EE live system shows a plymouth screen instead of the usual three dots (yay!)...

___________________________________________________
*) xfsprogs? but that's only a "Suggests"...

Re: New ISOs in ce/testing

Posted: 27 Dec 2017 12:53
by ilu
grizzler: Did you get the mate artwork done? Should I do something about it? If yes, mail me what you've got. Or tell me to start from scratch.

Re: New ISOs in ce/testing

Posted: 27 Dec 2017 14:56
by grizzler
No, I haven't had time to do anything with it yet. If you could look at it, that would be great.

Re: New ISOs in ce/testing

Posted: 27 Dec 2017 15:18
by smitty1
Frank:
Installing solydxk-system resolved the apt problem but I couldn't identify what caused it's removal. haveged maybe???
udisks2 reinstalled without xfsprogs. I'll attach the terminal output from those exercises maybe you can find something.

Re: New ISOs in ce/testing

Posted: 27 Dec 2017 16:22
by grizzler
smitty1 wrote:Installing solydxk-system resolved the apt problem but I couldn't identify what caused it's removal. haveged maybe???
Nope. It's caused by removing gdisk. libblockdev-part2 wants gdisk and udisks2 wants libblockdev-part2, so when gdisk is removed, udisks2 goes as well and that also takes everything that depends on it.
udisks2 reinstalled without xfsprogs. I'll attach the terminal output from those exercises maybe you can find something.
Yup. That helped. Thanks.

@Arjen, I'm removing gdisk from boot/live/filesystem.packages-remove in my build structures. It may not be necessary to do that for the stretch ISOs, but buster needs it and leaving gdisk installed won't hurt.

Re: New ISOs in ce/testing

Posted: 27 Dec 2017 17:22
by grizzler
smitty1 wrote:For SolydK
Installation appeared to work, but it would not boot from the vdi.
It gets to the login screen, which is just a login box and the top menu bar against a black screen.
I checked my settings and tried again with the same result. I'll try a fresh install later.
Don't bother. I get the exact same thing here. It could be because the installer's removal stage pulled out even more packages. The GRUB screen isn't correct either: no background (which is also what you're seeing when the login box appears).

Running the installer was weird as well. I ran it from the konsole because I wanted to see what it did at the end. It took an unusually long time to show the small "splash window" and then proceeded without producing any terminal output. It also seemed to take much longer than usual installing things, as the "screensaver" (a.k.a. screen blanking) kicked in well before it was finished. That has never happened before.

I'll build a new set (without the gdisk/udisks2/solydxk-system/whatever removal). This one's broken.

Re: New ISOs in ce/testing

Posted: 28 Dec 2017 12:05
by grizzler
A new SolydK EE 64 ISO is currently being uploaded. It isn't much better than the previous one, though. Still no terminal output if you run the installer in the konsole and although the backgrounds are available after installation, logging in still ends with a totally black screen instead of a desktop. It isn't completely unresponsive, as you can use Ctrl+Alt+Backspace (or the VBox equivalent) to go back to the login screen, but otherwise it's quite useless.

I don't have time to figure this out right now, but I'll run a build/upload batch for the SolydX EEs, which should be OK now (except - possibly - for LibreOffice crashing in the live system).

Re: New ISOs in ce/testing

Posted: 07 Jan 2018 13:36
by grizzler
Uploading new 32-bit SolydXK 9 ISOs now. Only briefly tested in a VM (just the live system).

EEs some time next week, after the new kernel has migrated to testing.

Re: New ISOs in ce/testing

Posted: 07 Jan 2018 15:44
by san-claudio
Pour EE avec les microcodes d'intel que je viens de voir passer hier...

Re: New ISOs in ce/testing

Posted: 08 Jan 2018 14:13
by ilu
Does anybody know whats happening to the transcode package in buster? It's not even in sid (only for ARM).

Re: New ISOs in ce/testing

Posted: 08 Jan 2018 14:45
by grizzler
Dead upstream. Removed from unstable and testing almost two years ago.

https://bugs.debian.org/cgi-bin/bugrepo ... bug=817199
https://tracker.debian.org/pkg/transcode

Re: New ISOs in ce/testing

Posted: 12 Mar 2018 18:24
by grizzler
Uploading all six CE ISOs now. Should appear here later this evening.

Not tested, only briefly checked in a VM. Just the live system, not installed, so no idea if they're any use after installation.

The SolydK EEs are (still) very slow at starting up: the plymouth screen shows, then a black one and after several minutes the desktop comes up.

These are Community Editions, people! I depend on 'the Community' to test them.

Re: New ISOs in ce/testing

Posted: 16 Mar 2018 09:01
by Arjen Balfoort
@grizzler
Shall I post a call for help on our site/Facebook/Twitter?

Re: New ISOs in ce/testing

Posted: 16 Mar 2018 21:06
by smitty1
For SolydKee_10_64_201803
I tested in a vm
Installing solydkee_10_64_20103
Seemed to take a long time to install
Sat a long time at installing packages when I clicked on the window it moved on to "Removing Live.."
Waited over 5 mins.while "Removing Live configuration".
Clicked on Quit and the “Installation Finished” dialog appeared.
Starting from the vdi took 2.5 mins to get to the log in screen & another 1+ min. to get to the welcome screen.
Overall the process felt like it was taking forever but I didn't do any other timing.

Installed some apps from the welcome screen.
All commonly apps opened and saved
I wanted to test Solydxk-System-Settings to rank mirrors and found a glitch.
After doing the speed test I chose 1 mirror each for Debian & Solydxk & clicked save mirrors. But then I noticed I had overlooked a faster Debian mirror. I selected the new mirror and clicked save. I checked that only 2 mirrors were checked in Solydxk-System-Settings.
When ran sudo apt update there were 3 lines in the sources 2 for the Debian mirrors. When I had changed my mind Solydxk-System-Settings added the new repository without removing the first one.
I have duplicated this behavior on a virtual machine of solydxee 201803 and on SolydX stretch on metal on a different computer.
The Original sources.list

Code: Select all

deb http://repository.solydxk.com/ solydxk-ee main upstream import
deb http://ftp.us.debian.org/debian testing main contrib non-free
After the 2 changes

Code: Select all

deb http://ftp.nluug.nl/os/Linux/distr/solydxk/repository/ solydxk-ee main upstream import
deb http://ftp.ca.debian.org/debian testing main contrib non-free
deb http://ftp.acc.umu.se/mirror/solydxk.com/repository solydxk main upstream import
deb http://deb.debian.org/debian testing main contrib non-free
Doing an update with this arrangement threw an error

Code: Select all

W: Conflicting distribution: http://ftp.acc.umu.se/mirror/solydxk.com/repository solydxk InRelease (expected solydxk but got solydxk-8)
The error was resolved by adding -10 to the acc.umu entry

Code: Select all

deb http://ftp.acc.umu.se/mirror/solydxk.com/repository solydxk -10 main upstream import
But I still had to manually edit the sources.list file.

Re: New ISOs in ce/testing

Posted: 18 Mar 2018 12:04
by grizzler
Schoelje wrote:@grizzler
Shall I post a call for help on our site/Facebook/Twitter?
That could be useful...

Re: New ISOs in ce/testing

Posted: 18 Mar 2018 12:14
by grizzler
smitty1 wrote:For SolydKee_10_64_201803
Overall the process felt like it was taking forever but I didn't do any other timing.
Thanks for testing.
The SolydK EE slowness (at least in a VM) is a known issue. I have no idea what could fix it at this time... :(

I don't know about the current state of solydxk-system handling EEs. The automatic adjustments don't handle the sources.list either (that was on purpose, by the way).

It may be a while before I have time to look at things properly. Currently, most of my free time and energy are spent on a non computer related issue. It looks like this may be coming to an end shortly. When it's over, I'll probably take a couple of days off (i.e. be out of town) to get it out of my system. After that, things should be more or less back to normal.

Re: New ISOs in ce/testing

Posted: 18 Mar 2018 14:18
by MAYBL8
Smitty,

I finally got solyxee64 running in my VB.
Removed splash from grub so I could see what was going on.
Managed to get updated after a few tries.
This is my source list:

Code: Select all

Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://repository.solydxk.com/ solydxk-ee main upstream import
           deb http://deb.debian.org/debian/ testing main contrib non-free
Edit:
Well I thought it was working. The session went to sleep giving me the login box and I typed my password in and the session froze with some graphics corruption.
Back to the drawing board.
I am going to give it more memory and see what happens. I'm currently at 1536.

Re: New ISOs in ce/testing

Posted: 19 Mar 2018 07:29
by Arjen Balfoort
I've posted a call for help:
https://solydxk.nl/enthusiasts-editions ... lp-needed/
Also on Twitter, Facebook and Google+