USB drive doesn't mount or show up in GUI

SolydXK is too quiet for you? SolydXK Enthusiast Editions, based on Debian Testing is for you! Here you can find news about Debian Testing and Unstable too, and also tests on SolydXK programs.
The support for SolydXK EE is provided by the community.
lilgman
Posts: 40
Joined: 04 Oct 2013 13:53
Location: Lesotho, Africa

USB drive doesn't mount or show up in GUI

Postby lilgman » 22 Nov 2016 19:13

I'm running SolydX EE. Everything is up to date and working fine except for the USB thumb drive that I used to install SolydX. When I plug it in, it doesn't show up in Thunar so that I can mount it. It works fine on other computers, and I can also mount it from a terminal. Other USB drives work as expected. Why won't it mount automatically?

Code: Select all

$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 048d:8386 Integrated Technology Express, Inc. 
Bus 001 Device 003: ID 03eb:8858 Atmel Corp. 
Bus 001 Device 008: ID 0cf3:3004 Atheros Communications, Inc. AR3012 Bluetooth 4.0
Bus 001 Device 006: ID 1bcf:2c66 Sunplus Innovation Technology Inc. 
Bus 001 Device 004: ID 04a9:2771 Canon, Inc. 
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 009: ID 0930:6544 Toshiba Corp. TransMemory-Mini / Kingston DataTraveler 2.0 Stick (2GB)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
It is Device 009

mount doesn't show up anything usb.

sudo dmesg gives the following:

Code: Select all

[  517.741847] scsi 2:0:0:0: Direct-Access     TOSHIBA  TransMemory      1.00 PQ: 0 ANSI: 4
[  517.745231] sd 2:0:0:0: Attached scsi generic sg1 type 0
[  517.745632] sd 2:0:0:0: [sdb] 60594432 512-byte logical blocks: (31.0 GB/28.9 GiB)
[  517.745978] sd 2:0:0:0: [sdb] Write Protect is off
[  517.745995] sd 2:0:0:0: [sdb] Mode Sense: 45 00 00 00
[  517.746352] sd 2:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[  517.749974]  sdb: sdb1
[  517.751884] sd 2:0:0:0: [sdb] Attached SCSI removable disk

Code: Select all

$ sudo fdisk -l
Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: C99BFEC4-3923-4C3F-8017-0A38D298CCF4

Device         Start       End   Sectors   Size Type
/dev/sda1       2048    534527    532480   260M EFI System
/dev/sda2     534528    567295     32768    16M Microsoft reserved
/dev/sda3     567296  51054591  50487296  24.1G Microsoft basic data
/dev/sda4  886059008 894500863   8441856     4G Microsoft basic data
/dev/sda5  938487808 940535807   2048000  1000M Windows recovery environment
/dev/sda6  940535808 974725119  34189312  16.3G Windows recovery environment
/dev/sda7  974725120 976773119   2048000  1000M Lenovo boot partition
/dev/sda8   51054592 877867007 826812416 394.3G Linux filesystem
/dev/sda9  877867008 886059007   8192000   3.9G Linux swap
/dev/sda10 894500864 938487807  43986944    21G Linux filesystem

Partition table entries are not in disk order.


Disk /dev/sdb: 28.9 GiB, 31024349184 bytes, 60594432 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x4d5c7a9c

Device     Boot Start      End  Sectors  Size Id Type
/dev/sdb1          63 60592895 60592833 28.9G  b W95 FAT32
This is may be a separate issue, but

Code: Select all

$ sudo mount -t vfat -o rw,users /dev/sdb1 /media/glenn
mounts the usb drive fine, but it can only be written to by root. Maybe I just don't understand the mount command, particularly the options?

Thanks for your help to sort out the automount problem and perhaps explain what I'm doing wrong to mount this manually in user space.

User avatar
ilu
Posts: 2159
Joined: 09 Oct 2013 12:45

Re: USB drive doesn't mount or show up in GUI

Postby ilu » 25 Nov 2016 13:28

Is the Media administration (don't know the exact english name) checkbox checked under Thunar - Settings - Advanced?
Check Settings - Desktop - Symbols - Standard Symbols - Show Removable Devices and see whether the device shows up on desktop when you plug it in.

The mount command looks about right but who owns /media/glenn?

lilgman
Posts: 40
Joined: 04 Oct 2013 13:53
Location: Lesotho, Africa

Re: USB drive doesn't mount or show up in GUI

Postby lilgman » 29 Nov 2016 10:54

I never found a solution to this. I eventually formatted the USB drive on another computer. Now it works fine.


User avatar
Arjen Balfoort
Site Admin
Posts: 8958
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: USB drive doesn't mount or show up in GUI

Postby Arjen Balfoort » 22 Oct 2018 15:02

I assume this is a copy/paste post from a future spammer.
If I get no appropriate reaction within a few days I'll remove this post.


SolydXK needs you!
Development | Testing | Translations

kurotsugi
Posts: 2136
Joined: 09 Jan 2014 00:17

Re: USB drive doesn't mount or show up in GUI

Postby kurotsugi » 23 Oct 2018 02:40

how should I read that post? :3


Return to “Testing Zone”

Who is online

Users browsing this forum: No registered users and 4 guests