ISO testing 201701

SolydXK is too quiet for you? SolydXK Enthusiast Editions, based on Debian Testing is for you! Here you can find news about Debian Testing and Unstable too, and also tests on SolydXK programs.
The support for SolydXK EE is provided by the community.
User avatar
Arjen Balfoort
Site Admin
Posts: 9313
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

ISO testing 201701

Postby Arjen Balfoort » 04 Jan 2017 10:53

It's time again to start testing for the new release. I don't think we'll find any major issues. These ISOs are fully updated and there were no major changes that we already tackled in the past six months.

I've built new ISOs including an RPI image: http://downloads.solydxk.nl/nightly/
I've also built new Dutch localized versions if you're interested: http://downloads.solydxk.nl/localized/testing/

These ISOs are the next release candidates.

I've attached a Calc sheet with test cases to help you to test.
Attachments
SolydXK ISO test cases.ods
(21.17 KiB) Downloaded 61 times


SolydXK needs you!
Development | Testing | Translations

User avatar
palimmo
Posts: 818
Joined: 19 Nov 2013 19:44
Contact:

Re: ISO testing 201701

Postby palimmo » 05 Jan 2017 12:50

SOLYDK 64
here my quick test result, only in live mode. No installation.
SolydXK ISO test cases.ods
(70.39 KiB) Downloaded 65 times
so far everything is good, with some notes:

- the clock is by default unreadable due to the white font over a white piece of background and panel transparency.
- SolydK 8 64 -bit Instaler. We miss an l here ;)
- touchpad and Windows-key work out of the box. Great.
- Firefox: if I press the Download arrow to see my Downloads and select "open containing folder" it launches Gwenview instead of Dolphin. :facepalm:
- unmaximized windows show always a strange dark sign on both sides right/left, exactly below the window title bar.
- window title bar has not always the same appearance. For example compare Dolphin and Software Manager.

Thanks guys
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
Arjen Balfoort
Site Admin
Posts: 9313
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: ISO testing 201701

Postby Arjen Balfoort » 05 Jan 2017 18:49

It seems that Gwenview has inode/directory in its mime list. This results in listing Gwenview as a possible application to open directories in /usr/share/applications/mimeinfo.cache.

I've fixed the Firefox issue by including an adapted gwenview.desktop in the solydxk-system package and refreshing the cache when done.

The single "l" in installer might be a translation issue. Did you select another language then English when you noticed the "l"?

I'll take a look at the rest after the weekend.

[Edit]
I've also adjusted the default color of the digital clock in solydk-system-adjustments from white to grey. I don't know how to do that for the EEs, yet.


SolydXK needs you!
Development | Testing | Translations

User avatar
Arjen Balfoort
Site Admin
Posts: 9313
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: ISO testing 201701

Postby Arjen Balfoort » 07 Jan 2017 17:23

I've uploaded updated ISOs with most of palimmo's suggestions resolved. The download URLs are the same as mentioned in the OP.

@palimmo
Can you tell me with what applications you had those graphical (window) issues. I cannot find them. An image would also be of great help.


SolydXK needs you!
Development | Testing | Translations

User avatar
eselma
Posts: 179
Joined: 24 Mar 2013 09:55
Location: Catalonia

Re: ISO testing 201701

Postby eselma » 08 Jan 2017 20:40

Well, finally I got the time (and suitable partition on my main PC) to test this ISO. No issues here. Only the (well known) fact of incompatibility between Plymouth and some video drivers, specially ATI/Radeon. As a sample test, with the 3.16 kernel the free driver gets about 3400 fps and the proprietary (installed flawlessly via DDM) 5400 fps. Well, but with the (4.7? and) 4.8 kernels* (at backports) the free drivers jumps to 4900 fps, so no need to install the AMD ones. Of course, i am not a gamer. But I've been using the backports drivers without issues from the first day they were available. Anyone too?

The calc sheet and a text file with the specifications of this PC are attached here.

Edit: apparently, the 4.8 kernel is the one which gets this speed, not so the 4.7.
Attachments
SolydXK_ISO_test_cases.ods
(21.64 KiB) Downloaded 66 times
inxi_orion.txt
(4.65 KiB) Downloaded 57 times

User avatar
bas_otten
Posts: 212
Joined: 19 Oct 2013 12:22
Location: Netherlands

Re: ISO testing 201701

Postby bas_otten » 11 Jan 2017 15:33

I did a whole bunch of testing on the new RC ISO this afternoon. And did not find anything at fault for my environment or use. Plain solyd it is :!:

Just one item for possible improvement:
Resulting from https://forums.solydxk.com/viewtopic.ph ... ilit=fstab and https://forums.solydxk.com/viewtopic.ph ... 536#p54494, I was expecting to find a '/var/log/clamav tmpfs' entry in fstab.

Regards, Bas

User avatar
Arjen Balfoort
Site Admin
Posts: 9313
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: ISO testing 201701

Postby Arjen Balfoort » 11 Jan 2017 15:54

bas_otten wrote:Just one item for possible improvement:
Resulting from https://forums.solydxk.com/viewtopic.ph ... ilit=fstab and https://forums.solydxk.com/viewtopic.ph ... 536#p54494, I was expecting to find a '/var/log/clamav tmpfs' entry in fstab.
The only thing that's done now is that /var/log/clamav is created on boot if it doesn't exist and clamav is installed. I haven't changed the fstab entries because there was no consensus/need in the community.


SolydXK needs you!
Development | Testing | Translations

User avatar
bas_otten
Posts: 212
Joined: 19 Oct 2013 12:22
Location: Netherlands

Re: ISO testing 201701

Postby bas_otten » 11 Jan 2017 18:07

I see the /var/log/clamav is indeed created on boot (how?), but apparently it comes just too late in time, since:

Code: Select all

root@bashost:/var/log/clamav #>>> systemctl status clamav-daemon.service clamav-freshclam.service

* clamav-daemon.service - Clam AntiVirus userspace daemon
   Loaded: loaded (/lib/systemd/system/clamav-daemon.service; enabled)
   Active: failed (Result: exit-code) since wo 2017-01-11 18:43:09 CET; 1min 5s ago
     Docs: man:clamd(8)
           man:clamd.conf(5)
           http://www.clamav.net/lang/en/doc/
  Process: 652 ExecStart=/usr/sbin/clamd --foreground=true (code=exited, status=1/FAILURE)
 Main PID: 652 (code=exited, status=1/FAILURE)

jan 11 18:43:09 bashost systemd[1]: Starting Clam AntiVirus userspace daemon...
jan 11 18:43:09 bashost systemd[1]: Started Clam AntiVirus userspace daemon.
jan 11 18:43:09 bashost clamd[652]: ERROR: Can't initialize the internal logger
jan 11 18:43:09 bashost clamd[652]: ERROR: Can't open /var/log/clamav/clamav.log in append mode (check permissions!).
jan 11 18:43:09 bashost systemd[1]: clamav-daemon.service: main process exited, code=exited, status=1/FAILURE
jan 11 18:43:09 bashost systemd[1]: Unit clamav-daemon.service entered failed state.

* clamav-freshclam.service - ClamAV virus database updater
   Loaded: loaded (/lib/systemd/system/clamav-freshclam.service; enabled)
   Active: failed (Result: exit-code) since wo 2017-01-11 18:43:09 CET; 1min 5s ago
     Docs: man:freshclam(1)
           man:freshclam.conf(5)
           http://www.clamav.net/lang/en/doc/
  Process: 531 ExecStart=/usr/bin/freshclam -d --foreground=true (code=exited, status=62)
 Main PID: 531 (code=exited, status=62)

jan 11 18:43:08 bashost systemd[1]: Started ClamAV virus database updater.
jan 11 18:43:09 bashost freshclam[531]: ERROR: Problem with internal logger (UpdateLogFile = /var/log/clamav/freshclam.log).
jan 11 18:43:09 bashost freshclam[531]: ERROR: Can't open /var/log/clamav/freshclam.log in append mode (check permissions!).
jan 11 18:43:09 bashost systemd[1]: clamav-freshclam.service: main process exited, code=exited, status=62/n/a
jan 11 18:43:09 bashost systemd[1]: Unit clamav-freshclam.service entered failed state.
Having a '/var/log/clamav tmpfs' entry in fstab seems in my experience the most easy and stable way to solve this issue.

User avatar
Arjen Balfoort
Site Admin
Posts: 9313
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: ISO testing 201701

Postby Arjen Balfoort » 11 Jan 2017 18:38

I see what you mean.
I've adapted the live installer and am building new ISOs now. I'll post back when they are available or try the new live installer in your live session before you start the installation:

Code: Select all

apt update
apt install live-installer-3


SolydXK needs you!
Development | Testing | Translations

User avatar
Arjen Balfoort
Site Admin
Posts: 9313
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: ISO testing 201701

Postby Arjen Balfoort » 12 Jan 2017 14:26

I've updated all ISOs and even the RPI image. Use the download links in the OP if you want to check them out.

The update manager of SolydX RPI will continue to tell you that there are updates available but when started it'll say that your system is up to date. I found out that xserver-xorg-input-all depends on xserver-xorg-input-libinput which is not available in any repository. The Raspbian repository updated its xserver-xorg-input-all but forgot to do so with its dependencies. Temporarily installing that package from Stretch is a bit risky: it'll import a bunch of other dependencies from Stretch. So, I left it as-is.

[Edit]
Installing the new ISO on SSD generates this fstab:

Code: Select all

solydxk@solydxk:~$ cat /etc/fstab
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
UUID=a936b1d0-1613-4e07-8038-34cb884ea551       /       ext4    rw,errors=remount-ro,noatime    0       1
UUID=3D09-DAAD  /boot/efi       vfat    defaults        0       0
UUID=b3a0b2fb-9e0e-481d-a220-6cba41e152ad       /home   ext4    rw,errors=remount-ro,noatime    0       2
UUID=1184d023-2fbf-4138-b50e-c07569acc64b       swap    swap    sw      0       0
                                                                                                                  
# RAM disks                                                                                                                             
tmpfs   /tmp                    tmpfs   defaults,noatime,mode=1777              0       0                                                                        
tmpfs   /var/tmp                tmpfs   defaults,noatime                        0       0
tmpfs   /var/backups            tmpfs   defaults,noatime                        0       0
tmpfs   /var/log                tmpfs   defaults,noatime                        0       0
tmpfs   /var/log/apt            tmpfs   defaults,noatime                        0       0
tmpfs   /var/log/samba          tmpfs   defaults,noatime                        0       0
tmpfs   /var/log/cups           tmpfs   defaults,noatime                        0       0
tmpfs   /var/log/lightdm        tmpfs   defaults,noatime                        0       0
tmpfs   /var/log/ConsoleKit     tmpfs   defaults,noatime                        0       0
tmpfs   /var/log/clamav         tmpfs   defaults,noatime                        0       0
tmpfs   /var/cache/apt/archives tmpfs   defaults,noexec,nosuid,nodev,mode=0755  0       0
This generates any missing directories.
Let me know if this is alright or not.

Code: Select all

solydxk@solydxk:~$ ls -l /var/log
total 324
drwxrwxrwt 2 root root     40 Jan 12 15:36 apt
-rw-r----- 1 root adm    3541 Jan 12 15:37 auth.log
-rw-r--r-- 1 root root   6673 Jan 12 15:36 boot.log
-rw------- 1 root utmp      0 Jan 12 15:36 btmp
drwxrwxrwt 2 root root     80 Jan 12 15:36 clamav
drwxrwxrwt 2 root root     60 Jan 12 15:36 ConsoleKit
drwxrwxrwt 2 root root    100 Jan 12 15:36 cups
-rw-r----- 1 root adm   52665 Jan 12 15:38 daemon.log
-rw-r----- 1 root adm   10080 Jan 12 15:37 debug
-rw-r----- 1 root adm   52064 Jan 12 15:37 kern.log
drwxrwxrwt 2 root root    100 Jan 12 15:36 lightdm
-rw-r----- 1 root adm   45868 Jan 12 15:37 messages
drwxrwxrwt 3 root root    200 Jan 12 15:36 samba
-rw-r--r-- 1 root root    283 Jan 12 15:36 solydxk-system.log
-rw-r----- 1 root adm  110234 Jan 12 15:38 syslog
-rw-r----- 1 root adm    4723 Jan 12 15:37 user.log
-rw-rw-r-- 1 root utmp   2688 Jan 12 15:38 wtmp
-rw-r--r-- 1 root root  22216 Jan 12 15:36 Xorg.0.log
I haven't added apache2, mysql and mpd. It doesn't hurt to add them even though these are not installed by default. Should I?


SolydXK needs you!
Development | Testing | Translations

User avatar
bas_otten
Posts: 212
Joined: 19 Oct 2013 12:22
Location: Netherlands

Re: ISO testing 201701

Postby bas_otten » 12 Jan 2017 20:06

Schoelje wrote:Let me know if this (fstab) is alright or not.
Looks perfect to me!
Schoelje wrote:I haven't added apache2, mysql and mpd. It doesn't hurt to add them even though these are not installed by default. Should I?
No, I would say to not progressively add subdirectories here for not-installed services. You'd get a whole list without ever being complete. Everyone can add their own after installing a package that requires it, like I did with the additional three mentioned in the SSD-topic.

User avatar
palimmo
Posts: 818
Joined: 19 Nov 2013 19:44
Contact:

Re: ISO testing 201701

Postby palimmo » 13 Jan 2017 21:42

Schoelje wrote: The single "l" in installer might be a translation issue. Did you select another language then English when you noticed the "l"?
Yes, Croatian.
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
palimmo
Posts: 818
Joined: 19 Nov 2013 19:44
Contact:

Re: ISO testing 201701

Postby palimmo » 13 Jan 2017 21:44

Schoelje wrote:I've uploaded updated ISOs with most of palimmo's suggestions resolved. The download URLs are the same as mentioned in the OP.

@palimmo
Can you tell me with what applications you had those graphical (window) issues. I cannot find them. An image would also be of great help.
- unmaximized windows show always a strange dark sign on both sides right/left, exactly below the window title bar.
With all applications.
Here for example with Dolphin, straight after the live boot was completed
snapshot1.png
- window title bar has not always the same appearance. For example compare Dolphin and Software Manager.
snapshot2.png
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
Arjen Balfoort
Site Admin
Posts: 9313
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: ISO testing 201701

Postby Arjen Balfoort » 14 Jan 2017 10:32

I must be daft because I still don't see it.
Let's say it's by design then ;)


SolydXK needs you!
Development | Testing | Translations

SolydForEver
Posts: 342
Joined: 13 Oct 2014 05:25
Location: East part of The Netherlands

Re: ISO testing 201701

Postby SolydForEver » 14 Jan 2017 14:37

palimmo wrote:
- window title bar has not always the same appearance. For example compare Dolphin and Software Manager.
snapshot2.png
Do you mean that in Dolphin you see a toolbar and in software manager you see a menu?
Totally different programs, each with its own interface. As Schoelje wrote already: it's by design.

User avatar
bas_otten
Posts: 212
Joined: 19 Oct 2013 12:22
Location: Netherlands

Re: ISO testing 201701

Postby bas_otten » 14 Jan 2017 21:45

I just noticed that "yelp, the Help browser for Gnome" is installed by default in the RC ISO SoyldK 64. Is that a deliberate choice? I always try to keep this one off the KDE lane, but it has a tendency to pop up as 'recommendation' for all sorts of packages ;)

EDIT: I see it was in solydk_8_64_201606 as well - so not a big deal, merely a question..

behrami
Posts: 15
Joined: 13 Dec 2016 10:59

Re: ISO testing 201701

Postby behrami » 16 Jan 2017 12:39

Seems fun, I will also participate in the testing:)

User avatar
Arjen Balfoort
Site Admin
Posts: 9313
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: ISO testing 201701

Postby Arjen Balfoort » 20 Jan 2017 06:26

I've uploaded new ISOs here: http://downloads.solydxk.nl/nightly/
If we don't find anything unusual, these will be released next week.


SolydXK needs you!
Development | Testing | Translations

User avatar
grizzler
Posts: 2178
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: ISO testing 201701

Postby grizzler » 20 Jan 2017 17:34

Just a bit of a technical issue...

I recently needed to create another user and to my surprise the UID and GID didn't end up as 1001:1001 but 1001:1003. Turns out SolydX has two system groups in the wrong range: sambashare and lpadmin (1001 and 1002 respectively). These two must have been created manually, without the --system switch. They're OK on the SolydK ISO, by the way.

So I checked which files and directories actually have these group values and used this little script to fix things:

Code: Select all

#!/bin/bash

ScriptName=fixsysgroups
ScriptVersion=1.0.0
ScriptDate=2017-01-20

[ $EUID -eq 0 ] && SudoUser=$SUDO_USER || { echo "Please run this with sudo"; exit 1; }
[ "$SudoUser" ] || { echo "Unable to determine sudo user - aborted"; exit 2; }

echo "Checking for user $SudoUser on $HOSTNAME . . ."

L=$(cut -d: -f3 < <(getent group lpadmin))
S=$(cut -d: -f3 < <(getent group sambashare))

if [ "$L" -gt 999 ]; then
	echo "group lpadmin has non-system value ($L) - modifying . . ."
	ischroot || delgroup $SudoUser lpadmin
	delgroup lpadmin
	addgroup --system lpadmin
	ischroot || addgroup $SudoUser lpadmin
	[ -e /run/cups/certs ] && chown -cR :lpadmin /run/cups/certs
	[ -e /usr/share/ppd/custom ] && chown -c :lpadmin /usr/share/ppd/custom
	if [ -e /var/log/cups ]; then
		chown -c :lpadmin /var/log/cups
		find /var/log/cups -group $L -exec chown -c :lpadmin {} \;
	fi
	[ -e /var/spool/cups-pdf/ANONYMOUS ] && chown -c :lpadmin /var/spool/cups-pdf/ANONYMOUS
fi

if [ "$S" -gt 999 ]; then
	echo "group sambashare has non-system value ($S) - modifying . . ."
	ischroot || delgroup $SudoUser sambashare
	delgroup sambashare
	addgroup --system sambashare
	ischroot || addgroup $SudoUser sambashare
	[ -e /var/lib/samba/usershares ] && chown -c :sambashare /var/lib/samba/usershares
fi

if [ "$L" -gt 999 ] || [ "$S" -gt 999 ]; then
	ischroot || echo "log in again to update $SudoUser's group set"
else
	echo "lpadmin and sambashare do not have a non-system value"
fi
While I was at it, I also noticed the main ISOs had an odd UID and GID for www-data: 999:135 (SolydK) and 999:133 (SolydX) instead of the usual 33:33. They were OK on my own system and on the CE ISOs.
Oddly enough there's a (redundant) file /etc/group.org on both main ISOs which does have the correct group value for www-data.

Edit
Also added the script in a zip, because I seem to remember picking it up out of a code section adds a lot of spaces at the start of each line...

Edit 2
Forgot to mention: the file boot/live/filesystem.packages-remove on the ISOs has the line live-config-sysvinit twice.
Attachments
fixsysgroups.zip
(748 Bytes) Downloaded 46 times
Frank

SolydX EE 64 - tracking Debian Testing

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: ISO testing 201701

Postby Zill » 20 Jan 2017 18:16

grizzler wrote:I recently needed to create another user and to my surprise the UID and GID didn't end up as 1001:1001 but 1001:1003. Turns out SolydX has two system groups in the wrong range: sambashare and lpadmin (1001 and 1002 respectively).
FWIW, my SolydXK (stable) /etc/group/ dates back to December 2013 and this also has sambashare and lpadmin as 1001 and 1002 respectively!

I must admit that I noticed this before when I added users but thought nothing of it as I always set my GIDs manually (I like to use 100 so that I can easily share data). Maybe I should have flagged it up as a bug! :oops:

I can confirm that www-data has remained as 33:33 on my (stable) system throughout.


Return to “Testing Zone”

Who is online

Users browsing this forum: No registered users and 3 guests