Wireless issue using SolydK EE

SolydXK is too quiet for you? SolydXK Enthusiast Editions, based on Debian Testing is for you! Here you can find news about Debian Testing and Unstable too, and also tests on SolydXK programs.
The support for SolydXK EE is provided by the community.
User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Wireless issue using SolydK EE

Postby MAYBL8 » 16 Mar 2017 01:34

OK fellow testing people.
I have a problem.
I don't know much about this I will admit. Done some research but need some help.
I have been using my wired connection and all working fine.
I now want to use the wireless card in my system instead of the wired one.
I have been able to run some rfkill commands to get this to work but upon reboot it doesn't stay working.

My research has led me to this being the problem but I don't know how to solve it.

Code: Select all

root@solydk64ee ~ # rfkill list all
0: phy0: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
root@solydk64ee ~ # 
Here is some system info:

Code: Select all

root@solydk64ee ~ # inxi -F
System:    Host: solydk64ee Kernel: 4.9.0-2-amd64 x86_64 (64 bit) Desktop: N/A Distro: SolydXK
Machine:   Device: desktop System: Dell product: Inspiron 3650 v: X00 serial: 8F3KMD2
           Mobo: Dell model: 0C2XKD v: A01 serial: .8F3KMD2.CN7016369P02U8.
           UEFI [Legacy]: Dell v: 3.3.6 date: 09/30/2016
CPU:       Quad core Intel Core i7-6700 (-HT-MCP-) cache: 8192 KB 
           clock speeds: max: 4000 MHz 1: 899 MHz 2: 933 MHz 3: 900 MHz 4: 902 MHz 5: 897 MHz 6: 899 MHz
           7: 900 MHz 8: 899 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM]
           Display Server: X.org 1.19.2 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           tty size: 138x27 Advanced Data: N/A for root
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] Tobago HDMI Audio [Radeon R7 360 / R9 360 OEM]
           driver: snd_hda_intel
           Card-2 Intel Sunrise Point-H HD Audio driver: snd_hda_intel
           Card-3 Logitech Webcam C270 driver: USB Audio
           Sound: Advanced Linux Sound Architecture v: k4.9.0-2-amd64
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: 48:4d:7e:9f:4d:2f
           Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter driver: ath9k
           IF: wlp3s0 state: down mac: 90:cd:b6:50:f6:2d
           Card-3: Qualcomm Atheros
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 2000.4GB (10.5% used)
           ID-1: /dev/sda model: ST2000DM001 size: 2000.4GB
Partition: ID-1: / size: 59G used: 13G (23%) fs: ext4 dev: /dev/sda7
           ID-2: /home size: 1.3T used: 168G (15%) fs: ext4 dev: /dev/sda8
           ID-3: swap-1 size: 17.18GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 49.0
           Fan Speeds (in rpm): cpu: 814 fan-1: 829
Info:      Processes: 282 Uptime: 7 min Memory: 973.3/15994.9MB Client: Shell (bash) inxi: 2.3.5 

Code: Select all

oot@solydk64ee ~ # lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 046d:0825 Logitech, Inc. Webcam C270
Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 006: ID 0cf3:e005 Qualcomm Atheros Communications 
Bus 001 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@solydk64ee ~ # lspci
00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 07)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #5 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #6 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] (rev 81)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Tobago HDMI Audio [Radeon R7 360 / R9 360 OEM]
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
03:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

Code: Select all

root@solydk64ee ~ # iwconfig
wlp3s0    IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
lo        no wireless extensions.

enp2s0    no wireless extensions.

Code: Select all

root@solydk64ee ~ # cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
# Uncomment lines below if you do not want to use a network manager
auto enp2s0 
allow-hotplug enp2s0
iface enp2s0 inet dhcp
# address 192.168.1.110
# netmask 255.255.255.0
# gateway 192.168.1.1

auto wlp3s0
allow-hotplug wlp3s0
iface wlp3s0 inet dhcp
Let me know if you need anything else.


User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: Breakages and News tracking Debian Testing

Postby Zill » 16 Mar 2017 11:42

MAYBL8: I suggest you try editing your /etc/network/interfaces file by commenting out the three primary network interface lines so that the file is as follows:

Code: Select all

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
# Uncomment lines below if you do not want to use a network manager
# auto enp2s0
# allow-hotplug enp2s0
# iface enp2s0 inet dhcp
Then reboot and, assuming your are using the standard NetworkManager applet, configure this with your WiFi details.

In my experience, NetworkManager gets confused if both an ethernet and a wireless connection are both enabled so please ensure that only one interface is enabled at one time.

User avatar
san-claudio
Posts: 209
Joined: 28 Dec 2015 20:26
Location: Paris, France

Re: Breakages and News tracking Debian Testing

Postby san-claudio » 16 Mar 2017 12:56

Je suis sur SolydX EE 9 64 la dernière version du site installation récente de 15 jours et je n'ai pas le même descriptif ...

Code: Select all

san-claudio@solydxk ~ $ sudo iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
wwan0     no wireless extensions.

san-claudio@solydxk ~ $ cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
# Uncomment lines below if you do not want to use a network manager
#auto eth0
#allow-hotplug eth0
#iface eth0 inet dhcp
san-claudio@solydxk ~ $ 

User avatar
ilu
Posts: 2425
Joined: 09 Oct 2013 12:45

Re: Breakages and News tracking Debian Testing

Postby ilu » 16 Mar 2017 16:58

Maybl8 (in case you don't understand french): San-claudio says that he is on a recent (15 days old) install of SolydXEE and that his - working, I guess - configuration looks different. You might have a look.

User avatar
san-claudio
Posts: 209
Joined: 28 Dec 2015 20:26
Location: Paris, France

Re: Breakages and News tracking Debian Testing

Postby san-claudio » 16 Mar 2017 17:55

Mon installation est récente faite avec 'solydxee_9_64_201607.iso' j'avais pendant 1 an la version antérieure.

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Breakages and News tracking Debian Testing

Postby MAYBL8 » 17 Mar 2017 01:35

This is the only way I can get it to work.
I did as suggested but it didn't work.

Code: Select all

root@solydk64ee ~ # cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
# Uncomment lines below if you do not want to use a network manager
# auto enp2s0 
# allow-hotplug enp2s0
# iface enp2s0 inet dhcp

# address 192.168.1.110
# netmask 255.255.255.0
# gateway 192.168.1.1

auto wlp3s0
allow-hotplug wlp3s0
iface wlp3s0 inet dhcp
Somehow with the wired ethernet commented out in the interfaces file it still connected wired.
So I unplugged the ethernet cable and rebooted.
No internet.

So this is what i did

Code: Select all

root@solydk64ee ~ # rfkill list all
0: phy0: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
1: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
root@solydk64ee ~ # ip link set wlp3s0 up
RTNETLINK answers: Operation not possible due to RF-kill
root@solydk64ee ~ # rfkill unblock wifi
root@solydk64ee ~ # ip link set wlp3s0 up
Then went into wicd and connected to the wifi I have at my house.

When I reboot i have to do the same thing to get it to work.


User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: Breakages and News tracking Debian Testing

Postby Zill » 17 Mar 2017 10:32

MAYBL8 wrote:Then went into wicd and connected to the wifi I have at my house.
This may be what is complicating matters!

AIUI, Wicd is not installed by default with Debian jessie (or stretch). Instead, NetworkManager is the default connection manager.

These two managers are incompatible with each other and so only one should be installed.

IIRC, Wicd does still use the ethernet configuration settings in /etc/network/interfaces, whereas NetworkManager does not.

I suggest that, using a wired connection, you could try installing NetworkManager and then remove Wicd.

Reboot and configure NetworkManager for both Wired and Wireless connections, then enable each one in turn, ensuring that the other connection is disabled. Hopefully, this will clear the "soft block" problem and connect properly.

If this works, you can then experiment further with Wicd, after removing NetworkManager.

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Breakages and News tracking Debian Testing

Postby MAYBL8 » 17 Mar 2017 10:58

Ok Zill I am taking your advice.
However I haver installed network-manger and removed wicd.
I have the wired connection hooked up.
How do I configure the Network Manger?
There doesn't seem to be an icon for it in the menu anywhere.
The cli command network-manager doesn't work either.
This seems like a silly question but I have never needed to do this before.


User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: Breakages and News tracking Debian Testing

Postby Zill » 17 Mar 2017 11:05

MAYBL8: You need to install both network-manager and network-manager-gnome.

After a reboot, you should be able to right-click on the NM panel icon to edit connections. Little configuration should be required as the defaults are quite sane and an ethernet connection should work out-of-the-box.

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Breakages and News tracking Debian Testing

Postby MAYBL8 » 17 Mar 2017 11:32

I seem to have installed them but there is no nm panel icon. This is weird.
How do I open it from the terminal?

Code: Select all

dcihon@solydk64ee:~$ apt policy network-manager
network-manager:
  Installed: 1.6.2-1
  Candidate: 1.6.2-1
  Version table:
 *** 1.6.2-1 500
        500 http://httpredir.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status
dcihon@solydk64ee:~$ apt policy network-manager-gnome
network-manager-gnome:
  Installed: 1.4.4-1
  Candidate: 1.4.4-1
  Version table:
 *** 1.4.4-1 500
        500 http://httpredir.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status


User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: Breakages and News tracking Debian Testing

Postby Zill » 17 Mar 2017 15:37

MAYBL8: Sorry, but I am running out of road on this one...

I only run stable (jessie) here and so your problem could be related to testing (stretch). Alternatively, it could be a KDE/Plasma issue as, again, I use XFCE here.

Hopefully, someone else running SolydK EE should be able to advise further on this.

NM should automatically start at boot and so there should be no need to start the applet from the terminal. However, you should also have a menu entry entitled "Network Connections" which should start the NM editor. If you wish to start this from the terminal then the command is "nm-connection-editor".

If you have a (recent) SolydK ISO on USB or DVD then you could try booting a live session. As NM is the default SolydXK connection manager, you could then play around with it to see what it looks like and how it works.

User avatar
ilu
Posts: 2425
Joined: 09 Oct 2013 12:45

Re: Breakages and News tracking Debian Testing

Postby ilu » 17 Mar 2017 15:46

Zill: Are you really sure that NM and especially the gnome applet is the way to go under KDE plasma?
Also ArchWiki says
KDE Plasma
Install the plasma-nm package.
nm-applet
network-manager-applet is a GTK+ 3 front-end which works in all environments.
Ubuntuusers says "plasma-widget-networkmanagement".
There are also references to " KNetworkManager" and " KNetworkManager-Applet".
It seems that KDE also uses NM but needs a different frontend and configuration tool.

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: Breakages and News tracking Debian Testing

Postby Zill » 17 Mar 2017 15:56

ilu: A good point! I am not at all sure that NM and the Gnome applet is used with KDE/plasma but I believe it was the default NM for both SolydX and SolydK originally.

However, times change and maybe this is no longer the case. Unfortunately, I can't comment on nm-applet or plasma-nm.

Hopefully one of our KDE fans will help out with this one. ;-)

Edit: NM was not the first default connection manager! Way back in 2013 the default was, IIRC, Wicd. This was only replaced later when NM was found to be more suitable for mobile broadband.

User avatar
grizzler
Posts: 2140
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: Breakages and News tracking Debian Testing

Postby grizzler » 17 Mar 2017 16:44

Split off of the Breakages and News... thread.
Frank

SolydX EE 64 - tracking Debian Testing

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Wireless issue using SolydK EE

Postby MAYBL8 » 17 Mar 2017 18:03

Thanks guys for the help and I will look to get the plasma stuff installed when I get home.
Hope it will fix the issue.


User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Wireless issue using SolydK EE

Postby MAYBL8 » 18 Mar 2017 02:14

Got the plasma-nm installed but still no wireless.
I think it is a network card issue.
I have this one:
03:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

Back to the drawing board.
I think I need to see if there is a firmware driver for this card.


User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: Wireless issue using SolydK EE

Postby Zill » 18 Mar 2017 12:30

It seems to me that the ath9k driver is the correct one for your card (0cf3:e005).

I suggest that you open a terminal, maximise the window and then post the output of the following three commands:

Code: Select all

apt policy firmware-atheros
apt policy initramfs-tools
lsmod | grep ath
p.s. has this card ever worked reliably on this system?

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Wireless issue using SolydK EE

Postby MAYBL8 » 18 Mar 2017 14:56

Code: Select all

root@solydk64ee ~ # apt policy firmware-atheros
firmware-atheros:
  Installed: 20161130-2
  Candidate: 20161130-2
  Version table:
 *** 20161130-2 500
        500 http://httpredir.debian.org/debian testing/non-free amd64 Packages
        500 http://httpredir.debian.org/debian testing/non-free i386 Packages
        100 /var/lib/dpkg/status
root@solydk64ee ~ # apt policy initramfs-tools
initramfs-tools:
  Installed: 0.127
  Candidate: 0.127
  Version table:
 *** 0.127 500
        500 http://httpredir.debian.org/debian testing/main amd64 Packages
        500 http://httpredir.debian.org/debian testing/main i386 Packages
        100 /var/lib/dpkg/status
root@solydk64ee ~ # lsmod | grep ath
ath3k                  20480  0
ath9k                  94208  0
ath9k_common           32768  1 ath9k
ath9k_hw              446464  2 ath9k,ath9k_common
ath                    32768  3 ath9k_hw,ath9k,ath9k_common
mac80211              667648  1 ath9k
cfg80211              589824  4 mac80211,ath9k,ath,ath9k_common
bluetooth             552960  36 btrtl,hci_uart,btintel,btqca,bnep,btbcm,rfcomm,ath3k,btusb
usbcore               249856  9 uvcvideo,usbhid,snd_usb_audio,xhci_pci,snd_usbmidi_lib,rtsx_usb,ath3k,btusb,xhci_hcd
I have never tried to use the wireless on it before until now.
I got a new access point and wanted to try it out.

I still think this problem has to do with this but I don't know how to fix it:

Code: Select all

root@solydk64ee ~ # ip link set wlp3s0 up      
RTNETLINK answers: Operation not possible due to RF-kill


User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: Wireless issue using SolydK EE

Postby Zill » 18 Mar 2017 15:06

I am not sure how "ath3k" appears in the module list. Maybe you could try blacklisting this and see if it makes a difference. :?

Other than that, I don't think I can help much further with this. I don't run testing for a reason... ;)

User avatar
xendistar
Posts: 510
Joined: 08 Jun 2014 08:17
Location: Bournemouth, UK

Re: Wireless issue using SolydK EE

Postby xendistar » 18 Mar 2017 18:04

Just a wild left field question MayBL8, have you confirmed the AP is working ok with any other wireless device, sorry if you have confirmed this but I can't see anything to confirm it.


Return to “Testing Zone”

Who is online

Users browsing this forum: No registered users and 2 guests