Page 1 of 1

Apt update error

Posted: 03 Jun 2018 22:22
by xendistar
Tried to do and an update tonight and got the following error

Code: Select all

mit@prometheus:~$ sudo apt-get update && sudo apt-get dist-upgrade
[sudo] password for mit: 
Get:1 http://ftp.uk.debian.org/debian testing InRelease [143 kB]
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease                                  
Hit:3 http://dl.google.com/linux/chrome/deb stable Release                                    
Ign:4 https://repository.solydxk.nl solydxk-ee InRelease                                  
Err:5 https://repository.solydxk.nl solydxk-ee Release                             
  Certificate verification failed: The certificate is NOT trusted. The name in the certificate does not match the expected.  Could not handshake: Error in the certificate verification. [IP: 81.169.195.233 443]
Reading package lists... Done
E: The repository 'https://repository.solydxk.nl solydxk-ee Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
I did an update this morning as I was installing a new email client (to test) and I did an apt update then with out issue?

Tim

Re: Apt update error

Posted: 03 Jun 2018 23:27
by ScottQuier
I just got the same error message.

Patiently waiting for a bit help.

TAI

Re: Apt update error

Posted: 04 Jun 2018 05:17
by Arjen Balfoort
I'm having server problems for the subdomains of solydxk.nl and the only thing that's somehow working is a redirect to their solydxk.com equivalents. I've tested that in a live session by replacing repository.solydxk.com with repository.solydxk.nl in the sources.list file and that worked.

I don't know why you have repository errors but check your sources file with this reference: https://forums.solydxk.com/viewtopic.ph ... 29&p=14922

Re: Apt update error

Posted: 04 Jun 2018 05:57
by xendistar
I have now changed my source list to the following

Code: Select all

deb https://repository.solydxk.com/ solydxk-ee main upstream import
deb http://ftp.uk.debian.org/debian/ testing non-free contrib main
deb http://security.debian.org/ testing/updates main contrib non-free
This allowed me to do apt update and download some new updates with out any issues, does it look OK\correct?

NOTE: In the link Arjen posted

https://forums.solydxk.com/viewtopic.ph ... 29&p=14922

the link at the bottom of the first post to the EE source list

http://forums.solydxk.nl/viewtopic.php?f=78&t=5620

DOES NOT work due to the same certificate error

Re: Apt update error

Posted: 04 Jun 2018 10:40
by Arjen Balfoort
xendistar wrote:
04 Jun 2018 05:57
http://forums.solydxk.nl/viewtopic.php?f=78&t=5620

DOES NOT work due to the same certificate error
Hmmm, I'm correctly being forwarded to forums.solydxk.com. I think the certificate that was previously used is still being used by the browser. I've edited the link.

Re: Apt update error

Posted: 04 Jun 2018 16:02
by ScottQuier
I'll give it a go when I get home this evening - say around 2200 (GMT)

Re: Apt update error

Posted: 05 Jun 2018 21:34
by xendistar
All seems to be working OK now, been ok the last couple of nights when I have done an update, cheers Arjen

Re: Apt update error

Posted: 06 Jun 2018 05:33
by Arjen Balfoort