Thunderbird 60.3.1 (64-bit) doesn't open hyperlinks

SolydXK is too quiet for you? SolydXK Enthusiast Editions, based on Debian Testing is for you! Here you can find news about Debian Testing and Unstable too, and also tests on SolydXK programs.
The support for SolydXK EE is provided by the community.
User avatar
troypulk
Posts: 156
Joined: 20 Jul 2014 22:43
Location: Washington State, USA

Thunderbird 60.3.1 (64-bit) doesn't open hyperlinks

Postby troypulk » 01 Jan 2019 22:35

I have SolydX 10 EE (64-bit) and Thunderbird 60.3.1 (64-bit)

In Edit > Preferences > Attachments > HTML Document

None of the options are working Not even "Always Ask"

Opened Thunderbird in a console and clicked on a link but nothing reported in the console.

Switched my default browser around to different ones in the Xfce > Settings manger > Preferred Applications, none worked but this did work in another App like Thunar.

Just reporting

Thanks

User avatar
gsus
Posts: 12
Joined: 26 Mar 2018 15:15

Re: Thunderbird 60.3.1 (64-bit) doesn't open hyperlinks

Postby gsus » 08 Jan 2019 14:26

I have the same problem.
I can figure out how to resolve it

User avatar
gsus
Posts: 12
Joined: 26 Mar 2018 15:15

Re: Thunderbird 60.3.1 (64-bit) doesn't open hyperlinks

Postby gsus » 08 Jan 2019 16:28

I found the cause of the problem.

The problem is an apparmor profile for thunderbird, disabling the profile makes thunderbird works again!

https://bugs.debian.org/cgi-bin/bugrepo ... bug=883245

User avatar
troypulk
Posts: 156
Joined: 20 Jul 2014 22:43
Location: Washington State, USA

Re: Thunderbird 60.3.1 (64-bit) doesn't open hyperlinks

Postby troypulk » 09 Jan 2019 03:01

Okay,

Thank you it works now.

User avatar
ilu
Posts: 2490
Joined: 09 Oct 2013 12:45

Re: Thunderbird 60.3.1 (64-bit) doesn't open hyperlinks

Postby ilu » 09 Jan 2019 07:57

Deactivating the profile is probably not the best solution but we don't have the resources to fix this problem. We'll have to wait for debian to work out a solution. To help getting there please have a look at https://wiki.debian.org/AppArmor/Reportbug and provide the output of

Code: Select all

sudo journalctl -kaf --no-hostname | grep -w 'apparmor="DENIED"'
-kaf means "kernel all follow" so the command will wait for new messages until you press ctrl-c.

But, since since this just came up following a rather big data leakage in my country: We never click on links in emails - NEVER EVER !! Really, NEVER !!! We always enter them into the browser by hand. If really neccessary - because the session codes in the link are important, usually to confirm that we registered somewhere - we carefully copy and paste. So in my opinion - and the really knowledgable security guys agree - the apparmor profile stopping you from clicking on links is perfectly correct.

User avatar
gsus
Posts: 12
Joined: 26 Mar 2018 15:15

Re: Thunderbird 60.3.1 (64-bit) doesn't open hyperlinks

Postby gsus » 09 Jan 2019 13:23

ilu wrote:
09 Jan 2019 07:57
Deactivating the profile is probably not the best solution but we don't have the resources to fix this problem. We'll have to wait for debian to work out a solution. To help getting there please have a look at https://wiki.debian.org/AppArmor/Reportbug and provide the output of

Code: Select all

sudo journalctl -kaf --no-hostname | grep -w 'apparmor="DENIED"'
-kaf means "kernel all follow" so the command will wait for new messages until you press ctrl-c.

But, since since this just came up following a rather big data leakage in my country: We never click on links in emails - NEVER EVER !! Really, NEVER !!! We always enter them into the browser by hand. If really neccessary - because the session codes in the link are important, usually to confirm that we registered somewhere - we carefully copy and paste. So in my opinion - and the really knowledgable security guys agree - the apparmor profile stopping you from clicking on links is perfectly correct.
You are right about of links in emails, but IMHO this must be a security option in thunderbird.

But the problem is that for the normal user (me) if a program(thunderbird) not work I thinks that the problem was in the program(thunderbird) so I reinstalled thunderbird, remove config, copy profile from another working thunderbird, execute in verbose mode, google it, search in the forums, etc.

So I gave up few months ago... until I had a little time in work and remember that my work machine (Linux Mint 19) thunderbird works.
So I so the search again and get this bug and then the debian bug.

I never think that apparmor maybe the problem, now I know.

So my mood now is: kill em all apparmor's policies!!. But I know that is not the best solution.

A year ago I try fedora and in the default installation exist a "SELinux troubleshoter" icon tray that inform to the user "Hey! SELinux block access XXX in process YYY, and is not defined any policy, is this rigth?"

with similar tool the normal user can provide info to package maintainers to polish the apparmor policys.

User avatar
Arjen Balfoort
Site Admin
Posts: 9279
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Thunderbird 60.3.1 (64-bit) doesn't open hyperlinks

Postby Arjen Balfoort » 06 Sep 2019 14:25

I know that this is an old thread, but this has become a personal issue for me since I upgraded to buster.

The following worked for me.

Disable apparmor for Thunderbird:

Code: Select all

sudo ln -s /etc/apparmor.d/usr.bin.thunderbird /etc/apparmor.d/disable/
sudo  apparmor_parser -R /etc/apparmor.d/usr.bin.thunderbird
And add these lines to my thunderbird prefs.js file:

Code: Select all

user_pref("network.protocol-handler.warn-external.http", true);
user_pref("network.protocol-handler.warn-external.https", true);
I could add this to the thunderbird-solydxk-adjustments package, but the question is: should I?


SolydXK needs you!
Development | Testing | Translations

User avatar
ilu
Posts: 2490
Joined: 09 Oct 2013 12:45

Re: Thunderbird 60.3.1 (64-bit) doesn't open hyperlinks

Postby ilu » 06 Sep 2019 15:32

If it includes deactivating apparmor: No. Opening hyperlinks from emails by clicking them is inherently dangerous behavior IMHO. People who insist on doing so should configure that manually.

User avatar
troypulk
Posts: 156
Joined: 20 Jul 2014 22:43
Location: Washington State, USA

Re: Thunderbird 60.3.1 (64-bit) doesn't open hyperlinks

Postby troypulk » 07 Sep 2019 03:14

What does apparmor do?

How important is this app and what else can do it's job?

Thanks

User avatar
Arjen Balfoort
Site Admin
Posts: 9279
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Thunderbird 60.3.1 (64-bit) doesn't open hyperlinks

Postby Arjen Balfoort » 08 Sep 2019 08:33

Wiki:
AppArmor ("Application Armor") is a Linux kernel security module that allows the system administrator to restrict programs' capabilities with per-program profiles. Profiles can allow capabilities like network access, raw socket access, and the permission to read, write, or execute files on matching paths. AppArmor supplements the traditional Unix discretionary access control (DAC) model by providing mandatory access control (MAC). It has been included in the mainline Linux kernel since version 2.6.36 and its development has been supported by Canonical since 2009.
https://en.wikipedia.org/wiki/AppArmor

So yes, it is important, but as you can see it is inconvenient in some cases.


SolydXK needs you!
Development | Testing | Translations

User avatar
Arjen Balfoort
Site Admin
Posts: 9279
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Thunderbird 60.3.1 (64-bit) doesn't open hyperlinks

Postby Arjen Balfoort » 08 Sep 2019 10:20

ilu wrote:
06 Sep 2019 15:32
If it includes deactivating apparmor: No. Opening hyperlinks from emails by clicking them is inherently dangerous behavior IMHO. People who insist on doing so should configure that manually.
I can provide a script with thunderbird-solydxk-adjustments that users can run to enable hyperlinks in Thunderbird if they like.

thunderbird-enable-hyperlinks

Code: Select all

#!/bin/bash

# Enable hyperlinks in Thunderbird

if [ ! -e "$HOME/.thunderbird" ]; then
    echo "Please run Thunderbird once to create your profile directory $HOME/.thunderbird"
    exit 1
fi

if [ ! -z "$(pidof thunderbird)" ]; then
   echo 'Please, close Thunderbird before you continue.'
   exit 2
fi

# Disable apparmor for Thunderbird
AAPROFILE='/etc/apparmor.d/usr.bin.thunderbird'
if [ -e $AAPROFILE ]; then
    sudo ln -s $AAPROFILE /etc/apparmor.d/disable/ 2>/dev/null
    sudo apparmor_parser -R $AAPROFILE 2>/dev/null
fi
for F in $(find $HOME/.thunderbird -name "prefs.js"); do
    echo "user_pref(\"network.protocol-handler.warn-external.http\", true);" >> "$F"
    echo "user_pref(\"network.protocol-handler.warn-external.https\", true);" >> "$F"
done

echo 'You can now start Thunderbird.'
exit 0


SolydXK needs you!
Development | Testing | Translations


Return to “Testing Zone”

Who is online

Users browsing this forum: patzy and 3 guests