Page 2 of 2

Re: problem with gdebi (SolydX, ee)

Posted: 24 May 2019 17:26
by Arjen Balfoort
Just for the heck of it I installed PCMan...no problem with GDebi.

Perhaps we should think of an alternative for Thunar?

Re: problem with gdebi (SolydX, ee)

Posted: 25 May 2019 09:06
by Arjen Balfoort
I created a SolydX 10 ISO and replaced Thunar with PCManfm. Suddenly, GDebi refused to work in PCManfm as well :o !
But....it gave a better output in terminal:
gdebi-gtk: error: no such option: --non-interactive /home/solydxk/usb-creator_0.6.1_all.deb

In /usr/bin/gdebi-gtk the optparse object is used to parse arguments to the application, but this is what the optparse reference said:
Deprecated since version 3.2: The optparse module is deprecated and will not be developed further; development will continue with the argparse module.
argparse is what I use in my applications. So, rewriting the code should be easy.

I'll upload the updated packages and post back here when I'm done.

Re: problem with gdebi (SolydX, ee)

Posted: 25 May 2019 09:40
by amnesix
Thank you ! :)

Re: problem with gdebi (SolydX, ee)

Posted: 25 May 2019 09:51
by amnesix
PCmanFM misses what makes Thunar fantastic : bulk rename.

Re: problem with gdebi (SolydX, ee)

Posted: 25 May 2019 15:53
by Arjen Balfoort
I've uploaded the adapte gdebi and gdebi-core packages to the solydxk-10 (solydxk-ee) repository.

B.t.w.: the gdebi project is not officially orphaned: https://wnpp.debian.net/

Sources: https://github.com/SolydXK/gdebi

Re: problem with gdebi (SolydX, ee)

Posted: 25 May 2019 16:42
by amnesix
Wonderful : it works ! Thank you !

Re: problem with gdebi (SolydX, ee) [SOLVED]

Posted: 26 May 2019 12:06
by amnesix
Little question : this morning, as I booted my machine, I was prompted by «/usr/bin/env» for my root password. Never happened before. Could it be linked with the new gdebi packages ?

Re: problem with gdebi (SolydX, ee) [SOLVED]

Posted: 26 May 2019 16:05
by Arjen Balfoort
No, nothing to do with this issue, it is a fix I implemented for pkexec.

This is why you can use gdebi from Thunar and also why you can run commands like:

Code: Select all

pkexec mousepad
or any other program.

You can find a simple explanation on the "why" here: https://askubuntu.com/questions/287845/ ... ure-pkexec

Re: problem with gdebi (SolydX, ee)

Posted: 27 May 2019 20:23
by grizzler
Arjen Balfoort wrote:
25 May 2019 15:53
I've uploaded the adapte gdebi and gdebi-core packages to the solydxk-10 (solydxk-ee) repository.
You should never increase the upstream version number of a package if you create a local derivative. Doing so effectively blocks any possible 'real' incarnation of that version.
While there's little chance of a gdebi 0.9.5.8 appearing any time soon, you can't be sure it will never be built.

Re: problem with gdebi (SolydX, ee) [SOLVED]

Posted: 28 May 2019 09:43
by Arjen Balfoort
I don't know what I was thinking.

You can downgrade the version number to 0.9.5.7+nmu3xk1 with:

Code: Select all

apt update
apt install gdebi=0.9.5.7+nmu3xk1 gdebi-core=0.9.5.7+nmu3xk1

Re: problem with gdebi (SolydX, ee) [SOLVED]

Posted: 07 Jun 2019 21:40
by ilu
I just discovered this site http://deriv.debian.net/patches/g/gdebi/. Did you know about it? Neat.

Re: problem with gdebi (SolydX, ee) [SOLVED]

Posted: 07 Jun 2019 22:09
by Arjen Balfoort
No, I didn't!
There's somebody with a lot of time for tracking all these patches :o