it is a «ee» problem or a pulseaudio problem ?

SolydXK is too quiet for you? SolydXK Enthusiast Editions, based on Debian Testing is for you! Here you can find news about Debian Testing and Unstable too, and also tests on SolydXK programs.
The support for SolydXK EE is provided by the community.
User avatar
amnesix
Posts: 176
Joined: 09 Nov 2013 12:46
Location: Berlin
Contact:

it is a «ee» problem or a pulseaudio problem ?

Postby amnesix » 10 Jun 2019 09:13

For years, I've had sound control through my keyboard, with such commands with «pactl set-sink-volume 0 -5%», «pactl set-sink-volume 0 +5%», «pactl set-sink-volume 0 toggle», and «quodlibet --play-pause», which I had, through xfce4-keyboard-settings, associated with the XF86AUDIO (lowervolume, raisevolume, mute and play) designed keys of my keyboard.

Then it all stopped to work after I installed ee on a new machine.

first, I could reassign the pactl commands on *other* keys. Same on my reserve keyboard. Then it just stopped to work.

I've trying something : since the pactl commands were associated with a «volume 0», I've tried with a «volume 1», and I had success, but only a partial success. See :

Code: Select all

$ pactl set-sink-volume 1 -5%
This did what it should do : it lowered the volume

BUT, just a second later :

Code: Select all

$ pactl set-sink-volume 1 toggle
Invalid volume specification
Of course, no effect there.

The maybe most surprising, is the quodlibet --play-pause command : it works, but *not* when I assign it the the XF86AUDIO Play key. I can use ShiftF1, for instance. And that on my two different keyboards.

This is no showstopper, but is is puzzling.

Return to “Testing Zone”

Who is online

Users browsing this forum: Bing [Bot] and 9 guests