User management doesn't work

Post your bugs here.
Getca
Posts: 4
Joined: 30 Mar 2014 07:56

User management doesn't work

Postby Getca » 24 Apr 2014 09:02

Hi, it happened after the latest updates. In terminal the system get something missing. The output after sudo /usr/bin/usermanager is:

Code: Select all

(usermanager.py:5176): Gtk-CRITICAL **: gtk_radio_button_set_group: assertion '!g_slist_find (group, radio_button)' failed

(usermanager.py:5176): Gtk-CRITICAL **: gtk_radio_button_set_group: assertion '!g_slist_find (group, radio_button)' failed

(usermanager.py:5176): Gtk-CRITICAL **: gtk_cell_view_set_displayed_row: assertion 'GTK_IS_TREE_MODEL (cell_view->priv->model)' failed
Traceback (most recent call last):
  File "/usr/lib/usermanager/usermanager.py", line 684, in <module>
    gui = UserManager()
  File "/usr/lib/usermanager/usermanager.py", line 179, in __init__
    self.refreshData()
  File "/usr/lib/usermanager/usermanager.py", line 658, in refreshData
    self.getUsers()
  File "/usr/lib/usermanager/usermanager.py", line 455, in getUsers
    self.usersInfo = self.usr.getAllUsersInfoDict()
  File "/usr/lib/usermanager/user.py", line 87, in getAllUsersInfoDict
    users.append({ 'user': p, 'groups': self.getUserGroups(p.pw_name), 'prgrp': self.getUserPrimaryGroupName(p.pw_name), 'pwd': self.getUserPasswordInfoDict(p.pw_name), 'face': self.getUserFacePath(p.pw_name) })
  File "/usr/lib/usermanager/user.py", line 179, in getUserFacePath
    copy(face, join(homeDir, ".face"))
  File "/usr/lib/python3.3/shutil.py", line 227, in copy
    copyfile(src, dst, follow_symlinks=follow_symlinks)
  File "/usr/lib/python3.3/shutil.py", line 110, in copyfile
    with open(dst, 'wb') as fdst:
NotADirectoryError: [Errno 20] Not a directory: '/dev/null/.face'
Regards !

crborga
Posts: 37
Joined: 22 Apr 2014 23:58
Location: Atlantic, Va

Re: User management doesn't work

Postby crborga » 28 Apr 2014 23:50

try running these commands

Code: Select all

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get upgrade
sudo apt-get dist-upgrade

Getca
Posts: 4
Joined: 30 Mar 2014 07:56

Re: User management doesn't work

Postby Getca » 29 Apr 2014 18:53

Still not working, sorry. It isn't so important, but yet...

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: User management doesn't work

Postby zerozero » 30 Apr 2014 00:02

[moved to a more suitable place]
bliss of ignorance

User avatar
Arjen Balfoort
Site Admin
Posts: 9518
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: User management doesn't work

Postby Arjen Balfoort » 30 Apr 2014 09:18

Somehow python cannot resolve your home directory.
Did you run usermanager as su (just guessing, because I have no clue)?

I've made a slight adjustment to the code to check for a real /home directory, and uploaded it to our testing repository.
You can also download the deb here: http://packages.solydxk.nl/testing/pool ... ermanager/


SolydXK needs you!
Development | Testing | Translations

Getca
Posts: 4
Joined: 30 Mar 2014 07:56

Re: User management doesn't work

Postby Getca » 01 May 2014 17:03

Hi, sorry for the wrong place of my post and thank You for its moving.
Schoelje wrote: You can also download the deb here: http://packages.solydxk.nl/testing/pool ... ermanager/
I downloaded usermanager 0.6.5 from the link and yes, it works.
Thank You !
Regards !

User avatar
arizon
Posts: 25
Joined: 05 Dec 2013 21:05
Location: Serbia

Re: User management doesn't work

Postby arizon » 21 Jul 2014 07:01

I've installed new 201407 ISO of SolydK and in System Settings under System Administration when starting User Management I get everytime:
Screenshot_1.jpg
Screenshot_1.jpg (51.65 KiB) Viewed 3252 times
I google it but I couldn't find any solution.
Any solution?
Image

User avatar
Arjen Balfoort
Site Admin
Posts: 9518
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: User management doesn't work

Postby Arjen Balfoort » 21 Jul 2014 09:13

This was mentioned in the information page in the update manager, and the opening post of the UP topic:

In SolydK, userconfig has been replaced by kuser:

Code: Select all

sudo apt-get purge userconfig; sudo apt-get install kuser


SolydXK needs you!
Development | Testing | Translations

User avatar
arizon
Posts: 25
Joined: 05 Dec 2013 21:05
Location: Serbia

Re: User management doesn't work

Postby arizon » 21 Jul 2014 15:59

Works!
Thank you.
Image

User avatar
Orbmiser
Posts: 829
Joined: 24 Aug 2013 22:58
Location: Portland,Oregon

Re: User management doesn't work

Postby Orbmiser » 21 Jul 2014 19:43

Schoelje wrote:This was mentioned in the information page in the update manager, and the opening post of the UP topic:

In SolydK, userconfig has been replaced by kuser:

Code: Select all

sudo apt-get purge userconfig; sudo apt-get install kuser
Hmmm mine is showing installed by no entry in System Admin pane of System Settings.
Admin Panel.jpeg
Admin Panel.jpeg (13.74 KiB) Viewed 3229 times
Just noticed it isn't there. Is this normal?
.
Portfolio
http://500px.com/Orbmiser
Flickr
http://www.flickr.com/photos/orb9220/

SolydK - Kernel 3.16-2-amd64 - KDE 4.14.1 Update Pack: 2014.10.15

User avatar
arizon
Posts: 25
Joined: 05 Dec 2013 21:05
Location: Serbia

Re: User management doesn't work

Postby arizon » 21 Jul 2014 19:55

Yes, it is normal.
You can find it in start menu in installed software.
Image

User avatar
Orbmiser
Posts: 829
Joined: 24 Aug 2013 22:58
Location: Portland,Oregon

Re: User management doesn't work

Postby Orbmiser » 21 Jul 2014 20:31

arizon wrote:Yes, it is normal.
You can find it in start menu in installed software.
Ahhh I see it use to be users manager in system setttings but was separate app that did not integrated into KDE well at all.
.
Portfolio
http://500px.com/Orbmiser
Flickr
http://www.flickr.com/photos/orb9220/

SolydK - Kernel 3.16-2-amd64 - KDE 4.14.1 Update Pack: 2014.10.15

User avatar
Grof
Posts: 32
Joined: 17 May 2013 08:08
Location: Croatia
Contact:

Re: User management doesn't work

Postby Grof » 23 Aug 2014 12:25

Hmmm, and why exactly userconfig KCModule doesn't work?
I prefer KCModules more than stand alone applications for system settings.


Return to “Bug Control”

Who is online

Users browsing this forum: No registered users and 9 guests