Page 1 of 1

[SOLVED] [drm] stuck on render ring

Posted: 11 May 2014 06:50
by dali
I have an Intel i5 3570K with Intel HD4000 graphics running SolydK Home Edition.

Sometimes (quite frequently) the graphics freezes for a few seconds and this is logged in dmesg:

[ 1170.927250] [drm] stuck on render ring
[ 1170.927253] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 1170.927253] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 1170.927254] [drm] Please file a _new_ bug report on against DRI -> DRM/Intel
[ 1170.927255] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 1170.927255] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 1170.929712] [drm:i915_set_reset_status] *ERROR* render ring hung inside bo (0x4b0a000 ctx 1) at 0x4b0b41c

The above hang occurred while I wrote this bug report. :)

The good news is that I've recently had the same issue in Debian Jessie (dual boot on the same computer) and it was resolved a few weeks ago, the next Update Pack should take care of it. I report this in case someone else has the same issue.


Re: [drm] stuck on render ring

Posted: 02 Jul 2014 08:07
by dali
As expected, this issue is solved by the 2014.07.15 update pack (currently in testing).

Re: [drm] stuck on render ring

Posted: 02 Jul 2014 10:17
by Arjen Balfoort
I love it when issues get solved by themselves! ;)
Could you put "[SOLVED]" in the subject of the opening post (OP)?

Re: [SOLVED] [drm] stuck on render ring

Posted: 02 Jul 2014 19:13
by dali
Yep, fixed. :)