[solved] (SolydXee) NumLock Setting Not Honored

Post your bugs here.
xfce
Posts: 14
Joined: 22 Jan 2019 02:53

[solved] (SolydXee) NumLock Setting Not Honored

Postby xfce » 22 Jan 2019 03:04

Bug: (SolydXee) NumLock Setting Not Honored -- 01.21.2019
-----------------------------------------------------------------------------------------
-- BIOS setting is not honored.
-- Settings > Keyboard > Behavior > General "Restore num lock state on startup" is not honored.

Following the "xfce" instructions in the 1st link provided by Arjen below:
-- https://wiki.archlinux.org/index.php/Ac ... ootup#Xfce


The NEW /home/$USER/.config/xfce4/xfconf/xfce-perchannel-xml/keyboards.xml works PERFECTLY!!

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>

<channel name="keyboards" version="1.0">
  <property name="Default" type="empty">
    <property name="Numlock" type="bool" value="true"/>
    <property name="RestoreNumlock" type="bool" value="true"/>
  </property>
</channel>
Thank you very much for your assistance in resolving this issue!!

User avatar
ilu
Posts: 2477
Joined: 09 Oct 2013 12:45

Re: Bug: (SolydXee) NumLock Setting Not Honored -- 01.21.2019

Postby ilu » 22 Jan 2019 15:56

SolydX1901 seems to have the same problem. I'll have to check with the BIOS settings again though - but I clearly remember having set those to "numlock".


xfce
Posts: 14
Joined: 22 Jan 2019 02:53

Re: RESOLVED -- Bug: (SolydXee) NumLock Setting Not Honored -- 01.21.2019

Postby xfce » 22 Jan 2019 20:40

updated: 01.22.2019
Image

User avatar
Arjen Balfoort
Site Admin
Posts: 9258
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: RESOLVED -- Bug: (SolydXee) NumLock Setting Not Honored -- 01.21.2019

Postby Arjen Balfoort » 23 Jan 2019 06:45

I assume the "numlockx on" did solve this issue?
I need to implement that in our ISOs.

[EDIT]
I see now. You edited your OP.


SolydXK needs you!
Development | Testing | Translations

xfce
Posts: 14
Joined: 22 Jan 2019 02:53

Re: RESOLVED -- Bug: (SolydXee) NumLock Setting Not Honored -- 01.21.2019

Postby xfce » 23 Jan 2019 15:02

Ah I was just updating the message . . . Somewhere in my travels, I believe "numlockx" was depreciated and removed from the repositories.

As an aside . . . I performed a new bare-metal install of SolydXee (solydxee_10_64_201812.iso) and subsequent updates returns normal numlock operation through a quick tweek:

Settings Manager > Settings Editor > Channel > keyboards

Right Click "Numlock" under Property and Edit . . . change the "Value" to TRUE and save.

Screenshot_2019-01-23_08-01-18.png
Screenshot_2019-01-23_08-01-18.png (47.03 KiB) Viewed 564 times

It updates the keybaord.xml thus:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>

<channel name="keyboards" version="1.0">
  <property name="Default" type="empty">
    <property name="Numlock" type="bool" value="true"/>
  </property>
</channel>
Numlock is working for me and seems to be persistent through reboots.
Image


Return to “Bug Control”

Who is online

Users browsing this forum: No registered users and 2 guests