Update errors on SolydX

Post your bugs here.
User avatar
ilu
Posts: 2420
Joined: 09 Oct 2013 12:45

Update errors on SolydX

Postby ilu » 22 Jan 2019 15:41

Code: Select all

E: https://repository.solydxk.com solydxk-9/main amd64 solydxk-system all 3.1.7 is not (yet) available (404  Not Found)
E: https://repository.solydxk.com solydxk-9/main i386 solydxk-system all 3.1.7 is not (yet) available (404  Not Found)
It seems that the updater doesn't run apt update first before trying to update. It just takes the (too) old results and then fails if a package has (again) been updated. I'm seeing different types of errors on different machines though. Does anybody else see update errors on SolydX?

User avatar
Arjen Balfoort
Site Admin
Posts: 9219
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Update errors on SolydX

Postby Arjen Balfoort » 23 Jan 2019 12:48

This is because gpk-update-viewer is run as user and you need root privileges to update the apt cache. Also, running gpk-update-viewer as root just crashes.

I created a workaround for this by diverting gpk-update-viewer and creating a bash script that runs the update before starting the diverted gpk-update-viewer. I don't like it that much but it's the only thing I could think about:

Code: Select all

#!/bin/sh

FLE='/usr/bin/gpk-update-viewer'
dpkg-divert --add --rename --divert $FLE.divert $FLE
echo '#!/bin/sh
pkexec apt-get update
gpk-update-viewer.divert
' > $FLE
chmod +x $FLE


SolydXK needs you!
Development | Testing | Translations


Return to “Bug Control”

Who is online

Users browsing this forum: No registered users and 2 guests