[Solved] How to change MAC and mobile surfstick

Questions about networking.
In the Original Post please also include the output of inxi -FNzxx
hirdel
Posts: 10
Joined: 27 Sep 2013 17:36

[Solved] How to change MAC and mobile surfstick

Postby hirdel » 01 Oct 2013 15:09

hello all

change the MAC

for some reason (MAC-security for web access) I should change the MAC of a machine.
I ve downloaded newest ISO 2013/09 and done what found in another topic:

... sudo mousepad /etc/NetworkManager/NetworkManager.conf
change the line ... managed=false .. to .. managed=true
Save, stop and start network manager with ... sudo service network-manager restart

(this isue is marked as solved, but still appears in newest iso)

After that you see in network-manager-gui its connected to ethernet - ifupdown (eth0)
for unknown reasons there is no change of mac in the connection which was automatically created = ifupdown

create a new connection for ethernet, there the MAC could be changed.

but after reboot you get lucky or not - when connect with your new connection you get success
when connect with old connection - ifupdown, same time you can switch to new connection and some time not

to make things better, just do

.. sudo mousepad /etc/network/interfaces

Remove everything but (or put a # in front of the line)

auto lo
iface lo inet loopback

after that do

.. sudo mousepad /etc/NetworkManager/nm-system-settings.conf

set

[ifupdown]
managed=false

Restart computer or NetworkManager service ... sudo service network-manager restart

now after reboot ifupdown is removed and you only have the connection you create with spoofed MAC which connect automatically

........................
Surfstick

my mobile surfstick was not recognized - huawei e173
so i installed "modemmanager" and "usb-modesmitch" manually - that solved the problem

(in another thread this is also marked as solved - maybe in iso to come?)

hope that helps ...

hirdel
Posts: 10
Joined: 27 Sep 2013 17:36

Re: [Solved] How to change MAC and mobile surfstick

Postby hirdel » 07 Feb 2014 07:01

have checked it out - in the new iso 2014/01 both is solved by default.
I am very pleased. Thanks a lot !!


Return to “Networking”

Who is online

Users browsing this forum: No registered users and 3 guests