Page 1 of 1

SAMBA Question

Posted: 17 Jul 2014 15:45
by freecicero
I come to SolydX from a background with PCLINUXOS. I am having a devil of a time getting my samba setup to resolve my other computers (some of them windows) in my office. Earlier this year I saw a post on the PCLINUX forum which said this:
Quick background on me, Linux hobbyist, burned out programmer, Novell guy that, 10 years ago got sick for a year, lost my company, and now work as the on-site guy for a national Geek company. not "squad" I get customer getting systems upgrades or Dead HDD’s that they want me to haul off their old equipment. So I play with Linux on the old systems, as a hobby not for a living. Doing this for 10 years or so. At the start of 2014, I stated getting a lot of old xp system, and down loaded my favorite Linux distro's and started installing...... Could not see Shared xp, win 7 systems. Thought it was just a bug with that release and tried another distro. Same problem, one after another, same problem. Would check boards and try lots of things and get it to work. But over and over on a fresh install, it would not see windows shares. Never had this problem before. Remember this is a hobby, but after 2 months I discovered the problem , small changes to smb.conf where made in the last 6 to 12 months that made it so you can't see XP, win 7 Shares “out of the box”. I think this was deliberate by “they who can not be named” that is if you don't want to get sued. This was done in prep for the upcoming deadline. So that first time Linux installers would install a Linux, not see other systems at home and give up on Linux.

Please change the Samba Default to see win shares.
Netbios section
Dns proxy = yes;
Set the “name resolve order” remove “;” by default and set order, I believe is “bcast host lmhost wins”.
Any other changes please make as needed.
Can you tell me whether you believe this to be correct? I think in am seeing that my Solydx samba.conf file is set to dns proxy "no", and I wonder if that is my issue. If it is, then this might help others so I wanted to post this here for that reason and perhaps this could be looked into for future Solydxk updates.


Re: SAMBA Question

Posted: 17 Jul 2014 18:51
by _q_
i dont know if that will fix it, but it sounds plausable... and if i was having the issues you are having, i would sure give it a go :D

the tinfoil hat theory though loses me a bit :twisted:

Re: SAMBA Question

Posted: 17 Jul 2014 19:29
by freecicero
It SOUNDS logical, but I am still running into a problem.

I am not able to get my solydx system to ping or "see" the other computer I am trying to mount

I can ping it by IP address, but I can't ping by the "name" that is assigned to it on the network.

I've been fiddling with these settings and still cannot get it correct, as when i type mount -a as root I get the response

"Could not resolve the address for [mycomputer]: Unknown error"

I can navigate to it by clicking the dolphin Network/SambaShares/ icons in dolphin, and indeed in that screen it shows up under the correct computer name. When I try to ping the same name from terminal, however, I get the "could not resolve" error.

I really don't want to hard code the IP addresss into FSTAB, as I am sure that the IP address will change at some point and I don't want to have to reset all my computers.

Can anyone advise anything to try?


Re: SAMBA Question

Posted: 17 Jul 2014 19:59
by freecicero
It seems clear to me after further work that I simply cannot resolve any computer name using DNS. I can ping IP addresses all day long, but when I use the associated name I get nothing but cannot resolve.

I have no clue how to get that working. Any suggestions?

I might as well post my stream of consciousness.

OK i finally gave in and added the IP address and name I wanted to reach to the etc/hosts file. So my fstab entry works and all is well FOR NOW.

But does that not mean that any day that I have a power failure and reset my network so that new IP addresses are handed out, I will have to reset my hosts file? I don't recall windows working that way - I must be missing something....

Re: SAMBA Question

Posted: 18 Jul 2014 01:44
by freecicero
Just in case my angst helps someone else, let me post what I think I have decided to do. I did not realize that my router would allow me to "hard map" IP addresses to particular MAC addresses. I hope that means that in future power failures and power cycles, then the same IP will be restored to each machine. That lessens my concern that I am wasting time by hard-coding in the IP addresses into the hosts file. Hopefully that will work.

Re: SAMBA Question

Posted: 18 Jul 2014 03:58
by Deleted User 2763
have you tried hostname.local?
Unless you have a domain assigned in your intranet, a router usually looks for .local before sending it out to some name service.

Re: SAMBA Question

Posted: 18 Jul 2014 15:08
by mhwelsh
Completely uneducated input.

I run on fixed ip's and I can add local names and addresses to /etc/hosts.

It may not be necessary and the systems may consider it unnecessary but I always put addresses on envelopes.

martin welsh

Re: SAMBA Question

Posted: 18 Jul 2014 15:13
by Deleted User 2763
If you are running fixed ip addresses then that's one way to do it. You just have to copy around the host table to the different machines.

Re: SAMBA Question

Posted: 28 Jul 2016 02:56
by Scott_CA
A quick 2 cent comment, since this thread is 2 years old.

I have current 2016 versions of X and K on the same dual-boot machine. SolydK refused to recognize or connect to a Win8.1 machine using the Windows computer name, but using the IP address, no problem. DHCP addresses are going to be a problem from time to time. X, on the other hand, connected immediately using the name--no IP address needed.

On Win10, my understanding is that Samba is broken, (unless it has been fixed recently) and has been since Nov 2015. There are long threads on Windows forums ( about the problem. I test my Win10 machine using exactly the same commands that work with 8.1, and to date it does not work. The problem is similar to others submitted here-- if it connects at all, some files show, some don't, and then it stops altogether.

It is a really, really complicated issue with multiple possible problems.

Re: SAMBA Question

Posted: 28 Jul 2016 14:23
by ilu
I really don't think the OP will ever come back to this thread - you are digging around a graveyard here. :roll:

The info about Win10 and smb is good to have though, and also the different behaviour of X and K could inspire someone to investigate further. Just don't be afraid to open a new thread in the future.

Re: SAMBA Question

Posted: 13 Aug 2016 15:22
by freecicero
Ha! I DID return! ;-) And yep, I have been able to resolve my samba issues on this and other distributions by making sure my etc/hosts file did not contain hard-coded addresses (which I had attempted to add in an earlier effort to make it work).

As long as my host file consists only of: localhost

all has been well.

Re: SAMBA Question

Posted: 14 Aug 2016 18:34
by ilu
Huh, you got me there. You are officially allowed to revisit this grave. ;)