Page 1 of 1

SolydX and RDP

Posted: 02 Mar 2015 22:19
by xendistar
I work from home and connect to the servers at work via RDP with my windows 7 PC and win8 laptop I don't have an issue but using linux I have very strange issue. I am using Shrewsoft VPN Access manger (as it accept Cisco profile files) to setup the VPN and to date I have used Remmina and xfreerdp as my RDP client. My problem is if I leave the RDP client for about 60 seconds without moving the mouse the client disconnects. Logging back on again and I pick up my existing seesion exactly where I left it (so I am been disconnected from the TS server rather than logged off). This is not an issue with the company TS servers as when I an in windows I can leave them idle for an hour before they disconnect (thats in the windows profile) and if I am logged in as admin they will stay up until I log off.

I did try contact the Remmina mailing list but it seem to be hibernation, not tried xfreerdp support yet but does anybody on here have any suggestions, is there anything on the Debian networking that could be forcing the rdp client to disconnect??

Re: SolydX and RDP

Posted: 04 Mar 2015 14:25
by Arjen Balfoort
I'm afraid nobody here has that kind of knowledge, so it seems.
Did you try nomachine? It's proprietary (not open source), but it's free to use for home users.

Re: SolydX and RDP

Posted: 04 Mar 2015 14:36
by Deleted User 2763
It sounds like it may be your vpn.
I don't have that problem using the vpn in Network Manager.
As I recall, I installed vpnc and used the settings in my company's cisco client. (I did have to decode the group password, or ask your admin)

For Remote Desktop, I use remmina and remmina-plugin-rdp.


Re: SolydX and RDP

Posted: 04 Mar 2015 18:46
by xendistar
It is not the VPN as I was running a ping in the background to one of our other servers yesterday while I had a RDP session running to one of our applications servers, the session disconnected but the ping to the other server continued without issue.

I have tried Remmina (with the RDP plugin) and XFreerdp and they both exhbit the same issue so it seems to me to be a Linux\Debian issue.

I am also going to download wireshark an see if that picks anything up.

Re: SolydX and RDP

Posted: 05 Mar 2015 01:37
by Deleted User 2763
See if ... 54272.aspx
Sheds any light. Apparently you can configure your server idle timeout values.
But I work from home, too and don't experience any problems.
I know it doesn't discount yours, but other than the VPN service, that's the only thing I can think of.