Page 1 of 1

Problem with SSH client

Posted: 14 May 2013 12:21
by marianof2000
Hi everybody
I'm trying to use ssh client. (solydX 64 up 06/05/13)
for example

$ ssh user@ip (this is a local network IP)
ssh_exchange_identification: read: Connection reset by peer
$

I'd try with other distros and everything is working OK.

Any ideas???

Than's in advance.

Mariano (from Argentina)

Re: Problem with SSH client

Posted: 14 May 2013 13:50
by Arjen Balfoort
This error can be caused by a gazillion reasons, but let's start by getting us a more verbose output:

Code: Select all

ssh -vT login@ip

Re: Problem with SSH client

Posted: 14 May 2013 14:10
by marianof2000
This is the output.

ssh -vT login@000.000.0.000
OpenSSH_6.0p1 Debian-4, OpenSSL 1.0.1e 11 Feb 2013
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 000.000.0.000 [000.000.0.000] port 22.
debug1: Connection established.
debug1: identity file /home/marianof/.ssh/id_rsa type -1
debug1: identity file /home/marianof/.ssh/id_rsa-cert type -1
debug1: identity file /home/marianof/.ssh/id_dsa type -1
debug1: identity file /home/marianof/.ssh/id_dsa-cert type -1
debug1: identity file /home/marianof/.ssh/id_ecdsa type -1
debug1: identity file /home/marianof/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.0p1 Debian-4
debug1: match: OpenSSH_6.0p1 Debian-4 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.0p1 Debian-4
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ECDSA ce:4f:45:e9:a1:8a:51:6b:fc:cb:62:69:c1:fe:6f:3d
The authenticity of host '000.000.0.000 (000.000.0.000)' can't be established.
ECDSA key fingerprint is ce:4f:45:e9:a1:8a:51:6b:fc:cb:62:69:c1:fe:6f:3d.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '000.000.0.000' (ECDSA) to the list of known hosts.
debug1: ssh_ecdsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
Write failed: Connection reset by peer

I've run a virtual LMDE Mate and works perfect the ssh conection.

Thanks

Re: Problem with SSH client

Posted: 14 May 2013 14:28
by Arjen Balfoort
Instead of "Write failed", I'd expect "debug1: SSH2_MSG_NEWKEYS received".
This looks like a permission issue: the received key needs to be saved, but it can't.
Here my knowledge stops, but it should help you to compare your system's permission with the VM's permissions.

Re: Problem with SSH client

Posted: 14 May 2013 16:44
by marianof2000
This is the debian VM output:

ssh -vT gnuhealth@192.168.1.142
OpenSSH_6.0p1 Debian-4, OpenSSL 1.0.1e 11 Feb 2013
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 192.168.1.142 [192.168.1.142] port 22.
debug1: Connection established.
debug1: identity file /home/test01/.ssh/id_rsa type -1
debug1: identity file /home/test01/.ssh/id_rsa-cert type -1
debug1: identity file /home/test01/.ssh/id_dsa type -1
debug1: identity file /home/test01/.ssh/id_dsa-cert type -1
debug1: identity file /home/test01/.ssh/id_ecdsa type -1
debug1: identity file /home/test01/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.0p1 Debian-4
debug1: match: OpenSSH_6.0p1 Debian-4 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.0p1 Debian-4
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ECDSA ce:4f:45:e9:a1:8a:51:6b:fc:cb:62:69:c1:fe:6f:3d
debug1: Host '192.168.1.142' is known and matches the ECDSA host key.
debug1: Found key in /home/test01/.ssh/known_hosts:1
debug1: ssh_ecdsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received

debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: /home/test01/.ssh/id_rsa
debug1: Trying private key: /home/test01/.ssh/id_dsa
debug1: Trying private key: /home/test01/.ssh/id_ecdsa
debug1: Next authentication method: password
gnuhealth@192.168.1.142's password:

Mariano

Re: Problem with SSH client

Posted: 14 May 2013 17:17
by Arjen Balfoort
Exactly, now compare the permissions for /home/marianof/.ssh with /home/test01/.ssh
I'm just guessing here, I really don't know what I'm doing. :?