Page 1 of 1

Adding a network Printer (Solved)

Posted: 08 Mar 2016 23:27
by Rocky
I am trying to add a canon Pixma MP495 printer ( wirelessly networked). When I add the printer in print settings I get a dialogue saying I must log in

IP address: 192.168.x.x ( my ip address for the printer)
Domain : WORKGROUP ( not sure where this is coming from )
Password: When I enter my sudo password it registers as incorrect ( it is not)

Does anybody know what password the dialogue is looking for

Re: Adding a network Printer

Posted: 09 Mar 2016 00:28
by ilu
Please provide some more information. SolydX or SolydK?
"Domain : WORKGROUP" indicates some Win/samba involvement which should not be necessary. Does the printer have a password setting? Some network printers have. Check the printer handbook for its network settings. It might be preconfigured for Windows.

Did you check the IP on the printer? Can you ping it? Try these commands to see whether cups finds it and post the output if it provides any info:

Code: Select all

$ ping 192.168.x.x
$ sudo lpinfo -v
$ usr/lib/cups/backend/snmp 192.168.x.x
I have no experience with Canon but since nobody else came along fo far ... maybe this helps.

Re: Adding a network Printer

Posted: 09 Mar 2016 13:21
by Ghstryder
I don't remember what mine asked for, but CUPS has always wanted the root user. If you are putting in your user, try "root".

Re: Adding a network Printer

Posted: 09 Mar 2016 15:38
by mhwelsh
My experiences, or flounderings connecting a Wireless Printer.
The printer should be a freestanding wireless. Therefore if you search your wlan you should find at least one and probably 2 transmitters that your wlan can pick up - the printer and probably your router that connects your computer to the internet.

When you have established contact with the printer, cups(localhost:631) should also find it and probably show it as a network printer.

After that just connect it like any other printer using cups.
I find localhost:631 more predictable than some of the gui programmes.
Initially I determined the ip number of the printer and connected a designated address but cups and the gui's insist on connecting to an indecipherable string of digits quite successfully.

I use a HP printer which demands that I switch it on, it is easy to forget but it is getting easier to find out what is wrong!
Do you need foo2zjs an additional driver needed by some printers?

martin welsh

Re: Adding a network Printer

Posted: 09 Mar 2016 23:00
by Rocky
Thank you all for the suggestions. I have the printer working ( for now at least :| )

@ilu Tried the terminal commands you suggested . I could ping the printer no problem . sudo lpinfo -v couldn’t find anything other than the CUPS-pdf printer which is already installed . I suspect that this is a shared printer and might be why the printer settings dialogue I mentioned last night was showing a domain and samba i.e. the printer settings probe was finding the shared PDF printer.

@Ghstryder and @mhwelsh. Decided to go with mhwelsh suggestion to use the localhost:631 webinterface ( which should be distro neutral). Appsocket and ipp protocols seemed not to work ( for me at least) . LPD/LPR worked ( :lol: ) . The format was lpd://192.168.x.x/ ( appending lp and lp0 also worked so not sure exactly what queue I am using).

Offtopic : Regarding password my own account and password worked when requested on the CUPS webinterface ( presumably because it has sudo privileges and is therefore effectively root ?). When I was with Debian vanilla the accepted school of thought seemed to be to have an actual root account and to be honest I found this more straightforward . To do anything administrative you logged into a root terminal and then back to own account when finished . This leaves one more conscious of being root only when really needed - you could always set up minimal sudo privileges if necessary. At least this way if your own account was compromised an attacker would not have root access.