SolydK refuses connecting to WEP Hotspot

Questions about networking.
In the Original Post please also include the output of inxi -FNzxx
Skylark92
Posts: 12
Joined: 30 Jun 2016 11:57

SolydK refuses connecting to WEP Hotspot

Postby Skylark92 » 30 Jun 2016 12:38

Hello Everyone,

I am new to Solyd K since this week.
I've been installing and configuring it at a friends place with a normal, solid internet connection on my HP Elitebook next to Ubuntu 14 and Windows 7.
But since I live "off the grid" quite literally in a cabin in some grassy meadow, at home I have to make do with my Nokia N900 and it's WEP Hotspot in order to get on-line. :D

For some years, I'm a very happy Ubuntu user. Reasonably experienced, however, I am a sucker for networks... I always kind of just expect them to work... :roll:

As much Ubuntu and Windows, have never had issues with my dodgy, old-fashioned WEP hotspot.
But in Solyd K I have now been trying every different setting for it, (at least those I dared touching), and still absolutely nothing happens.

It calls the connection "Deactivated" regardless of the settings, after trying to connect for vaguely 3 minutes.

Anyone any ideas to get this going? :mrgreen:

User avatar
ilu
Posts: 2006
Joined: 09 Oct 2013 12:45

Re: SolydK refuses connecting to WEP Hotspot

Postby ilu » 30 Jun 2016 13:02

Welcome to SolydXK and our forums! I'm not really knowledgable about networks either but others will come by.
I would like to collect some basic troubleshooting information first. Please open a terminal, enter the following commands and post the output:

Code: Select all

inxi -Fxz
sudo LC_ALL=C ifconfig
sudo LC_ALL=C iwconfig
cat /etc/network/interfaces
cat /etc/NetworkManager/NetworkManager.conf
In order to make the output easily readable on the forums, please enclose each output in "code" tags. e.g.

Code: Select all

[code]my output text
[/code]
Note that there is a "Code" button at the top of the forum editing window which does this automatically for any highlighted text.

Skylark92
Posts: 12
Joined: 30 Jun 2016 11:57

Re: SolydK refuses connecting to WEP Hotspot

Postby Skylark92 » 30 Jun 2016 13:28

Thanks there for the quick reply. :mrgreen:

Here are the outcomes:

Code: Select all

skylark@hp-elitebook-2560p ~ $ inxi -fxz
CPU:       Dual core Intel Core i7-2620M (-HT-MCP-) cache: 4096 KB bmips: 10774 
           Clock Speeds: 1: 2475 MHz 2: 1287 MHz 3: 799 MHz 4: 2909 MHz
           CPU Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov constant_tsc cx16 cx8 de
           ds_cpl dtes64 dtherm dts eagerfpu epb ept est flexpriority fpu fxsr ht ida lahf_lm lm mca mce mmx
           monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pebs pge pln pni popcnt pse pse36
           pts rdtscp rep_good sep smx ss sse sse2 sse4_1 sse4_2 ssse3 syscall tm tm2 tpr_shadow tsc
           tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology xtpr

Code: Select all

skylark@hp-elitebook-2560p ~ $ sudo ifconfig
[sudo] password for skylark: 
eth1      Link encap:Ethernet  HWaddr 10:1f:74:f0:35:7a  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:20 Memory:d4700000-d4720000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:815 errors:0 dropped:0 overruns:0 frame:0
          TX packets:815 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:100043 (97.6 KiB)  TX bytes:100043 (97.6 KiB)

wlan0     Link encap:Ethernet  HWaddr 08:11:96:5a:f0:e8  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Code: Select all

skylark@hp-elitebook-2560p ~ $ sudo iwconfig
wlan0     IEEE 802.11abgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off                     
          Encryption key:off                                                             
          Power Management:off                                                                  
                                                                                                   
eth1      no wireless extensions.                                                                            
                                                                                                                     
lo        no wireless extensions.  

Code: Select all

skylark@hp-elitebook-2560p ~ $ cat /etc/network/interfaces
# This file describes the network interfaces available on your system                                                                                  
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
# Uncomment lines below if you do not want to use a network manager
#auto eth0
#allow-hotplug eth0
#iface eth0 inet dhcp

Code: Select all

skylark@hp-elitebook-2560p ~ $ cat /etc/NetworkManager/NetworkManager.conf
[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

User avatar
ilu
Posts: 2006
Joined: 09 Oct 2013 12:45

Re: SolydK refuses connecting to WEP Hotspot

Postby ilu » 30 Jun 2016 13:44

Skylark92 wrote:

Code: Select all

skylark@hp-elitebook-2560p ~ $ inxi -fxz
Please try again with a capital "F". There's a difference!
Skylark92 wrote:

Code: Select all

skylark@hp-elitebook-2560p ~ $ cat /etc/network/interfaces
...
# The primary network interface
# Uncomment lines below if you do not want to use a network manager
#auto eth0
#allow-hotplug eth0
#iface eth0 inet dhcp
Huh, network manager disabled? That looks wrong ... did you do that?

Skylark92
Posts: 12
Joined: 30 Jun 2016 11:57

Re: SolydK refuses connecting to WEP Hotspot

Postby Skylark92 » 30 Jun 2016 13:52

Sorry, my bad.

Code: Select all

skylark@hp-elitebook-2560p ~ $ inxi -Fxz
System:    Host: hp-elitebook-2560p Kernel: 3.16.0-4-amd64 x86_64 (64 bit gcc: 4.8.4) 
           Desktop: KDE 4.14.2 (Qt 4.8.6) Distro: SolydXK 8 solydxk 
Machine:   System: Hewlett-Packard product: HP EliteBook 2560p v: A0001C02
           Mobo: Hewlett-Packard model: 162B v: KBC Version 04.1E
           Bios: Hewlett-Packard v: 68SSU Ver. F.02 date: 07/26/2011
CPU:       Dual core Intel Core i7-2620M (-HT-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10774 
           Clock Speeds: 1: 2997 MHz 2: 2918 MHz 3: 2686 MHz 4: 3005 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0
           Display Server: X.Org 1.16.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.00hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 10.3.2 Direct Rendering: Yes
Audio:     Card-1 Intel 6 Series/C200 Series Family High Definition Audio Controller 
           driver: snd_hda_intel bus-ID: 00:1b.0 
           Card-2 DigiTech driver: USB Audio usb-ID: 002-003 
           Sound: Advanced Linux Sound Architecture v: k3.16.0-4-amd64
Network:   Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e v: 2.3.2-k port: 4060 bus-ID: 00:19.0
           IF: eth1 state: down mac: <filter>
           Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi v: in-tree: bus-ID: 24:00.0
           IF: wlan0 state: down mac: <filter>
Drives:    HDD Total Size: 2250.5GB (1.1% used) ID-1: /dev/sda model: Samsung_SSD_850 size: 250.1GB
           ID-2: USB /dev/sdb model: HD720 size: 2000.4GB
Partition: ID-1: / size: 27G used: 20G (81%) fs: ext4 dev: /dev/sda4 
           ID-2: swap-1 size: 4.41GB used: 0.00GB (0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 58.0C mobo: 0.0C 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 200 Uptime: 0 min Memory: 559.5/15977.0MB Init: systemd runlevel: 5 Gcc sys: 4.9.2 
           Client: Shell (bash 4.3.301) inxi: 2.1.28 
And regarding the network manager, As far as I am aware, I did not do that.

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: SolydK refuses connecting to WEP Hotspot

Postby Zill » 30 Jun 2016 14:33

ilu: The /etc/network/interfaces output looks fine to me - there was some discussion earlier about this but I don't believe eth0 entries are now necessary when using the standard SolydXK NetworkManager applet.

Skylark92: Please left-click on the NetworkManager applet at the bottom right of your screen. Do you see a list of nearby WiFi access points? Is your WEP hotspot listed?

Then right-click on the same applet and advise us if all three items are checked as shown in my example:
NM.png
NM.png (13.1 KiB) Viewed 2169 times

Skylark92
Posts: 12
Joined: 30 Jun 2016 11:57

Re: SolydK refuses connecting to WEP Hotspot

Postby Skylark92 » 30 Jun 2016 15:02

@Zill
Yes, It shows up there and seemingly duplicates it once I try to connect ( Shows the same network twice) Connecting to neither.
And though I get notifications about every time it fails to connect, my networking and wifi appears to be running normally but I do not, however, get the same window as you showed here. No right click, anywhere shows me that same window.

When I was installing and configuring SolydXK I have used both WiFi and Cable at this friends place and both worked perfectly fine, straight away.

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: SolydK refuses connecting to WEP Hotspot

Postby Zill » 30 Jun 2016 15:08

Skylark92: Please open a terminal and post the full output of the following two commands:

Code: Select all

inxi -r
apt policy network-manager

Skylark92
Posts: 12
Joined: 30 Jun 2016 11:57

Re: SolydK refuses connecting to WEP Hotspot

Postby Skylark92 » 30 Jun 2016 15:39

Allright,

Code: Select all

 skylark@hp-elitebook-2560p ~ $ inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://repository.solydxk.com/ solydxk main upstream import
           deb http://ftp.debian.org/debian jessie main contrib non-free
           deb http://security.debian.org/ jessie/updates main contrib non-free
           deb http://ftp.debian.org/debian/ jessie-backports main contrib non-free

Code: Select all

skylark@hp-elitebook-2560p ~ $ apt policy network-manager
network-manager:
  Installed: 0.9.10.0-7
  Candidate: 0.9.10.0-7
  Version table:
 *** 0.9.10.0-7 0
        500 http://ftp.debian.org/debian/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: SolydK refuses connecting to WEP Hotspot

Postby Zill » 30 Jun 2016 19:19

Skylark92: You are running the same network-manager (NetworkManager) as me so I would expect similar outputs.

Please advise exactly what you see when you right-click on the NetworkManager applet. It would help if you would include a screen shot.

Skylark92
Posts: 12
Joined: 30 Jun 2016 11:57

Re: SolydK refuses connecting to WEP Hotspot

Postby Skylark92 » 30 Jun 2016 20:39

I hope this will suffice

What happens when I right-click the networks applet in the corner down right, is 2 options, ( which, when opened I am apparently not allowed to make a screenshot ) the bottom one allows me to change the entire arrangement of icons down there, or the top one will open the network management settings which brings me to the last 2 pictures...

http://s1036.photobucket.com/user/Skyla ... sort=9&o=4

User avatar
ilu
Posts: 2006
Joined: 09 Oct 2013 12:45

Re: SolydK refuses connecting to WEP Hotspot

Postby ilu » 30 Jun 2016 22:51

You have the possibility to attach pictures in this forum, the menu is below the posting window - scroll down when composing a post.

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: SolydK refuses connecting to WEP Hotspot

Postby Zill » 01 Jul 2016 10:04

Skylark92: I don't use KDE myself but the screenshots you have posted seem to me to be part of the KDE system settings, rather than the SolydXK NetworkManager.

My understanding is that both SolydX (XFCE) and SolydK (KDE) use the same (Gnome) NetworkManager, but I am sure that others will correct me if I'm wrong. ;-)

Accordingly, please right-click on each of the small icons at the bottom-right of your screen and see if the result of any of them look similar to the NM example I posted earlier. If so, then you have found the correct NetworkManager and you should then be able to left-click on the same icon and see all the Wi-Fi access points. Left-click on your WEP hotspot and you should then be asked for your WEP password. After entering this you should be connected!

Skylark92
Posts: 12
Joined: 30 Jun 2016 11:57

Re: SolydK refuses connecting to WEP Hotspot

Postby Skylark92 » 01 Jul 2016 10:46

@Ilu
I've been getting used to forums that don't want you uploading big pictures even though they offer the option so... Thanks, for next time :mrgreen:

@Zill
It is that very same applet I am on about.
If you have seen the photobucket pictures, you see all available networks with a left click. (Reminder to my cabin in the middle of a meadow, there is no one else here with Wi-Fi but me and my N900 ) the right click brings me to that last menu which shows a couple of notifications of things that have gone wrong and the rest there, makes no sense to me either.

Just clicking my network and entering my password is not the trick... If I would not have known how to do so I'd have stuck with Windows my entire life paying people to fix my computer. :D
All that standard procedure connecting does is to have the thing "trying" to make a connection, and then fail anyway. again and again...

There is however one more menu, I can get on by right clicking the spanner in the right top of the available wifi networks menu
I'll make a selection of screen-shots there too. Maybe that gives out something.

( to be continued )

Skylark92
Posts: 12
Joined: 30 Jun 2016 11:57

Re: SolydK refuses connecting to WEP Hotspot

Postby Skylark92 » 01 Jul 2016 11:18

Allright...
Uploading pictures to here forces me to spend another month making them smaller than ... some kbs
Which I had done, but not enough according to the forum. So, back to photobucket for me :D screw that.

This, really is the last thing I can find, regarding my connection.
I 've already experimented with several ( easy un-done ) settings in there yesterday... Adding and deleting the network manually as well...
just nothing works.

Also as you might notice there, It keeps saying it just disconnected from a wired network. The last time that was used, is the same as the Wireless one beneath that... This weekend, during installation :D

Image

Image

Image

Image

Image

Image

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: SolydK refuses connecting to WEP Hotspot

Postby Zill » 01 Jul 2016 13:43

Skylark92: One of your screenshots shows that the option "All users may connect to this network" is deselected. I suggest you edit this screen and enable this option. Then reboot your system and see if you can connect.

If this still fails then I will leave it for other SolydK users to provide further assistance.

p.s. Don't forget that Linux is case sensitive so please make sure your WEP password (key) uses the correct case throughout!

User avatar
ilu
Posts: 2006
Joined: 09 Oct 2013 12:45

Re: SolydK refuses connecting to WEP Hotspot

Postby ilu » 01 Jul 2016 14:10

all users ... that's what I thought too. It's not checked by default though (as it is on XFCE), I started a VM with Solydk to check. And, allthough most of the screens somehow look like the networkmanager we have on XFCE, the applet totally does not act like it on lft/right-click.
Isn't there any way to troubleshoot this via terminal?

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: SolydK refuses connecting to WEP Hotspot

Postby Zill » 01 Jul 2016 14:45

ilu wrote:Isn't there any way to troubleshoot this via terminal?
AIUI, all the GUI data is saved in /etc/NetworkManager. However, although we can use the CLI to see the settings, I don't really think it helps us in this case as all user info is visible in the GUI.

FWIW, there are other NM changes the OP could try such as:
Changing the "Mode" from "Ad-Hoc" to "Infrastructure"
Changing the security to "WEP 128-bit Passphrase"

Really just a case of "tweak it until it works"! ;-)

User avatar
ilu
Posts: 2006
Joined: 09 Oct 2013 12:45

Re: SolydK refuses connecting to WEP Hotspot

Postby ilu » 01 Jul 2016 15:47

Did you have a look at this http://talk.maemo.org/showthread.php?t=84077 - there they say that Gnome Network Manager should work and one of the suggestions says try open first,

Skylark92
Posts: 12
Joined: 30 Jun 2016 11:57

Re: SolydK refuses connecting to WEP Hotspot

Postby Skylark92 » 01 Jul 2016 16:21

Zill wrote: Really just a case of "tweak it until it works"! ;-)
That's what I thought... Been cocking around with it for hours... With no effect.

Standard, mode is Ad-Hoc, and the security set to WEP Key 40/128 bits Hex or ASCII
No issues with misspelling the password either.

Setting it to Infrastructure, blocks me from even trying to connect...
And changing the security to WEP 128 Pass phrase does nothing either...

Once I put it to Acces-Point though. ( all the rest, still set standard)
I can actually see in Gkrellm that networkconnection is being made and some communication between my laptop and the phone is happening somehow. Also the wifi-menu shows the following:
Image

It is "Setting Network Adress" which is more than I have ever seen it do until now... But left it going for 15 minutes, nothing happened at all...
So that seems kind of useless still...


Return to “Networking”

Who is online

Users browsing this forum: No registered users and 1 guest