Page 1 of 1

network okay no Internet

Posted: 04 Jun 2013 14:23
by k0mll
I am wondering if someone can give me a hint on fixing a new problem. I'm using SolydK, and the wireless network is as installed, "vanilla" settings. It was working until yesterday, after a few hours came back to the laptop (Dell 600) all looked fine, but none of the Internet programs (firefox / thunderbird / (desktop widgets) see the Internet. I can log to my wireless router, make it scan and see lots of wireless networks, change settings etc. and print. I reboot into LMDE and it works just fine. So some setting must have become corrupt and I don't have enough experience to find.

I thought if both are Debian I could compare configuration files, but don't know where to look. Google was no help, although I've seen some Debian posts, unanswered with the problem of Internet not working.

LSPCI gives: 02:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
If that helps. Power management has suspend, hibernate off. It can only shutdown if on battery but not suspend. Screen will turn off and does after 20 minutes.

I've deleted my wireless connections in the manager, added DNS services (like Google), and still no Internet. The showroute command fails which is a test Google suggested when troubleshooting DNS problems. It just don't get "out of the house".

Any ideas on where to look are appreciated, thanks for any help. It was working, only occasionally failing to connect to Internet, a disconnect - connect usually got it going. (or even a reboot) Using LMDE now to post.

Re: network okay no Internet

Posted: 04 Jun 2013 15:25
by k0mll
Update: I am at the Library now and the Internet is fine. I noticed when it broke before I logged to a distant neighbor's open wifi and it connected (unusable because of distance/signal), then logged in at home it worked. Will find out in a few hours if this repeats. ---thanks for any ideas or suggestions.

[ back home, it failed but had local network. I deleted the entries in the network manager for my wireless network, which promptly disconnected, re-edited the connection w/ google's dns and it is working. I am going NUTS trying to find out why this Solyd drops Internet... It just connected with that little effort --- sign me Confused!]

Re: network okay no Internet

Posted: 07 Jul 2013 09:54
by theuncontactable
If you issue the following commands at the terminal and post the responses then others will be able to help you with networking problems.

~ $ ifconfig

~ $ ping <address of your wireless router>

~ $ ping

~ $ ping

Your DNS settings should be the ones supplied to you by your isp. You should also find it in your wireless router when you log into it.

Re: network okay no Internet

Posted: 09 Oct 2013 18:44
by k0mll
Sorry, kind of lost track of the problem. It happens occasionally, loosing Internet. Printer (wireless) worked.
So since a reboot fixes, I ignore the problem. I can ping my router, I can print, can't ping google or any Internet site when bad.
Ifconfig shows it was assigned an IP address, if it disconnects during use, otherwise nothing.

So just let it go, maybe just old hardware. About 30 plus percent of the time using the keyboard "turn off the radio" key then back on will fix. So, time for a new laptop. --mc

Re: network okay no Internet

Posted: 16 Oct 2013 05:19
by Gustavo
First, excuse me for my English (I'm from San Juan, Argentina).
I had the same problem. And the solution was easy.
I edited my connection and IPv4 tab I put the OpenDNS: "," (with out double cuottes).
I hope this to be useful for you.


Re: network okay no Internet

Posted: 16 Oct 2013 12:56
by k0mll
Thanks, that is one thing I did do, the ISP's DNS is pretty bad and that helps lots. I think in the end I have a network card starting to go.