SOLVED: Cannot automount CIFS/Samba shares

Questions about networking.
In the Original Post please also include the output of inxi -FNzxx
User avatar
kwisher
Posts: 42
Joined: 30 Mar 2013 17:31

SOLVED: Cannot automount CIFS/Samba shares

Postby kwisher » 12 Jun 2013 18:53

Hello all,

Just recently I have not been able to mount a couple CIFS/Samba shares from my /etc/fstab file. This was working before the Wheezy release. Below are the lines from my fstab file:

Code: Select all

//10.1.0.59/iso	/media/backup	cifs	credentials=/root/.smbcredentials,iocharset=utf8,file_mode=0777,dir_mode=0777   0       0
//10.1.0.67/D$	/media/EHS-FS	cifs	credentials=/root/.smbcredentials,file_mode=0777,nocase,noperm,dir_mode=0777   0       0
The error message I receive when using mount -a command:

Code: Select all

kww-tech kevin # mount -a
mount error(5): Input/output error
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
Any help would be greatly appreciated.
The instructions suggested Windows XP or better, so I installed Linux :)

User avatar
Arjen Balfoort
Site Admin
Posts: 9043
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Cannot automount CIFS/Samba shares

Postby Arjen Balfoort » 12 Jun 2013 19:19

Can you manually mount?

Code: Select all

sudo mount -t cifs -o username=root,password=your_root_password //10.1.0.59/iso   /media/backup
Then add the parameters one by one to see when it crashes.


SolydXK needs you!
Development | Testing | Translations

User avatar
kwisher
Posts: 42
Joined: 30 Mar 2013 17:31

Re: Cannot automount CIFS/Samba shares

Postby kwisher » 13 Jun 2013 10:52

I'm going to mark this as solved. The main reason I was having problems was from general user error (using wrong credentials) :o . Thanks for the suggestion on manually mounting as that is how I was able to find my error.
The instructions suggested Windows XP or better, so I installed Linux :)

User avatar
Arjen Balfoort
Site Admin
Posts: 9043
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: SOLVED: Cannot automount CIFS/Samba shares

Postby Arjen Balfoort » 13 Jun 2013 10:59

Aha, the usual suspects :D


SolydXK needs you!
Development | Testing | Translations


Return to “Networking”

Who is online

Users browsing this forum: No registered users and 1 guest